bison-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202
  1. Summary: A GNU general-purpose parser generator.
  2. Summary(ja): GNU 汎用構文解析器生成プログラム
  3. Name: bison
  4. Version: 2.4.1
  5. Release: 2%{?_dist_release}
  6. License: GPL
  7. Group: Development/Tools
  8. Source: http://ftp.gnu.org/gnu/bison/bison-%{version}.tar.bz2
  9. Patch1: bison-2.4-reap_subpipe.patch
  10. URL: http://www.gnu.org/software/bison/
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: m4 >= 1.4
  13. Requires(post): install-info
  14. Requires(preun): install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. %description
  18. Bison is a general purpose parser generator which converts a grammar
  19. description for an LALR(1) context-free grammar into a C program to parse
  20. that grammar. Bison can be used to develop a wide range of language
  21. parsers, from ones used in simple desk calculators to complex programming
  22. languages. Bison is upwardly compatible with Yacc, so any correctly
  23. written Yacc grammar should work with Bison without any changes. If
  24. you know Yacc, you shouldn't have any trouble using Bison. You do need
  25. to be very proficient in C programming to be able to use Bison). Bison
  26. is only needed on systems that are used for development.
  27. If your system will be used for C development, you should install Bison
  28. since it is used to build many C programs.
  29. #'
  30. %description -l ja
  31. bison は汎用構文解析器を生成するプログラムで,LALR(1) 文脈自由文法で
  32. 書かれた文法記述を元に,その記述を解析する C プログラムを生成します.
  33. bison は簡単な電卓から複雑なプログラミング言語まで,幅広い種類の
  34. 言語解析器を開発するのに使うことが出来ます.
  35. bison は yacc の上位互換ですので,yacc で書かれた文法を修正すること
  36. なしに解析することが出来ます.yacc を知っているのであれば,bison を
  37. 使って困ることは何もないでしょう.bison を使うには C プログラミングの
  38. 豊富な知識が必要となります.bison は開発を行うシステム以外では特に
  39. 必要にならないでしょう.
  40. C 言語による開発を行う場合は,多くの C プログラムの作成に使われるので
  41. bison をインストールして下さい.
  42. %prep
  43. %setup -q
  44. %patch1 -p1
  45. %build
  46. %configure
  47. make
  48. make check
  49. %install
  50. rm -rf $RPM_BUILD_ROOT
  51. %makeinstall
  52. # Remove unpackaged files.
  53. rm -f $RPM_BUILD_ROOT/%{_bindir}/yacc
  54. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  55. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/yacc*
  56. %find_lang %{name}
  57. %clean
  58. rm -rf $RPM_BUILD_ROOT
  59. %post
  60. /sbin/install-info %{_infodir}/bison.info.gz %{_infodir}/dir \
  61. --entry="* bison: (bison). The GNU parser generator."
  62. %preun
  63. if [ $1 = 0 ]; then
  64. /sbin/install-info --delete %{_infodir}/bison.info.gz %{_infodir}/dir \
  65. --entry="* bison: (bison). The GNU parser generator."
  66. fi
  67. %files -f %{name}.lang
  68. %defattr(-,root,root)
  69. %doc AUTHORS COPYING ChangeLog NEWS OChangeLog README THANKS TODO
  70. %{_bindir}/bison
  71. %{_libdir}/liby.a
  72. %{_datadir}/bison
  73. %{_datadir}/aclocal/*.m4
  74. %{_datadir}/locale/*/LC_MESSAGES/%{name}-runtime.mo
  75. %{_mandir}/*/bison*
  76. %{_infodir}/bison.info*
  77. %changelog
  78. * Wed Feb 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
  79. - rebuilt with new toolchain
  80. * Tue Feb 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.1-1
  81. - new upstream release
  82. - import Patch1 from Fedora
  83. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
  84. - new upstream release
  85. - spec in UTF-8
  86. * Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.3-1
  87. - rebuild with new toolchain.
  88. - apply new versioning policy.
  89. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl1
  90. - new upstream release
  91. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1-0vl1
  92. - new upstream release
  93. * Thu Jun 09 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0-6vl1
  94. - new upstream release
  95. - dropped Patch1
  96. - added %doc files
  97. - updated URL
  98. * Sun Feb 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.875-6vl1
  99. - add Patch1 from fedora
  100. - add Requires: m4
  101. * Thu Oct 30 2003 Roland McGrath <roland@redhat.com> 1.875-6
  102. - add dependency on m4 (bug #108655)
  103. * Wed Sep 24 2003 Roland McGrath <roland@redhat.com> 1.875-5
  104. - remove problematic __attribute__ use for label (bug #105034)
  105. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.875-3vl1
  106. - based on Rawhide 1.875-3
  107. - s/Copyright/License/
  108. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.75-2vl1
  109. - new upstream release
  110. - merged with rawhide release
  111. * Thu Nov 21 2002 Tim Waugh <twaugh@redhat.com> 1.75-2
  112. - Run 'make check'.
  113. - Apply patch from bison-patches to fix bash compilation.
  114. * Thu Oct 17 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  115. - update to 1.75
  116. * Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  117. - 1.35-2vl1: synced with rawhide
  118. * Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  119. - 1.28-5vl1
  120. - rebuilt with new %%{_mandir} definition
  121. - added Japanese summary and description
  122. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.28-5vl1
  123. - build on Vine Linux with gcc-2.95.3
  124. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  125. - automatic rebuild
  126. * Sun Jun 18 2000 Than Ngo <than@redhat.de>
  127. - rebuilt in the new build environment
  128. - FHS packaging
  129. * Sat May 27 2000 Ngo Than <than@redhat.de>
  130. - rebuild for 7.0
  131. - put man pages and info files to correct place
  132. * Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
  133. - rebuild to gzip man page.
  134. * Fri Jul 16 1999 Jeff Johnson <jbj@redhat.com>
  135. - update to 1.28.
  136. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  137. - auto rebuild in the new build environment (release 3)
  138. * Mon Mar 8 1999 Jeff Johnson <jbj@redhat.com>
  139. - configure with datadir=/usr/lib (#1386).
  140. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  141. - updated text in spec file.
  142. - update to 1.27
  143. * Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
  144. - build for glibc 2.1
  145. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  146. - translations modified for de, fr, tr
  147. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  148. - built for Manhattan
  149. - added build root
  150. * Wed Oct 15 1997 Donnie Barnes <djb@redhat.com>
  151. - various spec file cleanups
  152. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  153. - built against glibc