empathy-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401
  1. %define major_ver 2.32
  2. %define minor_ver 0.1
  3. %define rel 1
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  6. ## respectively.
  7. %global gtk2_min_version 2.22
  8. %global glib2_min_version 2.26.0
  9. %global tp_mc_min_version 5.6.0
  10. %global tp_glib_min_version 0.13.0
  11. %global tp_logger_min_version 0.1.5
  12. #global enchant_version 1.4.0
  13. %global aspell_version 0.50
  14. %global libcanberra_version 0.4
  15. %global gnome_keyring_version 2.32
  16. %global libnotify_version 0.4.4
  17. Summary: GNOME Instant Messaging Client
  18. Summary(ja): GNOME インスタントメッセージクラアイント
  19. Name: empathy
  20. Version: %{major_ver}.%{minor_ver}
  21. Release: %{rel}%{?_dist_release}
  22. Group: Applications/Communications
  23. License: GPLv2+
  24. URL: http://live.gnome.org/Empathy
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{majorver}/%{name}-%{version}.tar.bz2
  26. Source1: %{name}-README.ConnectionManagers
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. #BuildRequires: enchant-devel >= %{enchant_version}
  29. BuildRequires: aspell-devel >= %{aspell_version}
  30. BuildRequires: iso-codes
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: evolution-data-server-devel
  33. BuildRequires: GConf2-devel
  34. BuildRequires: gettext
  35. BuildRequires: glib2-devel >= %{glib2_min_version}
  36. BuildRequires: gnome-doc-utils >= 0.17.3
  37. BuildRequires: gnome-panel
  38. BuildRequires: gtk2-devel >= %{gtk2_min_version}
  39. BuildRequires: intltool
  40. BuildRequires: libxml2-devel
  41. BuildRequires: perl(XML::Parser)
  42. BuildRequires: pygtk2-devel
  43. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  44. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  45. BuildRequires: farsight2-devel
  46. BuildRequires: telepathy-farsight-devel
  47. BuildRequires: libcanberra-devel >= %{libcanberra_version}
  48. BuildRequires: libgnome-keyring-devel >= %{gnome_keyring_version}
  49. BuildRequires: unique-devel
  50. BuildRequires: libnotify-devel >= %{libnotify_version}
  51. BuildRequires: libtelepathy-devel
  52. BuildRequires: libgnomecanvas-devel
  53. BuildRequires: libbonoboui-devel
  54. BuildRequires: folks-devel
  55. BuildRequires: telepathy-logger-devel >= %{tp_logger_min_version}
  56. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  57. Requires: telepathy-filesystem
  58. ## Empathy is useless without a proper Telepathy connection manager installed.
  59. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  60. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  61. ## (RHBZ: 308871 and 334221)
  62. ## TODO: Perhaps we can configure these to be installed "on demand" with
  63. ## PackageKit and friends?
  64. Requires: telepathy-gabble
  65. Requires: telepathy-salut
  66. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  67. ## and I'd hate for people to simply disregard it for lack of the "out of the
  68. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  69. BuildRequires: telepathy-haze
  70. # Require this for VOIP support
  71. Requires: telepathy-stream-engine
  72. Requires(post): GConf2
  73. Requires(post): scrollkeeper
  74. Requires(postun): scrollkeeper
  75. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  76. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  77. Provides: telepathy-haze-mission-control = 0.2.0-3
  78. ## upstream 2.29.1 removed shared libraries: #599086
  79. Obsoletes: empathy-libs < 2.29.1, empathy-devel < 2.29.1
  80. ## upstream 2.29.1 removed python bindings' #599039
  81. Obsoletes: empathy-python < 2.29.1
  82. %description
  83. Empathy provides a powerful multiple protocol instant messaging
  84. client using the Telepathy framework.
  85. %package -n nautilus-sendto-empathy
  86. License: GPLv2+
  87. Summary: Nautilus-sendto plugin for empathy
  88. Summary(ja): empathy 用 nautilus-sendto プラグイン
  89. Group: User Interface/Desktop
  90. Requires: %{name} = %{version}-%{release}
  91. Requires: nautilus-sendto
  92. BuildRequires: nautilus-sendto-devel
  93. %description -n nautilus-sendto-empathy
  94. This package contains nautilus-sendto plugin for the Empathy IM application.
  95. %prep
  96. %setup -q
  97. %build
  98. ## GCC complains about some unused functions, so we forcibly show those as
  99. ## simple warnings instead of build-halting errors.
  100. %configure --with-compile-warnings=yes --disable-static --enable-nautilus-sendto=yes
  101. ## RPATHs are yucky.
  102. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  103. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  104. ##make %{?_smp_mflags}
  105. ## don't use _smp_mflags at empathy-2.18.1
  106. make
  107. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  108. %install
  109. rm -rf $RPM_BUILD_ROOT
  110. make install DESTDIR=$RPM_BUILD_ROOT
  111. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  112. %find_lang %{name}
  113. desktop-file-install --vendor "" --delete-original \
  114. --dir %{buildroot}%{_datadir}/applications \
  115. %{buildroot}%{_datadir}/applications/%{name}.desktop
  116. %clean
  117. rm -rf %{buildroot}
  118. %post
  119. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  120. touch --no-create %{_datadir}/icons/hicolor ||:
  121. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  122. %postun
  123. scrollkeeper-update -q || :
  124. touch --no-create %{_datadir}/icons/hicolor || :
  125. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  126. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  127. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  128. fi
  129. %posttrans
  130. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null ||:
  131. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  132. %files -f %{name}.lang
  133. %defattr(-,root,root,-)
  134. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  135. %{_bindir}/empathy
  136. %{_bindir}/empathy-accounts
  137. %{_bindir}/empathy-debugger
  138. %{_libexecdir}/empathy-auth-client
  139. %{_libexecdir}/empathy-av
  140. %{_datadir}/dbus-1/services/*
  141. %{_datadir}/empathy
  142. %{_datadir}/glib-2.0/schemas/*.xml
  143. %{_datadir}/GConf/gsettings/*
  144. %{_datadir}/applications/*.desktop
  145. %{_datadir}/gnome/help/%{name}/
  146. #{_datadir}/omf/%{name}/
  147. %{_datadir}/icons/hicolor/*/apps/%{name}*
  148. #{_datadir}/mission-control/profiles/*.profile
  149. %{_datadir}/telepathy/clients/*.client
  150. %{_mandir}/man1/empathy*.1*
  151. %files -n nautilus-sendto-empathy
  152. %defattr(-,root,root,-)
  153. %{_libdir}/nautilus-sendto/plugins/libnstempathy.so
  154. %changelog
  155. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0.1-1
  156. - new upstream release
  157. - add BuildRequires: folks-devel, telepathy-logger-devel, gnome-keyring-devel
  158. - fix %files
  159. - fix %post, %postun
  160. - drop %pre, %preun
  161. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0.1-3
  162. - rebuild with evolution-data-server-2.30.2
  163. - add nautilus-sendto-empathy package
  164. - add configure option (--enable-nautilus-sendto=yes)
  165. - add BuildRequires: nautilus-sendto-devel
  166. * Sat Jun 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-2
  167. - add Obsoletes: empathy-python < 2.29.1
  168. * Tue Apr 13 2010 IWAI, Masaharu <iwai@alib.jp> 2.30.0.1-1
  169. - new upstream release
  170. - add new files: %%{_bindir}/empathy-{accounts,debugger}
  171. - drop -libs, -devel, -python sub packages: upstream removed
  172. - Obsoletes: empathy-{libs,devel} < 2.29.1
  173. - drop BuildRequires: python-devel
  174. - drop %%{_bindir}/empathy-logs in %%files: upstream don not install
  175. - drop applet files in %%files: upstream removed the panel applets
  176. - update %%post, %pre and %%preun
  177. - update BuildRequires version for glib2 and tp_glib
  178. - defined major_ver, minor_ver and rel
  179. - fix BuildRequires for gnome-keyring
  180. * Sat Mar 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  181. - new upstream release
  182. - add BuildRequires: libtelepathy-devel, libgnomecanvas-devel, libbonoboui-devel, python-devel
  183. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  184. - rebuilt with python-2.6.4
  185. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  186. - unuse %%{?_smp_mflags} option to make
  187. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  188. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  189. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  190. - new upstream release
  191. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  192. - new upstream release
  193. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  194. - initial build for Vine Linux
  195. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  196. - Update to 2.23.92
  197. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  198. - Update to 2.23.91
  199. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  200. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  201. on telepathy-haze to keep the same protocol functionality across upgrades,
  202. for a much improved "out of the box" experience.
  203. - Reference: bug 458935.
  204. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  205. - Update to new upstream release (2.23.90)
  206. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  207. - Apply patch from Colin Walters to automagically update profile namings for
  208. the switch to using Empathy's provided profiles.
  209. - Drop the upgrade script (no longer needed since it's automatically done).
  210. - upgrade-haze-profiles.sh
  211. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  212. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  213. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  214. horribly stale...). This makes for better automagic functionality (if Haze is
  215. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  216. + upgrade-haze-profiles.sh
  217. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  218. - Update to new upstream release (2.23.6)
  219. - Use the in-tarball libtool scripts instead of the system copy to workaround
  220. 'make install' errors.
  221. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  222. - Update to 0.23.4.
  223. - Update source url.
  224. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  225. - Update to 0.23.3.
  226. - Remove reference to stream-engine in connections managers readme.
  227. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  228. - Update to 0.23.2.
  229. - Add man pages.
  230. - Use enchant-devel, instead of aspell-devel.
  231. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  232. - Rebuild for new e-d-s.
  233. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  234. - Drop multiple copies of COPYING file.
  235. - Drop BR on gnome-vfs2-devel.
  236. - Require telepathy-stream-engine for VOIP support.
  237. - Add BR on iso-codes-devel, so spell-checking is enabled.
  238. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  239. - Update to new upstream release (0.23.1)
  240. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  241. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  242. - Update to new upstream release (0.22.1)
  243. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  244. - Update to new upstream release (0.22.0)
  245. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  246. - Update to new upstream release (0.21.91)
  247. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  248. - Update to new upstream release (0.21.90)
  249. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  250. - Autorebuild for GCC 4.3
  251. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  252. - Update to new upstream release (0.21.4)
  253. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  254. - Update to new upstream release (0.21.2)
  255. - Drop backported drag-and-drop patch (fixed upstream):
  256. - svn380-fix-contact-DnD.patch
  257. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  258. note (a feed-only connection manager isn't useful for instant messaging),
  259. and fix some wording.
  260. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  261. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  262. contact from the buddy list to the current conversation window to initiate a
  263. conversation:
  264. + svn380-fix-contact-DnD.patch
  265. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  266. dragged a contact ...)
  267. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  268. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  269. is essentially useless due to the need to install an external connection
  270. manager. Also, add a README.ConnectionManagers to the installed
  271. documentation which lists other possibilities.
  272. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  273. and bug 334221 (Default empathy install is useless).
  274. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  275. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  276. only). Though it is functional, it is still deemed rather unstable by
  277. upstream. Use it at your own risk. :)
  278. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  279. - Disable VoIP support at this time, since it is deemed unstable by upstream
  280. for now. (Thanks to Brian Pepple for the notice.)
  281. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  282. - Update to new upstream release (0.14).
  283. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  284. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  285. and python bindings.
  286. - Split shared libraries into a libs subpackage for easier handling
  287. in multi-lib environments.
  288. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  289. - Add ldconfig invocations to %%post and %%postun scriptlets.
  290. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  291. - Update to new upstream release (0.12).
  292. - Build against new mission-control stack.
  293. - Update License tag (GPLv2+).
  294. - Alphabetize BuildRequires list (aesthetic-only change).
  295. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  296. - Rebuild for selinux ppc32 issue.
  297. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  298. - Update to new upstream release (0.11)
  299. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  300. - bump to 0.8
  301. - Now with aspell support (deat to teh speeling mistaks)
  302. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  303. - bump to 0.7
  304. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  305. - Add telepathy-filesystem to Requires
  306. - Move .desktop from autostart to applications
  307. - Nasty hackery to make empathy launch from the menu
  308. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  309. - Add gettext to BuildRequires
  310. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  311. - Bump to 0.6
  312. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  313. - Let Empathy own the directory and not just the files in it
  314. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  315. - Initial package