fluxbox-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461
  1. %define FBversion 1.1.1
  2. %define patchversion 1.1.0.1
  3. %define fbumenu_version 0.5.2
  4. %define vinefiles_version 9.8
  5. Summary: Fluxbox is a windowmanager that is based on Blackbox.
  6. summary(ja): Fluxbox は Blackbox から派生したウインドウマネージャです。
  7. Name: fluxbox
  8. Version: %{FBversion}
  9. Release: 1%{?_dist_release}
  10. Group: User Interface/Desktops
  11. License: MIT
  12. URL: http://fluxbox.org/
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. Source0: http://downloads.sourceforge.net/fluxbox/%{name}-%{version}.tar.bz2
  16. # styles & scripts
  17. Source1: vinefiles-%{vinefiles_version}.tar.bz2
  18. Source2: styles2.tar.bz2
  19. Patch0: fluxbox-%{version}.init-in.patch
  20. ##Patch1: fluxbox-%{patchversion}.src-clock-tool.patch
  21. ##Patch2: fluxbox-%{patchversion}.src-Makefile-in.patch
  22. Patch3: fluxbox-%{patchversion}.nls-ja.patch
  23. Patch4: fluxbox-%{version}.startfb.patch
  24. Patch5: fluxbox-%{patchversion}.menugen-menu-default.patch
  25. Patch6: fluxbox-%{patchversion}.menugen-add-app.patch
  26. Patch8: fluxbox-%{patchversion}.menugen-utf-8.patch
  27. Patch9: fluxbox-%{patchversion}.menugen-vine-ext.patch
  28. Patch10: fbsetbg_setter_priority.patch
  29. Patch20: fluxbox-%{patchversion}.Xclients.patch
  30. ##Patch30: fluxbox-%{patchversion}.nls-hh.patch
  31. Patch40: fluxbox-%{patchversion}.nls-ja-make.patch
  32. Patch41: fluxbox-%{patchversion}.update_cfg.patch
  33. #Patch100: fluxbox-%{patchversion}.20080913.patch
  34. BuildRoot: %{_tmppath}/%{name}-buildroot
  35. BuildRequires: libX11-devel libXext-devel
  36. BuildRequires: bzip2 imlib2-devel zlib-devel freetype2-devel
  37. Requires: imlib2 imlib2-loader ImageMagick nkf xsri xinitrc
  38. %description
  39. Fluxbox is yet another windowmanager for X.
  40. It's based on the Blackbox 0.61.1 code.
  41. Fluxbox looks like blackbox and handles styles, colors, window
  42. placement and similar thing exactly like blackbox
  43. (100% theme/style compability).
  44. So what's the difference between fluxbox and blackbox then?
  45. The answer is: LOTS!
  46. Here is a list of features that fluxbox already has, or is in the works...
  47. %description -l ja
  48. fluxbox は X Window System 用の、一味違ったウィンドウマネージャです。
  49. それは blackbox-0.61.1 のプログラムコードをベースに開発されています。
  50. fluxbox は blackbox によく似ていて、スタイル、カラーリング、ウィンドウ
  51. の配置などを blackbox 同様に処理します。(スタイル(テーマ)は 100% 互換)
  52. では、fluxbox と blackbox の違いは? ... その答えは「いっぱい」!
  53. fluxbox に何が出来るか、今後何を計画しているのか?
  54. 詳しくは http://fluxbox.sourceforge.net/ をご覧下さい。
  55. %prep
  56. %__rm -rf %{buildroot}
  57. ##%%setup -T -n %{name}-%{version} -c
  58. %setup -q -a 1
  59. ##%__tar jxf %{SOURCE0}
  60. ##mv -f %{name}-%{FBversion}/* ./
  61. ##rm -rf %{name}-%{FBversion}
  62. %patch0 -p1
  63. ##%patch1 -p1
  64. ##%patch2 -p1
  65. %patch3 -p1
  66. %patch4 -p1
  67. %patch5 -p1
  68. %patch6 -p1
  69. %patch8 -p1
  70. %patch9 -p1
  71. %patch10 -p1
  72. ##%patch30 -p1
  73. %patch40 -p1
  74. %patch41 -p1
  75. ##%patch100 -p1
  76. %__tar jxf %{SOURCE1}
  77. %__tar jxf %{SOURCE2}
  78. %build
  79. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
  80. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
  81. FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
  82. ./configure --enable-nls \
  83. --prefix=%{_prefix} \
  84. --exec-prefix=%{_exec_prefix} \
  85. --bindir=%{_bindir} \
  86. --sbindir=%{_sbindir} \
  87. --sysconfdir=%{_sysconfdir} \
  88. --datadir=%{_datadir} \
  89. --includedir=%{_includedir} \
  90. --libdir=%{_libdir} \
  91. --libexecdir=%{_libexecdir} \
  92. --localstatedir=%{_localstatedir} \
  93. --sharedstatedir=%{_sharedstatedir} \
  94. --mandir=%{_mandir} \
  95. --infodir=%{_infodir}
  96. %__make
  97. %install
  98. %__rm -rf %{buildroot}
  99. # fluxbox installation
  100. make "DESTDIR=%{buildroot}" install
  101. %__rm data/styles/Makefile*
  102. %__cp -a data/styles %{buildroot}%{_datadir}/%{name}/
  103. %__cp -a data/styles2 %{buildroot}%{_datadir}/%{name}/
  104. %__cp -a data/backgrounds %{buildroot}%{_datadir}/%{name}/
  105. %__cp -a data/images %{buildroot}%{_datadir}/%{name}/
  106. %__cp -a data/UserMenu %{buildroot}%{_datadir}/%{name}/
  107. %__cp data/fb_welcome.sh %{buildroot}%{_datadir}/%{name}/
  108. %__cp data/*.html %{buildroot}%{_datadir}/%{name}/
  109. %__cp data/fluxbox.desktop.seed %{buildroot}%{_datadir}/%{name}/fluxbox.desktop
  110. %__cp data/*.sample %{buildroot}%{_datadir}/%{name}/
  111. %__cp data/fb_welcome %{buildroot}%{_datadir}/%{name}/
  112. %__cp data/cng_fbtips %{buildroot}%{_datadir}/%{name}/
  113. %__cp data/change-rootcmd %{buildroot}%{_datadir}/%{name}/
  114. %__cp data/change-init_rootcmd %{buildroot}%{_datadir}/%{name}/
  115. %__cp %{PATCH20} %{buildroot}%{_datadir}/%{name}/
  116. %__cp data/mk-rootcmds %{buildroot}%{_bindir}/
  117. %__cp data/fbumenu_gen-%{fbumenu_version} %{buildroot}%{_bindir}/fbumenu_gen
  118. %__cp ChangeLog %{buildroot}%{_datadir}/%{name}/
  119. # gdm session
  120. %__mkdir_p %{buildroot}%{_sysconfdir}/X11/dm/Sessions/
  121. %__cp %{buildroot}%{_datadir}/fluxbox/fluxbox.desktop %{buildroot}%{_sysconfdir}/X11/dm/Sessions/
  122. if [ -z "$DEBUG" ]; then
  123. strip %{buildroot}%{_bindir}/fluxbox \
  124. %{buildroot}%{_bindir}/fbsetroot \
  125. %{buildroot}%{_bindir}/fbrun
  126. fi
  127. bzip2 %{buildroot}%{_mandir}/man1/*.1
  128. %post
  129. local_lang=`echo $LANG | grep ja_JP`
  130. if ! [ -z "$local_lang" ]; then
  131. l_lang=`echo $LANG | grep ja_JP | cut -d '.' -f 2`
  132. case $l_lang in
  133. UTF-8)
  134. nkfopt="-w"
  135. ;;
  136. eucJP)
  137. nkfopt="-e"
  138. ;;
  139. esac
  140. fi
  141. if [ -n "`grep -n "startWM FluxBox fluxbox" /etc/X11/xinit/Xclients | grep "^43:"`" ]; then
  142. %__patch -p0 < %{_datadir}/%{name}/fluxbox-%{patchversion}.Xclients.patch
  143. elif [ -z "`grep "startWM" /etc/X11/xinit/Xclients | grep "startfluxbox$"`" ]; then
  144. cat << EOF | nkf $nkfopt
  145. 最新でない、改変された /etc/X11/xinit/Xclients が使われているようです。
  146. 起動コマンドを "fluxbox" ではなく "startfluxbox" に設定して下さい。
  147. EOF
  148. fi
  149. # New menu-system
  150. %__rm %{_datadir}/fluxbox/menu*
  151. %{_bindir}/fluxbox-generate_menu \
  152. -p %{_prefix} \
  153. -o %{_datadir}/fluxbox/menu 2> /dev/null
  154. cat << EOF | nkf $nkfopt
  155. * fluxbox-%{version} : インストール|アップグレードされました。*
  156. ※幾つかの更新が有ります。詳細は、
  157. file:///usr/share/fluxbox/flux_news.html
  158. を御覧下さい。
  159. EOF
  160. %clean
  161. %__rm -rf %{buildroot}
  162. %files
  163. %defattr(-,root,root,755)
  164. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
  165. %dir %{_datadir}/%{name}
  166. %{_bindir}/*
  167. %{_mandir}/*
  168. %{_datadir}/%{name}/*
  169. %{_sysconfdir}/X11/dm/Sessions/fluxbox.desktop
  170. %changelog
  171. * Fri Sep 19 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.1-1
  172. - new upstream release.
  173. - removed upstream patchs.
  174. - rewrote Vine documents.
  175. * Sat Sep 14 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-3
  176. - Applied upstream patchs.
  177. * Fri Sep 12 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-2
  178. - updated mk-rootcmds
  179. - updated vine documents. (keys.html, flux_news.html)
  180. * Thu Sep 11 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.1.0.1-1
  181. - new upstream release
  182. - removed fluxbox-%{FBversion}.nls-hh.patch
  183. - rewrote documents. (keys.html, flux_news.html)
  184. - added new default keys file
  185. * Sun Aug 24 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-6
  186. - fixed locale problem
  187. - rewrote scripts for eucJP and UTF-8
  188. - revived fluxbox-%{FBversion}.Xclients.patch. (for startx)
  189. * Sun Jun 22 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-5
  190. - add new style. (tux)
  191. * Mon Jun 16 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-3
  192. - corrected line gap of nls-header
  193. - (fluxbox-1.0.0.nls-hh.patch)
  194. * Tue May 27 2008 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-2
  195. - adjust startup sequence
  196. - (rewrite desktop entry file for dm sessions)
  197. - (remove fluxbox-%{FBversion}.Xclients.patch)
  198. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1
  199. - applied new versioning policy
  200. - rebuilt with xorg-x11 7.3
  201. - spec in UTF-8
  202. * Tue Dec 4 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl3, 4
  203. - retouch patchs for ja_JP.UTF-8 locale
  204. - : for root menu & help message
  205. - rewrite vine documents
  206. * Mon Oct 15 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0.0-0vl1, 2
  207. - new upstream 'stable' release
  208. - add new documents(styles tips, keys tips).
  209. - add new styles
  210. - update patch files, vine documents, vine scripts
  211. * Wed Apr 11 2007 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc3.1, 2
  212. - new upstream release
  213. - add rewrited system styles
  214. - update patch files
  215. - update vine documents
  216. * Sun Dec 24 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.3, 4
  217. - add BuildRequires: zlib-devel freetype2-devel
  218. - add Requires: xsri
  219. - Change wpsetter's priority (fbsetbg_setter_priority.patch)
  220. * Thu Jul 20 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc2.1, 2
  221. - new upstream release
  222. - update patch files
  223. - update vine documents
  224. * Thu Jul 6 2006 KATO Masashi <mkato@par.odn.ne.jp> 1.0-0vl0.rc0.1, 2
  225. - new upstream release
  226. - update patch files
  227. - added 'additional applications' extension to fluxbox-generate_menu
  228. * Tue Apr 8 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15.1-0vl1, 2
  229. - new upstream release
  230. - add 'init file rewrite' script for back-compatible
  231. - rewrite documents
  232. * Wed Mar 29 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.15-0vl1, 2
  233. - new upstream release
  234. - update *tips*
  235. - update patch files
  236. - add & update script files
  237. - update & retouch style files (VineStyle*, BlueStar*)
  238. - retouch menu structure (Vine tools)
  239. - add script for back compatible to background-style
  240. * Sun Mar 19 2006 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1.1, 2.2
  241. - update *_tips.html
  242. (retouch link errors)
  243. - retouch ja_JP/Translation.m
  244. - update menugen patch
  245. - update style file (VineStyle, BlueStar)
  246. - add index.html, scripts for 'wellcome'
  247. * Tue Oct 25 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.14-0vl1, 2
  248. - new upstream release
  249. - update vine patch
  250. (retouch init file for new spec.)
  251. - update vinefiles
  252. (update fbumenu_gen(usermenu generator))
  253. (update 2 style files for new spec.)
  254. (update fluxtips.txt)
  255. - update fluxbox_menu_tips.html
  256. * Sun Jun 5 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl3, 4
  257. - update vine patch
  258. (add some menu items to fluxbox-generate_menu)
  259. (retouch menu structure)
  260. (rewrite 'about menu')
  261. - update vinefiles
  262. (add usermenu generator to x-utilus)
  263. - update fluxbox_menu_tips.html
  264. * Fri May 27 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.13-0vl1
  265. - new upstream release
  266. - update vine patch
  267. (add some menu items to fluxbox-generate_menu)
  268. (extend 'about toolbar')
  269. - update nls-ja patch
  270. - update fluxtips.txt
  271. (rewrite, add '0.9.13 news')
  272. * Sun Feb 6 2005 KATO Masashi <mkato@par.odn.ne.jp> 0.9.12-0vl1
  273. - new upstream release
  274. - update vine patch
  275. (add some menu items to fluxbox-generate_menu)
  276. (include blackbox styles)
  277. (extend 'my_mail')
  278. (extend 'about menu')
  279. - add nls-ja patch
  280. * Sun Dec 12 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.11-0vl1
  281. - new upstream release
  282. - update vine patch
  283. (generate japanese menu)
  284. (add some menu items to fluxbox-generate_menu)
  285. (retouch menu structure)
  286. (fix menu backup problem)
  287. * Wed Nov 24 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.10-0vl1
  288. - new upstream release
  289. - update vine patch ( merged vine patches )
  290. - add font_locale patch ( Patch100 )
  291. - fix typo: s/buidroot/buildroot/g
  292. * Sun Jun 20 2004 KATO Masashi <mkato@par.odn.ne.jp> 0.9.9-0vl2
  293. - rewrite 2 styles (VineStyleII, BlueStarII)
  294. - rewrite fluxtips.txt(for 0.9.x)
  295. - modifying menu-generator
  296. (fix problems of 'can't generates some menus')
  297. (add some menu items)
  298. (Japanese help messages)
  299. - modifying 'init' file(default style, menu-alpha)
  300. - append sample of 'keys' file
  301. * Sun May 2 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.9-0vl1
  302. - new upstream release
  303. * Sun Mar 14 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl2
  304. - using rpm macros
  305. - fix nonexistent directory for styles in postscript
  306. - add BuildRequires: bzip2
  307. - drop Prefix tag
  308. * Sat Mar 6 2004 IWAI, Masaharu <iwai@alib.jp> 0.9.8-0vl1
  309. - new upstream release
  310. - update vine patch (Patch101)
  311. * Mon Aug 11 2003 IWAI, Masaharu <iwai@alib.jp> 0.1.14-1_0vl2
  312. - build for VineSeed
  313. - fix Group tag for VineLinux:
  314. Graphical desktop/Other -> User Interface/Desktops
  315. - add /usr/share/%%{name} directory in %%files section
  316. * Sat May 31 2003 KATO Masashi <mkato@par.odn.ne.jp> 0.1.14-1_0vl1
  317. - fluxbox for Vine Linux. Japanese menu enabled at default.
  318. - modified menu-generator patch (x-terminals)
  319. - modified init.in patch (date,workspace name,default style)
  320. - added 2 styles (VineStyle, BlueStar)
  321. * Mon Dec 9 2002 Han Boetes <han@mijncomputer.nl> 0.1.14-1
  322. - And we have a new release
  323. * Sun Dec 1 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-4
  324. - added only missing patch from bugfixpatch
  325. * Mon Nov 25 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-3
  326. - aa-startup- and openoffice-patch from Rathnor
  327. * Thu Nov 21 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-2
  328. - Fix locales patch
  329. * Tue Nov 19 2002 Han Boetes <han@linux-mandrake.com> 0.1.13-1
  330. - Bump
  331. * Fri Sep 13 2002 Han Boetes <han@linux-mandrake.com> 0.1.12-1
  332. - Bump
  333. * Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-3
  334. - Applied bugfix2 patch
  335. * Tue Sep 10 2002 Han Boetes <han@linux-mandrake.com> 0.1.11-2
  336. - Applied bugfix1 patch
  337. * Tue Sep 3 2002 Han Boetes <han@mijncomputer.nl> 0.1.11-1
  338. - Bump
  339. * Mon Jul 15 2002 Han Boetes <han@mijncomputer.nl> 0.1.10-1
  340. - Bump ;kudo's to Kurt Bechstein for recovering the rpm.
  341. * Mon Jun 3 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-2
  342. - Applied bugfix-patch 2
  343. * Sat May 25 2002 Han Boetes <han@mijncomputer.nl> 0.1.9-1
  344. - Version Bump
  345. - New menu-system
  346. * Thu May 9 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-4
  347. - Esthetic and Profilactic cleanups
  348. * Fri May 3 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-3
  349. - Applied bugfix-patch 1+2+3
  350. * Sat Apr 27 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-2
  351. - Applied bugfix-patch 1
  352. * Fri Apr 19 2002 Han Boetes <han@mijncomputer.nl> 0.1.8-1
  353. - Bump to version 0.1.8
  354. * Sat Mar 9 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-3
  355. - Applied patch 1
  356. * Wed Mar 6 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-2
  357. - Added DEBUG flavor
  358. * Fri Mar 1 2002 Han Boetes <han@mijncomputer.nl> 0.1.7-1
  359. - BUMP!
  360. * Thu Feb 07 2002 Christian Pelealu <chris@nerv-9.net> 0.1.6-3RH
  361. - Changed a lot of the build spec for RedHat 7.2
  362. * Tue Jan 29 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-3
  363. - Applied patch 2
  364. * Sun Jan 13 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-2
  365. - Applied patch.
  366. * Fri Jan 11 2002 Han Boetes <han@mijncomputer.nl> 0.1.6-1
  367. - Bump version.
  368. * Fri Dec 28 2001 Han Boetes <han@mijncomputer.nl> 0.1.5-1
  369. - Initial build