kdebindings-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707
  1. %define csharp 1
  2. %define falcon 0
  3. %define php 1
  4. %define ruby 1
  5. %define smoke 1
  6. %define java 0
  7. %define pykde4_akonadi 1
  8. %define pyqt4_version 4.7
  9. # Qt4 version auto-detection -- inagaki
  10. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
  11. %define mono_dir %{_prefix}/lib/mono
  12. #if 0%{?ruby}%{?smoke}
  13. #define devel 1
  14. #endif
  15. %global ruby_lib %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')
  16. %global ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
  17. %global ruby_sitelib %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
  18. %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  19. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  20. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  21. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  22. Name: kdebindings
  23. Summary: KDE bindings to non-C++ languages.
  24. Summary(ja): C++ 言語以外の KDE バインディング集
  25. Version: 4.5.1
  26. Release: 2%{?_dist_release}
  27. # http://techbase.kde.org/Policies/Licensing_Policy
  28. License: LGPLv2+
  29. Group: System Environment/Libraries
  30. URL: http://www.kde.org/
  31. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebindings-%{version}.tar.bz2
  32. ## upstreamable patches
  33. Patch50: kdebindings-4.5.1-RUBY_VERSION.patch
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: akonadi-devel >= 1.4.0
  36. BuildRequires: kdebase-workspace-devel >= %{version}
  37. # okular bindings
  38. BuildRequires: kdegraphics4-devel >= %{version}
  39. BuildRequires: kdelibs4-devel >= %{version}
  40. BuildRequires: kdepimlibs-devel >= %{version}
  41. # kdebindings does not support polkit-qt-1 yet
  42. %if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
  43. BuildRequires: polkit-qt-devel
  44. %endif
  45. BuildRequires: python-devel
  46. BuildRequires: PyQt4-devel >= %{pyqt4_version}
  47. BuildRequires: qimageblitz-devel
  48. BuildRequires: qscintilla-devel >= 2.4
  49. BuildRequires: soprano-devel
  50. %if %{csharp}
  51. BuildRequires: mono-core
  52. BuildRequires: mono-devel
  53. %endif
  54. %if %{falcon}
  55. BuildRequires: Falcon-devel >= 0.8.12
  56. %endif
  57. %if %{php}
  58. BuildRequires: php5-devel
  59. %endif
  60. %if %{ruby}
  61. BuildRequires: ruby-devel
  62. BuildRequires: ruby
  63. %endif
  64. %if %{java}
  65. # TODO: kross-java is a mess, not sure what it needs to build
  66. # CMakeLists.txt is also not portable (only gcj and i486 hardcoded)
  67. # -- mathstuf
  68. BuildRequires: java-1.6.0-openjdk-devel
  69. %endif
  70. Requires: kdelibs4 >= %{version}
  71. Conflicts: kdebindings < 4
  72. %description
  73. KDE bindings to non-C++ languages
  74. %description -l ja
  75. C++ 言語以外の KDE バインディング集です.
  76. %package devel
  77. Summary: Development files for kdebindings.
  78. Summary(ja): kdebindings の開発用ファイル
  79. Group: Development/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: kdelibs4-devel
  82. Conflicts: kdebindings-devel < 4
  83. %description devel
  84. Development files for the KDE bindings.
  85. Install kdebindings-devel if you want to develop non-KDE applications
  86. that talk to KDE.
  87. %package -n PyKDE4
  88. Summary: Python bindings for KDE4
  89. Summary(ja): KDE4 の Python バインディング
  90. Group: Development/Languages
  91. Requires: kdelibs4 >= %{version}
  92. Requires: PyQt4 >= %{pyqt4_version}
  93. %description -n PyKDE4
  94. %{summary}.
  95. %package -n PyKDE4-akonadi
  96. Summary: Akonadi runtime support for PyKDE4
  97. Summary(ja): PyKDE4 の Akonadi サポート
  98. Group: Development/Languages
  99. Requires: PyKDE4 = %{version}-%{release}
  100. Requires: kdepimlibs-akonadi >= %{version}
  101. %description -n PyKDE4-akonadi
  102. %{summary}.
  103. %package -n PyKDE4-devel
  104. Summary: Files needed to build PyKDE4-based applications
  105. Summary(ja): PyKDE4 を使用するアプリケーションのビルドに必要なファイル集
  106. Group: Development/Libraries
  107. Requires: PyQt4-devel
  108. Requires: PyKDE4 = %{version}-%{release}
  109. Requires: PyKDE4-akonadi = %{version}-%{release}
  110. %description -n PyKDE4-devel
  111. %{summary}.
  112. # C# bindings
  113. %if %{csharp}
  114. %package -n kimono
  115. Summary: C# bindings for KDE4
  116. Summary(ja): KDE4 の C# バインディング
  117. Group: Development/Languages
  118. Requires: kdelibs4 >= %{version}
  119. Requires: qyoto = %{version}-%{release}
  120. Provides: kimono4 = %{version}-%{release}
  121. %description -n kimono
  122. %{summary}.
  123. %package -n qyoto
  124. Summary: C# bindings for Qt4
  125. Summary(ja): Qt4 の C# バインディング
  126. Group: Development/Languages
  127. Requires: qt4 >= %{qt4_version}
  128. Provides: qyoto4 = %{version}-%{release}
  129. %description -n qyoto
  130. %{summary}.
  131. %package -n qyoto-devel
  132. Summary: Development files for qyoto
  133. Summary(ja): qyoto の開発用ファイル
  134. Group: Development/Libraries
  135. Requires: qyoto = %{version}-%{release}
  136. Requires: mono-devel
  137. Provides: qyoto4-devel = %{version}-%{release}
  138. %description -n qyoto-devel
  139. %{summary}.
  140. %endif
  141. # Ruby
  142. %if %{ruby}
  143. %package -n korundum
  144. Summary: Ruby bindings for KDE4
  145. Summary(ja): KDE4 の Ruby バインディング
  146. Group: Development/Languages
  147. Requires: kdelibs4 >= %{version}
  148. Requires: QtRuby = %{version}-%{release}
  149. Provides: korundum4 = %{version}-%{release}
  150. %description -n korundum
  151. %{summary}.
  152. %package -n korundum-devel
  153. Summary: Development files for korundum
  154. Summary(ja): korundum の開発用ファイル
  155. Group: Development/Libraries
  156. Requires: QtRuby-devel
  157. Requires: korundum = %{version}-%{release}
  158. Provides: korundum4-devel = %{version}-%{release}
  159. %description -n korundum-devel
  160. %{summary}.
  161. %package -n QtRuby
  162. Summary: Ruby bindings for Qt4
  163. Summary(ja): Qt4 の Ruby バインディング
  164. Group: Development/Languages
  165. Requires: qt4 >= %{qt4_version}
  166. Provides: QtRuby4 = %{version}-%{release}
  167. %description -n QtRuby
  168. %{summary}.
  169. %package -n QtRuby-devel
  170. Summary: Development files for QtRuby
  171. Summary(ja): QtRuby の開発用ファイル
  172. Group: Development/Libraries
  173. Requires: QtRuby = %{version}-%{release}
  174. Provides: QtRuby4-devel = %{version}-%{release}
  175. %description -n QtRuby-devel
  176. %{summary}.
  177. %endif
  178. %if %{php}
  179. %package -n php-qt
  180. Summary: PHP bindings for Qt4
  181. Summary(ja): Qt4 の PHP バインディング
  182. Group: Development/Languages
  183. Requires: qt4 >= %{qt4_version}
  184. Provides: php-qt4 = %{version}-%{release}
  185. %description -n php-qt
  186. %{summary}.
  187. %package -n php-qt-devel
  188. Summary: Development files for php-qt
  189. Summary(ja): php-qt の開発用ファイル
  190. Group: Development/Libraries
  191. Requires: php-qt = %{version}-%{release}
  192. Provides: php-qt4-devel = %{version}-%{release}
  193. %description -n php-qt-devel
  194. %{summary}.
  195. %endif
  196. %package -n kross-python
  197. Summary: Kross plugin for python
  198. Summary(ja): Python 向け Kross プラグイン
  199. Group: Development/Languages
  200. Requires: kdelibs4 >= %{version}
  201. Provides: kross(python) = %{version}-%{release}
  202. %description -n kross-python
  203. Python plugin for the Kross archtecture in KDE4.
  204. %description -n kross-python -l ja
  205. KDE 4 の Kross アーキテクチャ向け python プラグインです.
  206. %if %{ruby}
  207. %package -n kross-ruby
  208. Summary: Kross plugin for ruby
  209. Summary(ja): Ruby 向け Kross プラグイン
  210. Group: Development/Languages
  211. Requires: ruby
  212. Requires: kdelibs4 >= %{version}
  213. Provides: kross(ruby) = %{version}-%{release}
  214. %description -n kross-ruby
  215. Ruby plugin for the Kross archtecture in KDE4.
  216. %description -n kross-ruby -l ja
  217. KDE 4 の Kross アーキテクチャ向け ruby プラグインです.
  218. %endif
  219. %if %{falcon}
  220. %package -n kross-falcon
  221. Summary: Kross plugin for falcon
  222. Summary(ja): Falcon 向け Kross プラグイン
  223. Group: Development/Languages
  224. Requires: Falcon >= 0.8.12
  225. Requires: kdelibs4 >= %{version}
  226. Provides: kross(falcon) = %{version}-%{release}
  227. %description -n kross-falcon
  228. Falcon plugin for the Kross archtecture in KDE4.
  229. %description -n kross-falcon -l ja
  230. KDE 4 の Kross アーキテクチャ向け falcon プラグインです.
  231. %endif
  232. %prep
  233. %setup -q -n kdebindings-%{version}
  234. %patch50 -p1 -b .RUBY_VERSION
  235. %build
  236. mkdir -p %{_target_platform}
  237. pushd %{_target_platform}
  238. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  239. %cmake \
  240. -DCMAKE_BUILD_TYPE=release \
  241. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  242. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  243. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  244. -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
  245. -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
  246. -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
  247. %if %{csharp}
  248. -DENABLE_QYOTO=ON \
  249. %else
  250. -DBUILD_csharp=OFF \
  251. %endif
  252. %if %{falcon}
  253. -DENABLE_KROSSFALCON=ON \
  254. %else
  255. -DBUILD_falcon=OFF \
  256. %endif
  257. %if %{php}
  258. -DENABLE_PHP-QT=ON \
  259. %else
  260. -DBUILD_php=OFF \
  261. %endif
  262. %if %{ruby}
  263. -DRUBY_SITE_LIB_DIR:PATH=%{ruby_sitelib} \
  264. -DRUBY_SITE_ARCH_DIR:PATH=%{ruby_sitearch} \
  265. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
  266. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
  267. %else
  268. -DBUILD_ruby=OFF \
  269. %endif
  270. %if %{smoke}
  271. -DENABLE_SMOKE=ON \
  272. %else
  273. -DBUILD_smoke=OFF \
  274. %endif
  275. %if %{java}
  276. -DENABLE_KROSSJAVA=ON \
  277. %else
  278. -DBUILD_java=OFF \
  279. %endif
  280. -DCMAKE_SKIP_RPATH:BOOL=OFF \
  281. -DBUILD_perl=OFF \
  282. ..
  283. popd
  284. # -DRUBY_INCLUDE_PATH:PATH=%{ruby_arch} \
  285. # smp build not recommended (upstream)
  286. make -C %{_target_platform}
  287. %install
  288. rm -rf $RPM_BUILD_ROOT
  289. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  290. # HACK: fix multilb conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
  291. rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  292. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
  293. $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  294. ln -s %{_bindir}/pykdeuic4 \
  295. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
  296. # install pykde4 examples under correct dir
  297. #mkdir -p %{buildroot}%{_docdir}
  298. #rm -f %{buildroot}%{_datadir}/kde4/apps/pykde4/examples/*.py?
  299. #mv %{buildroot}%{_datadir}/kde4/apps/pykde4 %{buildroot}%{_docdir}/
  300. # bz#551534 - qyoto doesn't pull mono in
  301. %if %{csharp}
  302. find %{buildroot} -name \*.dll -not -type l | xargs chmod ugo+x
  303. %endif
  304. %clean
  305. rm -rf $RPM_BUILD_ROOT
  306. %post -p /sbin/ldconfig
  307. %postun -p /sbin/ldconfig
  308. %pre -n PyKDE4-devel
  309. if [ -d %{_bindir}/pykdeuic4 ]; then
  310. rm -rf %{_bindir}/pykdeuic4/
  311. fi
  312. %if %{csharp}
  313. %post -n qyoto -p /sbin/ldconfig
  314. %postun -n qyoto -p /sbin/ldconfig
  315. %endif
  316. %files
  317. %defattr(-,root,root)
  318. %doc AUTHORS ChangeLog COPYING NEWS README
  319. %if %{smoke}
  320. %{_libdir}/libsmoke*.so.*
  321. %endif
  322. %files devel
  323. %defattr(-,root,root)
  324. %if %{smoke}
  325. %{_bindir}/smoke*
  326. %{_includedir}/smoke.h
  327. %{_includedir}/smoke
  328. %{_includedir}/smokegen
  329. %{_libdir}/libcppparser.so
  330. %{_libdir}/libsmoke*.so
  331. %dir %{_libdir}/smokegen
  332. %{_libdir}/smokegen/*.so
  333. %{_datadir}/smokegen
  334. %endif
  335. %files -n PyKDE4
  336. %defattr(-,root,root,-)
  337. %doc COPYING
  338. %{python_sitearch}/PyKDE4
  339. %{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
  340. %dir %{_datadir}/kde4/apps/pykde4
  341. %{_libdir}/kde4/kpythonpluginfactory.so
  342. %exclude %{python_sitearch}/PyKDE4/akonadi.so
  343. %files -n PyKDE4-akonadi
  344. %defattr(-,root,root,-)
  345. %{python_sitearch}/PyKDE4/akonadi.so
  346. %files -n PyKDE4-devel
  347. %defattr(-,root,root,-)
  348. %{_bindir}/pykdeuic4
  349. %{python_sitearch}/PyQt4/uic/pykdeuic4.py*
  350. %{_datadir}/kde4/apps/pykde4/examples/
  351. %{_datadir}/sip/PyKDE4
  352. %if %{csharp}
  353. %files -n kimono
  354. %defattr(-,root,root,-)
  355. %{_libdir}/kde4/kimonopluginfactory.so
  356. %{_libdir}/libakonadi-sharp.so
  357. %{_libdir}/libkhtml-sharp.so
  358. %{_libdir}/libkimono.so
  359. %{_libdir}/libktexteditor-sharp.so
  360. %{_libdir}/libnepomuk-sharp.so
  361. %{_libdir}/libphonon-sharp.so
  362. %{_libdir}/libplasma-sharp.so
  363. %{_libdir}/libqimageblitz-sharp.so
  364. %{_libdir}/libqscintilla-sharp.so
  365. %{_libdir}/libsoprano-sharp.so
  366. %{mono_dir}/qyoto/qimageblitz.dll
  367. %{mono_dir}/qyoto/akonadi.dll
  368. %{mono_dir}/qyoto/kde-dotnet.dll
  369. %{mono_dir}/qyoto/khtml-dll.dll
  370. %{mono_dir}/qyoto/ktexteditor-dotnet.dll
  371. %{mono_dir}/qyoto/nepomuk-dll.dll
  372. %{mono_dir}/qyoto/phonon.dll
  373. %{mono_dir}/qyoto/plasma-dll.dll
  374. %{mono_dir}/qyoto/qscintilla.dll
  375. %{mono_dir}/qyoto/soprano.dll
  376. %{mono_dir}/gac/akonadi
  377. %{mono_dir}/gac/kde-dotnet
  378. %{mono_dir}/gac/khtml-dll
  379. %{mono_dir}/gac/ktexteditor-dotnet
  380. %{mono_dir}/gac/nepomuk-dll
  381. %{mono_dir}/gac/phonon
  382. %{mono_dir}/gac/plasma-dll
  383. %{mono_dir}/gac/qscintilla
  384. %{mono_dir}/gac/soprano
  385. %{mono_dir}/gac/qimageblitz
  386. %{_datadir}/kde4/apps/plasma_scriptengine_kimono
  387. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  388. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  389. %files -n qyoto
  390. %defattr(-,root,root,-)
  391. %{_libdir}/libqtscript-sharp.so
  392. %{_libdir}/libqttest-sharp.so
  393. %{_libdir}/libqtuitools-sharp.so
  394. %{_libdir}/libqtwebkit-sharp.so
  395. %{_libdir}/libqyoto.so.*
  396. %{mono_dir}/qyoto/qt-dotnet.dll
  397. %{mono_dir}/qyoto/qtscript.dll
  398. %{mono_dir}/qyoto/qttest.dll
  399. %{mono_dir}/qyoto/qtuitools.dll
  400. %{mono_dir}/qyoto/qtwebkit.dll
  401. %{mono_dir}/gac/qt-dotnet
  402. %{mono_dir}/gac/qtscript
  403. %{mono_dir}/gac/qttest
  404. %{mono_dir}/gac/qtuitools
  405. %{mono_dir}/gac/qtwebkit
  406. %files -n qyoto-devel
  407. %defattr(-,root,root,-)
  408. %{_bindir}/csrcc
  409. %{_bindir}/uics
  410. %{_includedir}/qyoto
  411. %{_libdir}/libqyoto.so
  412. %{_libdir}/pkgconfig/*
  413. %endif
  414. %if %{ruby}
  415. %files -n korundum
  416. %defattr(-,root,root,-)
  417. %{_bindir}/krubyapplication
  418. %{ruby_lib}/KDE/
  419. %{ruby_lib}/akonadi/
  420. %{ruby_lib}/khtml/
  421. %{ruby_lib}/kio/
  422. %{ruby_lib}/ktexteditor/
  423. %{ruby_lib}/okular/
  424. %{ruby_lib}/phonon/
  425. %{ruby_lib}/qscintilla/
  426. %{ruby_lib}/solid/
  427. %{ruby_lib}/soprano/
  428. %{ruby_lib}/nepomuk/
  429. %{ruby_arch}/akonadi.so
  430. %{ruby_arch}/khtml.so
  431. %{ruby_arch}/kio.so
  432. %{ruby_arch}/korundum4.so
  433. %{ruby_arch}/ktexteditor.so
  434. %{ruby_arch}/okular.so
  435. %{ruby_arch}/phonon.so
  436. %{ruby_arch}/plasma_applet.so
  437. %{ruby_arch}/solid.so
  438. %{ruby_arch}/soprano.so
  439. %{ruby_arch}/nepomuk.so
  440. %{ruby_arch}/qscintilla.so
  441. %{_libdir}/kde4/krubypluginfactory.so
  442. %{_datadir}/applications/kde4/dbpedia_references.desktop
  443. %{_datadir}/kde4/apps/dbpedia_references
  444. %files -n korundum-devel
  445. %defattr(-,root,root,-)
  446. %{_bindir}/rbkconfig_compiler4
  447. %{_includedir}/qtruby/
  448. %exclude %{_libdir}/libqtruby4shared.so
  449. %files -n QtRuby
  450. %defattr(-,root,root,-)
  451. %{ruby_lib}/Qt/
  452. %{ruby_lib}/Qt*.rb
  453. %{ruby_lib}/qtscript/
  454. %{ruby_lib}/qttest/
  455. %{ruby_lib}/qtuitools/
  456. %{ruby_lib}/qtwebkit/
  457. %{ruby_arch}/qt*.so
  458. %{_libdir}/libqtruby4shared.so.2
  459. %{_libdir}/libqtruby4shared.so.2.0.0
  460. %files -n QtRuby-devel
  461. %defattr(-,root,root,-)
  462. %{_bindir}/rbqtapi
  463. %{_bindir}/rbrcc
  464. %{_bindir}/rbuic4
  465. %{_libdir}/libqtruby4shared.so
  466. %endif
  467. %if %{php}
  468. %files -n php-qt
  469. %defattr(-,root,root,-)
  470. %{_libdir}/php5/php_qt.so
  471. %files -n php-qt-devel
  472. %defattr(-,root,root,-)
  473. %{_bindir}/phpuic
  474. %endif
  475. %files -n kross-python
  476. %defattr(-,root,root,-)
  477. # unversioned library
  478. %{_libdir}/kde4/krosspython.so
  479. %if %{ruby}
  480. %files -n kross-ruby
  481. %defattr(-,root,root,-)
  482. %{_libdir}/kde4/krossruby.so
  483. %endif
  484. %if %{falcon}
  485. %files -n kross-falcon
  486. %defattr(-,root,root,-)
  487. %{_libdir}/kde4/krossfalcon.so
  488. %endif
  489. %changelog
  490. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
  491. - rebuilt with rpm-4.8.1 for pkg-config
  492. * Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  493. - new upstream release
  494. - added Patch50
  495. - added more japanese summaries
  496. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  497. - new upstream release
  498. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  499. - new upstream release
  500. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  501. - new upstream release
  502. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  503. - new upstream release
  504. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  505. - new upstream release
  506. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  507. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  508. - built with new toolchain
  509. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  510. - new upstream release
  511. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  512. - merged 4.3.1-2 %changelog
  513. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  514. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  515. - use %%{_prefix}/lib for mono-dll (for x86_64)
  516. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  517. - new upstream release
  518. - built with PyQt4-4.6
  519. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  520. - define %%{mono_dir} to specify mono library install path
  521. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  522. - new upstream release
  523. - fixed ruby modules installation path
  524. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  525. - new upstream release
  526. - spilt sub package based on Fedora
  527. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  528. - applied new versioning policy
  529. - added Patch1
  530. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  531. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  532. - added --with-qt-libraries option
  533. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  534. - rebuild for VineSeed
  535. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  536. - new upstream release
  537. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  538. - rebuild for VineSeed
  539. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  540. - new upstream release
  541. - update Patch0
  542. - drop Patch1
  543. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  544. - new upstream release
  545. - add Patch1
  546. - add --enable-libsuffix option
  547. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  548. - rebuild for VineSeed
  549. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  550. - new upstream release
  551. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  552. - rebuild for VineSeed
  553. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  554. - new upstream release
  555. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  556. - rebuild for VineSeed
  557. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  558. - new upstream release
  559. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  560. - rebuild for VineSeed
  561. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  562. - new upstream release
  563. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  564. - rebuild for VineSeed
  565. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  566. - new upstream release
  567. - renew BuildPrereq and build section
  568. - renew %%files
  569. - enable python
  570. - change spec to make main and devel package
  571. - add BuildPrereq: ruby ruby-devel
  572. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  573. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  574. - build for VineSeed
  575. - disable python and mozilla
  576. - objprelink (i386 only)
  577. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  578. - 2.2.2
  579. - build kmozilla binding only on x86/alpha
  580. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  581. - Make sure %%{name}-kmozilla isn't built on ia64
  582. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  583. - Move python bindings to separate package
  584. - Add perl bindings
  585. - Shut up rpmlint
  586. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  587. - 2.1
  588. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  589. - initial RPM