libindi-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133
  1. Name: libindi
  2. Summary: Instrument Neutral Distributed Interface
  3. Version: 0.6.2
  4. Release: 2%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: LGPLv2+ and GPLv2+
  7. # The code is LGPLv2+ except:
  8. # some files for v4l2 conversion under libs/webcam are GPLv2+
  9. # drivers/video/stvdriver (indi_stv driver) appears to contain GPL code
  10. # upstream bug https://sourceforge.net/tracker2/?func=detail&aid=2572902&group_id=90275&atid=593019
  11. URL: http://indi.sourceforge.net/
  12. %define majorver 0
  13. Source0: http://downloads.sourceforge.net/indi/%{name}_%{version}.tar.gz
  14. Patch0: libindi-suffix.patch
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: cmake
  17. BuildRequires: cfitsio-devel >= 3.03
  18. BuildRequires: libfli-devel
  19. BuildRequires: libnova-devel >= 0.12.1
  20. BuildRequires: zlib-devel
  21. Conflicts: kdeedu3
  22. %description
  23. INDI is a distributed control protocol designed to operate
  24. astronomical instrumentation. INDI is small, flexible, easy to parse,
  25. and scalable. It supports common DCS functions such as remote control,
  26. data acquisition, monitoring, and a lot more.
  27. %package devel
  28. Summary: Libraries, includes, etc. used to develop an application with %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Provides: libindi-static = %{version}-%{release}
  32. %description devel
  33. These are the header files needed to develop a %{name} application
  34. %prep
  35. %setup -q -n %{name}-%{version}
  36. %patch0 -p1
  37. #patch1 -p1
  38. %build
  39. mkdir -p %{_target_platform}
  40. pushd %{_target_platform}
  41. CFLAGS="${CFLAGS:-%optflags}" \
  42. CXXFLAGS="${CXXFLAGS:-%optflags}" \
  43. FFLAGS="${FFLAGS:-%optflags}" \
  44. %cmake \
  45. -DCMAKE_BUILD_TYPE=release \
  46. -DDATA_INSTALL_DIR:PATH=%{_datadir} \
  47. ..
  48. popd
  49. make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
  50. %install
  51. rm -fr %{buildroot}
  52. make install DESTDIR=%{buildroot} -C %{_target_platform}
  53. %clean
  54. rm -fr %{buildroot}
  55. %post -p /sbin/ldconfig
  56. %postun -p /sbin/ldconfig
  57. %files
  58. %defattr(-,root,root,-)
  59. %doc AUTHORS ChangeLog COPYING.LIB LICENSE README README.drivers README.robofocus
  60. %{_bindir}/*
  61. %{_libdir}/*.so.*
  62. %{_datadir}/indi
  63. %files devel
  64. %defattr(-,root,root,-)
  65. %doc README COPYING.LIB LICENSE
  66. %{_includedir}/*
  67. %{_libdir}/*.so
  68. %{_libdir}/*.a
  69. %{_libdir}/pkgconfig/*.pc
  70. %changelog
  71. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.3-1
  72. - rebuilt with rpm-4.8.1 for pkg-config
  73. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6.2-1
  74. - new upstream release
  75. - updated Patch0
  76. * Wed Jul 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-12
  77. - added Conflicts: kdeedu3
  78. * Sat Apr 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-11
  79. - rebuilt with new toolchain and libnova-0.13
  80. * Sat Sep 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.6-10
  81. - use %%cmake macro
  82. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.6-9
  83. - Inisital build for Vine Linux
  84. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-8
  85. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  86. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-7
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  88. * Wed Feb 18 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-6
  89. - Provides libindi-static
  90. * Tue Feb 17 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-5
  91. - Need to provide the static library libindidriver.a to build indi-apogee
  92. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-4
  93. - Fixed patch to find cfitsio
  94. * Sat Feb 14 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-3
  95. - Patch to detect cfitsio in all architectures
  96. * Fri Feb 06 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-2
  97. - Commands (rm, make) instead of macros
  98. - Upstream bug about licenses (GPLv2 missing)
  99. - Upstream bug about libindi calling exit
  100. * Mon Jan 28 2009 Sergio Pascual <sergiopr at fedoraproject.org> - 0.6-1
  101. - First version