self-build-vlc-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333
  1. %define pkgname vlc
  2. %define name self-build-%{pkgname}
  3. %define version 1.1.5
  4. %define release 1%{?_dist_release}
  5. %if %{?_dist_release} == "vl4"
  6. ## dummy echo
  7. echo This package cannot build on Vine Linux 4.2.
  8. exit 1
  9. %endif
  10. %define with_mozilla 0
  11. %define with_dc1394 0
  12. %define with_directfb 1
  13. %define with_samba 0
  14. %define sourceurl0 http://download.videolan.org/pub/videolan/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.bz2
  15. Summary: Package to automatically build %{pkgname} rpm package
  16. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  17. Name: %{name}
  18. Version: %{version}
  19. Release: %{release}
  20. Obsoletes: vlc < 1.1.0
  21. Obsoletes: vlc-devel < 1.1.0
  22. Source0: %{pkgname}-vl.spec
  23. Source100: vlc-1.1.0-vlc-cache-gen_noerror.patch
  24. Source101: 0001-Libnotify-depends-on-a-gtk.patch
  25. Source103: vlc-1.1.4-hardode_font_patch.patch
  26. Source104: vlc-1.1.4-tls_path.patch
  27. License: GPLv2+
  28. Group: Restricted Software
  29. Requires(post): self-build-setup >= 0.9.9
  30. Requires(post): desktop-file-utils
  31. Requires(post): gettext
  32. Requires(post): gettext-devel
  33. Requires(post): libtool
  34. Requires(post): aalib-devel
  35. Requires(post): alsa-lib-devel
  36. Requires(post): avahi-devel
  37. Requires(post): cdparanoia-devel
  38. Requires(post): dbus-devel
  39. %{?_with_dirac: Requires(post): dirac-devel >= 1.0.0}
  40. %if %with_directfb
  41. Requires(post): libdirectfb-devel
  42. %endif
  43. Requires(post): flac-devel
  44. Requires(post): fribidi-devel
  45. Requires(post): gnome-vfs2-devel
  46. Requires(post): gnutls-devel >= 1.0.17
  47. Requires(post): gsm-devel
  48. Requires(post): hal-devel
  49. Requires(post): jack-audio-connection-kit-devel
  50. Requires(post): libavc1394-devel
  51. Requires(post): libcdio-devel >= 0.77-3
  52. Requires(post): libdv-devel
  53. Requires(post): libdvdread-devel
  54. Requires(post): libebml-devel
  55. Requires(post): libid3tag-devel
  56. %{?_with_kate: Requires(post): libkate-devel}
  57. Requires(post): libmatroska-devel >= 0.7.6
  58. Requires(post): libmpcdec-devel
  59. Requires(post): libmtp-devel
  60. Requires(post): libnotify-devel
  61. Requires(post): librsvg2-devel >= 2.5.0
  62. Requires(post): libshout-devel
  63. Requires(post): libsmbclient-devel
  64. Requires(post): libtheora-devel
  65. Requires(post): libtiff-devel
  66. Requires(post): libupnp-devel
  67. Requires(post): libv4l-devel
  68. Requires(post): libvorbis-devel
  69. Requires(post): libxml2-devel
  70. Requires(post): lirc
  71. Requires(post): kernel-headers >= 2.6.20
  72. Requires(post): libmusicbrainz-devel
  73. Requires(post): lua-devel
  74. Requires(post): ncurses-devel
  75. Requires(post): openslp-devel
  76. Requires(post): qt4-devel
  77. Requires(post): SDL_image-devel
  78. Requires(post): speex-devel >= 1.1.5
  79. %ifarch %{ix86} x86_64
  80. Requires(post): svgalib-devel
  81. %endif
  82. Requires(post): taglib-devel
  83. Requires(post): twolame-devel
  84. Requires(post): xosd-devel
  85. Requires(post): zlib-devel
  86. # X-libs
  87. Requires(post): libXt-devel
  88. Requires(post): libXv-devel
  89. Requires(post): libXxf86vm-devel
  90. Requires(post): libX11-devel
  91. Requires(post): libXext-devel
  92. Requires(post): libXpm-devel
  93. %ifarch %{ix86} x86_64
  94. Requires(post): libXvMC-devel
  95. %endif
  96. Requires(post): xorg-x11-proto-devel
  97. %if %with_samba
  98. Requires(post): samba-libsmbclient-devel
  99. %endif
  100. Requires(post): pulseaudio-libs-devel >= 0.9.8
  101. %if %with_mozilla
  102. Requires(post): gecko-devel
  103. Requires(post): nspr-devel
  104. %endif
  105. Requires(post): libraw1394-devel
  106. Requires: TrueType-dejavu
  107. ## vine
  108. %if %{?_dist_release} == "vl6"
  109. Requires(post): libva-devel
  110. %endif
  111. Requires(post): libgcrypt-devel
  112. Requires(post): wx-gtk2-devel
  113. Requires: mesa-libGL
  114. Requires(post): xorg-x11-devel
  115. Requires(post): mesa-libGL-devel
  116. Requires(post): self-build-libmpeg2
  117. Requires(post): self-build-a52dec
  118. Requires(post): self-build-faac
  119. Requires(post): self-build-faad2
  120. Requires(post): self-build-ffmpeg >= 0.4.9
  121. Requires(post): self-build-libdca
  122. Requires(post): self-build-libdvbpsi
  123. Requires(post): self-build-libdvdnav
  124. Requires(post): self-build-libmad
  125. Requires(post): self-build-libmp4v2
  126. Requires(post): self-build-x264 >= 0.0.0-9.20090522
  127. Requires(post): self-build-xvidcore
  128. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  129. Packager: munepi
  130. %description
  131. VLC (initially VideoLAN Client) is a highly portable multimedia player
  132. for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX,
  133. mp3, ogg, ...) as well as DVDs, VCDs, and various streaming protocols.
  134. It can also be used as a server to stream in unicast or multicast in
  135. IPv4 or IPv6 on a high-bandwidth network.
  136. [Note]
  137. This package requires many other packages to compile
  138. targetsoftware. So it consume more disk space than usual.
  139. Also installation takes logner time because of compilation.
  140. (This will take a few minutes to quarter or half of an hour,
  141. depends on building environment)
  142. [About self-build package]
  143. For some kind of software, distributing of binary package
  144. may viorate the patent or law. Therefore we chose self-build
  145. packge, create binary package on your machine, for such kind
  146. of softwares instead of distributing binary package.
  147. Please obey the national law when you use the created binary
  148. packages. And if you want to use the softwares using patented
  149. thechnology, it may be required to get a permission, make an
  150. agreement or purchas a license. Please consider it with your
  151. purpose or way of use and take appropriate action.
  152. %description -l ja
  153. VLC(初期は VideoLAN Client)は高い可搬性のあるマルチメディアプレーヤーで,
  154. 様々なオーディオおよびビデオフォーマット(MPEG-1, MPEG-2, MPEG-4, DivX,
  155. mp3, ogg など)だけでなく,DVD や VCD,様々なストリーミングプロトコルにも
  156. 対応しています.
  157. また,高帯域幅上の IPv4 や IPv6 で,
  158. ユニキャストやマルチキャストのストリームに,
  159. サーバーとして使用することもできます.
  160. このパッケージをインストールすると、自動的にソースコードを
  161. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  162. の rpm パッケージを作成します。
  163. また apt-get コマンドや synaptic パッケージマネージャから実行
  164. した場合は、作成された rpm パッケージのインストールも自動的に
  165. 行います。
  166. [注意]
  167. コンパイルに必要な多くの関連パッケージを要求するので通常より
  168. ディスクの領域を多く消費します。
  169. またインストール時にコンパイルを行うため、通常より時間がかか
  170. る場合があります。(環境にもよりますが数分から数十分程度)
  171. [self-build パッケージについて]
  172. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  173. 違反する可能性があるものがあります。その為、このような問題が
  174. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  175. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  176. ジという方法を採っています。
  177. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  178. アのライセンス、および利用する国の各種法令に従ってください。
  179. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  180. センスの購入などが必要となる場合がありますので、利用する目的
  181. や形態に応じて各自で判断し適切な対応を取ってください。
  182. %prep
  183. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  184. %install
  185. %{__rm} -rf ${RPM_BUILD_ROOT}
  186. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  187. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  188. %{__install} -m 644 \
  189. %{SOURCE100} %{SOURCE101} %{SOURCE103} %{SOURCE104} \
  190. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  191. %clean
  192. %{__rm} -rf ${RPM_BUILD_ROOT}
  193. %posttrans
  194. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 1216000
  195. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  196. %{pkgname}-devel-%{version}-%{release}
  197. %files
  198. %defattr(-,root,root)
  199. %{_datadir}/%{name}
  200. %changelog
  201. * Sun Nov 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.5-1
  202. - new upstream release
  203. * Mon Aug 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
  204. - new upstream release
  205. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.2-1
  206. - new upstream release
  207. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-2
  208. - for only vl6, supported libva
  209. - set Obsoletes: vlc < 1.1.0 vlc-devel < 1.1.0
  210. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0-1
  211. - new upstream release
  212. - added Requires(post): libva-devel
  213. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-3
  214. - renamed %%{Source0} to vlc-vl.spec
  215. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-2
  216. - added Requires(post): libsmbclient-devel
  217. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.5-1
  218. - new upstream release
  219. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-2
  220. - built with libdvbpsi-devel
  221. - dropped 0002-Default-aout-for-pulse.patch
  222. * Tue Jan 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.4-1
  223. - new upstream release
  224. - updated 0002-Default-aout-for-pulse.patch
  225. * Tue Nov 10 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-2
  226. - added Requires(post): libmtp-devel
  227. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.3-1
  228. - new upstream release
  229. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-2
  230. - rebuilt to add signature
  231. * Sat Sep 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.2-1
  232. - new upstream release
  233. - applied vlc-1.0.2-compiler.patch from RPM Fusion
  234. - added Requires(post): lua-devel
  235. * Sat Aug 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.1-1
  236. - new upstream release
  237. * Sat Jul 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-2
  238. - added Obsoletes: vlc < 1.0.0, vlc-devel < 1.0.0
  239. * Wed Jul 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0.0-1
  240. - new upstream release
  241. - clean-up some old patches and merged some patches from RPM Fusion package
  242. - added vlc-trunk-default_font-vine.patch
  243. - added vlc-handlers.schemas
  244. - Gonf2 url-handler support
  245. - added shine.c, enc_base.h
  246. - missing sources
  247. - check version between original spec and self-build spec in %%prep
  248. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.9a-3
  249. - dropped BuildArch: noarch (with svglib-devel for %%{ix86} x86_64)
  250. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-2
  251. - rebuild with x264 >= 0.0.0-9.20090522
  252. - avoided to execute self-build-rpm.sh on RPM transaction
  253. - moved %%post actions to %%posttrans
  254. * Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.9a-1
  255. - new upstream release
  256. - added BuildArch: noarch
  257. - s/TrueType-DejaVu/TrueType-dejavu/
  258. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 0.9.8a-7
  259. - corrected release number in vlc.spec
  260. - dropped ExclusiveArch
  261. * Fri Feb 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.8a-6
  262. - add ppc to ExclusiveArch
  263. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-5
  264. - changed to PreReq: self-build-faad2 from faad2-devel
  265. - changed to PreReq: self-build-libmad from libmad-devel
  266. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.9.8a-4
  267. - initial build
  268. ### end of file