qjson-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. Name: qjson
  2. Summary: A qt-based library that maps JSON data to QVariant objects
  3. Version: 0.7.1
  4. Release: 5%{?_dist_release}
  5. Group: System Environment/Libraries
  6. License: GPLv2+
  7. URL: http://sourceforge.net/projects/qjson/
  8. Source0: http://downloads.sourceforge.net/project/qjson/qjson/0.7.1/%{name}-%{version}.tar.bz2
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: cmake >= 2.6
  11. BuildRequires: qt4-devel
  12. BuildRequires: doxygen
  13. %description
  14. JSON is a lightweight data-interchange format. It can represents integer, real
  15. number, string, an ordered sequence of value, and a collection of
  16. name/value pairs.QJson is a qt-based library that maps JSON data to
  17. QVariant objects.
  18. %package devel
  19. Summary: Development files for qjson
  20. Summary(ja): qjson の開発用ファイル
  21. Group: Development/Libraries
  22. Requires: %{name} = %{version}-%{release}
  23. Requires: qt4-devel
  24. %description devel
  25. The %{name}-devel package contains the libraries and header files required for
  26. developing applications that use %{name}.
  27. %prep
  28. %setup -qn qjson
  29. %build
  30. mkdir -p %{_target_platform}
  31. pushd %{_target_platform}
  32. %cmake -DQJSON_BUILD_TESTS=1 \
  33. -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules/ \
  34. ..
  35. cd %{_builddir}/%{buildsubdir}/doc
  36. doxygen
  37. popd
  38. sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
  39. -e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
  40. -e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
  41. make %{?_smp_mflags} -C %{_target_platform}
  42. %install
  43. rm -rf %{buildroot}
  44. make install DESTDIR=%{buildroot} -C %{_target_platform}
  45. %check
  46. LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
  47. %{_target_platform}/tests/testparser
  48. LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
  49. %{_target_platform}/tests/testserializer
  50. %clean
  51. rm -rf %{buildroot}
  52. %post -p /sbin/ldconfig
  53. %postun -p /sbin/ldconfig
  54. %files
  55. %defattr(-,root,root,-)
  56. %doc COPYING
  57. %{_libdir}/*.so.*
  58. %files devel
  59. %defattr(-,root,root,-)
  60. %doc doc/html
  61. %{_includedir}/qjson/
  62. %{_libdir}/pkgconfig/*.pc
  63. %{_datadir}/cmake/Modules/FindQJSON.cmake
  64. %{_libdir}/*.so
  65. %changelog
  66. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-5
  67. - rebuilt with rpm-4.8.1
  68. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-4
  69. - re-fixed CMAKE_MODULES_INSTALL_DIR
  70. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-3
  71. - fixed CMAKE_MODULES_INSTALL_DIR
  72. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
  73. - initial build for Vine Linux
  74. * Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
  75. -0.7.1
  76. - Version upgrade
  77. - Fixed doxygen documentation (Thanks again Orcan)
  78. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
  79. -0.6.3
  80. - Fixed capitalization of the summary
  81. * Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
  82. -0.6.3
  83. - Moved Doxygen docs to the development package.
  84. - Corrected placement of the cmake project file (Thanks Orcan)
  85. - Fixed the running of the build tests
  86. - Corrected column length of the descriptions
  87. - Changed description of the devlepment package
  88. * Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
  89. -0.6.3
  90. - Additional placment of library files fix
  91. * Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
  92. -0.6.3
  93. - Fixed placment of library files
  94. - Activated build tests
  95. - Corrected ownership of include directory
  96. - Corrected dependacies
  97. - Added doxygen documentation
  98. - Fixed reported version in the changelogs
  99. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
  100. -0.6.3
  101. - Split off development libraries to its own package
  102. - Modified licensing in spec file to reflect GPL2 code though docs state that qjson
  103. - licensed under LPGL
  104. - Uncommeted and corrected sed line in this spec file
  105. * Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
  106. -0.6.3
  107. - Initial Build