wpa_supplicant-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  2. Name: wpa_supplicant
  3. Version: 0.6.4
  4. Release: 1%{?_dist_release}
  5. License: GPL
  6. Group: System Environment/Base
  7. URL: http://w1.fi/wpa_supplicant/
  8. Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
  9. Source1: %{name}.config
  10. Source2: %{name}.conf
  11. Source3: %{name}.init.d
  12. Source4: %{name}.sysconfig
  13. Source6: %{name}.logrotate
  14. Patch0: wpa_supplicant-assoc-timeout.patch
  15. Patch1: wpa_supplicant-0.5.7-qmake-location.patch
  16. Patch2: wpa_supplicant-0.5.7-flush-debug-output.patch
  17. Patch3: wpa_supplicant-0.5.7-use-IW_ENCODE_TEMP.patch
  18. Patch4: wpa_supplicant-0.5.10-dbus-service-file.patch
  19. Patch5: wpa_supplicant-0.6.4-handle-invalid-ies.patch
  20. Patch6: wpa_supplicant-0.6.4-scan-fixes-1.patch
  21. Patch7: wpa_supplicant-0.6.4-scan-fixes-2.patch
  22. Patch8: wpa_supplicant-0.6.4-validate-wext-event.patch
  23. Patch9: wpa_supplicant-0.6.4-set-mode-handler.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: qt-devel
  26. BuildRequires: openssl-devel
  27. BuildRequires: readline-devel
  28. BuildRequires: dbus-devel
  29. Requires(post): chkconfig
  30. Requires(preun): chkconfig
  31. %description
  32. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  33. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  34. component that is used in the client stations. It implements key negotiation
  35. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  36. authentication/association of the wlan driver.
  37. %package gui
  38. Summary: Graphical User Interface for %{name}
  39. Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
  40. Group: Applications/System
  41. %description gui
  42. Graphical User Interface for wpa_supplicant written using QT3
  43. %description -l ja gui
  44. QT3 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  45. %prep
  46. %setup -q
  47. %patch0 -p1 -b .assoc-timeout
  48. %patch1 -p1 -b .qmake-location
  49. %patch2 -p1 -b .flush-debug-output
  50. %patch3 -p1 -b .use-IW_ENCODE_TEMP
  51. %patch4 -p1 -b .dbus-service-file
  52. %patch5 -p1 -b .handle-invalid-ies
  53. %patch6 -p1 -b .scan-fixes-1
  54. %patch7 -p1 -b .scan-fixes-2
  55. %patch8 -p1 -b .validate-wext-event
  56. %patch9 -p1 -b .set-mode-handler
  57. %build
  58. pushd wpa_supplicant
  59. cp %{SOURCE1} ./.config
  60. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
  61. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
  62. make %{_smp_mflags}
  63. QTDIR=%{_libdir}/qt3 make wpa_gui %{_smp_mflags}
  64. popd
  65. %install
  66. rm -rf %{buildroot}
  67. # init scripts
  68. install -d %{buildroot}/%{_sysconfdir}/rc.d/init.d
  69. install -d %{buildroot}/%{_sysconfdir}/sysconfig
  70. install -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  71. install -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  72. install -d %{buildroot}/%{_sysconfdir}/logrotate.d
  73. install -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  74. # config
  75. install -d %{buildroot}/%{_sysconfdir}/%{name}
  76. install -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}
  77. # binary
  78. install -d %{buildroot}/%{_sbindir}
  79. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  80. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  81. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  82. install -d %{buildroot}/%{_sysconfdir}/dbus-1/system.d/
  83. install -m 0644 %{name}/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  84. install -d %{buildroot}/%{_datadir}/dbus-1/system-services/
  85. install -m 0644 %{name}/dbus-wpa_supplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  86. # gui
  87. install -d %{buildroot}/%{_bindir}
  88. install -m 0755 %{name}/wpa_gui/wpa_gui %{buildroot}/%{_bindir}
  89. # running
  90. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  91. # man pages
  92. install -d %{buildroot}%{_mandir}/man{5,8}
  93. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  94. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  95. # some cleanup in docs
  96. rm -f %{name}/doc/.cvsignore
  97. rm -rf %{name}/doc/docbook
  98. %clean
  99. rm -rf %{buildroot}
  100. %post
  101. if [ $1 = 1 ]; then
  102. chkconfig --add %{name}
  103. fi
  104. %preun
  105. if [ $1 = 0 ]; then
  106. service %{name} stop > /dev/null 2>&1
  107. /sbin/chkconfig --del %{name}
  108. fi
  109. %files
  110. %defattr(-, root, root)
  111. %doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  112. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  113. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  114. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  115. %{_sysconfdir}/rc.d/init.d/%{name}
  116. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  117. %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  118. %{_sbindir}/wpa_passphrase
  119. %{_sbindir}/wpa_supplicant
  120. %{_sbindir}/wpa_cli
  121. %dir %{_localstatedir}/run/%{name}
  122. %dir %{_sysconfdir}/%{name}
  123. %{_mandir}/man8/*
  124. %{_mandir}/man5/*
  125. %files gui
  126. %defattr(-, root, root)
  127. %{_bindir}/wpa_gui
  128. %changelog
  129. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  130. - new upstream release
  131. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  132. - drop upstream patches
  133. - import some fedora patches
  134. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  135. - Better scanning behavior on resume from suspend/hibernate
  136. - Better interaction with newer kernels and drivers
  137. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  138. - start wpa_supplicant by default.
  139. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  140. - new upstream release
  141. - import some fedora patches
  142. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  143. - rebuild with new openssl
  144. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  145. - new upstream release
  146. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  147. - initial build for Vine Linux based on FC package.
  148. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  149. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  150. - Fix up madwifi-ng private ioctl()s for r1331 and later
  151. - Update madwifi headers to r1475
  152. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  153. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  154. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  155. - Fix control interface key obfuscation a bit
  156. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  157. - Work around older & incorrect drivers that return null-terminated SSIDs
  158. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  159. - Add patch to make orinoco happy with WEP keys
  160. - Enable Prism54-specific driver
  161. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  162. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  163. - Increase association timeout, mainly for drivers that don't
  164. fully support WPA ioctls yet
  165. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  166. - Add additional BuildRequires #rh181914#
  167. - Add prereq on chkconfig #rh182905# #rh182906#
  168. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  169. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  170. - Install wpa_passphrase too #rh183480#
  171. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  172. - Don't expose private data on the control interface unless requested
  173. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  174. - Downgrade to 0.4.8 stable release rather than a dev release
  175. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  176. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  177. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  178. - Move initscript to /etc/rc.d/init.d
  179. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  180. - bump again for double-long bug on ppc(64)
  181. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  182. - rebuilt for new gcc4.1 snapshot and glibc changes
  183. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  184. - Update to 0.5.1
  185. - Add WE auth fallback to actually work with older drivers
  186. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  187. - Bring package into Fedora Core
  188. - Add ap_scan control interface patch
  189. - Enable madwifi-ng driver
  190. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  191. - upgrade to 0.4.7
  192. - added package w/ wpa_gui in it
  193. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  194. - upgrade to 0.4.6
  195. - adding ctrl interface changes recommended
  196. by Hugo Paredes <hugo.paredes@e-know.org>
  197. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  198. - upgrade to 0.4.5
  199. - updated config file wpa_supplicant is built with
  200. especially, the ipw2100 driver changed to just ipw
  201. and enabled a bunch more EAP
  202. - disabled dist tag
  203. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  204. - fix typo in init script
  205. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  206. - fixing init script using fedora-extras' template
  207. - removing chkconfig default startup
  208. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  209. - upgrade to 0.4.2
  210. - new sample conf file that will use any unrestricted AP
  211. - make sysconfig config entry
  212. - new BuildRoot for Fedora Extras
  213. - adding dist tag to Release
  214. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  215. - upgrade to 0.3.8
  216. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  217. - compile ipw driver in
  218. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  219. - upgrade to 0.3.6
  220. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  221. - fixing init script
  222. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  223. - fixing init script
  224. - adding post/preun items to add/remove via chkconfig
  225. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  226. - adding sysV scripts
  227. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  228. - Initial RPM release.