rsync-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %bcond_with systemd
  2. Summary: A program for synchronizing files over a network.
  3. Summary(ja): ネットワーク越しにファイルを同期させるプログラム
  4. Name: rsync
  5. Version: 3.2.3
  6. Release: 2%{_dist_release}%{?with_systemd:.systemd}
  7. Group: network
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: GPLv3+
  12. URL: https://rsync.samba.org/
  13. Source: https://download.samba.org/pub/rsync/src/rsync-%{version}.tar.gz
  14. Source1: https://download.samba.org/pub/rsync/src/rsync-patches-%{version}.tar.gz
  15. Source2: rsyncd.socket
  16. Source3: rsyncd.service
  17. Source4: rsyncd.conf
  18. Source5: rsyncd.sysconfig
  19. Source6: rsyncd@.service
  20. Source100: rsync.xinetd
  21. #Added temporarily until new rebase
  22. Patch0: rsync-3.2.2-ssl-verify-hostname.patch
  23. #Added due to rhbz#1873975 - default-acls test fail on s390x due to libacl
  24. Patch1: rsync-3.2.2-runtests.patch
  25. # security fixes
  26. # none
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: libacl-devel libattr-devel popt-devel
  29. BuildRequires: lz4-devel openssl-devel libzstd-devel
  30. BuildRequires: acl attr
  31. %description
  32. Rsync uses a quick and reliable algorithm to very quickly bring
  33. remote and host files into sync. Rsync is fast because it just
  34. sends the differences in the files over the network (instead of
  35. sending the complete files). Rsync is often used as a very powerful
  36. mirroring process or just as a more capable replacement for the
  37. rcp command. A technical report which describes the rsync algorithm
  38. is included in this package.
  39. Install rsync if you need a powerful mirroring program.
  40. %description -l ja
  41. rsync は高速で信頼性の高いアルゴリズムを使い,遠隔ホスト上のファイルと
  42. 高速に同期させることが出来ます.rsync が高速に動作するのは,ネットワーク
  43. 上に流れるデータがファイルの差分だけだからです (ファイル全体をやりとり
  44. するのではなく).rsync は強力なミラリングツールとしても,rcp コマンドの
  45. 代替としても使うことが出来ます.rsync のアルゴリズムに関する技術情報は
  46. このパッケージに同梱されています.
  47. 強力なミラープログラムが必要ならば rsync をインストールして下さい.
  48. %package daemon
  49. Summary: Service for anonymous access to rsync
  50. Group: servers
  51. BuildArch: noarch
  52. Requires: %{name} = %{version}-%{release}
  53. %if %{with systemd}
  54. %{?systemd_requires}
  55. %else
  56. Requires: xinetd
  57. %endif
  58. %description daemon
  59. Rsync can be used to offer read only access to anonymous clients. This
  60. package provides the anonymous rsync service.
  61. %debug_package
  62. %prep
  63. %setup -q -b 1
  64. #Enable --copy-devices parameter
  65. patch -p1 -i patches/copy-devices.diff
  66. %patch0 -p1 -b .verify-hostname
  67. %patch1 -p1 -b .runtests
  68. # security fixes
  69. # none
  70. %build
  71. %configure --disable-xxhash
  72. make %{?_smp_mflags} CCOPTFLAGS="$RPM_OPT_FLAGS"
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. %makeinstall
  76. install -D -m644 %{SOURCE4} $RPM_BUILD_ROOT/%{_sysconfdir}/rsyncd.conf
  77. %if %{with systemd}
  78. install -D -m644 %{SOURCE3} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.service
  79. install -D -m644 %{SOURCE2} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd.socket
  80. install -D -m644 %{SOURCE6} $RPM_BUILD_ROOT/%{_unitdir}/rsyncd@.service
  81. install -D -m644 %{SOURCE5} $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/rsyncd
  82. %else
  83. mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
  84. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT/etc/xinetd.d/rsync
  85. %endif
  86. %check
  87. make check
  88. chmod -x support/*
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %if %{with systemd}
  92. %post daemon
  93. %systemd_post rsyncd.service
  94. %preun daemon
  95. %systemd_preun rsyncd.service
  96. %postun daemon
  97. %systemd_postun_with_restart rsyncd.service
  98. %endif
  99. %files
  100. %defattr(-,root,root)
  101. %license COPYING
  102. %doc README* tech_report.tex support/
  103. %doc NEWS* TODO
  104. %{_bindir}/%{name}
  105. %{_bindir}/%{name}-ssl
  106. %config(noreplace) %{_sysconfdir}/rsyncd.conf
  107. %{_mandir}/man1/%{name}.1*
  108. %{_mandir}/man1/%{name}-ssl.1*
  109. %{_mandir}/man5/rsyncd.conf.5*
  110. %files daemon
  111. %if %{with systemd}
  112. %{_unitdir}/rsyncd.socket
  113. %{_unitdir}/rsyncd.service
  114. %{_unitdir}/rsyncd@.service
  115. %config(noreplace) %{_sysconfdir}/sysconfig/rsyncd
  116. %else
  117. %config(noreplace) /etc/xinetd.d/rsync
  118. %endif
  119. %changelog
  120. * Mon Oct 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-2
  121. - rebuilt with openssl-3.0.0.
  122. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  123. - updated to 3.2.3.
  124. - re-impoerted all patches from rawhide.
  125. - added systemd support (disabled as default).
  126. * Wed Oct 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.3-1
  127. - updated to 3.1.2.
  128. - imported Patch1-3 from rawhide.
  129. - dropped Patch100-130.
  130. * Sat Jan 13 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.2-1
  131. - update to 3.1.2
  132. - add patch100-130 to fix security issue from debian
  133. - use make reconfigure in build section
  134. * Sat Nov 14 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-2
  135. - added Patch100 to fix CVE-2014-9512
  136. * Fri Nov 07 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.1-1
  137. - new upstream release
  138. - deleted Patch100 to merge source
  139. * Wed Jun 11 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.1.0-2
  140. - add Patch100 to fix CVE-2014-2855
  141. * Sat Nov 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.1.0-1
  142. - new upstream release
  143. * Fri Jan 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.9-1
  144. - new upstream release
  145. * Sun May 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.8-1
  146. - new upstream release with security fixes
  147. - drop patch100 (is included in new release)
  148. * Sat Apr 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.7-2
  149. - add Patch100 for fix CVE-2011-1097 (filelist)
  150. - change specfile name (-vl)
  151. * Sat Jan 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.7-1
  152. - new upstream release
  153. * Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.6-1
  154. - new upstream release
  155. - changed License tag
  156. - added Patch0 from Debian
  157. - added BuildRequires: libattr-devel popt-devel
  158. - added patch -p1 -i patches/copy-devices.diff in %setup
  159. (to enable --copy-devices parameter)
  160. * Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 3.0.4-2
  161. - added BuildRequires: libacl-devel (to enable ACL)
  162. * Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.4-1
  163. - new upstream release
  164. - add rsync-patches (replaces patch1,2)
  165. use xattr.patch and acls.patch for backword compatibility
  166. * Sun Apr 13 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.0.2-1
  167. - new upstream release
  168. - add patch1,2 for backward compatibility from fc
  169. - new versioning policy
  170. * Tue Aug 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.9-0vl2
  171. - add Patch10 for CVE-2007-4091
  172. (rsync "f_name()" Function Directory Name Handling Off-By-One Vulnerability)
  173. * Wed Jan 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.9-0vl1
  174. - new upstream release
  175. - add Vendor/Distribution tag
  176. * Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  177. - new upstream release
  178. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  179. - new upstream release
  180. - drop obsolete patch1 which is merged in upstream.
  181. * Tue Aug 17 2004 SATO Masakiyo <info@pocomoco.net> 2.6.2-0vl2
  182. - added patch1 for a path-sanitizing bug
  183. * Wed May 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  184. - new upstream release
  185. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  186. - new upstream release
  187. * Fri Dec 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.7-0vl1
  188. - new upstream release
  189. - security fix
  190. * Mon Apr 21 2003 IWAI Masaharu <iwai@alib.jp> 2.5.6-0vl1
  191. - new upstream release
  192. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
  193. - new upstream release
  194. * Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 2.5.4-0vl1
  195. - updated to 2.5.4, which contains additional fix for zlib double-free bug.
  196. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5.3-0vl1
  197. - upstream release
  198. * Sat Jan 26 2002 Toru Sagami <sagami@vinelinux.org> 2.5.2-0vl1
  199. - SECURITY FIXES:
  200. * Signedness security patch from Sebastian Krahmer
  201. - added more docs
  202. * Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
  203. - 2.5.1-0vl1
  204. * Sun Dec 2 2001 Yoichi Imai <yoichi@silver-forest.com>
  205. - 2.5.0-0vl1
  206. - update to 2.5.0
  207. - edit maxdel.patch for 2.5.0
  208. * Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  209. - 2.4.6-2vl1
  210. - based on 2.4.6-2 from Rawhide
  211. - added Japanese summary and description
  212. * Sat Sep 30 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  213. - add xinetd configuration
  214. * Tue Sep 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  215. - 2.4.6
  216. * Mon Jul 31 2000 Bill Nottingham <notting@redhat.com>
  217. - update to 2.4.4 - fixes yet another problem with rsh transport
  218. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  219. - automatic rebuild
  220. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  221. - rebuild in new build env.
  222. * Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
  223. - update to 2.4.3
  224. * Tue Apr 4 2000 Bill Nottingham <notting@redhat.com>
  225. - update to 2.4.2
  226. * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
  227. - fix maxdelete behavior so it isn't sent to older servers.
  228. * Mon Jan 31 2000 Jeff Johnson <jbj@redhat.com>
  229. - update to 2.4.1.
  230. * Fri Dec 17 1999 Bill Nottingham <notting@redhat.com>
  231. - update to 2.3.2
  232. * Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
  233. - add "max. delete" patch to limit damage when server is hosed.
  234. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  235. - update to 2.3.1.
  236. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  237. - auto rebuild in the new build environment (release 2)
  238. * Tue Mar 16 1999 Jeff Johnson <jbj@redhat.com>
  239. - update to 2.3.0.
  240. * Sat Mar 13 1999 Jeff Johnson <jbj@redhat.com>
  241. - update to 2.3.0 beta.
  242. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  243. - update to 2.2.1
  244. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  245. - updated to 2.1.1
  246. * Mon Aug 17 1998 Erik Troan <ewt@redhat.com>
  247. - updated to 2.1.0
  248. * Thu Aug 06 1998 Erik Troan <ewt@redhat.com>
  249. - buildrooted and attr-rophied
  250. - removed tech-report.ps; the .tex should be good enough
  251. * Mon Aug 25 1997 John A. Martin <jam@jamux.com>
  252. - Built 1.6.3-2 after finding no rsync-1.6.3-1.src.rpm although there
  253. was an ftp://ftp.redhat.com/pub/contrib/alpha/rsync-1.6.3-1.alpha.rpm
  254. showing no packager nor signature but giving
  255. "Source RPM: rsync-1.6.3-1.src.rpm".
  256. - Changes from 1.6.2-1 packaging: added '$RPM_OPT_FLAGS' to make, strip
  257. to '%build', removed '%prefix'.
  258. * Thu Apr 10 1997 Michael De La Rue <miked@ed.ac.uk>
  259. - rsync-1.6.2-1 packaged. (This entry by jam to credit Michael for the
  260. previous package(s).)