audit-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: User space tools for kernel auditing
  5. Name: audit
  6. Version: 3.0.8
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. License: GPLv2+
  9. Group: system,admin-tools
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. URL: https://people.redhat.com/sgrubb/audit/
  13. Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: gettext intltool libtool swig
  16. BuildRequires: python-devel python-rpm-macros
  17. BuildRequires: python3-devel python3-rpm-macros
  18. BuildRequires: openldap-devel
  19. BuildRequires: krb5-devel
  20. BuildRequires: kernel-headers >= 2.6.18
  21. BuildRequires: libcap-ng-devel
  22. BuildRequires: automake >= 1.9
  23. BuildRequires: autoconf >= 2.59
  24. %if %{with systemd}
  25. %{?systemd_requires}
  26. %else
  27. Requires(post): /sbin/chkconfig
  28. Requires(preun): /sbin/chkconfig
  29. Requires(preun): /sbin/service
  30. Requires(postun): /sbin/service
  31. %endif
  32. Requires: %{name}-libs = %{version}-%{release}
  33. Requires(pre): coreutils
  34. %description
  35. The audit package contains the user space utilities for
  36. storing and searching the audit records generate by
  37. the audit subsystem in the Linux kernel.
  38. %package libs
  39. Summary: Dynamic library for libaudit
  40. License: LGPLv2+
  41. Group: system
  42. %description libs
  43. The audit-libs package contains the dynamic libraries needed for
  44. applications to use the audit framework.
  45. %package libs-devel
  46. Summary: Header files and static library for libaudit
  47. License: LGPLv2+
  48. Group: programming
  49. Requires: %{name}-libs = %{version}-%{release}
  50. Requires: kernel-headers >= 2.6.18
  51. %description libs-devel
  52. The audit-libs-devel package contains the static libraries and header
  53. files needed for developing applications that need to use the audit
  54. framework libraries.
  55. %package libs-python
  56. Summary: Python2 bindings for libaudit
  57. License: LGPLv2+
  58. Group: programming
  59. Requires: %{name}-libs = %{version}-%{release}
  60. %description libs-python
  61. The audit-libs-python package contains the bindings so that libaudit
  62. and libauparse can be used by python2.
  63. %package libs-python3
  64. Summary: Python3 bindings for libaudit
  65. License: LGPLv2+
  66. Group: programming
  67. Provides: python-audit = %{version}-%{release}
  68. Requires: %{name}-libs = %{version}-%{release}
  69. %description libs-python3
  70. The audit-libs-python3 package contains the bindings so that libaudit
  71. and libauparse can be used by python3.
  72. %package -n audispd-plugins
  73. Summary: Plugins for the audit event dispatcher
  74. Group: system
  75. License: GPLv2+
  76. Provides: python3-audit = %{version}-%{release}
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: %{name}-libs = %{version}-%{release}
  79. %description -n audispd-plugins
  80. The audispd-plugins package provides plugins for the real-time
  81. interface to the audit system, audispd. These plugins can do things
  82. like relay events to remote machines or analyze events for suspicious
  83. behavior.
  84. %package -n audispd-plugins-zos
  85. Summary: z/OS plugin for the audit event dispatcher
  86. Group: system
  87. License: GPLv2+
  88. Requires: %{name}%{?_isa} = %{version}-%{release}
  89. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  90. Requires: openldap
  91. %description -n audispd-plugins-zos
  92. The audispd-plugins-zos package provides a plugin that will forward all
  93. incoming audit events, as they happen, to a configured z/OS SMF (Service
  94. Management Facility) database, through an IBM Tivoli Directory Server
  95. (ITDS) set for Remote Audit service.
  96. %package -n compat32-%{name}-libs
  97. Summary: Dynamic library for libaudit
  98. License: LGPLv2+
  99. Group: system,legacy
  100. %description -n compat32-%{name}-libs
  101. The audit-libs package contains the dynamic libraries needed for
  102. applications to use the audit framework.
  103. %debug_package
  104. %prep
  105. %setup -q -n audit-userspace-%{version}
  106. autoreconf -vif
  107. # Remove the ids code, its not ready
  108. sed -i 's/ ids / /' audisp/plugins/Makefile.in
  109. %build
  110. %configure --sbindir=/sbin --libdir=/%{_lib} \
  111. --with-python=yes --with-python3=yes \
  112. --with-libcap-ng=yes --enable-gssapi-krb5=yes \
  113. --enable-zos-remote \
  114. --enable-experimental \
  115. %if %{with systemd}
  116. --enable-systemd
  117. %else
  118. %{nil}
  119. %endif
  120. make CFLAGS="%{optflags}" %{?_smp_mflags}
  121. %install
  122. rm -rf $RPM_BUILD_ROOT
  123. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audit/plugins.d,rc.d/init.d,audit/rules.d}}
  124. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  125. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  126. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  127. mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
  128. mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
  129. make DESTDIR=$RPM_BUILD_ROOT install
  130. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  131. # This winds up in the wrong place when libtool is involved
  132. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  133. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  134. curdir=`pwd`
  135. cd $RPM_BUILD_ROOT/%{_libdir}
  136. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  137. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  138. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  139. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  140. cd $curdir
  141. # Remove these items so they don't get picked up.
  142. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  143. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  144. find $RPM_BUILD_ROOT -name '*.la' -delete
  145. find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
  146. # Move the pkgconfig file
  147. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  148. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  149. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  150. touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
  151. %if %{with systemd}
  152. rm -rf %{buildroot}%{_libexecdir}/initscripts
  153. rm -f %{buildroot}%{_libexecdir}/audit-functions
  154. mkdir -p %{buildroot}%{_unitdir}
  155. mv %{buildroot}/usr/lib/systemd/system/auditd.service %{buildroot}%{_unitdir}/
  156. %endif
  157. %check
  158. make check
  159. # Get rid of make files so that they don't get packaged.
  160. rm -f rules/Makefile*
  161. %clean
  162. rm -rf $RPM_BUILD_ROOT
  163. rm -rf zos-remote-policy
  164. %post
  165. # This is to migrate users from audit-1.0.x installations
  166. if [ -f /etc/auditd.conf ]; then
  167. mv /etc/auditd.conf /etc/audit/auditd.conf
  168. fi
  169. if [ -f /etc/audit.rules ]; then
  170. mv /etc/audit.rules /etc/audit/audit.rules
  171. fi
  172. # This is to enable the dispatcher option which was commented out
  173. if [ -f /etc/audit/auditd.conf ]; then
  174. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  175. if [ $? -eq 1 ] ; then
  176. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  177. if [ -n $tmp ]; then
  178. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  179. cat $tmp > /etc/audit/auditd.conf
  180. rm -f $tmp
  181. fi
  182. fi
  183. fi
  184. # Copy default rules into place on new installation
  185. files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
  186. if [ "$files" -eq 0 ] ; then
  187. # FESCO asked for audit to be off by default. #1117953
  188. if [ -e %{_datadir}/%{name}/sample-rules/10-no-audit.rules ] ; then
  189. cp %{_datadir}/%{name}/sample-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
  190. else
  191. touch /etc/audit/rules.d/audit.rules
  192. fi
  193. chmod 0600 /etc/audit/rules.d/audit.rules
  194. fi
  195. %if %{with systemd}
  196. %systemd_post auditd.service
  197. %else
  198. /sbin/chkconfig --add auditd
  199. %endif
  200. %preun
  201. %if %{with systemd}
  202. %systemd_preun auditd.service
  203. %else
  204. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  205. /sbin/service auditd stop > /dev/null 2>&1
  206. /sbin/chkconfig --del auditd
  207. fi
  208. %endif
  209. %postun
  210. %if %{with systemd}
  211. %systemd_postun_with_restart auditd.service
  212. %else
  213. if [ $1 -ge 1 ]; then
  214. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  215. fi
  216. %endif
  217. %files libs
  218. %defattr(-,root,root)
  219. %{!?_licensedir:%global license %%doc}
  220. %license COPYING.LIB
  221. /%{_lib}/libaudit.*
  222. /%{_lib}/libauparse.*
  223. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  224. %{_mandir}/man5/libaudit.conf.5.gz
  225. %files libs-devel
  226. %defattr(-,root,root)
  227. %{!?_licensedir:%global license %%doc}
  228. %license COPYING.LIB
  229. %doc contrib/skeleton.c contrib/plugin
  230. %{_libdir}/libaudit.a
  231. %{_libdir}/libauparse.a
  232. %{_libdir}/libaudit.so
  233. %{_libdir}/libauparse.so
  234. %{_includedir}/libaudit.h
  235. %{_includedir}/auparse.h
  236. %{_includedir}/auparse-defs.h
  237. %{_datadir}/aclocal/audit.m4
  238. %{_libdir}/pkgconfig/audit.pc
  239. %{_libdir}/pkgconfig/auparse.pc
  240. %{_mandir}/man3/*
  241. %files libs-python
  242. %defattr(-,root,root)
  243. %attr(755,root,root) %{python_sitearch}/_audit.so
  244. %attr(755,root,root) %{python_sitearch}/auparse.so
  245. %{python_sitearch}/audit.py*
  246. %files libs-python3
  247. %defattr(-,root,root,-)
  248. %attr(755,root,root) %{python3_sitearch}/*
  249. %files
  250. %defattr(-,root,root,-)
  251. %doc README ChangeLog rules init.d/auditd.cron
  252. %{!?_licensedir:%global license %%doc}
  253. %license COPYING
  254. %dir %{_datadir}/%{name}
  255. %dir %{_datadir}/%{name}/sample-rules
  256. %attr(644,root,root) %{_datadir}/%{name}/sample-rules/*
  257. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  258. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  259. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  260. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  261. %attr(644,root,root) %{_mandir}/man8/autrace.8.gz
  262. %attr(644,root,root) %{_mandir}/man8/aulast.8.gz
  263. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  264. %attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
  265. %attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
  266. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  267. %attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
  268. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  269. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  270. %attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
  271. %attr(750,root,root) /sbin/auditctl
  272. %attr(750,root,root) /sbin/auditd
  273. %attr(755,root,root) /sbin/ausearch
  274. %attr(755,root,root) /sbin/aureport
  275. %attr(750,root,root) /sbin/autrace
  276. %attr(750,root,root) /sbin/augenrules
  277. %attr(750,root,root) %{_bindir}/aulastlog
  278. %attr(750,root,root) %{_bindir}/aulast
  279. %attr(755,root,root) %{_bindir}/ausyscall
  280. %attr(755,root,root) %{_bindir}/auvirt
  281. %attr(750,root,root) %dir %{_var}/log/audit
  282. %attr(750,root,root) %dir /etc/audit
  283. %attr(750,root,root) %dir /etc/audit/rules.d
  284. %attr(750,root,root) %dir /etc/audit/plugins.d
  285. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  286. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  287. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  288. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  289. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
  290. %if %{with systemd}
  291. %attr(644,root,root) %{_unitdir}/auditd.service
  292. %else
  293. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  294. %attr(755,root,root) /etc/rc.d/init.d/auditd
  295. %endif
  296. %files -n audispd-plugins
  297. %defattr(-,root,root,-)
  298. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
  299. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-remote.conf
  300. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
  301. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
  302. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
  303. %attr(750,root,root) /sbin/audisp-remote
  304. %attr(750,root,root) /sbin/audisp-syslog
  305. %attr(750,root,root) /sbin/audisp-statsd
  306. %attr(700,root,root) %dir %{_var}/spool/audit
  307. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  308. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  309. %attr(644,root,root) %{_mandir}/man8/audisp-syslog.8.gz
  310. %attr(644,root,root) %{_mandir}/man8/audisp-statsd.8.gz
  311. %files -n audispd-plugins-zos
  312. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  313. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  314. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
  315. %config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
  316. %attr(750,root,root) /sbin/audispd-zos-remote
  317. %if %{build_compat32}
  318. %files -n compat32-%{name}-libs
  319. %{!?_licensedir:%global license %%doc}
  320. %license COPYING.LIB
  321. %defattr(-,root,root)
  322. %attr(755,root,root) /%{_lib}/libaudit.*
  323. %attr(755,root,root) /%{_lib}/libauparse.*
  324. %endif
  325. %changelog
  326. * Wed Mar 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  327. - new upstream release.
  328. * Mon Jan 24 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.7-1
  329. - new upstream release.
  330. * Sat Oct 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.6-1
  331. - new upstream release.
  332. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
  333. - new upstream release.
  334. - dropped Patch1.
  335. - dropped ldconfig scriptlets.
  336. * Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  337. - new upstream release.
  338. - dropped Patch1.
  339. - imported Patch1 from rawhide.
  340. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
  341. - new upstream release.
  342. - imported Patch1 from rawhide.
  343. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
  344. - new upstream release.
  345. - dropped all patches.
  346. - dropped system-config-audit.
  347. - added python3 bindings.
  348. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  349. - fix sca_release
  350. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  351. - create compat32-audit-libs subpackage
  352. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  353. - rebuild with python-2.7.2
  354. - add Patch12 (audit-1.7.18-libaudit.patch)
  355. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  356. - new upstream release
  357. - rebuild with krb5-1.8.2
  358. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  359. - forgot to increment sca_release macro (why on earth is sca_release
  360. individually defined from main package's release number anyway?)
  361. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  362. - rebuilt with gcc-4.4.3-3 on ppc
  363. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  364. - rebuilt with rpm-4.8.0-3 (on ppc)
  365. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  366. - rebuild with python-2.6
  367. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  368. - rebuild with openldap-2.4.11
  369. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  370. - initial build for Vine Linux
  371. - disable krb5, prelude and selinux
  372. - add ja.po (XXX: minimal)
  373. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  374. - Add subject to audit daemon events (Chu Li)
  375. - Add tcp_wrappers support for auditd
  376. - Updated syscall tables for 2.6.27 kernel
  377. - Audit connect/disconnect of remote clients
  378. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  379. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  380. - Update system-config-audit to 0.4.8
  381. - Whole lot of bug fixes - see ChangeLog for details
  382. - Reimplement auditd main loop using libev
  383. - Add TCP listener to auditd to receive remote events
  384. - Fix scheduler problem (#457061)
  385. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  386. - Move ausearch-expression to main package (#453437)
  387. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  388. - Fix interpreting of keys in syscall records
  389. - Don't error on name=(null) PATH records in ausearch/report
  390. - Add key report to aureport
  391. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  392. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  393. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  394. - Fix output of keys in ausearch interpretted mode
  395. - Fix ausearch/report --start now to not be reset to midnight
  396. - audispd now has a priority boost config option
  397. - Look for laddr in avcs reported via prelude
  398. - Detect page 0 mmaps and alert via prelude
  399. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  400. - Fix overflow in audit_log_user_command, better (#438840)
  401. - ausearch was not matching path in avc records
  402. - audisp-prelude attempt to reposition index after examining each type
  403. - correct building of mls policy
  404. - Fix auparse iterating in auparse_find_field and next_field
  405. - Don't alert on USER_AVC's - they are not quite right
  406. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  407. - Fix buffer overflow in audit_log_user_command, again (#438840)
  408. - Fix memory leak in EOE code in auditd (#440075)
  409. - In auditctl, don't use new operators in legacy rule format
  410. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  411. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  412. - Fix memleak in auditd eoe code
  413. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  414. - Remove LSB headers from init scripts
  415. - Fix buffer overflow in audit_log_user_command again
  416. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  417. - Handle user space avcs in prelude plugin
  418. - Fix watched account login detection for some failed login attempts
  419. - Couple fixups in audit logging functions (Miloslav Trmac)
  420. - Add support in auditctl for virtual keys
  421. - auparse_find_field_next was not iterating correctly, fixed it
  422. - Add idmef alerts for access or execution of watched file
  423. - Fix buffer overflow in audit_log_user_command
  424. - Add basic remote logging plugin - only sends & no flow control
  425. - Update ausearch with interpret fixes from auparse
  426. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  427. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  428. - Apply auparse expression interface patch (Miloslav Trmac)
  429. - Fix potential memleak in audit event dispatcher
  430. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  431. - audisp-prelude alerts now controlled by config file
  432. - Updated syscall table for 2.6.25 kernel
  433. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  434. - Added watched account login detection for prelude plugin
  435. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  436. - Update for gcc 4.3
  437. - Cleanup descriptors in audispd before running plugin
  438. - Fix 'recent' keyword for aureport/search
  439. - Fix SE Linux policy for zos_remote plugin
  440. - Add event type for group password authentication attempts
  441. - Couple of updates to the translation tables
  442. - Add detection of failed group authentication to audisp-prelude
  443. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  444. - In ausearch/report, prefer -if to stdin
  445. - In ausearch/report, add new command line option --input-logs (#428860)
  446. - Updated audisp-prelude based on feedback from prelude-devel
  447. - Added prelude alert for promiscuous socket being opened
  448. - Added prelude alert for SE Linux policy enforcement changes
  449. - Added prelude alerts for Forbidden Login Locations and Time
  450. - Applied patch to auparse fixing error handling of searching by
  451. interpreted value (Miloslav Trmac)
  452. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  453. - Add prelude IDS plugin for IDMEF alerts
  454. - Add --user option to aulastlog command
  455. - Use desktop-file-install for system-config-audit
  456. - Avoid touching auditd.conf most of the time (#408501)
  457. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  458. - Updates for spec file review
  459. - Adjust permission on selinux policy file
  460. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  461. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  462. - Check for audit log being writable by owner in auditd
  463. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  464. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  465. - Added aulastlog utility
  466. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  467. - Allow 0600 file perms for audit logs
  468. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  469. - fchmod of log file was on wrong variable (#426934)
  470. - Allow use of errno strings for exit codes in audit rules
  471. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  472. - Don't fchmod() /dev/null to mode 0400 (#426934)
  473. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  474. - Add kernel release string to DEAMON_START events
  475. - Fix keep_logs when num_logs option disabled (#325561)
  476. - Fix auparse to handle node fields for syscall records
  477. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  478. - Add keyword week-ago to aureport & ausearch start/end times
  479. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  480. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  481. - Add event queue overflow action to audispd
  482. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  483. - Don't retry if the rt queue is full.
  484. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  485. - Add support for searching by posix regular expressions in auparse
  486. - Route DEAMON events into rt interface
  487. - If event pipe is full, try again after doing local logging
  488. - Optionally add node/machine name to records in audit daemon
  489. - Update ausearch/aureport to specify nodes to search on
  490. - Fix segfault interpretting saddr fields in avcs
  491. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  492. - Fix uninitialized variable in auparse (John Dennis)
  493. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  494. - External plugin support in place
  495. - Fix reference counting in auparse python bindings (#263961)
  496. - Moved default af_unix plugin socket to /var/run/audispd_events
  497. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  498. - Add newline to audispd string formatted events
  499. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  500. - spec file cleanups
  501. - Update to s-c-audit 0.4.3
  502. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  503. - Update Licence tags
  504. - Adding perm field should not set syscall added flag in auditctl
  505. - Fix segfault when aureport -if option is used
  506. - Fix auditctl to better check keys on rule lines
  507. - Add support for audit by TTY and other new event types
  508. - Auditd config option for group permission of audit logs
  509. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  510. - New audit event dispatcher
  511. - Update syscall tables for 2.6.23 kernel
  512. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  513. - Fix potential buffer overflow in print clone flags of auparse
  514. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  515. - Update auditctl to handle legacy kernels when putting a watch on a dir
  516. - Fix acct interpretation in auparse
  517. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  518. - Fix a double free when auditd receives SIGHUP
  519. - Move the system-config-audit menu entry to the Administration menu
  520. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  521. - Add system-config-audit (Miloslav Trmac)
  522. - Correct bug in audit_make_equivalent function (Al Viro)
  523. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  524. - Add feed interface to auparse library (John Dennis)
  525. - Apply patch to libauparse for unresolved symbols (#241178)
  526. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  527. - Change seresults to seresult in libauparse (John Dennis)
  528. - Add unit32_t definition to swig (#244210)
  529. - Add support for directory auditing
  530. - Update acct field to be escaped
  531. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  532. - Change buffer size to prevent truncation of DAEMON events with large labels
  533. - Fix memory leaks in auparse (John Dennis)
  534. - Update syscall tables for 2.6.21 kernel
  535. - Update capp & lspp rules
  536. - New python bindings for libauparse (John Dennis)
  537. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  538. - New event dispatcher (James Antill)
  539. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  540. - Apply patch correcting python libs permissions (Philipp Hahn)
  541. - Fix auditd segfault on reload
  542. - Fix bug in auparse library for file pointers and descriptors
  543. - Extract subject information out of daemon events for ausearch
  544. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  545. - Remove requires kernel-headers for python-libs
  546. - Apply patch to prevent segfaults on auditd reload
  547. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  548. - Updated autrace to monitor *at syscalls
  549. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  550. - Finish reworking auditd config parser
  551. - In auparse, interpret open, fcntl, and clone flags
  552. - In auparse, when interpreting execve record types, run args through unencode
  553. - Add support for OBJ_PID message type
  554. - Event dispatcher updates
  555. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  556. - rebuild
  557. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  558. - NEW audit dispatcher program & plugin framework
  559. - Correct hidden variables in libauparse
  560. - Added NISPOM sample rules
  561. - Verify accessibility of files passed in auparse_init
  562. - Fix bug in parser library interpreting socketcalls
  563. - Add support for stdio FILE pointer in auparse_init
  564. - Adjust init script to allow anyone to status auditd (#230626)
  565. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  566. - Add man pages
  567. - Reduce text relocations in parser library
  568. - Add -n option to auditd for no fork
  569. - Add exec option to space_left, admin_space_left, disk_full,
  570. and disk_error - eg EXEC /usr/local/script
  571. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  572. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  573. - Finished search options for audit parsing library
  574. - Fix ausearch -se to work correctly
  575. - Fix auditd init script for /usr on netdev (#228528)
  576. - Parse avc seperms better when there are more than one
  577. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  578. - New report about authentication attempts
  579. - Updates for python 2.5
  580. - update autrace to have resource usage mode
  581. - update auditctl to support immutable config
  582. - added audit_log_user_command function to libaudit api
  583. - interpret capabilities
  584. - added audit event parsing library
  585. - updates for 2.6.20 kernel
  586. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  587. - Make more adjustments for python 2.5
  588. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  589. - Fix a couple parsing problems (#217952)
  590. - Add tgkill to S390* syscall tables (#218484)
  591. - Fix error messages in ausearch/aureport
  592. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  593. - rebuild against python 2.5
  594. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  595. - Fix timestamp for libaudit.conf (#218053)
  596. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  597. - Fix minor parsing problem and add new msg types
  598. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  599. - ausearch & aureport implement uid/gid caching
  600. - In ausearch & aureport, extract addr when hostname is unknown
  601. - In ausearch & aureport, test audit log presence O_RDONLY
  602. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  603. - Added --add & --delete option to aureport
  604. - Update res parsing in config change events
  605. - Increase the size on audit daemon buffers
  606. - Parse avc_path records in ausearch/aureport
  607. - ausearch has new output mode, raw, for extracting events
  608. - ausearch/aureport can now read stdin
  609. - Rework AVC processing in ausearch/aureport
  610. - Added long options to ausearch and aureport
  611. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  612. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  613. - Fix some defines in libaudit.h
  614. - Some auditd config strings were not initialized in aureport (#211443)
  615. - Updated man pages
  616. - Add Netlabel event types to libaudit
  617. - Update aureports to current audit event types
  618. - Update autrace a little
  619. - Deprecated all the old audit_rule functions from public API
  620. - Drop auparse library for the moment
  621. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  622. - Add dist tag and bump version (#208532)
  623. - Make internal auditd buffers bigger for context info
  624. - Correct address resolving of hostname in logging functions
  625. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  626. - Only =, != operators for arch & inode fields in auditctl (#206427)
  627. - Updated audit message type table
  628. - Remove watches from aureport since FS_WATCH is deprecated
  629. - Add audit_log_avc back temporarily (#208152)