ffmpeg-vl5.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. #TODO: Build with openjpeg
  2. %define name ffmpeg
  3. %define version 0.5.4
  4. #% define svndate 20090227
  5. %define release 2%{?svndate:.%svndate}%{?_dist_release}
  6. Summary: Digital VCR and streaming server
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. Source: http://ffmpeg.org/releases/%{name}-%{version}.tar.bz2
  11. #Source1: %{name}-snapshot.sh
  12. # For no texi2html
  13. # these man files for ffmpeg-0.5 are genereted with texi2html
  14. Source90: ffmpeg.1.gz
  15. Source91: ffplay.1.gz
  16. Source92: ffserver.1.gz
  17. # get rid of textrels on x86_64 in yasm code (from RPM Fusion)
  18. Patch0: %{name}-textrel.patch
  19. Patch10: ffmpeg-0.5-disable-texi2html.patch
  20. # upstreamed patches:
  21. # AMV: Fix possibly exploitable crash.
  22. # http://git.videolan.org/gitweb.cgi?p=ffmpeg.git;a=commit;h=8210ee22e2f69d540f8835523dd78a205ae6c2a6
  23. Patch51: ffmpeg-0.5.4-fix-possibly-exploitable-crash.patch
  24. # Fix apparently exploitable race condition.
  25. # http://git.videolan.org/gitweb.cgi/ffmpeg.git/?a=commit;h=24cd7c5df78c53c1d1a36b81fb130594e84b3f12
  26. Patch52: ffmpeg-0.5.4-fix-apparently-exploitable-race-condition.patch
  27. License: GPLv2+
  28. Group: Applications/Multimedia
  29. URL: http://ffmpeg.org/
  30. BuildRequires: bzip2-devel
  31. BuildRequires: zlib-devel
  32. BuildRequires: SDL-devel
  33. BuildRequires: imlib2-devel
  34. BuildRequires: speex-devel
  35. #BuildRequires: texi2html
  36. BuildRequires: libogg-devel
  37. BuildRequires: libvorbis-devel
  38. #BuildRequires: openjpeg-devel
  39. BuildRequires: libtheora-devel
  40. BuildRequires: gsm-devel
  41. BuildRequires: libdc1394-devel
  42. BuildRequires: libraw1394-devel
  43. %ifarch %{ix86} x86_64
  44. BuildRequires: yasm
  45. %endif
  46. # *-devel packages provided by other self-build-* should only be listed
  47. # in self-build-%{name}.spec as PreReq.
  48. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  49. #BuildRequires: x264-devel, libdca-devel, a52dec-devel
  50. #BuildRequires: faad2-devel
  51. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  52. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  53. %description
  54. FFMpeg is a complete and free Internet live audio and video
  55. broadcasting solution for Linux/Unix. It also includes a digital
  56. VCR. It can encode in real time in many formats including MPEG1 audio
  57. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  58. %package libs
  59. Group: System Environment/Libraries
  60. Summary: Libraries for %{name}
  61. Group: System Environment/Libraries
  62. #Requires: a52dec, faad2
  63. %description libs
  64. FFMpeg is a complete and free Internet live audio and video
  65. broadcasting solution for Linux/Unix. It also includes a digital
  66. VCR. It can encode in real time in many formats including MPEG1 audio
  67. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  68. This package contains the libraries for %{name}.
  69. %package devel
  70. Summary: Development package for %{name}
  71. Group: Development/Libraries
  72. Requires: %{name}-libs = %{version}-%{release}
  73. Requires: pkgconfig
  74. %description devel
  75. FFMpeg is a complete and free Internet live audio and video
  76. broadcasting solution for Linux/Unix. It also includes a digital
  77. VCR. It can encode in real time in many formats including MPEG1 audio
  78. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  79. This package contains development files for %{name}.
  80. %prep
  81. #% setup -q -n %{name}-%{svndate}
  82. %setup -q
  83. %patch0 -p1 -b .textrel
  84. %patch10 -p1 -b .texi2html
  85. ## upstreamed patches
  86. %patch51 -p1 -b .orig
  87. %patch52 -p1 -b .orig
  88. %build
  89. %ifarch ppc
  90. # compile with -mlongcall on ppc/ppc64 (rf804)
  91. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  92. %endif
  93. ./configure \
  94. --prefix=%{_prefix} \
  95. --incdir=%{_includedir}/%{name} \
  96. --shlibdir=%{_libdir} \
  97. --libdir=%{_libdir} \
  98. --mandir=%{_mandir} \
  99. --arch=%{_target_cpu} \
  100. %ifarch %{ix86}
  101. --cpu=%{_target_cpu} \
  102. %endif
  103. %ifarch ppc
  104. --cpu=g3 \
  105. %endif
  106. --enable-runtime-cpudetect \
  107. --extra-cflags="$RPM_OPT_FLAGS" \
  108. %{?_with_amr:--enable-libamr-nb --enable-libamr-wb --enable-nonfree} \
  109. --enable-bzlib \
  110. --enable-libdc1394 \
  111. --enable-libfaac --enable-nonfree \
  112. --enable-libfaad \
  113. --enable-libgsm \
  114. --enable-libmp3lame \
  115. %{?_with_openjpeg:--enable-libopenjpeg} \
  116. --enable-libtheora \
  117. --enable-libvorbis \
  118. --enable-libx264 \
  119. --enable-libxvid \
  120. --enable-x11grab \
  121. --enable-avfilter \
  122. --enable-avfilter-lavf \
  123. --enable-postproc \
  124. --enable-swscale \
  125. --enable-pthreads \
  126. --disable-static \
  127. --enable-shared \
  128. --enable-gpl \
  129. --disable-debug \
  130. --disable-stripping
  131. #% {__make} %{?_smp_mflags}
  132. %{__make}
  133. %install
  134. %__make install DESTDIR=$RPM_BUILD_ROOT
  135. ## install man
  136. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1
  137. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
  138. %clean
  139. %{__rm} -rf $RPM_BUILD_ROOT
  140. %post libs -p /sbin/ldconfig
  141. %postun libs -p /sbin/ldconfig
  142. %files
  143. %defattr(-,root,root,-)
  144. %doc COPYING.GPL CREDITS Changelog README RELEASE doc/*.*
  145. %{_prefix}/bin/ffmpeg
  146. %{_prefix}/bin/ffplay
  147. %{_prefix}/bin/ffserver
  148. %{_mandir}/man1/ffmpeg.1*
  149. %{_mandir}/man1/ffplay.1*
  150. %{_mandir}/man1/ffserver.1*
  151. %{_datadir}/ffmpeg
  152. %{?_with_amr:%{_datadir}/%{name}}
  153. %files libs
  154. %defattr(-,root,root,-)
  155. %{_libdir}/lib*.so.*
  156. %{_libdir}/vhook/
  157. %files devel
  158. %defattr(-,root,root,-)
  159. %{_includedir}/ffmpeg
  160. %{_libdir}/pkgconfig/lib*.pc
  161. %{_libdir}/lib*.so
  162. %changelog
  163. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-2
  164. - applied some upstreamed/security patches:
  165. - AMV: fix possibly exploitable crash
  166. - fix apparently exploitable race condition
  167. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.4-1
  168. - new upstream release
  169. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-2
  170. - change release to sync with self-build-ffmpeg
  171. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.3-1
  172. - new upstream release
  173. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-2
  174. - change release to sync with self-build-ffmpeg
  175. * Thu Jun 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.2-1
  176. - new upstream release
  177. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.1-1
  178. - new upstream release
  179. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  180. - applied ffmpeg-0.5-disable-texi2html.patch, return
  181. (in face, no ffmpeg-0.5-disable-texi2html.patch applied for 0.5-4)
  182. - added ffmpeg.1, ffplay.1, ffserver.1
  183. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  184. - change release to sync with self-build-ffmpeg
  185. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  186. - applied ffmpeg-0.5-disable-texi2html.patch
  187. - dropped BuildRequires: texi2html
  188. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  189. - change release to sync with self-build-ffmpeg
  190. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  191. - corrected release number
  192. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  193. - new upstream release
  194. - added BuildRequires:
  195. - speex-devel
  196. - bzip2-devel
  197. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  198. - 20090227 snapshot
  199. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  200. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  201. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  202. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  203. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  204. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  205. - 20090202 snapshot
  206. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  207. - 20090110 snapshot
  208. - dropped some patches
  209. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  210. - source updated (r15488)
  211. - fixed License: GPLv2+
  212. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  213. - added BuildRequires: yasm (only %%ix86)
  214. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  215. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  216. - spec in utf8
  217. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  218. - change release to sync with self-build-ffmpeg
  219. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  220. - drop "Patch100: ffmpeg-vine.patch".
  221. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  222. - build with new versioning policy
  223. - change to use svn export from svn checkout on post install
  224. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  225. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  226. - [self-build-ffmpeg.spec]
  227. For all pre-required package that is provied by self-build,
  228. changed to its self-build package
  229. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  230. - initial build for Vine Linux 4.2
  231. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  232. ### end of file