123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269 |
- # -*- coding: utf-8-unix -*-
- Name: mjpegtools
- Version: 1.9.0
- Release: 1%{?_dist_release}
- Summary: Tools to manipulate MPEG data
- Summary(ja): MPEG データを操作するツール集
- Group: Applications/Multimedia
- License: GPLv2
- URL: http://mjpeg.sourceforge.net/
- Source0: http://downloads.sourceforge.net/mjpeg/%{name}-%{version}.tar.gz
- Patch0: mjpegtools-1.9.0rc1-anytovcd-ffmpegver.patch
- Patch1: mjpegtools-1.9.0-gcc44.patch
- Patch2: mjpegtools-1.9.0-png-memleak.patch
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: libjpeg-devel
- BuildRequires: nasm
- BuildRequires: libdv-devel
- BuildRequires: SDL-devel >= 1.1.3
- BuildRequires: SDL_gfx-devel
- #BuildRequires: libquicktime-devel >= 0.9.8
- #BuildRequires: self-build-libquicktime >= 0.9.8
- BuildRequires: libpng-devel
- BuildRequires: gtk2-devel >= 2.4.0
- # mencoder for lav2avi.sh
- #Requires: mencoder
- #Requires: self-build-mplayer
- # ffmpeg main package, y4mscaler and which for anytovcd.sh
- #Requires: ffmpeg
- #Requires: self-build-ffmpeg
- #Requires: y4mscaler
- Requires: which
- Requires(post): /sbin/install-info
- Requires(preun): /sbin/install-info
- %description
- The mjpeg programs are a set of tools that can do recording of videos
- and playback, simple cut-and-paste editing and the MPEG compression of
- audio and video under Linux.
- %description -l ja
- mjpegtools は、Linux 上で
- ビデオ録画や再生、
- 簡単なカット&ペーストの編集、
- オーディオやビデオの MPEG 圧縮
- ができるツール集です。
- %package devel
- Summary: Development files for mjpegtools libraries
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- The mjpeg programs are a set of tools that can do recording of videos
- and playback, simple cut-and-paste editing and the MPEG compression of
- audio and video under Linux. This package contains development files
- for building applications that use mjpegtools libraries.
- %prep
- %setup -q
- %patch0 -p1
- %patch1 -p1
- %patch2 -p1
- %__sed -i -e 's/ARCHFLAGS=.*/ARCHFLAGS=/' configure*
- %__sed -i -e 's|/lib /usr/lib|/%{_lib} %{_libdir}|' configure # lib64 rpaths
- for f in docs/yuvfps.1 ; do
- iconv -f iso-8859-1 -t utf-8 $f > $f.utf8 ; mv $f.utf8 $f
- done
- %build
- %configure --disable-dependency-tracking --disable-static
- %__make # %{?_smp_mflags}
- %install
- %__rm -rf $RPM_BUILD_ROOT
- %__make install DESTDIR=$RPM_BUILD_ROOT
- %__rm -f $RPM_BUILD_ROOT{%{_infodir}/dir,%{_libdir}/lib*.la}
- # too broken/outdated to be useful in 1.[89].0 (and would come with dep chain)
- %__rm -f $RPM_BUILD_ROOT%{_bindir}/mpegtranscode
- %clean
- %__rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- /sbin/install-info %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
- %postun
- /sbin/ldconfig
- %preun
- [ $1 -eq 0 ] && \
- /sbin/install-info --delete %{_infodir}/mjpeg-howto.info %{_infodir}/dir || :
- %files
- %defattr(-,root,root,-)
- %doc COPYING CHANGES ChangeLog AUTHORS BUGS README.lavpipe NEWS TODO
- %{_bindir}/*
- %{_mandir}/man1/*.1*
- %{_mandir}/man5/yuv4mpeg.5*
- %{_infodir}/mjpeg-howto.info*
- ## gui
- %doc README.glav
- %{_bindir}/glav
- # lavplay and yuvplay won't save -libs/console util users from X11 and SDL
- # dependencies as long as liblavplay is in -libs, but they're inherently
- # GUI tools -> include them here
- %{_bindir}/lavplay
- %{_bindir}/y4mhist
- %{_bindir}/yuvplay
- %{_mandir}/man1/lavplay.1*
- %{_mandir}/man1/yuvplay.1*
- ## libs
- %{_libdir}/lib*.so.*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/%{name}
- %{_libdir}/lib*.so
- %{_libdir}/pkgconfig/%{name}.pc
- %changelog
- * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.0-1
- - new upstream release
- * Fri Sep 3 2010 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-2
- - Fix a memleak which is causing issues for LiVES
- * Wed Apr 15 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-1
- - Update to upstream 1.9.0 final release
- * Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 1.9.0-0.7.rc3
- - rebuild for new F11 features
- * Sat Dec 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.0-1.rc3
- - initial build
- * Fri Jul 25 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.9.0-0.6.rc3
- - Release bump for rpmfusion
- - Sync with freshrpms (no changes)
- * Tue Apr 22 2008 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.5.rc3
- - Apply patch from Gentoo to fix build with GCC 4.3 (#1941).
- * Tue Dec 4 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc3
- - 1.9.0rc3.
- * Sat Sep 29 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.4.rc2
- - Requires: which
- * Wed Aug 22 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.3.rc2
- - License: GPLv2
- * Thu Jun 21 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.2.rc2
- - Rebuild.
- * Fri Jun 8 2007 Ville Skyttä <ville.skytta at iki.fi> - 1.9.0-0.1.rc2
- - 1.9.0rc2.
- * Sat Nov 25 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-7
- - Split GUI utilities into -gui subpackage.
- - Don't ship mpegtranscode, it's broken/outdated.
- - Require mencoder for lav2avi.sh.
- * Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 1.8.0-6
- - rebuilt for unwind info generation, broken in gcc-4.1.1-21
- * Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-5
- - Specfile cleanup.
- * Sun Jun 4 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-4
- - Get rid of undefined non-weak symbols in liblav*.
- - Apply upstream fix for compiling with libquicktime 0.9.8.
- * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- - switch to new release field
- * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
- - add dist
- * Sat Jan 21 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.8.0-0.lvn.3
- - Include license text in -libs, it can be installed without the main package.
- - Convert yuvfps man page to UTF-8.
- - Fix -devel Group tag.
- * Thu Jan 19 2006 Adrian Reber <adrian@lisas.de> - 1.8.0-0.lvn.2
- - Added patch to compile with gcc 4.1
- - Dropped 0 Epoch
- * Mon Sep 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.8.0-0.lvn.1
- - 1.8.0.
- * Sat Aug 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc3
- - 1.6.3-rc3, Altivec fixes applied upstream.
- * Fri Aug 12 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.3-0.lvn.0.1.rc2
- - 1.6.3-rc2, clean up obsolete pre-FC2 stuff.
- - Fix Altivec build, kudos to upstream.
- * Thu May 26 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6,3-0.lvn.0.1.rc1
- - 1.6.3-rc1 (1.7.0 snapshot package not released, so no Epoch bump).
- * Sun May 22 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.2.cvs20050521
- - PPC: disable Altivec due to gcc4 build failure, honor $RPM_OPT_FLAGS.
- * Sat May 21 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.7.0-0.lvn.0.1.cvs20050521
- - Pre-1.7.0 snapshot as of today, all patches applied or obsoleted upstream.
- - Require pkgconfig in -devel.
- * Wed Feb 2 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.7
- - Add corrected -fPIC tweak from Thorsten.
- * Mon Jan 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.6
- - Include PNG input support.
- - Remove no-op $RPM_OPT_FLAGS setting from %%build.
- - Remove bogus optimization settings from configure script.
- * Fri Dec 31 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:1.6.2-0.lvn.5
- - CFLAGS="$CFLAGS -fPIC" on non x86; Fixes build error on x86_64; The
- option --with-pic is not enough
- * Sat Dec 18 2004 Dams <anvil[AT]livna.org> - 0:1.6.2-0.lvn.4
- - Disabling static libraries building
- * Tue Dec 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.6.2-0.lvn.3
- - Include quicktime support.
- - Apply patch from ALT Linux to fix info pages, fix typo in %%post.
- - Require /sbin/install-info.
- - Add "--without static" rpmbuild option to work around an issue with FC3 strip
- - Always enable SIMD accelerations, CPU capabilities detected at runtime.
- - Always disable use of cmov.
- * Thu Nov 11 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.2
- - Added patch to fix gcc3.4 build
- - Detected race condition in Makefiles (disabling _smp_mflags use)
- - Added info files & scriptlets
- - Dropped patch0 and patch1
- * Tue Jun 8 2004 Dams <anvil[AT]livna.org> 0:1.6.2-0.lvn.1
- - Updated to 1.6.2
- * Sun Sep 28 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.6
- - Removed comment after scriptlets
- * Fri Aug 22 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.5
- - buildroot -> RPM_BUILD_ROOT
- * Sun Aug 10 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.4
- - Applied upstream patches to fix build on gcc3.3 systems
- * Tue Apr 29 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.3
- - Now test arch for configure options (from Ville)
- - Removed ImageMagick-devel BuildRequires
- * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.6.1-0.fdr.2
- - Added missing BuildRequires
- - Added post/postun scriplets for libs package
- * Wed Apr 23 2003 Dams <anvil[AT]livna.org>
- - Initial build.
|