screen-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253
  1. Summary: A screen manager that supports multiple logins on one terminal.
  2. Summary(ja): スクリーンマネージャ - 一つの端末で多重ログイン
  3. Name: screen
  4. Version: 4.0.3
  5. Release: 4%{?_dist_release}
  6. License: GPL
  7. Group: Applications/System
  8. Source0: ftp://ftp.uni-erlangen.de/pub/utilities/screen/screen-%{version}.tar.gz
  9. # based http://git.savannah.gnu.org/gitweb/?p=screen.git;a=commit;h=97059b7ad521cf796daee07397c658d9716dd1e7
  10. Patch0: screen-4.0.3-execvpe.patch
  11. Patch6: screen-3.9.8-hascrypt.patch
  12. Patch11: screen-3.9.11-utf8-install.patch
  13. # obtained Patch11 from redhat
  14. Patch12: screen-4.0.3-stropts.patch
  15. Requires: ncurses
  16. Requires(post,preun): /sbin/install-info
  17. BuildRequires: ncurses-devel, texinfo, perl
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. The screen utility allows you to have multiple logins on just one
  23. terminal. Screen is useful for users who telnet into a machine or
  24. are connected via a dumb terminal, but want to use more than just
  25. one login.
  26. Install the screen package if you need a screen manager that can
  27. support multiple logins on one terminal.
  28. %description -l ja
  29. 一つの端末プログラムだけで多重のログインを可能にするスクリーン管理
  30. ユーティリティです。telnetで操作しているユーザやダムターミナルから
  31. 接続しているユーザでもっと多くの端末画面を使いたい場合にはとても
  32. 便利なプログラムです。
  33. %prep
  34. %setup -q
  35. %patch0 -p1 -b .execvpe
  36. # avoid duplicated type declaration of crypt.
  37. %patch6 -p1 -b .hascrypt
  38. # to make directories under $RPM_BUILD_ROOT
  39. %patch11 -p1 -b .utf8
  40. # do not include <sys/stropts.h>
  41. %patch12 -p1 -b .stropts
  42. %build
  43. autoconf
  44. %configure \
  45. --enable-pam \
  46. --enable-locate \
  47. --enable-telnet \
  48. --enable-colors256 \
  49. --with-sys-screenrc=%{_sysconfdir}/screenrc
  50. # configure can figure out these values.
  51. #perl -pi -e 's|.*#.*PTYMODE.*|#define PTYMODE 0620|' config.h
  52. #perl -pi -e 's|.*#.*PTYGROUP.*|#define PTYGROUP 5|' config.h
  53. perl -pi -e 's|.*#undef HAVE_BRAILLE.*|#define HAVE_BRAILLE 1|' config.h
  54. perl -pi -e 's|/usr/local/etc/screenrc|/etc/screenrc|' etc/etcscreenrc doc/*
  55. perl -pi -e 's|/local/etc/screenrc|/etc/screenrc|' doc/*
  56. rm doc/screen.info*
  57. make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. mkdir -p $RPM_BUILD_ROOT/etc/skel
  61. perl -pi -e 's,/usr/local/etc/screenrc,/etc/screenrc,' etc/etcscreenrc
  62. %makeinstall DDESTDIR=$RPM_BUILD_ROOT
  63. ( cd $RPM_BUILD_ROOT
  64. # gzip -9nf .%{_infodir}/screen.info*
  65. # strip .%{_bindir}/screen-%{version}
  66. rm -f .%{_bindir}/screen.old .%{_bindir}/screen
  67. mv .%{_bindir}/screen-%{version} .%{_bindir}/screen
  68. )
  69. install -c -m 0444 etc/etcscreenrc $RPM_BUILD_ROOT/etc/screenrc
  70. install -c -m 0644 etc/screenrc $RPM_BUILD_ROOT/etc/skel/.screenrc
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post
  74. /sbin/install-info %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  75. if [ -d /tmp/screens ]; then
  76. # we're not setuid root anymore
  77. chmod 777 /tmp/screens
  78. fi
  79. %preun
  80. if [ $1 = 0 ]; then
  81. /sbin/install-info --delete %{_infodir}/screen.info.* %{_infodir}/dir --entry="* screen: (screen). Terminal multiplexer."
  82. fi
  83. %files
  84. %defattr(-,root,root)
  85. %doc COPYING NEWS* README doc/FAQ TODO doc/README.DOTSCREEN terminfo
  86. #%attr(755,root,root) %{_bindir}/screen
  87. %{_bindir}/screen
  88. %{_mandir}/man1/screen.*
  89. %{_infodir}/screen.info*
  90. %{_datadir}/screen
  91. %config(noreplace) /etc/screenrc
  92. %config /etc/skel/.screenrc
  93. %changelog
  94. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.3-4
  95. - rebuild with VineSeed environment
  96. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.3-3vl6
  97. - build on current VineSeed
  98. - add execvpe patch (Patch0) based upstream git
  99. * Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.0.3-2
  100. - spec in UTF-8
  101. - add Patch12 to build against glibc-2.8
  102. - fix typo (from --enable-color256 to --enable-colors256)
  103. thanks Minematsu Hiroki-san for pointing this out
  104. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.3-1vl5
  105. - used %%{?_dist_release}
  106. * Mon Nov 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.3-0vl4
  107. - rebuild for VineSeed
  108. * Mon Nov 20 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.3-0vl3
  109. - rebuilt without libelf-devel (ppc.rpm linked with libelf.so.0)
  110. * Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.3-0vl2
  111. - add BuildRequires: texinfo, perl
  112. * Tue Oct 31 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-0vl1
  113. - upstream release with security fix (build for Vine 4.0)
  114. * Sat Jul 01 2006 NAKAMURA Kenta <kenta@vinelinux.org> 4.0.2-0vl2
  115. - use License instead of Copyright
  116. * Sat Jun 5 2004 IWAI, Masaharu <iwai@alib.jp> 4.0.2-0vl1
  117. - new upstream release
  118. - add %%{_datadir}/screen in %%files
  119. - no replace configuration file: /etc/screenrc
  120. * Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 3.9.13-0vl2
  121. - eliminate %%{_bindir} from %%files section
  122. * Thu Sep 12 2002 Yoshihiro Ota <ota@j.email.ne.jp> 3.9.13-0vl1
  123. - update to 3.9.13
  124. - add FAQ instead of a symbolic link to FAQ
  125. - remove unnecessary patches
  126. * Thu Nov 1 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.10-0vl1
  127. - update to 3.9.10 (security update)
  128. * Mon Aug 27 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.9-0vl1
  129. - update to 3.9.9
  130. - rebuild by current Seed
  131. - remove makeinfo patch, jbj patch
  132. * Sat Mar 10 2001 sagami@vinelinux.org
  133. - made minor spec fixes
  134. * Fri Mar 2 2001 Shoji Matsumoto <shom@vinelinux.org> 3.9.8-0vl1
  135. - update to 3.9.8
  136. - update 3.9.5-jbj.patch for 3.9.8
  137. - add hascrypt patch
  138. * Sat Dec 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  139. - 3.9.5-1vl3
  140. - built with gcc-2.95.3
  141. - partially used rpmmacros
  142. * Tue Oct 24 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  143. - 3.9.5-1vl2
  144. - fixed %files section to handle compressed man page
  145. * Fri Mar 3 2000 Taro FUNAKI <taro@KU3G.org>
  146. - updated to 3.9.5
  147. * Sun Feb 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  148. - 3.9.4-5vl1
  149. - merged missing patches from screen-3.9.4-3 on Red Hat 6.1
  150. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  151. - you know, we weren't just patching in Unix98 pty support for fun.
  152. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  153. - put screendir in ~
  154. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  155. - update to 3.9.4.
  156. * Wed Jun 16 1999 Bill Nottingham <notting@redhat.com>
  157. - force tty permissions/group
  158. * Sat Jun 5 1999 Dale Lovelace <dale@redhat.com>
  159. - permissions on /etc/skel/.screenrc to 644
  160. * Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
  161. - take out warning of directory permissions so root can still use screen
  162. * Wed Apr 07 1999 Bill Nottingham <notting@redhat.com>
  163. - take out warning of directory ownership so root can still use screen
  164. * Wed Apr 07 1999 Erik Troan <ewt@redhat.com>
  165. - patched in utempter support, turned off setuid bit
  166. * Fri Mar 26 1999 Erik Troan <ewt@redhat.com>
  167. - fixed unix98 pty support
  168. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  169. - auto rebuild in the new build environment (release 3)
  170. * Thu Mar 11 1999 Bill Nottingham <notting@redhat.com>
  171. - add patch for Unix98 pty support
  172. * Mon Dec 28 1998 Jeff Johnson <jbj@redhat.com>
  173. - update to 3.7.6.
  174. * Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
  175. - build root
  176. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  177. - translations modified for de, fr, tr
  178. * Tue Oct 21 1997 Cristian Gafton <gafton@redhat.com>
  179. - upgraded to 3.7.4
  180. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  181. - removed glibc 1.99 specific patch
  182. * Tue Sep 23 1997 Erik Troan <ewt@redhat.com>
  183. - added install-info support
  184. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  185. - built against glibc