bash-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558
  1. %define bashversion 4.3
  2. %define patchlevel 18
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
  17. Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
  18. Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
  19. Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
  20. Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
  21. Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
  22. Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
  23. Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
  24. Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
  25. Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
  26. Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
  27. Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
  28. Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
  29. Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
  30. Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
  31. Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
  32. Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
  33. Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
  34. # Other patches
  35. Patch101: bash-2.02-security.patch
  36. Patch102: bash-2.03-paths.patch
  37. Patch103: bash-2.03-profile.patch
  38. Patch104: bash-2.05a-interpreter.patch
  39. Patch105: bash-2.05b-debuginfo.patch
  40. Patch106: bash-2.05b-manso.patch
  41. Patch107: bash-2.05b-pgrp_sync.patch
  42. Patch108: bash-2.05b-readline-oom.patch
  43. Patch109: bash-2.05b-xcc.patch
  44. Patch110: bash-3.2-audit.patch
  45. Patch111: bash-3.2-ssh_source_bash.patch
  46. Patch112: bash-bashbug.patch
  47. Patch113: bash-infotags.patch
  48. Patch114: bash-requires.patch
  49. Patch115: bash-setlocale.patch
  50. Patch116: bash-tty-tests.patch
  51. # 484809, check if interp section is NOBITS
  52. Patch117: bash-4.0-nobits.patch
  53. # Do the same CFLAGS in generated Makefile in examples
  54. Patch118: bash-4.1-examples.patch
  55. # Builtins like echo and printf won't report errors
  56. # when output does not succeed due to EPIPE
  57. Patch119: bash-4.1-broken_pipe.patch
  58. # Enable system-wide .bash_logout for login shells
  59. Patch120: bash-4.2-rc2-logout.patch
  60. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  61. Patch121: bash-4.2-coverity.patch
  62. # Don't call malloc in signal handler
  63. Patch122: bash-4.1-defer-sigchld-trap.patch
  64. # 799958, updated info about trap
  65. Patch123: bash-4.2-manpage_trap.patch
  66. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  67. Patch125: bash-4.2-size_type.patch
  68. Buildroot: %{_tmppath}/%{name}-%{version}-root
  69. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  70. Obsoletes: bash <= 1.14.7
  71. Obsoletes: bash2
  72. %description
  73. Bash is a GNU project sh-compatible shell or command language
  74. interpreter. Bash (Bourne Again shell) incorporates useful features
  75. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  76. can be run by bash without modification.
  77. Bash offers several improvements over sh, including command line
  78. editing, unlimited size command history, job control, shell
  79. functions and aliases, indexed arrays of unlimited size and
  80. integer arithmetic in any base from two to 64. Bash is ultimately
  81. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  82. Tools standard.
  83. %package doc
  84. Summary: Documentation for the GNU Bourne Again shell (bash).
  85. Summary: GNU Bourne Again シェル向けドキュメント
  86. Group: Applications/Documentation
  87. Requires: %{name} = %{version}-%{release}
  88. Obsoletes: bash2-doc
  89. %description doc
  90. This is a separate documentation package for the GNU Bourne
  91. Again shell.
  92. %prep
  93. %setup -q -n %{name}-%{bashversion}
  94. # Official upstream patches
  95. %patch1 -p0 -b .001
  96. %patch2 -p0 -b .002
  97. %patch3 -p0 -b .003
  98. %patch4 -p0 -b .004
  99. %patch5 -p0 -b .005
  100. %patch6 -p0 -b .006
  101. %patch7 -p0 -b .007
  102. %patch8 -p0 -b .008
  103. %patch9 -p0 -b .009
  104. %patch10 -p0 -b .010
  105. %patch11 -p0 -b .011
  106. %patch12 -p0 -b .012
  107. %patch13 -p0 -b .013
  108. %patch14 -p0 -b .014
  109. %patch15 -p0 -b .015
  110. %patch16 -p0 -b .016
  111. %patch17 -p0 -b .017
  112. %patch18 -p0 -b .018
  113. # Other patches
  114. %patch101 -p1 -b .security
  115. %patch102 -p1 -b .paths
  116. %patch103 -p1 -b .profile
  117. %patch104 -p1 -b .interpreter
  118. %patch105 -p1 -b .debuginfo
  119. %patch106 -p1 -b .manso
  120. %patch107 -p1 -b .pgrp_sync
  121. %patch108 -p1 -b .readline_oom
  122. %patch109 -p1 -b .xcc
  123. %patch110 -p1 -b .audit
  124. %patch111 -p1 -b .ssh_source_bash
  125. %patch112 -p1 -b .bashbug
  126. %patch113 -p1 -b .infotags
  127. %patch114 -p1 -b .requires
  128. %patch115 -p1 -b .setlocale
  129. %patch116 -p1 -b .tty_tests
  130. %patch117 -p1 -b .nobits
  131. %patch118 -p1 -b .examples
  132. %patch119 -p1 -b .broken_pipe
  133. %patch120 -p1 -b .logout
  134. %patch121 -p1 -b .coverity
  135. %patch122 -p1 -b .defer_sigchld_trap
  136. %patch123 -p1
  137. %patch125 -p1 -b .size_type
  138. echo %{version} > _distribution
  139. echo %{release} |sed 's/vl.*//' > _patchlevel
  140. %build
  141. %configure --with-bash-malloc=no
  142. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  143. %install
  144. rm -rf %{buildroot}
  145. # Fix bug #83776
  146. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  147. make DESTDIR=$RPM_BUILD_ROOT install
  148. pushd $RPM_BUILD_ROOT
  149. mkdir ./bin
  150. mv ./usr/bin/bash ./bin/bash
  151. ln -s bash ./bin/sh
  152. rm -f .%{_infodir}/dir
  153. popd
  154. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  155. # make manpages for bash builtins as per suggestion in DOC/README
  156. pushd doc
  157. sed -e '
  158. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  159. /^\.SH NAME/d
  160. s/^bash, //
  161. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  162. s/,//g
  163. b
  164. }
  165. d
  166. ' builtins.1 > man.pages
  167. for i in echo pwd test kill; do
  168. perl -pi -e "s,$i,,g" man.pages
  169. perl -pi -e "s, , ,g" man.pages
  170. done
  171. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  172. for i in `cat man.pages` ; do
  173. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  174. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  175. done
  176. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  177. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  178. # Not for printf, false and true (conflict with coreutils)
  179. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  180. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  181. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  182. popd
  183. %find_lang %{name}
  184. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  185. %clean
  186. rm -rf %{buildroot}
  187. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  188. # to prevent prereq loops
  189. # post is in lua so that we can run it without any external deps. Helps
  190. # for bootstrapping a new install.
  191. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  192. %post -p <lua>
  193. bashfound = false;
  194. shfound = false;
  195. f = io.open("/etc/shells", "r");
  196. if f == nil
  197. then
  198. f = io.open("/etc/shells", "w");
  199. else
  200. repeat
  201. t = f:read();
  202. if t == "/bin/bash"
  203. then
  204. bashfound = true;
  205. end
  206. if t == "/bin/sh"
  207. then
  208. shfound = true;
  209. end
  210. until t == nil;
  211. end
  212. f:close()
  213. f = io.open("/etc/shells", "a");
  214. if not bashfound
  215. then
  216. f:write("/bin/bash\n")
  217. end
  218. if not shfound
  219. then
  220. f:write("/bin/sh\n")
  221. end
  222. f:close()
  223. %files -f %{name}.lang
  224. %defattr(-,root,root)
  225. %doc CHANGES COPYING
  226. %doc examples
  227. %config(noreplace) /etc/bashrc
  228. /bin/bash
  229. /bin/sh
  230. %{_infodir}/bash.info*
  231. %{_mandir}/*/*
  232. %{_mandir}/*/..1*
  233. %{_bindir}/bashbug
  234. %files doc
  235. %defattr(-,root,root)
  236. %doc COMPAT NEWS NOTES POSIX RBASH
  237. %doc examples/functions/ examples/misc/
  238. %doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
  239. %doc examples/startup-files/ examples/complete/ examples/loadables/
  240. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  241. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  242. %changelog
  243. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  244. - update to 4.3 patch level 18
  245. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  246. - update to 4.3 patch level 11
  247. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  248. - update to 4.2 patch level 45
  249. - import some patch from fedora package (122-127)
  250. - patch122: Don't call malloc in signal handler
  251. - patch123: #799958, updated info about trap
  252. - patch124: #695656, block the signal and unblock it after the
  253. new handler is installed
  254. - patch125: Use unsigned type for size
  255. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  256. - patch126: #903833, Fix missing close(), fixes fd leaks
  257. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  258. - remove postun lua script because bash will be never uninstalled
  259. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  260. - update to 4.2 patch level 37
  261. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  262. - update to 4.2 patch level 20
  263. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  264. - update to 4.2 patch level 8
  265. - use lua script in post/postun
  266. - update patches from fedora
  267. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  268. - update to 4.1 patch level 7
  269. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  270. - check if /bin/grep exists on %%post script
  271. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  272. - rebuilt with gcc-4.4.3-3 on ppc
  273. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  274. - rebuilt with new toolchain
  275. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  276. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  277. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  278. - add Requires(post): grep
  279. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  280. - remove obsolete /bin/bash2 entry from /etc/shells
  281. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  282. - add Requires(post): ncurses (should be added by find-requires..)
  283. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  284. - add upstream patch (from 040 to 048)
  285. - build against ncurses-devel (libtinfo)
  286. - spec in utf-8
  287. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  288. - added upstream patch (from 026 to 039)
  289. - added Japanese summary
  290. - applied new versioning policy
  291. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  292. - rebuilt with libtermcap-devel
  293. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  294. - new upstream release
  295. - add upstream patch (from 001 to 025)
  296. - remove Provides: bash2
  297. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  298. - rebuilt with new toolchain
  299. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  300. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  301. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  302. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  303. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  304. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  305. - update to 2.05b
  306. - rebuild with new toolchains
  307. - add make check
  308. - add %postun script based on Fedora development
  309. - README file moved doc package
  310. - update Patch5 and Patch8 from Fedora development
  311. - change Patch6
  312. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  313. - add Patch11--39 from Fedora development 2.05b-36
  314. * Tim Waugh <twaugh@redhat.com>
  315. - Fix parameter expansion in multibyte locales (bug #112657).
  316. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  317. bug #110777).
  318. - Apply upstream patches (bug #109269 among others).
  319. - Fix bash.info (bug #83776).
  320. - Add bash205b-007 patch to fix bug #106876.
  321. - Avoid crashing on multibyte input when locale is set incorrectly
  322. (bug #74266).
  323. - LFS support (bug #103627).
  324. - Fix completion display when multibyte or control characters are to be
  325. shown (bug #90201).
  326. - Fix a warning message (bug #79629).
  327. - Don't build with AFS support (bug #86514).
  328. - Don't explicitly strip binaries (bug #85995).
  329. - Really fix bug #83331 for good.
  330. - Fix builtins.1.
  331. - Actually apply the patch (bug #83331).
  332. - Fix history/UTF-8 bug (bug #83331).
  333. - More tab-completion fixing (bug #72512).
  334. - Force pgrp synchronization (bug #81653).
  335. - Prevent prompt overwriting output (bug #74383).
  336. - Fix '-rbash' (bug #78455).
  337. - Add readline-init patch (bug #74925).
  338. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  339. - Ship '.' man page, which doesn't get picked up by glob.
  340. - Locale shell variables fix (bug #74701).
  341. * Elliot Lee <sopwith@redhat.com>
  342. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  343. cross compiles.
  344. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  345. - update to 2.05
  346. - add README.jpatch to %doc
  347. - remove patch4 (bash2): revert command name in man pages to "bash"
  348. - fix perl command to remove man pages conflict with sh-utils
  349. - remove section of config.h.in from patch0 to prevent remake of configure
  350. - change patch9: define in config-top.h to avoid conflict with patch100
  351. - remove patches 7, 10 & 101
  352. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  353. - made a link for man sh
  354. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  355. - added missing %%post and %%triggerpostun section
  356. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  357. - 2.04-1vl12
  358. - now bash2 is finally bash
  359. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  360. - build for Playstation2
  361. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  362. - 2.04-1vl10
  363. - Provides: bash = %%{version}
  364. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  365. - added Provides: bash
  366. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  367. - Obsoletes: bash
  368. - changed Copyright to License
  369. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  370. - 2.04-1vl7
  371. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  372. - corrected: bashrc-vine -> bashrc
  373. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  374. - combined bash-1.x and bash-2.x packages
  375. - added some patches from bash-2.04-13mdk
  376. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  377. - fix spec macros
  378. - added tests
  379. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  380. - build with gcc-2.95.3
  381. - partially used rpmmacros
  382. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  383. - minor bug fix in spec file
  384. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  385. - 2.04-1vl3
  386. - modified %install and %files section to handle compressed man page(s)
  387. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  388. - added pcomplete patch to fix complete if the candidate list is NULL.
  389. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  390. - updated to 2.04
  391. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  392. - Remove annoying ^H's from documentation
  393. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  394. - patch to detect what executables are required by a script.
  395. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  396. - auto rebuild in the new build environment (release 4)
  397. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  398. - strip binaries.
  399. - include bash-doc correctly.
  400. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  401. - fixed post/postun /etc/shells work.
  402. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  403. - updated again text in the spec file
  404. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  405. - updated text in spec file.
  406. - update to 2.03.
  407. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  408. - build it as bash2 instead of bash
  409. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  410. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  411. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  412. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  413. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  414. - patch for the arm
  415. - use $RPM_ARCH-redhat-linux as the build target
  416. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  417. - rewrite %pre, axe %postun (to avoid prereq loops)
  418. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  419. - resurrect for RH 6.0.
  420. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  421. - update to 2.02.1
  422. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  423. - Package for 5.2.
  424. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  425. - added POSIX.NOTES doc file
  426. - some extraneous doc files removed
  427. - minor .spec file changes
  428. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  429. - upgraded to version 2.02
  430. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  431. - glibc & signal patches no longer required
  432. - added documentation subpackage (doc)
  433. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  434. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  435. is based on a change made in bash 2.0. Should fix some early exit
  436. problems with suspends and fg.
  437. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  438. - added %clean
  439. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  440. - added comment explaining why install-info isn't used
  441. - added mips patch
  442. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  443. - added BuildRoot
  444. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  445. - built against glibc