msgpack-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. %define ver 2.1.1
  2. %define rel 1
  3. Name: msgpack
  4. Version: %{ver}
  5. Release: %{rel}%{?_dist_release}
  6. Summary: Binary-based efficient object serialization library
  7. Group: System Environment/Libraries
  8. License: Boost Software License 1.0
  9. URL: http://msgpack.org
  10. Source0: http://msgpack.org/releases/cpp/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildRequires: cmake >= 2.8.6
  13. BuildRequires: zlib-devel
  14. BuildRequires: libboost-devel
  15. # for %%check
  16. BuildRequires: gtest-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: iwaim
  20. %description
  21. MessagePack is a binary-based efficient object serialization
  22. library. It enables to exchange structured objects between many
  23. languages like JSON. But unlike JSON, it is very fast and small.
  24. %package devel
  25. Summary: Libraries and header files for %{name}
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. %description devel
  29. Libraries and header files for %{name}
  30. %prep
  31. %setup -q
  32. %build
  33. %__cmake \
  34. -DCMAKE_VERBOSE_MAKEFILE=ON \
  35. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  36. -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \
  37. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir} \
  38. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  39. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  40. -DSHARE_INSTALL_PREFIX:PATH=%{_datadir} \
  41. -DMSGPACK_BOOST=ON \
  42. -DBoost_USE_STATIC_LIBS=OFF \
  43. .
  44. make %{?_smp_mflags}
  45. %check
  46. make test
  47. %install
  48. make install DESTDIR=$RPM_BUILD_ROOT
  49. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f '{}' ';'
  50. %post -p /sbin/ldconfig
  51. %postun -p /sbin/ldconfig
  52. %files
  53. %doc AUTHORS COPYING ChangeLog LICENSE* NOTICE README README.md
  54. %{_libdir}/*.so.*
  55. %files devel
  56. %{_includedir}/*
  57. %{_libdir}/*.so
  58. %{_libdir}/pkgconfig/msgpack.pc
  59. %changelog
  60. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-1
  61. - update to 2.2.1
  62. - update License tag
  63. - update BuildRequires
  64. - using cmake
  65. - using libboost
  66. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 0.5.8-2
  67. - rebuild with gcc-5.4.0
  68. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 0.5.8-1
  69. - update to 0.5.8
  70. - drop gtest patch: upstream fixed
  71. - add pkgconfig file in msgpack-devel package
  72. * Fri Feb 1 2013 IWAI, Masaharu <iwai@alib.jp> 0.5.7-1
  73. - initial build for Vine Linux
  74. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.7-2
  75. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  76. * Wed Feb 15 2012 Daiki Ueno <dueno@redhat.com> - 0.5.7-1
  77. - initial packaging for Fedora