netcdf-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. %define pkg_name netcdf
  2. %define pkg_version 4.3.2
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: Libraries for the Unidata network Common Data Form
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: NetCDF
  9. Group: System Environment/Libraries
  10. URL: http://www.unidata.ucar.edu/downloads/netcdf/index.jsp
  11. Source0: ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
  12. # Use pkgconfig in nc-config to avoid multi-lib issues
  13. Patch0: netcdf-pkgconfig.patch
  14. # Upstream patch to support hdf5 1.8.13 mpio change
  15. Patch1: netcdf-mpio.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: chrpath
  18. BuildRequires: curl-devel
  19. BuildRequires: doxygen
  20. BuildRequires: gawk
  21. BuildRequires: hdf-devel
  22. BuildRequires: hdf5-devel
  23. BuildRequires: m4
  24. BuildRequires: libjpeg-turbo-devel
  25. BuildRequires: zlib-devel
  26. Requires: hdf5
  27. %description
  28. NetCDF (network Common Data Form) is an interface for array-oriented
  29. data access and a freely-distributed collection of software libraries
  30. for C, Fortran, C++, and perl that provides an implementation of the
  31. interface. The NetCDF library also defines a machine-independent
  32. format for representing scientific data. Together, the interface,
  33. library, and format support the creation, access, and sharing of
  34. scientific data. The NetCDF software was developed at the Unidata
  35. Program Center in Boulder, Colorado.
  36. NetCDF data is:
  37. o Self-Describing: A NetCDF file includes information about the
  38. data it contains.
  39. o Network-transparent: A NetCDF file is represented in a form that
  40. can be accessed by computers with different ways of storing
  41. integers, characters, and floating-point numbers.
  42. o Direct-access: A small subset of a large dataset may be accessed
  43. efficiently, without first reading through all the preceding
  44. data.
  45. o Appendable: Data can be appended to a NetCDF dataset along one
  46. dimension without copying the dataset or redefining its
  47. structure. The structure of a NetCDF dataset can be changed,
  48. though this sometimes causes the dataset to be copied.
  49. o Sharable: One writer and multiple readers may simultaneously
  50. access the same NetCDF file.
  51. %package devel
  52. Summary: Development files for netcdf
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. %description devel
  56. This package contains the netCDF header files, libs, and man pages.
  57. %package static
  58. Summary: Static libs for netcdf
  59. Group: Development/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. %description static
  62. This package contains the netCDF C static libs.
  63. %prep
  64. %setup -q -n %{name}-%{version}
  65. %patch0 -p1 -b .pkgconfig
  66. %patch1 -p1 -b .mpio
  67. %build
  68. export LDFLAGS="-L%{_libdir}/hdf"
  69. export CPPFLAGS=-I%{_includedir}/hdf
  70. export LIBS="-ldf -ljpeg"
  71. %configure \
  72. --enable-shared \
  73. --enable-netcdf-4 \
  74. --enable-dap \
  75. --enable-extra-example-tests \
  76. --enable-hdf4 \
  77. --disable-dap-remote-tests
  78. %{__make} %{?_smp_mflags}
  79. %install
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  82. chrpath --delete ${RPM_BUILD_ROOT}%{_bindir}/nc{copy,dump,gen,gen3}
  83. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  84. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  85. %check
  86. %{__make} check
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %post -p %{_syssbindir}/ldconfig
  90. %postun -p %{_syssbindir}/ldconfig
  91. %files
  92. %defattr(-,root,root,-)
  93. %doc COPYRIGHT README.md RELEASE_NOTES.md
  94. %{_bindir}/*
  95. %{_libdir}/*.so.*
  96. %{_mandir}/man1/*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %{_includedir}/*
  100. %{_libdir}/*.so
  101. %{_libdir}/pkgconfig/*
  102. %{_mandir}/man3/*
  103. %files static
  104. %{_libdir}/*.a
  105. %changelog
  106. * Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.3.2-2
  107. - rebuild under hdf5-1.8.20
  108. * Sun Jan 25 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.2-1
  109. - updated to 4.3.2
  110. - built with hdf and hdf5
  111. * Sun May 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-2
  112. - add configure options (--enable-netcdf-4, --enable-dap)
  113. - add BuildRequires: curl-devel
  114. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-1
  115. - update to 4.2.1.1
  116. - add BuildRequires: zlib-devel, hdf5-devel
  117. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
  118. - new upstream release
  119. * Sun Oct 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0.p1-1
  120. - new versioning policy
  121. * Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 3.6.0.p1-0vl2
  122. - changed BuildRequires gcc-g77 to gcc-gfortran
  123. * Fri Oct 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.0.p1-0vl1
  124. - initial build for Vine Linux