totem-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594
  1. # define versions
  2. %define _glib_ver 2.48.0
  3. %define _gtk_ver 3.20.0
  4. %define _gnomeicon_ver 3.12.0
  5. %define _gnome_doc_utils_ver 0.20.0
  6. %define _dbus_ver 1.6.0
  7. %define _gst_ver 1.2.0
  8. %define _gstpb_ver 1.2.0
  9. %define _gstpg_ver 1.2.0
  10. %define _gstpbad_ver 1.2.0
  11. %define _xulrunner_ver 1.9
  12. %define _nautilus_ver 3.20.0
  13. %define _shared_mime_info_ver 0.17
  14. %define _unique_ver 1.0
  15. %define _totem_pl_parser_ver 3.4.4
  16. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  17. Summary: Movie player for GNOME 3
  18. Summary(ja): GNOME3 用動画プレイヤー
  19. Name: totem
  20. Version: 3.20.1
  21. Release: 1%{?_dist_release}
  22. License: GPL
  23. Group: Applications/Multimedia
  24. URL: http://www.gnome.org/projects/totem/
  25. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
  26. # from upstream
  27. Patch0: totem-3.20.1-gint64-format.patch
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. Packager: Takemikaduchi
  32. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  33. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  34. BuildRequires: dbus-devel >= %{_dbus_ver}
  35. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  36. BuildRequires: gnome-desktop3-devel
  37. BuildRequires: gettext
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: yelp-tools
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: grilo-devel
  43. BuildRequires: bluez-libs-devel >= 4.15
  44. BuildRequires: lirc-devel
  45. BuildRequires: unique-devel >= %{_unique_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pylint
  48. BuildRequires: pygobject3-devel
  49. BuildRequires: libpeas-devel
  50. BuildRequires: libXtst-devel
  51. BuildRequires: gsettings-desktop-schemas-devel
  52. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  53. BuildRequires: vala
  54. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  55. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  56. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  57. BuildRequires: clutter-gtk-devel
  58. BuildRequires: clutter-gst3-devel
  59. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  60. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  61. Requires: gstreamer1 >= %{_gst_ver}
  62. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  63. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  64. Requires: iso-codes
  65. Requires: grilo-plugins
  66. Obsoletes: nautilus-media
  67. Obsoletes: %{name}-gstreamer < 2.30.1-2
  68. Obsoletes: %{name}-xine < 2.30.1-2
  69. Obsoletes: %{name}-common < 2.30.1-3
  70. Obsoletes: %{name}-mozilla < 3.14.0
  71. Provides: nautilus-media
  72. Provides: %{name}-common = %{version}-%{release}
  73. Requires(post): ldconfig, desktop-file-utils
  74. Requires(postun): ldconfig, desktop-file-utils
  75. %description
  76. Totem is simple movie player for the Gnome desktop. It features a
  77. simple playlist, a full-screen mode, seek and volume controls, as well as
  78. a pretty complete keyboard navigation.
  79. %package devel
  80. Summary: Plugin writer's documentation for totem
  81. Group: Development/Libraries
  82. Requires: %{name} = %{version}-%{release}
  83. %description devel
  84. The %{name}-devel package contains API documentation for
  85. developing developing plugins for %{name}.
  86. %prep
  87. %setup -q
  88. %patch0 -p1 -b .gint64
  89. %build
  90. #DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  91. #export MOZILLA_PLUGINDIR=%{mozplug_dir}
  92. %configure \
  93. --enable-python \
  94. --enable-vala \
  95. --enable-nautilus
  96. make %{?_smp_mflags}
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. make install DESTDIR=$RPM_BUILD_ROOT
  100. # remove unneeded files
  101. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  102. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  103. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  104. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  105. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  106. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  107. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  108. # remove unused file
  109. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  110. %__rm -f %{buildroot}%{_libexecdir}/%{name}/totem-bugreport.py
  111. %find_lang %{name} --with-gnome
  112. # save space by linking identical images in translated docs
  113. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  114. for f in $helpdir/C/figures/*.png; do
  115. b="$(basename $f)"
  116. for d in $helpdir/*; do
  117. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  118. g="$d/figures/$b"
  119. if [ -f "$g" ]; then
  120. if cmp -s $f $g; then
  121. rm "$g"; ln -s "../../C/figures/$b" "$g"
  122. fi
  123. fi
  124. fi
  125. done
  126. done
  127. %clean
  128. %__rm -rf %{buildroot}
  129. %post
  130. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  131. touch %{_datadir}/icons/hicolor
  132. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  133. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  134. fi
  135. %postun
  136. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  137. touch %{_datadir}/icons/hicolor
  138. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  139. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  140. fi
  141. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  142. %posttrans
  143. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  144. %files -f %{name}.lang
  145. %defattr(-,root,root,-)
  146. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  147. %{_bindir}/totem
  148. %{_bindir}/totem-audio-preview
  149. %{_bindir}/totem-video-thumbnailer
  150. %{_datadir}/GConf/gsettings/opensubtitles.convert
  151. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  152. %{_datadir}/GConf/gsettings/totem.convert
  153. %{_datadir}/appdata/org.gnome.Totem.appdata.xml
  154. %{_datadir}/applications/org.gnome.Totem.desktop
  155. %{_datadir}/dbus-1/services/org.gnome.Totem.service
  156. %{_datadir}/glib-2.0/schemas/*.xml
  157. %{_datadir}/icons/*/*/*/*
  158. %{_datadir}/thumbnailers/totem.thumbnailer
  159. %{_datadir}/%{name}
  160. %{_datadir}/gtk-doc/html/totem
  161. %{_libdir}/libtotem.so.*
  162. %{_libdir}/girepository-1.0/*.typelib
  163. %dir %{_libdir}/totem
  164. %dir %{_libdir}/totem/plugins
  165. %{_libdir}/totem/plugins/apple-trailers/
  166. %{_libdir}/totem/plugins/autoload-subtitles
  167. %{_libdir}/totem/plugins/brasero-disc-recorder
  168. %{_libdir}/totem/plugins/dbus
  169. %{_libdir}/totem/plugins/gromit
  170. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  171. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  172. %{_libdir}/totem/plugins/lirc
  173. %{_libdir}/totem/plugins/media-player-keys
  174. %{_libdir}/totem/plugins/ontop
  175. %{_libdir}/totem/plugins/opensubtitles
  176. %{_libdir}/totem/plugins/properties
  177. %{_libdir}/totem/plugins/pythonconsole
  178. %{_libdir}/totem/plugins/recent
  179. %{_libdir}/totem/plugins/rotation
  180. %{_libdir}/totem/plugins/screensaver
  181. %{_libdir}/totem/plugins/screenshot
  182. %{_libdir}/totem/plugins/skipto
  183. %{_libdir}/totem/plugins/save-file/libsave-file.so
  184. %{_libdir}/totem/plugins/save-file/save-file.plugin
  185. %{_libdir}/totem/plugins/vimeo
  186. %{_libdir}/nautilus/extensions-3.0/*.so*
  187. %{_mandir}/man1/*
  188. %files devel
  189. %defattr(-, root, root,-)
  190. %{_includedir}/totem
  191. %{_libdir}/libtotem.so
  192. %{_libdir}/pkgconfig/totem.pc
  193. %{_datadir}/gir-1.0/Totem-1.0.gir
  194. %{_datadir}/gtk-doc/html/totem
  195. %changelog
  196. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
  197. - new upstream release
  198. - add BuildRequires: lirc-devel
  199. - add Patch0 (totem-3.20.1-gint64-format.patch)
  200. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  201. - new upstream release
  202. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.4-1
  203. - new upstream release
  204. * Wed Jul 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-3
  205. - add Requires: grilo-plugins
  206. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-2
  207. - remove BuildRequires: gstreamer1-plugins-bad-free-devel
  208. * Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  209. - new upstream release
  210. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  211. - new upstream release
  212. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  213. - new upstream release
  214. - change BuildRequires: clutter-gst3-devel instead of clutter-gst-devel
  215. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  216. - new upstream release
  217. * Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  218. - new upstream release
  219. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  220. - new upstream release
  221. - add BuildRequires: gnome-desktop3-devel
  222. - remove BuildRequires: xulrunner-devel
  223. - remove %%{name}-mozilla subpackage
  224. * Thu Aug 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  225. - new upstream release
  226. * Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  227. - new upstream release
  228. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  229. - new upstream release
  230. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-2
  231. - rebuild with VineSeed environment
  232. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  233. - new upstream release
  234. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  235. - new upstream release
  236. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  237. - new upstream release
  238. - add BuildRequires: yelp-tools, vala
  239. - change configure option (--enable-vala)
  240. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  241. - new upstream release
  242. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  243. - new upstream release
  244. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  245. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  246. - new upstream release
  247. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  248. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  249. - new upstream release
  250. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  251. - add configure option (--disable-vegas-plugin)
  252. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  253. - new upstream release
  254. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  255. - new upstream release
  256. - add BuildRequires: pylint
  257. - remove BuildRequires: libgdata-devel
  258. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  259. - new upstream release
  260. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  261. - new upstream release
  262. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  263. - new upstream release
  264. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  265. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  266. - new upstream release
  267. - change BuildRequires: gtk3-devel instead of gtk2-devel
  268. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  269. clutter-gst-devel, libmx-devel
  270. - change configure option (--disable-vala)
  271. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  272. - new upstream release
  273. - fix %files
  274. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  275. - new upstream release
  276. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  277. - clean up spec file
  278. - remove totem-common and merged to totem main package.
  279. - add Obsoletes: totem-common
  280. - remove unneeded BR: and R:
  281. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  282. - libmusicbrainz, alternatives
  283. - remove explicit dependency
  284. - gtk2, glib2, dbus
  285. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  286. - add R: gstreamer-plugins-good
  287. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  288. - rebuild with libgdata (add youtube plugin)
  289. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  290. - add Obsolete: totem-gstreamer, totem-xine)
  291. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  292. - new upstream release
  293. - chagnge _gst_ver from 0.10.19 to 0.10.29
  294. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  295. - new upstream release
  296. - drop totem-tracker package
  297. - add BuildRequires: unique-devel
  298. - remove BuildRequires: hal-devel
  299. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  300. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  301. - remove unneeded autoreconf
  302. - add BR: lirc
  303. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  304. - new upstream release
  305. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  306. - remove bemused plugin
  307. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  308. - new upstream release
  309. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  310. - added tracker video search sub-package
  311. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  312. - new upstream release
  313. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  314. - new upstream release
  315. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  316. - remove libxine dependency from totem-common
  317. - build xine backend with minimum dependency
  318. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  319. - add BR: bluez-libs-devel >= 4.15
  320. - fix typo in %%postun xine
  321. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  322. - rebuild with bluez-libs-devel-4.15
  323. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  324. - new upstream release
  325. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  326. - new upstream release
  327. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  328. - new upstream release
  329. - add patch1 to build with xulrunner-1.9
  330. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  331. - new upstream release
  332. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  333. - new upstream release
  334. - disabled devel package (replaced by totem-pl-parser-devel)
  335. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  336. - new upstream release
  337. - update version macros
  338. - enable browser plugins on x86_64
  339. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  340. - new upstream release
  341. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  342. - upstream release
  343. - drop obsolete ja.po.patch (patch0)
  344. - revert change of 1.4.4-0vl2
  345. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  346. - upstream release
  347. - enable browser plugins (exclude x86_64 arch)
  348. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  349. - upstream release
  350. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  351. - update configure options
  352. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  353. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  354. - fix mistranslation (patch0)
  355. - add icon symlink
  356. - add BuildRequires: gstreamer-plugins-good
  357. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  358. - upstream release
  359. - update %%_glib_ver, %%_xine_ver
  360. - add BuildRequires: hal
  361. - update %%configure options
  362. - update %%files
  363. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  364. - upstream release
  365. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  366. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  367. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  368. - upstream release
  369. - drop obsolete patch0
  370. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  371. - upstream release
  372. - add patch0 to build with intltool-0.35
  373. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  374. - upstream release
  375. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  376. - upstream release
  377. - update alternatives entry
  378. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  379. - upstream release
  380. - drop fix-sort-function.patch (was merged to upstream, #331426)
  381. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  382. - rebuild with gnome-2.14rc
  383. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  384. - upstream release
  385. - add macros
  386. - _gtk_ver, _glib_ver
  387. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  388. - _dbus_ver
  389. - _gst_ver, gstpb_ver, _xine_ver
  390. - add fix-sort-function.patch to build with glib < 2.9.1
  391. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  392. - upstream release
  393. - add BuildRequires:
  394. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  395. - gnome-vfs2-devel >= 2.9.92
  396. - dbus-devel >= 0.35
  397. - use gstreamer-0.10 as backend for totem-gstreamer
  398. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  399. - use gstreamer08 instead of gstreamer
  400. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  401. - upstream release
  402. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  403. - fix missing links
  404. - update file list
  405. - update update-alternatives scripts
  406. - fix totem-gstreamer's %%postun script
  407. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  408. - upstream release
  409. - add BuildRequires: iso-codes, libmusicbrainz-devel
  410. - add Requires: iso-codes, libmusicbrains to -common package
  411. - remove BuildRequires: nautilus-cd-burner
  412. - remove Requires: nautilus-cd-burner from -common package
  413. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  414. - totem-gstreamer obsoletes nautilus-media
  415. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  416. - upstream release
  417. - add Requires(post,postun): alternatives for gstreamer,xine
  418. - add Requires(postun,triggers): alternatives for common
  419. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  420. - upstream release
  421. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  422. - build xine backend
  423. - move common files to common package
  424. - move GStreamer related files to gstreamer package
  425. - install xine related files to xine package
  426. - fix scripts
  427. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  428. - upstream release
  429. - update URL
  430. - move *.{a,la} to devel package
  431. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  432. - fix %%{post,preun} script (video-thumbnail.schemas)
  433. - sync with Fedora Core's 1.0.1-1
  434. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  435. - Update to upstream version 1.0.1
  436. - Break out devel package
  437. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  438. - add %%{post,pre}un script
  439. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  440. - initial build for Vine Linux
  441. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  442. - fix %%post
  443. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  444. - Obsolete nautilus-media
  445. - Install property page and thumbnailer
  446. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  447. - Update to 0.101
  448. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  449. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  450. missing menu entry (144088)
  451. - Remove workaround for desktop file being misinstalled, fixed
  452. by above patch
  453. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  454. - New upstream version 0.100
  455. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  456. - update to 0.99.22
  457. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  458. - Add patch to remove removed items from package from help
  459. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  460. - New upstream 0.99.19
  461. - Fixes crasher with CD playback (see NEWS)
  462. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  463. - Call update-desktop-database in post
  464. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  465. - update to 0.99.18
  466. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  467. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>