tzdata-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394
  1. %bcond_without java18
  2. Summary: Timezone data
  3. Summary(ja): タイムゾーンのデータ
  4. Name: tzdata
  5. Version: 2017b
  6. %define tzdata_version 2017b
  7. %define tzcode_version 2017b
  8. Release: 1%{?_dist_release}
  9. License: Public Domain
  10. Group: System Environment/Base
  11. URL: https://www.iana.org/time-zones
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # These are official upstream.
  15. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  16. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  17. Source2: javazic.tar.gz
  18. Source3: javazic-1.8-37392f2f5d59.tar.xz
  19. Patch100: javazic-fixup.patch
  20. Patch101: rebase-01.patch
  21. Patch102: rebase-02.patch
  22. Patch103: 7090844.patch
  23. Patch104: 7133138.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. BuildRequires: gawk, glibc, perl
  27. BuildRequires: java-1.8.0-openjdk-devel
  28. BuildRequires: glibc-common >= 2.5.90-7
  29. Conflicts: glibc-common <= 2.3.2-63
  30. %description
  31. This package contains data files with rules for various timezones around
  32. the world.
  33. %description -l ja
  34. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  35. %package java
  36. Summary: Timezone data for Java
  37. Group: System Environment/Base
  38. %description java
  39. This package contains timezone information for use by Java runtimes.
  40. %prep
  41. %setup -q -c -a 1
  42. mkdir javazic
  43. tar zxf %{SOURCE2} -C javazic
  44. pushd javazic
  45. %patch100
  46. %patch101
  47. %patch102
  48. %patch103
  49. %patch104
  50. # Hack alert! sun.tools may be defined and installed in the
  51. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  52. # for creating the zoneinfo files, rebase all the packages
  53. # from "sun." to "rht.". Unfortunately, gcj does not support
  54. # any of the -Xclasspath options, so we must go this route
  55. # to ensure the greatest compatibility.
  56. mv sun rht
  57. find . -type f -name '*.java' -print0 \
  58. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  59. -e 's:sun\.util\.:rht.util.:g'
  60. popd
  61. tar xf %{SOURCE3}
  62. echo "%{name}%{tzdata_version}" >> VERSION
  63. %build
  64. FILES="africa antarctica asia australasia europe northamerica southamerica
  65. pacificnew etcetera backward"
  66. mkdir zoneinfo/{,posix,right}
  67. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  68. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  69. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  70. grep -v tz-art.htm tz-link.htm > tz-link.html
  71. # Java 6/7 tzdata
  72. pushd javazic
  73. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  74. popd
  75. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  76. -d javazi \
  77. $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  78. %if %{with java18}
  79. # Java 8 tzdata
  80. pushd javazic-1.8
  81. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  82. popd
  83. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  84. -srcdir . -dstfile tzdb.dat \
  85. -verbose \
  86. $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  87. %endif
  88. %install
  89. rm -fr $RPM_BUILD_ROOT
  90. install -d $RPM_BUILD_ROOT%{_datadir}
  91. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  92. install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  93. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  94. %if %{with java18}
  95. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  96. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  97. %endif
  98. %clean
  99. rm -fr $RPM_BUILD_ROOT
  100. %files
  101. %defattr(-,root,root)
  102. %{_datadir}/zoneinfo
  103. %doc README
  104. %doc Theory
  105. %doc tz-link.html
  106. %files java
  107. %defattr(-,root,root)
  108. %{_datadir}/javazi
  109. %if %{with java18}
  110. %{_datadir}/javazi-1.8
  111. %endif
  112. %changelog
  113. * Mon Jun 26 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2017b-1
  114. - update to 2017b
  115. * Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
  116. - updated to 2016j.
  117. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
  118. - fixed changelog.
  119. - added Vendor and Distribution tag.
  120. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
  121. - updated to 2016f.
  122. * Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
  123. - updated to 2016e.
  124. - enabled java18 stuff.
  125. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  126. - updated to 2016d.
  127. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  128. - updated to 2015f.
  129. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  130. - updated to 2015e.
  131. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  132. - update to tzdata-2012c, tzcode-2012b
  133. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  134. - rebuilt with rpm-4.8.1-3
  135. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  136. - update to tzdata-2010l, tzcode-2010l
  137. - added java subpackage
  138. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  139. - update to tzdata-2009d, tzcode-2009d
  140. - spec in utf-8
  141. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  142. - update to tzdata-2008b, tzcode-2008a
  143. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  144. - initial build for VineSeed
  145. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  146. - Upstream 2007d
  147. - Mongolia has abolished DST.
  148. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  149. than 01:00 standard time.
  150. - Cuba observed DST starting Sunday.
  151. - Resolute, Nunavut switched from Central to Eastern time last
  152. November.
  153. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  154. - Upstream 2007c
  155. - Pulaski County, Indiana, switched back to eastern time.
  156. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  157. - Upstream 2007b
  158. - Changes to the commentary in "leapseconds".
  159. - Upstream 2007a
  160. - Updates to Bahamas, they will be in sync with 2007 US DST change
  161. - New zone Australia/Eucla
  162. - Africa/Asmera renamed to Africa/Asmara, link created
  163. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  164. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  165. - Upstream 2006p
  166. - Covers changes from 2006m-2 and 2006m-3
  167. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  168. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  169. - Patch for Western Australia DST trial
  170. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  171. - Proposed upstream patch (#210058)
  172. - Jordan will switch to winter time on October 27, not September 29
  173. - Brazil's DST this year is the first Sunday in November to the last
  174. Sunday in February. (Thanks to Frederico A. C. Neves.)
  175. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  176. - Commentary and past timestamps changes
  177. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  178. - Upstream 2006m:
  179. - Adjustments for Egypt, Palestine, Uruguay
  180. - Better description of `until' field in zic (8) manpage
  181. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  182. - Upstream 2006k, 2006l:
  183. - Adjustments for Egypt, Palestine, Cuba, Honduras
  184. - Documentation changes
  185. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  186. - Upstream 2006j
  187. - Honduras stopped observing DST on Monday at 00:00
  188. - America/Bermuda will follow the US's lead next year
  189. - America/Moncton will use US-style rules next year
  190. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  191. year
  192. - New zone: America/Atikokan instead of America/Coral_Harbour
  193. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  194. - Historical changes
  195. - Commentary updates
  196. - Upstream 2006i
  197. - localtime.c fixes
  198. - Upstream 2006h
  199. - zic leapsecond fix
  200. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  201. - rebuild
  202. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  203. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  204. - Nicaragua updates
  205. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  206. - Upstream 2006f
  207. - America/Guatemala observes DST between Apr/30 and Oct/1
  208. - Historical changes for Nicaragua
  209. - Update of America/Indiana/Vincennes in zone table
  210. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  211. - Upstream 2006d
  212. - Haiti observes DST
  213. - Sri Lanka change actually took effect Apr/15
  214. - All Canada is now scheduled for 2007 US DST rules
  215. - Some historical fixes
  216. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  217. - Upstream 2006c
  218. - Time-related changes:
  219. - dozens of historical and commentary changes
  220. - Iran stopped observing DST
  221. - Sri Lanka switches from UTC+6 to UTC+5:30
  222. - America/Thule and America/Edmonton will adopt new US rules,
  223. starting 2007
  224. - Tunisia is adopting regular DST
  225. - Code:
  226. - asctime.c: Chages in format strings to silent gcc warnings
  227. - removing K&R notation from function signatures
  228. - few fixes across the code
  229. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  230. - Patch for Sri Lanka time zone change (#184514)
  231. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  232. - Upstream 2006b:
  233. - using tz64code version, as 32 is legacy according to tzdata ML
  234. - new manual pages for ctime, strftime, tzset
  235. - some source code reorganizations
  236. - no timezone/dst rule updates
  237. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  238. - Small changes in tst-timezone.c
  239. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  240. - Upstream 2006a:
  241. - private.h(scheck): changing char* to char const*
  242. - Rule changes for Palestine, zone changes for Indiana/US, both
  243. changes for Canada.
  244. - Many related doc changes.
  245. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  246. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  247. - 2005r-3
  248. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  249. so that it won't clash across updates.
  250. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  251. - 2005r
  252. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  253. northamerica to guard against old files with obsolete information
  254. being left in the time zone binary directory.
  255. - Changes for countries that are supposed to join 2007 US DST
  256. change. This includes most of Canada, however entries already in
  257. the database (Alberta, British Columbia, Newfoundland, Northwest
  258. Territories, and Yukon) were left alone for the time being.
  259. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  260. is checked for emptiness.
  261. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  262. - 2005q
  263. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  264. - SystemV timezone changes
  265. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  266. - 2005n
  267. - changes for Kyrgyzstan and Uruguay
  268. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  269. make check), update tst-timezone.c from glibc CVS (#172102)
  270. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  271. - 2005m
  272. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  273. Australia, Kazakhstan
  274. - historical timezone data changes for Japan, Poland, Northern Ireland and
  275. Mali
  276. - timezone name change for East Timor
  277. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  278. - 2005k
  279. - leap seconds update
  280. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  281. - 2005i
  282. - updates for Iran, Haiti and Nicaragua
  283. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  284. - 2005h
  285. - fixes for Kazakhstan
  286. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  287. - 2005g
  288. - fixes for Uruguay
  289. - include README and Theory from tzcode tarball in %{_docdir};
  290. Theory includes a good summary of how the timezone data files
  291. are supposed to be named
  292. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  293. - 2005f
  294. - more updates for Israel, updates for Azerbaijan
  295. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  296. - 2005c
  297. - updates for Israel and Paraguay
  298. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  299. - 2004g (#141107)
  300. - updates for Cuba
  301. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  302. - 2004e (#135194)
  303. - updates for Brazil, Uruguay and Argentina
  304. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  305. - 2004b
  306. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  307. - 2003d
  308. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  309. - 2003c
  310. - updates for Brazil (#104840)
  311. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  312. - rebuilt
  313. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  314. - initial package