qt5-qtwebengine-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620
  1. %global qt_module qtwebengine
  2. %global _hardened_build 1
  3. # define to build docs, need to undef this for bootstrapping
  4. # where qt5-qttools builds are not yet available
  5. # only primary archs (for now), allow secondary to bootstrap
  6. %ifarch %{arm} %{ix86} x86_64
  7. %global docs 1
  8. %endif
  9. %if 0
  10. # need libvpx >= 1.4.0
  11. %global use_system_libvpx 1
  12. %endif
  13. %if 0%{?fedora} || 0%{?rhel} > 6
  14. # need libwebp >= 0.4.3
  15. %global use_system_libwebp 1
  16. %endif
  17. #global prerelease rc
  18. # exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
  19. # else)
  20. %global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
  21. # exclude libv8.so (i686, it's static everywhere else)
  22. %global __requires_exclude ^libv8\\.so$
  23. %global qt5_minorver 5.6
  24. %global qt5_version 5.6.1
  25. %global qt5_patchlevel 1
  26. Summary: Qt5 - QtWebEngine components
  27. Name: qt5-qtwebengine
  28. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  29. Release: 1%{?_dist_release}
  30. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  31. # See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
  32. # The other licenses are from Chromium and the code it bundles
  33. License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
  34. URL: http://www.qt.io
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. # cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
  38. # wget http://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-opensource-src-5.6.1-1.tar.xz
  39. # ./clean_qtwebengine.sh 5.6.1-1
  40. Source0: %{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
  41. # cleanup scripts used above
  42. Source1: clean_qtwebengine.sh
  43. Source2: clean_ffmpeg.sh
  44. Source3: process_ffmpeg_gyp.py
  45. # do not compile with -Wno-format, which also bypasses -Werror-format-security
  46. Patch0: qtwebengine-opensource-src-5.6.0-beta-no-format.patch
  47. # some tweaks to linux.pri (system libs, link libpci, run unbundling script)
  48. Patch1: qtwebengine-opensource-src-5.6.1-linux-pri.patch
  49. # quick hack to avoid checking for the nonexistent icudtl.dat and silence the
  50. # resulting warnings - not upstreamable as is because it removes the fallback
  51. # mechanism for the ICU data directory (which is not used in our builds because
  52. # we use the system ICU, which embeds the data statically) completely
  53. Patch2: qtwebengine-opensource-src-5.6.0-no-icudtl-dat.patch
  54. # fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
  55. # ARM flags with our %%qmake_qt5 macro, including for the next patch
  56. Patch3: qtwebengine-opensource-src-5.6.0-beta-fix-extractcflag.patch
  57. # disable NEON vector instructions on ARM for now, the NEON code FTBFS due to
  58. # GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
  59. Patch4: qtwebengine-opensource-src-5.6.0-beta-no-neon.patch
  60. # use the system NSPR prtime (based on Debian patch)
  61. # We already depend on NSPR, so it is useless to copy these functions here.
  62. # Debian uses this just fine, and I don't see relevant modifications either.
  63. Patch5: qtwebengine-opensource-src-5.6.0-beta-system-nspr-prtime.patch
  64. # use the system ICU UTF functions
  65. # We already depend on ICU, so it is useless to copy these functions here.
  66. # I checked the history of that directory, and other than the renames I am
  67. # undoing, there were no modifications at all. Must be applied after Patch5.
  68. Patch6: qtwebengine-opensource-src-5.6.0-beta-system-icu-utf.patch
  69. # do not require SSE2 on i686
  70. # cumulative revert of upstream reviews 187423002, 308003004, 511773002 (parts
  71. # relevant to QtWebEngine only), 516543004, 1152053004 and 1161853008, along
  72. # with some custom fixes and improvements
  73. # also build V8 shared and twice on i686 (once for x87, once for SSE2)
  74. Patch7: qtwebengine-opensource-src-5.6.1-no-sse2.patch
  75. # the architectures theoretically supported by the version of V8 used (#1298011)
  76. # You may need some minor patching to build on one of the secondary
  77. # architectures, e.g., to add to the Qt -> Chromium -> V8 arch translations.
  78. # If you cannot get this package to build on your secondary architecure, please:
  79. # * remove your architecture from this list AND
  80. # * put #1298011 onto your ExcludeArch tracker.
  81. ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
  82. BuildRequires: qt5-qtbase-devel >= %{version}
  83. BuildRequires: qt5-qtbase-private-devel
  84. # TODO: check of = is really needed or if >= would be good enough -- rex
  85. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  86. BuildRequires: qt5-qtdeclarative-devel >= %{version}
  87. BuildRequires: qt5-qtxmlpatterns-devel >= %{version}
  88. BuildRequires: qt5-qtlocation-devel >= %{version}
  89. BuildRequires: qt5-qtsensors-devel >= %{version}
  90. BuildRequires: qt5-qtwebchannel-devel >= %{version}
  91. BuildRequires: qt5-qttools-static >= %{version}
  92. BuildRequires: ninja
  93. BuildRequires: bison
  94. BuildRequires: git
  95. BuildRequires: gperf
  96. BuildRequires: libicu-devel
  97. BuildRequires: libjpeg-devel
  98. #BuildRequires: re2-devel
  99. BuildRequires: snappy-devel
  100. %ifarch %{ix86} x86_64
  101. BuildRequires: yasm
  102. %endif
  103. BuildRequires: pkgconfig(expat)
  104. BuildRequires: pkgconfig(gobject-2.0)
  105. BuildRequires: pkgconfig(glib-2.0)
  106. BuildRequires: pkgconfig(fontconfig)
  107. BuildRequires: pkgconfig(freetype2)
  108. BuildRequires: pkgconfig(gl)
  109. BuildRequires: pkgconfig(egl)
  110. BuildRequires: pkgconfig(libpng)
  111. BuildRequires: pkgconfig(libudev)
  112. %if 0%{?use_system_libwebp}
  113. BuildRequires: pkgconfig(libwebp) >= 0.4.3
  114. %endif
  115. BuildRequires: pkgconfig(harfbuzz)
  116. BuildRequires: pkgconfig(jsoncpp)
  117. BuildRequires: pkgconfig(protobuf)
  118. BuildRequires: pkgconfig(libdrm)
  119. BuildRequires: pkgconfig(opus)
  120. BuildRequires: pkgconfig(libevent)
  121. BuildRequires: pkgconfig(zlib)
  122. #BuildRequires: pkgconfig(minizip)
  123. BuildRequires: pkgconfig(libxml-2.0)
  124. BuildRequires: pkgconfig(libxslt)
  125. BuildRequires: pkgconfig(x11)
  126. BuildRequires: pkgconfig(xi)
  127. BuildRequires: libXcursor-devel
  128. BuildRequires: pkgconfig(xext)
  129. BuildRequires: pkgconfig(xfixes)
  130. BuildRequires: pkgconfig(xrender)
  131. BuildRequires: pkgconfig(xdamage)
  132. BuildRequires: pkgconfig(xcomposite)
  133. BuildRequires: pkgconfig(xtst)
  134. BuildRequires: pkgconfig(xrandr)
  135. BuildRequires: pkgconfig(xscrnsaver)
  136. BuildRequires: pkgconfig(libcap)
  137. BuildRequires: pkgconfig(libpulse)
  138. BuildRequires: pkgconfig(alsa)
  139. BuildRequires: pciutils-devel
  140. BuildRequires: pkgconfig(dbus-1)
  141. BuildRequires: pkgconfig(nss)
  142. BuildRequires: pkgconfig(libsrtp)
  143. BuildRequires: perl
  144. BuildRequires: python
  145. %if 0%{?use_system_libvpx}
  146. BuildRequires: pkgconfig(vpx) >= 1.4.0
  147. %endif
  148. # extra (non-upstream) functions needed, see
  149. # src/3rdparty/chromium/third_party/sqlite/README.chromium for details
  150. #BuildRequires: pkgconfig(sqlite3)
  151. ## Various bundled libraries that Chromium does not support unbundling :-(
  152. ## Only the parts actually built are listed.
  153. ## Query for candidates:
  154. ## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
  155. ## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
  156. ## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
  157. ## some false positives where only shim headers are generated for some reason
  158. ## some false positives with dummy placeholder dirs (swiftshader, widevine)
  159. ## some false negatives where a header-only library is bundled (e.g. x86inc)
  160. ## Spot's chromium.spec also has a list that I checked.
  161. # Of course, Chromium itself is bundled. It cannot be unbundled because it is
  162. # not a library, but forked (modified) application code.
  163. # Some security fixes are backported, see:
  164. # http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
  165. Provides: bundled(chromium) = 45
  166. # Bundled in src/3rdparty/chromium/third_party:
  167. # Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
  168. # except where specified otherwise.
  169. Provides: bundled(angle) = 2422
  170. # Google's fork of OpenSSL
  171. # We cannot build against NSS instead because it no longer works with NSS 3.21:
  172. # HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
  173. # completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
  174. # http://kaosx.us/phpBB3/viewtopic.php?t=1235
  175. # https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
  176. # So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
  177. # use the BoringSSL code and the system NSS certificates.
  178. Provides: bundled(boringssl)
  179. Provides: bundled(brotli)
  180. # Don't get too excited. MPEG and other legally problematic stuff is stripped
  181. # out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
  182. # see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
  183. Provides: bundled(ffmpeg) = 2.7
  184. Provides: bundled(iccjpeg)
  185. # bundled as "khronos", headers only
  186. Provides: bundled(khronos_headers)
  187. # bundled as "leveldatabase"
  188. Provides: bundled(leveldb) = r80
  189. Provides: bundled(libjingle) = 9564
  190. %if !0%{?use_system_libvpx}
  191. Provides: bundled(libvpx) = 1.4.0
  192. %endif
  193. %if !0%{?use_system_libwebp}
  194. Provides: bundled(libwebp) = 0.4.3
  195. %endif
  196. Provides: bundled(libXNVCtrl) = 302.17
  197. Provides: bundled(libyuv) = 1444
  198. Provides: bundled(modp_b64)
  199. Provides: bundled(mojo)
  200. # headers only
  201. Provides: bundled(npapi)
  202. Provides: bundled(openmax_dl) = 1.0.2
  203. Provides: bundled(ots)
  204. Provides: bundled(qcms) = 4
  205. Provides: bundled(sfntly) = 0-0.1.svn111
  206. Provides: bundled(skia)
  207. # bundled as "smhasher"
  208. Provides: bundled(SMHasher) = 0-0.1.svn147
  209. Provides: bundled(sqlite) = 3.8.7.4
  210. Provides: bundled(usrsctp) = 0-0.1.svn9045
  211. Provides: bundled(webrtc) = 90
  212. %ifarch %{ix86} x86_64
  213. # header (for assembly) only
  214. Provides: bundled(x86inc) = 0
  215. %endif
  216. # Bundled in src/3rdparty/chromium/base/third_party:
  217. # Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
  218. # numbers, except where specified otherwise.
  219. Provides: bundled(dmg_fp)
  220. Provides: bundled(dynamic_annotations) = 4384
  221. Provides: bundled(superfasthash) = 0
  222. Provides: bundled(symbolize)
  223. # bundled as "valgrind", headers only
  224. Provides: bundled(valgrind.h)
  225. # bundled as "xdg_mime"
  226. Provides: bundled(xdg-mime)
  227. # bundled as "xdg_user_dirs"
  228. Provides: bundled(xdg-user-dirs) = 0.10
  229. # Bundled in src/3rdparty/chromium/net/third_party:
  230. # Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
  231. # numbers, except where specified otherwise.
  232. Provides: bundled(mozilla_security_manager) = 1.9.2
  233. # Bundled in src/3rdparty/chromium/url/third_party:
  234. # Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
  235. # numbers, except where specified otherwise.
  236. # bundled as "mozilla", file renamed and modified
  237. Provides: bundled(nsURLParsers)
  238. # Bundled outside of third_party, apparently not considered as such by Chromium:
  239. # see src/3rdparty/chromium/v8/include/v8_version.h for the version number
  240. Provides: bundled(v8) = 4.5.103.35
  241. # bundled by v8 (src/3rdparty/chromium/v8/src/third_party/fdlibm)
  242. # see src/3rdparty/chromium/v8/src/third_party/fdlibm/README.v8 for the version
  243. Provides: bundled(fdlibm) = 5.3
  244. %{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
  245. %description
  246. %{summary}.
  247. %package devel
  248. Summary: Development files for %{name}
  249. Requires: %{name}%{?_isa} = %{version}-%{release}
  250. Requires: qt5-qtbase-devel%{?_isa}
  251. Requires: qt5-qtdeclarative-devel%{?_isa}
  252. %description devel
  253. %{summary}.
  254. %package examples
  255. Summary: Example files for %{name}
  256. %description examples
  257. %{summary}.
  258. %if 0%{?docs}
  259. %package doc
  260. Summary: API documentation for %{name}
  261. BuildRequires: qt5-qhelpgenerator
  262. BuildRequires: qt5-qdoc
  263. BuildArch: noarch
  264. %description doc
  265. %{summary}.
  266. %endif
  267. %prep
  268. %setup -q -n %{qt_module}-opensource-src-%{qt5_version}
  269. %patch0 -p1 -b .no-format
  270. %patch1 -p1 -b .linux-pri
  271. %patch2 -p1 -b .no-icudtl-dat
  272. %patch3 -p1 -b .fix-extractcflag
  273. %patch4 -p1 -b .no-neon
  274. %patch5 -p1 -b .system-nspr-prtime
  275. %patch6 -p1 -b .system-icu-utf
  276. %patch7 -p1 -b .no-sse2
  277. # fix // in #include in content/renderer/gpu to avoid debugedit failure
  278. sed -i -e 's!gpu//!gpu/!g' \
  279. src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
  280. # remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
  281. sed -i -e 's!\./!!g' \
  282. src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
  283. src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
  284. # http://bugzilla.redhat.com/1337585
  285. # can't just delete, but we'll overwrite with system headers to be on the safe side
  286. #cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/re2/
  287. #ifnarch x86_64
  288. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  289. sed -i -e 's/=-g$/=-g1/g' src/core/gyp_run.pro
  290. #endif
  291. %build
  292. export STRIP=strip
  293. export NINJAFLAGS="-v %{_smp_mflags}"
  294. export NINJA_PATH=%{_bindir}/ninja-build
  295. export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
  296. export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks -I$RE2_INCLUDE"
  297. #ifnarch x86_64
  298. # most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
  299. export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
  300. #endif
  301. mkdir %{_target_platform}
  302. pushd %{_target_platform}
  303. %{qmake_qt5} CONFIG+="webcore_debug v8base_debug force_debug_info" WEBENGINE_CONFIG+="use_system_icu" ..
  304. # workaround, disable parallel compilation as it fails to compile in brew
  305. make %{?_smp_mflags}
  306. %if 0%{?docs}
  307. make %{?_smp_mflags} docs
  308. %endif
  309. popd
  310. %install
  311. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  312. %if 0%{?docs}
  313. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  314. %endif
  315. ## .prl/.la file love
  316. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  317. pushd %{buildroot}%{_qt5_libdir}
  318. for prl_file in libQt5*.prl ; do
  319. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  320. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  321. rm -fv "$(basename ${prl_file} .prl).la"
  322. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  323. fi
  324. done
  325. popd
  326. %post -p /sbin/ldconfig
  327. %postun -p /sbin/ldconfig
  328. %files
  329. %{_qt5_libdir}/libQt5*.so.*
  330. %{_qt5_libdir}/qt5/qml/*
  331. %{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
  332. %ifarch %{ix86}
  333. # shared V8 library and its SSE2 version
  334. %{_qt5_libdir}/qtwebengine/
  335. %endif
  336. %{_qt5_plugindir}/designer/libqwebengineview.so
  337. %{_qt5_datadir}/resources/
  338. %dir %{_qt5_translationdir}/qtwebengine_locales
  339. %lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
  340. %lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
  341. %lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
  342. %lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
  343. %lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
  344. %lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
  345. %lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
  346. %lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
  347. %lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
  348. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
  349. %lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
  350. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
  351. %lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
  352. %lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
  353. %lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
  354. %lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
  355. %lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
  356. %lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
  357. %lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
  358. %lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
  359. %lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
  360. %lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
  361. %lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
  362. %lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
  363. %lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
  364. %lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
  365. %lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
  366. %lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
  367. %lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
  368. %lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
  369. %lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
  370. %lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
  371. %lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
  372. %lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
  373. %lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
  374. %lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
  375. %lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
  376. %lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
  377. %lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
  378. %lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
  379. %lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
  380. %lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
  381. %lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
  382. %lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
  383. %lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
  384. %lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
  385. %lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
  386. %lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
  387. %lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
  388. %lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
  389. %lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
  390. %lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
  391. %lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
  392. %files devel
  393. %{_qt5_headerdir}/Qt*/
  394. %{_qt5_libdir}/libQt5*.so
  395. %{_qt5_libdir}/libQt5*.prl
  396. %{_qt5_libdir}/cmake/Qt5*/
  397. %{_qt5_libdir}/pkgconfig/Qt5*.pc
  398. %{_qt5_archdatadir}/mkspecs/modules/*.pri
  399. %files examples
  400. %{_qt5_examplesdir}/
  401. %if 0%{?docs}
  402. %files doc
  403. %{_qt5_docdir}/*
  404. %endif
  405. %changelog
  406. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  407. - new upstream release.
  408. - initial build for Vine Linux.
  409. - updated Source1.
  410. * Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
  411. - rebuild (glibc)
  412. * Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  413. - add versioned qt5-qtbase runtime dep
  414. * Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
  415. - Update to 5.6.1
  416. - Rebase linux-pri patch (drop the parts already fixed upstream)
  417. - Drop backported chimera-nss-init patch, already applied upstream
  418. - Rebase no-sse2 patch (the core_module.pro change)
  419. - Add the new designer/libqwebengineview.so plugin to the file list
  420. * Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
  421. - workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
  422. * Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
  423. - rebuild (pciutuils)
  424. * Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
  425. - BR: git-core
  426. * Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
  427. - rebuild for ICU 57.1
  428. * Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
  429. - drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
  430. * Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
  431. - Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
  432. - Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
  433. - Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
  434. - Work around debugedit failure by removing "./" from #line commands and
  435. changing "//" to "/" in an #include command
  436. * Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
  437. - Avoid checking for the nonexistent icudtl.dat and silence the warnings
  438. * Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
  439. - Update to 5.6.0 (final)
  440. - Drop system-icu54 patch, fixed upstream
  441. * Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
  442. - Update to 5.6.0 RC
  443. - Rebase linux-pri and no-sse2 patches
  444. - Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
  445. - Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
  446. - Tag translations with correct %%lang tags
  447. * Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
  448. - no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
  449. * Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
  450. - Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
  451. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
  452. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  453. * Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
  454. - Build V8 as a shared library on i686 to allow for swappable backends
  455. - Build both the x87 version and the SSE2 version of V8 on i686
  456. - Add the private library directory to the file list on i686
  457. - Add Provides/Requires filtering for libv8.so (i686) and for plugins
  458. * Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
  459. - Do not require SSE2 on i686
  460. * Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
  461. - Drop nss321 backport (and the related nss-headers patch), it did not help
  462. - Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
  463. - Update License accordingly (add "OpenSSL")
  464. - Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
  465. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
  466. - Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
  467. * Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
  468. - Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
  469. * Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
  470. - Unbundle prtime.cc, use the system NSPR instead (which is already required)
  471. - Unbundle icu_utf.cc, use the system ICU instead (which is already required)
  472. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
  473. - linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
  474. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
  475. - Build against the system libvpx also on F23 (1.4.0), worked in Copr
  476. * Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
  477. - Use the system libvpx on F24+ (1.5.0)
  478. - Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
  479. * Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
  480. - Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
  481. - Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
  482. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
  483. - Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
  484. - Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
  485. * Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
  486. - Use more specific BuildRequires for docs (thanks to rdieter)
  487. - Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
  488. * Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
  489. - Fix License tag
  490. - Use %%_qt5_examplesdir macro
  491. - Add Provides: bundled(*) for all the bundled libraries that I found
  492. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
  493. - linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
  494. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
  495. - linux-pri patch: Add missing newline at the end of the log line
  496. - Use export for NINJA_PATH (fixes system ninja-build use)
  497. * Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
  498. - Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
  499. - BR yasm only on x86 (i686, x86_64)
  500. - Add dot at the end of %%description
  501. - Rebase no-format patch
  502. - Replace unbundle-gyp.patch with new linux-pri.patch
  503. - Use system ninja-build instead of the bundled one
  504. - Run the unbundling script replace_gyp_files.py in linux.pri rather than here
  505. - Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
  506. * Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
  507. - Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
  508. pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
  509. pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
  510. pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
  511. perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
  512. - Add missing explicit BRs on pkgconfig(x11), pkgconfig(xext),
  513. pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
  514. - Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
  515. - Fix BR python-devel to python
  516. - Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
  517. - Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
  518. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
  519. - Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
  520. * Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
  521. - Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
  522. - Remove unused BR v8-devel (cannot currently be unbundled)
  523. * Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
  524. - Update to 5.5.1
  525. - Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
  526. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
  527. - Update with unbundle flags. Adapted from original 5.4 Suse package
  528. - Disable vpx and sqlite as unbundle due some compilation issues
  529. - Enable verbose build
  530. * Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
  531. - Initial spec
  532. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  533. - Update for official RC1 released packages