chkconfig-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353
  1. Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
  2. Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
  3. Name: chkconfig
  4. Version: 1.3.61
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Base
  8. Source: %{name}-%{version}.tar.bz2
  9. Source2: chkconfig.8
  10. Source3: ntsysv.8
  11. Source4: update-alternatives.ja.8
  12. Patch1: chkconfig-1.3.51-vine.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: newt-devel
  15. BuildRequires: popt-devel
  16. Conflicts: initscripts <= 5.30-1
  17. %description
  18. Chkconfig is a basic system utility. It updates and queries runlevel
  19. information for system services. Chkconfig manipulates the numerous
  20. symbolic links in /etc/rc.d, to relieve system administrators of some
  21. of the drudgery of manually editing the symbolic links.
  22. %description -l ja
  23. chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
  24. runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
  25. 多数のシンボリックリンクを操作しますので、システム管理者は手動で
  26. シンボリックリンクをたびたびエディットしなくてもよい。
  27. %package -n ntsysv
  28. Summary: A tool to set the stop/start of system services in a runlevel.
  29. Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
  30. Group: System Environment/Base
  31. %description -n ntsysv
  32. Ntsysv provides a simple interface for setting which system services
  33. are started or stopped in various runlevels (instead of directly
  34. manipulating the numerous symbolic links in /etc/rc.d). Unless you
  35. specify a runlevel or runlevels on the command line (see the man
  36. page), ntsysv configures the current runlevel (5 if you're using X).
  37. %description -n ntsysv -l ja
  38. ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
  39. ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
  40. 操作することから解放する。
  41. %package -n alternatives
  42. Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
  43. Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  44. Group: System Environment/Base
  45. %description -n alternatives
  46. maintain symbolic links determining default commands (from Debian dpkg utilities)
  47. %description -n alternatives -l ja
  48. コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
  49. %prep
  50. %setup -q
  51. %patch1 -p1
  52. %build
  53. %ifarch sparc
  54. LIBMHACK=-lm
  55. %endif
  56. %__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. %__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
  60. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  61. ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
  62. for n in 0 1 2 3 4 5 6; do
  63. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
  64. ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
  65. done
  66. mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
  67. cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
  68. # alternatives
  69. mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
  70. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
  71. mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
  72. install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
  73. ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
  74. # create compat symlinks
  75. mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
  76. for i in alternatives update-alternatives chkconfig
  77. do
  78. ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
  79. done
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root)
  84. /sbin/chkconfig
  85. %{_sbindir}/chkconfig
  86. /etc/init.d
  87. /etc/rc.d/init.d
  88. /etc/rc[0-6].d
  89. /etc/rc.d/rc[0-6].d
  90. %{_mandir}/*/chkconfig*
  91. %{_mandir}/ja/*/chkconfig*
  92. %{_localedir}/*/LC_MESSAGES/chkconfig.mo
  93. %files -n ntsysv
  94. %defattr(-,root,root)
  95. %{_sbindir}/ntsysv
  96. %{_mandir}/*/ntsysv.8*
  97. %{_mandir}/ja/*/ntsysv.8*
  98. %files -n alternatives
  99. %defattr (-, root, root)
  100. /sbin/alternatives
  101. /sbin/update-alternatives
  102. %{_sbindir}/alternatives
  103. %{_sbindir}/update-alternatives
  104. %{_sysconfdir}/alternatives
  105. %{_mandir}/man8/*
  106. %{_mandir}/ja/man8/*
  107. /var/lib/rpm/alternatives
  108. %changelog
  109. * Wed Nov 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.61-1
  110. - update to 1.3.61
  111. - create compat symlinks in %%{_sbindir}
  112. * Thu Jun 06 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.60-1
  113. - update to 1.3.60
  114. * Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
  115. - change BuildRequires: popt-devel intead of popt
  116. * Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
  117. - new upstream release
  118. - enable fedora version of alternatives
  119. - add alternatives subpackage, replace debian's alternatives
  120. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
  121. - new upstream release
  122. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
  123. - applied new versioning policy and spec in utf-8
  124. * Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
  125. - dropped obsoleted Makefile.x86_64.patch
  126. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
  127. - new upstream release
  128. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
  129. - add Makefile.x86_64.patch
  130. * Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
  131. - add Patch10 to skip xinetd parsing if not exist.
  132. * Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
  133. - rebuild
  134. * Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
  135. - Requires -> Conflicts.
  136. apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
  137. Conflicts/Pre-Depends-loop does not happen.
  138. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
  139. - Oops not PreReq but Requires. Fixed.
  140. * Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
  141. - change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
  142. to avoid Conflicts/Pre-Depends loop on apt
  143. * Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  144. - 1.2.17-1vl3
  145. - change checkbox color
  146. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  147. - 1.2.17-1vl2
  148. - rebuilt for VineSeed
  149. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
  150. - 1.2.17-1vl1
  151. * Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
  152. - ignore .rpmnew files (#18915)
  153. - fix typo in error message (#17575)
  154. * Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  155. - make xinetd config files mode 0644, not 644
  156. * Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
  157. - updated it and es translations
  158. * Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
  159. - get man pages in proper packages
  160. * Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
  161. - new translations
  162. * Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  163. - don't worry about extra whitespace on chkconfig: lines (#16150)
  164. * Thu Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
  165. - i18n merge
  166. * Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
  167. - new translations for de fr it es
  168. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  169. - change prereqs
  170. * Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
  171. - fix ntsysv's handling of xinetd/init files with the same name
  172. * Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
  173. - fix segv when reading malformed files
  174. * Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
  175. - put links, rc[0-6].d dirs back, those are necessary
  176. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  177. - add quick hack support for reading descriptions from xinetd files
  178. * Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  179. - don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
  180. * Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
  181. - move back to old file layout
  182. * Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
  183. - bump copyright date
  184. * Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
  185. - no %pre today. Maybe tomorrow.
  186. * Thu Jul 6 2000 Bill Nottingham <notting@redhat.com>
  187. - put initscripts %pre here too
  188. * Mon Jul 3 2000 Bill Nottingham <notting@redhat.com>
  189. - oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
  190. * Sun Jul 2 2000 Bill Nottingham <notting@redhat.com>
  191. - add xinetd support
  192. * Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
  193. - changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
  194. - fixed sumary and description where a global string replace nuked them
  195. * Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
  196. - what Bill said, but actually build this version
  197. * Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
  198. - don't own /etc/rc.*
  199. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  200. - typo in man page
  201. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  202. - fix description
  203. * Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
  204. - link chkconfig statically against popt
  205. * Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
  206. - fix querying alternate levels
  207. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  208. - don't use strchr to skip unwanted files, look at extension instead (#4166).
  209. * Thu Aug 5 1999 Bill Nottingham <notting@redhat.com>
  210. - fix --help, --verson
  211. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  212. - rebuilt ntsysv against newt 0.50
  213. * Mon Aug 2 1999 Jeff Johnson <jbj@redhat.com>
  214. - fix i18n problem in usage message (#4233).
  215. - add --help and --version.
  216. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  217. - release for Red Hat 6.0
  218. * Thu Apr 8 1999 Matt Wilson <msw@redhat.com>
  219. - added support for a "hide: true" tag in initscripts that will make
  220. services not appear in ntsysv when run with the "--hide" flag
  221. * Thu Apr 1 1999 Matt Wilson <msw@redhat.com>
  222. - added --hide flag for ntsysv that allows you to hide a service from the
  223. user.
  224. * Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
  225. - fix glob, once and for all. Really. We mean it.
  226. * Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
  227. - revert fix for services@levels, it's broken
  228. - change default to only edit the current runlevel
  229. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  230. - don't remove scripts that don't support chkconfig
  231. * Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
  232. - made glob a bit more specific so xinetd and inetd don't cause improper matches
  233. * Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
  234. - removed debugging output when starting ntsysv
  235. * Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
  236. - fixed globbing error
  237. - fixed ntsysv running services not at their specified levels.
  238. * Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
  239. - print the value of errno on glob failures.
  240. * Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
  241. - rebuilt for newt 0.40 (ntsysv)
  242. * Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
  243. - add ru.po.
  244. * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
  245. - build for Raw Hide (slang-1.2.2)
  246. * Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
  247. - translation updates
  248. * Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
  249. - updated czech translation (and use cs instead of cz)
  250. * Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
  251. - added pt_BR translations
  252. - added more translatable strings
  253. - support for i18n init.d scripts description
  254. * Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
  255. - built against newt 0.30
  256. - split ntsysv into a separate package
  257. * Thu May 07 1998 Erik Troan <ewt@redhat.com>
  258. - added numerous translations
  259. * Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
  260. - added i18n support
  261. * Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
  262. - added --back