js-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. #% global hgdate 51702867d932
  2. Summary: JavaScript interpreter and libraries
  3. Name: js
  4. Version: 1.8.5
  5. Release: 1%{?hgdate:.hg%{hgdate}}%{?_dist_release}
  6. # The sources are triple licensed, but when we link against readline which is
  7. # GPL, the result can only be GPL.
  8. %if 0%{?_without_readline:1}
  9. License: GPLv2+ or LGPLv2+ or MPLv1.1
  10. %else
  11. License: GPLv2+
  12. %endif
  13. Group: Development/Languages
  14. URL: http://www.mozilla.org/js/
  15. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
  16. Patch0: js-1.8.5-64bit-big-endian.patch
  17. Patch1: js-1.8.5-secondary-jit.patch
  18. Patch2: js185-destdir.patch
  19. Patch3: js-1.8.5-configure.patch
  20. Provides: libjs = %{version}-%{release}
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. Buildrequires: nspr-devel >= 4.7, python, zip
  23. Buildrequires: readline-devel, ncurses-devel, autoconf213
  24. Epoch: 1
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. JavaScript is the Netscape-developed object scripting language used in millions
  29. of web pages and server applications worldwide. Netscape's JavaScript is a
  30. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  31. with only mild differences from the published standard.
  32. %package devel
  33. Summary: Header files, libraries and development documentation for %{name}
  34. Group: Development/Libraries
  35. Requires: %{name} = %{epoch}:%{version}-%{release}
  36. Requires: pkgconfig
  37. Requires: ncurses-devel readline-devel
  38. Provides: libjs-devel = %{version}-%{release}
  39. %description devel
  40. This package contains the header files, static libraries and development
  41. documentation for %{name}. If you like to develop programs using %{name},
  42. you will need to install %{name}-devel.
  43. %prep
  44. # All patches come from old version and maintainer. I think it is Fedora related only
  45. %setup -q -n %{name}-%{version}
  46. %patch0 -p2 -b .64bit-big-endian
  47. %patch1 -p2 -b .secondary-jit
  48. %patch2 -p0 -b .destdir
  49. %patch3 -p1 -b .version
  50. cd js
  51. # Rm parts with spurios licenses, binaries
  52. # Some parts under BSD (but different suppliers): src/assembler
  53. #rm -rf src/assembler src/yarr/yarr src/yarr/pcre src/yarr/wtf src/v8-dtoa
  54. rm -rf src/ctypes/libffi src/t src/tests/src/jstests.jar src/tracevis src/v8
  55. pushd src
  56. autoconf-2.13
  57. %configure \
  58. --with-system-nspr \
  59. --enable-threadsafe \
  60. %if 0%{!?_without_readline:1}
  61. --enable-readline \
  62. %endif
  63. popd
  64. # Create pkgconfig file
  65. %{__cat} > libjs.pc << 'EOF'
  66. prefix=%{_prefix}
  67. exec_prefix=%{_prefix}
  68. libdir=%{_libdir}
  69. includedir=%{_includedir}
  70. Name: libjs
  71. Description: JS library
  72. Requires: nspr >= 4.7
  73. Version: %{version}
  74. Libs: -L${libdir} -ljs
  75. Cflags: -DXP_UNIX=1 -DJS_THREADSAFE=1 -I${includedir}/js
  76. EOF
  77. %build
  78. cd js
  79. %{__make} %{?_smp_mflags} -C src
  80. %install
  81. cd js
  82. %{__make} -C src install DESTDIR=%{buildroot}
  83. # We don't want this
  84. %{__rm} -f %{buildroot}%{_bindir}/js-config
  85. %{__install} -m 0755 src/jscpucfg src/shell/js %{buildroot}%{_bindir}/
  86. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  87. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  88. %{__install} -m 0644 src/js*.h src/prmjtime.h src/js.msg src/*.tbl %{buildroot}%{_includedir}/
  89. # For compatibility
  90. # XXX do we really need libjs?!?!?!
  91. pushd %{buildroot}%{_libdir}
  92. %{__ln_s} libmozjs185.so.1.0 libmozjs.so.1
  93. %{__ln_s} libmozjs185.so.1.0 libjs.so.1
  94. %{__ln_s} libmozjs185.so libmozjs.so
  95. %{__ln_s} libmozjs185.so libjs.so
  96. popd
  97. %{__install} -m 0644 libjs.pc %{buildroot}%{_libdir}/pkgconfig/
  98. %clean
  99. %{__rm} -rf %{buildroot}
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %files
  103. %defattr(-,root,root,-)
  104. %doc js/src/README.html
  105. %{_bindir}/js
  106. %{_libdir}/*.so.*
  107. %files devel
  108. %defattr(-,root,root,-)
  109. %{_bindir}/jscpucfg
  110. %{_libdir}/pkgconfig/*.pc
  111. %{_libdir}/*.so
  112. %{_includedir}/js
  113. %{_includedir}/js*.h
  114. %{_includedir}/*.tbl
  115. %{_includedir}/js.msg
  116. %{_includedir}/prmjtime.h
  117. %changelog
  118. * Sun Aug 14 2011 Yoji TOYODA <Yoji TOYODA> - 1:1.8.5-1
  119. - add Patch3 (js-1.8.5-configure.patch)
  120. - merge spec file with fedora package
  121. * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.70-1
  122. - new upstream release
  123. - applied new versioning policy
  124. - removed no longer provided perlconnect parts.
  125. * Mon Jun 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60-2vl1
  126. - initial build for Vine Linux
  127. * Thu Jun 23 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1:1.8.5-7
  128. - Make build system more proper (bz#710837), thanks to Jasper St. Pierre.
  129. - Add missing header prmjtime.h (bz#709955), thanks to Jim Meyering.
  130. - Merge Colin Walters build changes http://www.spinics.net/lists/fedora-devel/msg153214.html (1:1.8.5-6)
  131. * Wed Jun 22 2011 Colin Walters <walters@verbum.org> - 1:1.8.5-6
  132. - Include mozjs185.pc, clean up build
  133. - Based on work from Christopher Aillon <caillon@redhat.com>
  134. - Switch to using make install DESTDIR=, instead of hardcoding build rules.
  135. - Add DESTDIR= patch from GNOME 3.2 jhbuild
  136. - Make mozjs185 the canonical target for both libmozjs and libmozjs185.
  137. * Fri May 27 2011 Dan Horák <dan[at]danny.cz> - 1.8.5-5
  138. - add secondary arch patches from xulrunner
  139. * Tue Apr 12 2011 Christopher Aillon <caillon@redhat.com> - 1.8.5-4
  140. - devel subpackage needs to ask for the newly added epoch
  141. * Tue Apr 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-3
  142. - Add Epoch: 1 to allow update of 1.70-13 version.
  143. * Sat Apr 9 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-2
  144. - Correct symlink to provide backward capabiliies libjs.so.1
  145. * Wed Apr 6 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-1
  146. - Update to release.
  147. - Remove unneeded anymore patches.
  148. - Add backward capability symlink.
  149. * Sat Feb 12 2011 Pavel Alexeev <Pahan@Hubbitus.info> - 1.8.5-0.hg51702867d932
  150. - Build version 1.8.5 by update request - BZ#676441 from Firefox 4.0 mercurial repository.
  151. - Gone -DJS_C_STRINGS_ARE_UTF8
  152. - Add BR autoconf213, change build system to use configure.
  153. - Adopt patch0 (js-1.7.0-make.patch -> js-1.8.5-make.patch)
  154. - Adopt patch1 (js-shlib.patch -> js-1.8.5-shlib.patch)
  155. - Remove Patch2 (js-1.5-va_copy.patch) and Patch3 (js-ldflags.patch)
  156. - Add BR python, zip.
  157. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-13
  158. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  159. * Wed Jun 16 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-12
  160. - Add UTF-8 support (add -DJS_C_STRINGS_ARE_UTF8 ) by request Peter Halliday: BZ#576585
  161. * Mon Jun 14 2010 Dan Horák <dan[at]danny.cz> - 1.70-11
  162. - updated the va_copy patch for s390
  163. * Mon Jan 25 2010 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-10
  164. - Remove static library from -devel - %%{_libdir}/*.a (bz#556057) to meet guidelines.
  165. * Sun Aug 2 2009 Pavel Alexeev <Pahan@Hubbitus.info> - 1.70-8
  166. - Reformat spec with tabs.
  167. - By report of Thomas Sondergaard (BZ#511162) Add -DXP_UNIX=1 -DJS_THREADSAFE=1 flags and nspr requires into libjs.pc
  168. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.70-7
  169. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  170. * Fri May 29 2009 Dan Horak <dan[at]danny.cz> 1.70-6
  171. - update the va_copy patch for s390x
  172. * Thu Apr 9 2009 Matthias Saou <http://freshrpms.net/> 1.70-5
  173. - Update description (#487903).
  174. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  176. * Wed Jun 4 2008 Jon McCann <jmccann@redhat.com> - 1.70-3
  177. - Add two missing files (#449715)
  178. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-2
  179. - Rebuild for perl 5.10 (again)
  180. * Sun Feb 3 2008 Matthias Saou <http://freshrpms.net/> 1.70-1
  181. - Update to 1.7.0, as 1.70 to avoid introducing an epoch for now...
  182. - Remove no longer provided perlconnect parts.
  183. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-6
  184. - BR: perl(ExtUtils::Embed)
  185. * Sun Jan 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.60-5
  186. - rebuild for new perl
  187. * Wed Aug 22 2007 Matthias Saou <http://freshrpms.net/> 1.60-4
  188. - Rebuild for new BuildID feature.
  189. * Mon Aug 6 2007 Matthias Saou <http://freshrpms.net/> 1.60-3
  190. - Update License field.
  191. - Add perl(ExtUtils::MakeMaker) build requirement to pull in perl-devel.
  192. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-2
  193. - Include jsopcode.tbl and js.msg in devel (#235481).
  194. - Install static lib mode 644 instead of 755.
  195. * Fri Feb 2 2007 Matthias Saou <http://freshrpms.net/> 1.60-1
  196. - Update to 1.60.
  197. - Rebuild in order to link against ncurses instead of termcap (#226773).
  198. - Add ncurses-devel build requirement and patch s/termcap/ncurses/ in.
  199. - Change mode of perl library from 555 to 755 (#224603).
  200. * Mon Aug 28 2006 Matthias Saou <http://freshrpms.net/> 1.5-6
  201. - Fix pkgconfig file (#204232 & dupe #204236).
  202. * Mon Jul 24 2006 Matthias Saou <http://freshrpms.net/> 1.5-5
  203. - FC6 rebuild.
  204. - Enable JS_THREADSAFE in the build (#199696), add patch and nspr build req.
  205. * Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 1.5-4
  206. - FC5 rebuild.
  207. * Thu Feb 9 2006 Matthias Saou <http://freshrpms.net/> 1.5-3
  208. - Rebuild for new gcc/glibc.
  209. * Mon Jan 30 2006 Matthias Saou <http://freshrpms.net/> 1.5-2
  210. - Fix .pc file.
  211. * Thu Jan 26 2006 Matthias Saou <http://freshrpms.net/> 1.5-1
  212. - Update to 1.5.0 final.
  213. - Spec file cleanups.
  214. - Move docs from devel to main, since we need the license there.
  215. - Remove no longer needed js-perlconnect.patch.
  216. - Update js-1.5-va_copy.patch.
  217. - Include a pkgconfig file (#178993).
  218. * Tue Apr 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.6
  219. - Link shared lib with libperl.
  220. * Fri Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  221. - rebuilt
  222. * Mon Feb 14 2005 David Woodhouse <dwmw2@infradead.org> - 1.5-0.rc6a.4
  223. - Take js-va_copy.patch out of %%ifarch x86_64 so it fixes the PPC build too
  224. * Sun Feb 13 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 1.5-0.rc6a.3
  225. - Add js-va_copy.patch to fix x86_64; Patch was found in a Mandrake srpm
  226. * Sat Dec 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.rc6a.2
  227. - Include perlconnect.
  228. - Include readline support, rebuild using "--without readline" to disable.
  229. - Add libjs* provides for upstream compatibility.
  230. - Install header files in %%{_includedir} instead of %%{_includedir}/js.
  231. * Tue Jun 15 2004 Matthias Saou <http://freshrpms.net> 1.5-0.rc6a
  232. - Update to 1.5rc6a.
  233. * Tue Mar 02 2004 Dag Wieers <dag@wieers.com> - 1.5-0.rc6
  234. - Initial package. (using DAR)