qt-assistant-adp-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. Name: qt-assistant-adp
  2. Summary: Compatibility version of Qt Assistant
  3. Version: 4.6.3
  4. Release: 4%{?_dist_release}
  5. Group: System Environment/Libraries
  6. # See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
  7. License: LGPLv2 with exceptions or GPLv3 with exceptions
  8. URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
  9. Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
  10. # missing header files from Debian (Fathi Boudra)
  11. Source1: QAssistantClient
  12. Source2: QtAssistant
  13. # build fixes from Debian (Fathi Boudra)
  14. Patch1: 01_build_system.diff
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
  17. Requires: qt4 = %{_qt4_version}
  18. %description
  19. The old version of Qt Assistant, based on Assistant Document Profile (.adp)
  20. files, and the associated QtAssistantClient library, for compatibility with
  21. applications providing help in that format.
  22. New applications should use the new version of Qt Assistant introduced in Qt
  23. 4.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
  24. %package devel
  25. Summary: Development files for the compatibility QAssistantClient
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: qt4-devel = %{_qt4_version}
  29. %description devel
  30. This package contains the files necessary to build applications using the
  31. deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
  32. which is used together with the legacy Assistant Document Profile (.adp) version
  33. of Qt Assistant.
  34. This class is obsolete. It is provided to keep old source code working. We
  35. strongly advise against using it in new code. New code should use the Qt Help
  36. Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
  37. (also introduced in Qt 4.4) instead.
  38. %prep
  39. %setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
  40. %patch1 -p1 -b .build_system
  41. mkdir include
  42. cp -p %{SOURCE1} %{SOURCE2} include/
  43. %build
  44. # build assistant_adp
  45. qmake QT_PRODUCT=OpenSource
  46. make %{?_smp_mflags}
  47. # build libQtAssistantClient
  48. cd lib
  49. qmake CONFIG=create_prl
  50. make %{?_smp_mflags}
  51. # build assistant_adp translations
  52. cd ../translations
  53. lrelease assistant_adp_*.ts
  54. cd ..
  55. %install
  56. rm -rf %{buildroot}
  57. # install assistant_adp
  58. make install INSTALL_ROOT=%{buildroot}
  59. # install libQtAssistantClient
  60. make install INSTALL_ROOT=%{buildroot} -C lib
  61. # install assistant_adp translations
  62. mkdir -p %{buildroot}%{_qt4_translationdir}
  63. install -p -m644 translations/assistant_adp_*.qm \
  64. %{buildroot}%{_qt4_translationdir}/
  65. # install assistant.prf mkspec
  66. install -D -p -m644 features/assistant.prf \
  67. %{buildroot}%{_qt4_datadir}/mkspecs/features/assistant.prf
  68. # install missing headers (thanks to Fathi Boudra from Debian)
  69. install -p -m644 include/Q* %{buildroot}%{_qt4_headerdir}/QtAssistant/
  70. # nuke dangling reference(s) to the buildroot
  71. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" %{buildroot}%{_qt4_libdir}/*.prl
  72. # let rpm handle binaries conflicts
  73. mkdir %{buildroot}%{_bindir}
  74. pushd %{buildroot}%{_qt4_bindir}
  75. mv assistant_adp ../../../bin/
  76. ln -s ../../../bin/assistant_adp .
  77. popd
  78. # _debug target (see bug #196513)
  79. pushd %{buildroot}%{_qt4_libdir}
  80. echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
  81. popd
  82. # Note that we intentionally DO NOT install a .desktop file for assistant_adp
  83. # because it makes no sense to invoke it without a specific .adp file to open.
  84. # By default, it views the Qt documentation, for which we already have a menu
  85. # entry using the current version of the Qt Assistant, and there is no UI for
  86. # viewing anything different. The .adp file needs to be passed on the command
  87. # line, which is usually done by the application.
  88. %find_lang assistant_adp --with-qt --without-mo
  89. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  90. mv $RPM_BUILD_ROOT%{_qt4_libdir}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  91. %clean
  92. rm -rf %{buildroot}
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files -f assistant_adp.lang
  96. %defattr(-,root,root,-)
  97. %doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
  98. %{_bindir}/assistant_adp
  99. %{_qt4_bindir}/assistant_adp
  100. %{_qt4_libdir}/libQtAssistantClient.so.4*
  101. %files devel
  102. %defattr(-,root,root,-)
  103. %{_qt4_headerdir}/QtAssistant/
  104. %{_qt4_libdir}/libQtAssistantClient.so
  105. %{_qt4_libdir}/libQtAssistantClient_debug.so
  106. %{_qt4_libdir}/libQtAssistantClient.prl
  107. %{_libdir}/pkgconfig/QtAssistantClient.pc
  108. %{_qt4_datadir}/mkspecs/features/assistant.prf
  109. %changelog
  110. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
  111. - fixed BR
  112. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
  113. - Initial build for Vine Linux
  114. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  116. * Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
  117. - new upstream tarball with only the compat assistant_adp and QAssistantClient
  118. - build fixes from Debian (Fathi Boudra)
  119. - use find_lang to package the qm files (#609749)
  120. * Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
  121. - use versioned BR/Requires to avoid Conflicts
  122. * Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
  123. - first Fedora package