texlive-collection-binextra-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec 2009-4:
  3. ## tlpdb2rpmspec collection-binextra
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: TeX auxiliary programs
  22. Summary(ja): TeX Live: TeX auxiliary programs
  23. Name: texlive-collection-binextra
  24. Version: 2009
  25. Release: 4%{?_dist_release}
  26. License: GPL+, LGPLv2+, Knuth, Freely redistributable without restriction, Public Domain, No Info, LPPL, Artistic
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of TeX auxiliary programs:
  48. Various useful, but non-essential, support programs. Includes
  49. programs and macros for DVI file manipulation, literate
  50. programming, patgen, and the TeX Works Editor.
  51. This package contains the following CTAN packages:
  52. a2ping: Advanced PS, PDF, EPS converter.
  53. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  54. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  55. ctie:
  56. cweb: A Web system in C.
  57. detex: Strip TeX from a source file.
  58. dtl: Tools to dis-assemble and re-assemble DVI files.
  59. dvi2tty: Produce ASCII from DVI.
  60. dviasm: A utility for editing DVI files.
  61. dvicopy: Copy DVI files, flattening VFs.
  62. dvidvi: Convert one DVI file into another.
  63. dviljk: DVI to Laserjet output.
  64. dvipng: A fast DVI to PNG/GIF converter.
  65. dvipos:
  66. findhyph: Find hyphenated words in a document.
  67. fragmaster: Using psfrag with PDFLaTeX.
  68. getnonfreefonts:
  69. hyphenex: Generate a hyphenation exceptions file.
  70. lacheck: LaTeX checker.
  71. latex2man: Translate LaTeX-based manual pages into Unix man format.
  72. latexmk: Fully automated LaTeX document generation routine.
  73. listings-ext: Automated input of source.
  74. mkind-english:
  75. mkjobtexmf: Generate a texmf tree for a particular job.
  76. patgen:
  77. pdfcrop: Crop PDF graphics.
  78. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  79. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  80. pkfix-helper: Make PostScript files accessible to pkfix.
  81. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  82. seetexk: Utiities for manipulating DVI files.
  83. synctex:
  84. texcount: Count words in a LaTeX document.
  85. texdiff: Compare documents and produce tagged merge.
  86. texdirflatten: Collect files related to a LaTeX job in a single directory.
  87. texdoc: Documentation access for TeX distributions.
  88. texloganalyser: Analyse TeX logs.
  89. texware: Utility programs for use with TeX.
  90. tie: Allow multiple web change files.
  91. tpic2pdftex: Use tpic commands in PDFTeX.
  92. web: original web programs tangle and weave
  93. xindy: A general-purpose index processor.
  94. %description -l ja
  95. TeX Live ソフトウェアディストリビューションは、
  96. さまざまな Unix, Macintosh, Windows、および
  97. 他のプラットホームに対して完全な TeX システムを提供します。
  98. 多くの異なった言語を含む TeX ドキュメントの
  99. 編集、組版、閲覧、印刷するためのプログラム、
  100. そして、TeX マクロやフォントライブラリの大きなコレクションを
  101. 同梱しています。
  102. このディストリビューションは
  103. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  104. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  105. このパッケージは以下のようなパッケージ集です。
  106. TeX auxiliary programs:
  107. Various useful, but non-essential, support programs. Includes
  108. programs and macros for DVI file manipulation, literate
  109. programming, patgen, and the TeX Works Editor.
  110. このパッケージは以下の CTAN パッケージを含んでいます:
  111. a2ping: Advanced PS, PDF, EPS converter.
  112. asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
  113. bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
  114. ctie:
  115. cweb: A Web system in C.
  116. detex: Strip TeX from a source file.
  117. dtl: Tools to dis-assemble and re-assemble DVI files.
  118. dvi2tty: Produce ASCII from DVI.
  119. dviasm: A utility for editing DVI files.
  120. dvicopy: Copy DVI files, flattening VFs.
  121. dvidvi: Convert one DVI file into another.
  122. dviljk: DVI to Laserjet output.
  123. dvipng: A fast DVI to PNG/GIF converter.
  124. dvipos:
  125. findhyph: Find hyphenated words in a document.
  126. fragmaster: Using psfrag with PDFLaTeX.
  127. getnonfreefonts:
  128. hyphenex: Generate a hyphenation exceptions file.
  129. lacheck: LaTeX checker.
  130. latex2man: Translate LaTeX-based manual pages into Unix man format.
  131. latexmk: Fully automated LaTeX document generation routine.
  132. listings-ext: Automated input of source.
  133. mkind-english:
  134. mkjobtexmf: Generate a texmf tree for a particular job.
  135. patgen:
  136. pdfcrop: Crop PDF graphics.
  137. pdftools: PDF-related utilities, including PostScript-to-PDF conversion
  138. pkfix: Replace pk fonts in PostScript with Type 1 fonts.
  139. pkfix-helper: Make PostScript files accessible to pkfix.
  140. purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
  141. seetexk: Utiities for manipulating DVI files.
  142. synctex:
  143. texcount: Count words in a LaTeX document.
  144. texdiff: Compare documents and produce tagged merge.
  145. texdirflatten: Collect files related to a LaTeX job in a single directory.
  146. texdoc: Documentation access for TeX distributions.
  147. texloganalyser: Analyse TeX logs.
  148. texware: Utility programs for use with TeX.
  149. tie: Allow multiple web change files.
  150. tpic2pdftex: Use tpic commands in PDFTeX.
  151. web: original web programs tangle and weave
  152. xindy: A general-purpose index processor.
  153. %package doc
  154. Summary: TeX Live: Documentation files of %{name}
  155. Group: Applications/Publishing
  156. Requires: %{name} = %{version}-%{release}
  157. %description doc
  158. This package contains documentation files of %{name}.
  159. %prep
  160. %build
  161. %install
  162. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  163. PREF=%{buildroot}%{tex_destdir}
  164. manifest=(
  165. texmf-dist/bibtex/csf/base/88591lat.csf
  166. texmf-dist/bibtex/csf/base/88591sca.csf
  167. texmf-dist/bibtex/csf/base/README.TEXLIVE
  168. texmf-dist/bibtex/csf/base/ascii.csf
  169. texmf-dist/bibtex/csf/base/cp437lat.csf
  170. texmf-dist/bibtex/csf/base/cp850lat.csf
  171. texmf-dist/bibtex/csf/base/cp850sca.csf
  172. texmf-dist/bibtex/csf/base/cp866rus.csf
  173. texmf-dist/bibtex/csf/base/csfile.txt
  174. texmf-dist/bibtex/csf/polish-csf/88592pl.csf
  175. texmf-dist/bibtex/csf/polish-csf/cp1250pl.csf
  176. texmf-dist/bibtex/csf/polish-csf/cp852pl.csf
  177. texmf-dist/bibtex/csf/polish-csf/iso8859-7.csf
  178. texmf-dist/doc/plain/cweb/cwebman.dvi
  179. texmf-dist/tex/plain/cweb/cwebmac.tex
  180. texmf-dist/tex/plain/cweb/pdfXcwebmac.tex
  181. texmf-dist/tex/plain/cweb/pdfcwebmac.tex
  182. texmf-dist/tex/plain/cweb/pdfdcwebmac.tex
  183. texmf-dist/tex/plain/cweb/pdffcwebmac.tex
  184. texmf-dist/tex/plain/cweb/pdficwebmac.tex
  185. texmf-dist/tex/plain/cweb/pdfwebmac.tex
  186. texmf-dist/scripts/dviasm/dviasm.py
  187. texmf-dist/doc/support/findhyph/Makefile
  188. texmf-dist/doc/support/findhyph/README
  189. texmf-dist/doc/support/findhyph/findhyph.bat
  190. texmf-dist/doc/support/findhyph/findhyph.txt
  191. texmf-dist/scripts/findhyph/findhyph
  192. texmf-dist/doc/support/fragmaster/AUTHORS
  193. texmf-dist/doc/support/fragmaster/COPYING
  194. texmf-dist/doc/support/fragmaster/CREDITS
  195. texmf-dist/doc/support/fragmaster/README
  196. texmf-dist/doc/support/fragmaster/README.de
  197. texmf-dist/doc/support/fragmaster/example/document.pdf
  198. texmf-dist/doc/support/fragmaster/example/document.ps
  199. texmf-dist/doc/support/fragmaster/example/document.tex
  200. texmf-dist/doc/support/fragmaster/example/parabel.eps
  201. texmf-dist/doc/support/fragmaster/example/parabel.pdf
  202. texmf-dist/doc/support/fragmaster/example/parabel_fm
  203. texmf-dist/doc/support/fragmaster/example/parabel_fm.eps
  204. texmf-dist/doc/support/fragmaster/example/parabel_fm.gp
  205. texmf-dist/doc/support/fragmaster/example/parabel_fm.pdf
  206. texmf-dist/scripts/fragmaster/fragmaster.pl
  207. texmf-dist/source/generic/hyphenex/GNUmakefile
  208. texmf-dist/source/generic/hyphenex/README
  209. texmf-dist/source/generic/hyphenex/hyphenex.pl
  210. texmf-dist/source/generic/hyphenex/hyphenex.sh
  211. texmf-dist/source/generic/hyphenex/tb0hyf.tex
  212. texmf-dist/source/generic/hyphenex/test.tex
  213. texmf-dist/tex/generic/hyphenex/ushyphex.tex
  214. texmf-dist/doc/support/latex2man/CHANGES
  215. texmf-dist/doc/support/latex2man/INSTALL
  216. texmf-dist/doc/support/latex2man/Makefile
  217. texmf-dist/doc/support/latex2man/README
  218. texmf-dist/doc/support/latex2man/THIS-IS-VERSION-1.23
  219. texmf-dist/doc/support/latex2man/latex2man.1
  220. texmf-dist/doc/support/latex2man/latex2man.html
  221. texmf-dist/doc/support/latex2man/latex2man.pdf
  222. texmf-dist/doc/support/latex2man/latex2man.tex
  223. texmf-dist/doc/support/latex2man/latex2man.texi
  224. texmf-dist/doc/support/latex2man/latex2man.trans
  225. texmf-dist/doc/support/latex2man/latex2man.txt
  226. texmf-dist/scripts/latex2man/latex2man
  227. texmf-dist/tex/latex/latex2man/latex2man.cfg
  228. texmf-dist/tex/latex/latex2man/latex2man.sty
  229. texmf-dist/doc/support/latexmk/CHANGES
  230. texmf-dist/doc/support/latexmk/COPYING
  231. texmf-dist/doc/support/latexmk/INSTALL
  232. texmf-dist/doc/support/latexmk/README
  233. texmf-dist/doc/support/latexmk/example_rcfiles/README
  234. texmf-dist/doc/support/latexmk/example_rcfiles/pdflatexmkrc
  235. texmf-dist/doc/support/latexmk/extra-scripts/README1
  236. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call
  237. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call.bat
  238. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call
  239. texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call.bat
  240. texmf-dist/doc/support/latexmk/extra-scripts/kickxdvi
  241. texmf-dist/doc/support/latexmk/extra-scripts/l1
  242. texmf-dist/doc/support/latexmk/extra-scripts/l2
  243. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk
  244. texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk_README.txt
  245. texmf-dist/doc/support/latexmk/extra-scripts/startacroread
  246. texmf-dist/doc/support/latexmk/latexmk.1
  247. texmf-dist/doc/support/latexmk/latexmk.bat
  248. texmf-dist/doc/support/latexmk/latexmk.pdf
  249. texmf-dist/doc/support/latexmk/latexmk.txt
  250. texmf-dist/scripts/latexmk/latexmk.pl
  251. texmf-dist/doc/latex/listings-ext/README
  252. texmf-dist/doc/latex/listings-ext/THIS_IS_VERSION_v48
  253. texmf-dist/doc/latex/listings-ext/getversion.tex
  254. texmf-dist/doc/latex/listings-ext/hyperref.cfg
  255. texmf-dist/doc/latex/listings-ext/listings-ext.bib
  256. texmf-dist/doc/latex/listings-ext/listings-ext.el
  257. texmf-dist/doc/latex/listings-ext/listings-ext.makemake
  258. texmf-dist/doc/latex/listings-ext/listings-ext.mk
  259. texmf-dist/doc/latex/listings-ext/listings-ext.pdf
  260. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_a.java
  261. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_b.java
  262. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_c.java
  263. texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_d.java
  264. texmf-dist/doc/latex/listings-ext/listings-ext_test_a.tex
  265. texmf-dist/doc/latex/listings-ext/listings-ext_test_d.tex
  266. texmf-dist/doc/latex/listings-ext/listings.cfg
  267. texmf-dist/source/latex/listings-ext/listings-ext.dtx
  268. texmf-dist/source/latex/listings-ext/listings-ext.ins
  269. texmf-dist/scripts/listings-ext/listings-ext.sh
  270. texmf-dist/tex/latex/listings-ext/listings-ext.sty
  271. texmf-dist/makeindex/mkind-english/digit.ist
  272. texmf-dist/makeindex/mkind-english/letter.ist
  273. texmf-dist/makeindex/mkind-english/special.ist
  274. texmf-dist/doc/generic/mkjobtexmf/README
  275. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.html
  276. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.ltx
  277. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.man
  278. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.pdf
  279. texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.txt
  280. texmf-dist/source/generic/mkjobtexmf/Makefile.in
  281. texmf-dist/source/generic/mkjobtexmf/configure
  282. texmf-dist/source/generic/mkjobtexmf/configure.ac
  283. texmf-dist/source/generic/mkjobtexmf/install-sh
  284. texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  285. texmf-dist/doc/support/patgen/patgen2.tutorial
  286. texmf-dist/doc/support/pdfcrop/README
  287. texmf-dist/scripts/pdfcrop/pdfcrop.pl
  288. texmf-dist/doc/support/pkfix/README
  289. texmf-dist/scripts/pkfix/pkfix.pl
  290. texmf-dist/doc/support/pkfix-helper/README
  291. texmf-dist/doc/support/pkfix-helper/encoding-samples.pdf
  292. texmf-dist/doc/support/pkfix-helper/encoding-samples.tex
  293. texmf-dist/scripts/pkfix-helper/pkfix-helper
  294. texmf-dist/doc/support/purifyeps/README
  295. texmf-dist/scripts/purifyeps/purifyeps
  296. texmf-dist/doc/support/texcount/QuickReference.pdf
  297. texmf-dist/doc/support/texcount/QuickReference.tex
  298. texmf-dist/doc/support/texcount/README
  299. texmf-dist/doc/support/texcount/TeXcount.pdf
  300. texmf-dist/doc/support/texcount/TeXcount.tex
  301. texmf-dist/doc/support/texcount/macros.tex
  302. texmf-dist/scripts/texcount/texcount.pl
  303. texmf-dist/doc/support/texdiff/README
  304. texmf-dist/scripts/texdiff/texdiff
  305. texmf-dist/scripts/texdirflatten/texdirflatten
  306. texmf-dist/doc/support/texloganalyser/README
  307. texmf-dist/scripts/texloganalyser/texloganalyser
  308. )
  309. %__mkdir_p ${PREF}/texmf-dist
  310. for i in "${manifest[@]}"; do
  311. %__install -D %{texlive_src}/$i ${PREF}/$i
  312. done
  313. ## make symlinks of core script utils
  314. mk_symlinks=(
  315. texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
  316. texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
  317. texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
  318. texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
  319. texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
  320. texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
  321. texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
  322. texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
  323. texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
  324. texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
  325. texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
  326. texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
  327. texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
  328. texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
  329. texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
  330. texlive-collection-context,/usr/bin/context,/usr/share/texmf-dist/scripts/context/stubs/unix/context
  331. texlive-collection-context,/usr/bin/ctxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/ctxtools
  332. texlive-collection-context,/usr/bin/luatools,/usr/share/texmf-dist/scripts/context/lua/luatools.lua
  333. texlive-collection-context,/usr/bin/makempy,/usr/share/texmf-dist/scripts/context/stubs/unix/makempy
  334. texlive-collection-context,/usr/bin/mpstools,/usr/share/texmf-dist/scripts/context/stubs/unix/mpstools
  335. texlive-collection-context,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/stubs/unix/mptopdf
  336. texlive-collection-context,/usr/bin/mtxrun,/usr/share/texmf-dist/scripts/context/lua/mtxrun.lua
  337. texlive-collection-context,/usr/bin/mtxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/mtxtools
  338. texlive-collection-context,/usr/bin/pdftools,/usr/share/texmf-dist/scripts/context/stubs/unix/pdftools
  339. texlive-collection-context,/usr/bin/pstopdf,/usr/share/texmf-dist/scripts/context/stubs/unix/pstopdf
  340. texlive-collection-context,/usr/bin/rlxtools,/usr/share/texmf-dist/scripts/context/stubs/unix/rlxtools
  341. texlive-collection-context,/usr/bin/runtools,/usr/share/texmf-dist/scripts/context/stubs/unix/runtools
  342. texlive-collection-context,/usr/bin/texexec,/usr/share/texmf-dist/scripts/context/stubs/unix/texexec
  343. texlive-collection-context,/usr/bin/texfont,/usr/share/texmf-dist/scripts/context/stubs/unix/texfont
  344. texlive-collection-context,/usr/bin/texmfstart,/usr/share/texmf-dist/scripts/context/ruby/texmfstart.rb
  345. texlive-collection-context,/usr/bin/textools,/usr/share/texmf-dist/scripts/context/stubs/unix/textools
  346. texlive-collection-context,/usr/bin/texutil,/usr/share/texmf-dist/scripts/context/stubs/unix/texutil
  347. texlive-collection-context,/usr/bin/tmftools,/usr/share/texmf-dist/scripts/context/stubs/unix/tmftools
  348. texlive-collection-context,/usr/bin/xmltools,/usr/share/texmf-dist/scripts/context/stubs/unix/xmltools
  349. texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
  350. texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
  351. texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
  352. texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
  353. texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
  354. texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
  355. texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
  356. texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
  357. texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
  358. texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
  359. texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
  360. texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
  361. texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/bengali/ebong.py
  362. texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
  363. texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
  364. texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
  365. texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
  366. texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex
  367. texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
  368. texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
  369. texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
  370. texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
  371. texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
  372. texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
  373. texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
  374. texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf
  375. texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk
  376. texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
  377. texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf.pl
  378. texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
  379. )
  380. %__mkdir_p %{buildroot}%{_bindir}
  381. pushd %{buildroot}%{_bindir}
  382. for i in "${mk_symlinks[@]}"; do
  383. tlc=$(echo $i | cut -f 1 -d",")
  384. lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
  385. rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
  386. [ "%{name}" = "$tlc" ] || continue
  387. [ -f $rlnk ] || exit 1
  388. %__ln_s $rlnk $lnk || exit 1
  389. done
  390. popd
  391. ## info
  392. %__rm -f %{buildroot}%{_infodir}/dir
  393. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  394. ## man
  395. ## man t1* files are provided by t1utils
  396. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  397. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  398. done
  399. ## man some files are provided by psutils
  400. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  401. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  402. done
  403. ## fix perl path
  404. for i in source/metapost/expressg/expressg.dtx \
  405. doc/metapost/expressg/n2mpsprl.prl \
  406. doc/latex/songbook/contrib/crd2sb/crd2sb; do
  407. [ -f %{build_texmf}-dist/${i} ] && \
  408. %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
  409. done
  410. ## remove asymptote directries, which provides asymptote package
  411. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  412. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  413. # ## remove xindy
  414. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  415. # ## remove tex4ht
  416. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  417. ## remove arch dependent binaries
  418. %__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
  419. ## remove unpackaging files
  420. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  421. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  422. ## Files list
  423. find %{buildroot} -type f -or -type l | \
  424. %__sed -e "s|%{buildroot}||g" > filelist.full
  425. find %{buildroot}%{texmf}-dist -type d | \
  426. %__sed -e "s|^%{buildroot}|%dir |" \
  427. -e "s|$|/|" >> filelist.full
  428. ## subpackages
  429. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  430. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  431. %__mv -f filelist.tmp filelist.full
  432. %clean
  433. %__rm -rf %{buildroot}
  434. %post
  435. %{exec_texhash}
  436. exit 0
  437. %postun
  438. if [ "$1" = 0 ]; then
  439. %{exec_texhash}
  440. fi
  441. exit 0
  442. %files -f filelist.full
  443. %defattr(-,root,root)
  444. %files -f filelist.doc doc
  445. %defattr(-,root,root)
  446. %changelog
  447. * Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  448. - generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-binextra
  449. - make symlinks of core script utils (texlive-collection-binextra,
  450. texlive-collection-context, texlive-collection-fontutils,
  451. texlive-collection-langgreek, texlive-collection-langindic,
  452. texlive-collection-latex, texlive-collection-latexextra,
  453. texlive-collection-latexrecommended, texlive-collection-pictures,
  454. texlive-collection-pstricks, texlive-collection-science)
  455. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  456. - generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-binextra
  457. - improved %%post
  458. * Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  459. - generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-binextra
  460. - removed arch dependent binaries (texlive-collection-latexextra)
  461. - fixed perl path
  462. - improved updmap process in %%post and %%postun
  463. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  464. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-binextra