xorg-x11-font-utils-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288
  1. %define pkgname font-utils
  2. Summary: X.Org X11 font utilities
  3. Summary(ja): X.Org X11 font ユーティリティ
  4. Name: xorg-x11-%{pkgname}
  5. Version: 7.6
  6. Release: 1%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.3.tar.bz2
  11. Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
  12. Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.6.tar.bz2
  13. Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.0.9.tar.bz2
  14. Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.2.0.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pkgconfig
  17. # xorg-x11-libXfont-devel needed for bdftopcf
  18. BuildRequires: libXfont-devel
  19. # xorg-x11-libX11-devel needed for fonttosfnt
  20. BuildRequires: libX11-devel
  21. # xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
  22. BuildRequires: libfontenc-devel >= 0.99.2-2
  23. # freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
  24. BuildRequires: freetype2-devel
  25. # zlib-devel needed for bdftopcf
  26. BuildRequires: zlib-devel
  27. # xorg-x11-proto-devel is needed for mkfontscale, which includes headers
  28. # from it directly.
  29. BuildRequires: xorg-x11-proto-devel
  30. BuildRequires: autoconf
  31. Requires(pre): xorg-x11-filesystem
  32. # NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
  33. # bug #173875 is installed in order for mkfontscale/mkfontdir to work
  34. # properly. It is a "pre" dep, to ensure libfontenc gets installed before
  35. # xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
  36. # set, avoiding a possible race condition.
  37. Requires(pre): libfontenc
  38. Provides: %{pkgname}
  39. Provides: XOrg-%{pkgname} = %{version}
  40. Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
  41. # NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
  42. # is needed for upgrades to work properly from OS releases that had XFree86
  43. Obsoletes: XFree86-font-utils, XOrg-font-utils
  44. # NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
  45. # this is needed for upgrades to work.
  46. Obsoletes: XFree86
  47. # NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
  48. # xorg-x11-font-utils in 6.7.99.903-3
  49. Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
  50. # NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
  51. Obsoletes: XOrg-tools <= 6.7.99.903-3
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. %description
  55. X.Org X11 font utilities required for font installation, conversion,
  56. and generation.
  57. %package -n bdftruncate
  58. Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
  59. Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
  60. Group: Applications/System
  61. %description -n bdftruncate
  62. bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
  63. other ISO10646-1 BDF fonts in which all characters above a threshold
  64. code value are stored unencoded. This is often desirable because the
  65. Xlib API and X11 protocol data structures used for representing font
  66. metric information are extremely inefficient when handling sparsely
  67. populated fonts.
  68. %prep
  69. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  70. %build
  71. # Build all apps
  72. {
  73. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
  74. pushd $app-*
  75. # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
  76. case $app in
  77. font-util)
  78. autoconf
  79. ;;
  80. esac
  81. %configure
  82. make
  83. popd
  84. done
  85. }
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. # Install all apps
  89. {
  90. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
  91. pushd $app-*
  92. make install DESTDIR=$RPM_BUILD_ROOT
  93. popd
  94. done
  95. for i in */README ; do
  96. [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
  97. done
  98. for i in */COPYING ; do
  99. grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
  100. done
  101. }
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %files
  105. %defattr(-,root,root,-)
  106. %doc README-* COPYING-*
  107. %{_bindir}/bdftopcf
  108. %{_bindir}/fonttosfnt
  109. %{_bindir}/mkfontdir
  110. %{_bindir}/mkfontscale
  111. %{_bindir}/ucs2any
  112. # blech. this one should be in -filesystem
  113. %dir %{_datadir}/fonts/X11
  114. %dir %{_datadir}/fonts/X11/util
  115. %{_datadir}/fonts/X11/util/map-*
  116. %{_datadir}/aclocal/fontutil.m4
  117. %{_libdir}/pkgconfig/fontutil.pc
  118. %{_mandir}/man1/bdftopcf.1*
  119. %{_mandir}/man1/fonttosfnt.1*
  120. %{_mandir}/man1/mkfontdir.1*
  121. %{_mandir}/man1/mkfontscale.1*
  122. %{_mandir}/man1/ucs2any.1*
  123. %files -n bdftruncate
  124. %defattr(-,root,root,-)
  125. %{_bindir}/bdftruncate
  126. %{_mandir}/man1/bdftruncate.1*
  127. %changelog
  128. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
  129. - mkfontscale-1.0.9
  130. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
  131. - mkfontdir-1.0.6
  132. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
  133. - bdftopcf-1.0.3
  134. - mkfontscale-1.0.8
  135. - font-util-1.2.0
  136. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
  137. - rebuild with rpm-4.8.1 for pkg-config file
  138. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  139. - bdftopcf-1.0.2
  140. - mkfontdir-1.0.5
  141. - mkfontscale-1.0.7
  142. - font-util-1.1.1
  143. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
  144. - mkfontscale 1.0.6
  145. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  146. - fonttosfnt 1.0.4
  147. - mkfontdir 1.0.4
  148. - mkfontscale 1.0.5
  149. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
  150. - new versioning policy
  151. * Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
  152. - initial build for Vine Linux
  153. * Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
  154. - Move bdftruncate (and its perl dependency) to a subpackage.
  155. - %%doc for the non-empty READMEs and non-stub COPYINGs.
  156. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
  157. - Rebuild for build id
  158. * Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
  159. - bdftopcf 1.0.1
  160. - Superstition bump to 7.2-1
  161. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
  162. - mkfontdir 1.0.3
  163. * Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
  164. - fonttosfnt 1.0.3
  165. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
  166. - Remove X11R6 symlinks.
  167. * Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
  168. - Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
  169. with new freetype 2.2.
  170. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
  171. - rebuild
  172. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
  173. - Update to font-util-1.0.1 from X11R7.1
  174. - Set package version to X11 release the tarballs are based from.
  175. * Thu Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
  176. - Update mkfontdir
  177. * Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
  178. - Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
  179. itself. Leftover from the original package template it seems. (#182439)
  180. * Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
  181. - Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
  182. mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
  183. binaries. This will provide backward compatibilty for Fedora Core 5, however
  184. 3rd party developers and rpm package maintainers should update to using the
  185. new X11R7 locations immediately, as these compatibility links are temporary,
  186. and will be removed from a future OS release.
  187. - Remove system directories from file manifest to appease the banshees.
  188. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
  189. - bump again for double-long bug on ppc(64)
  190. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
  191. - rebuilt for new gcc4.1 snapshot and glibc changes
  192. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
  193. - Updated all utilities to the versions shipped in X11R7.0.
  194. * Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
  195. - Updated all utilities to version 1.0.0 from X11R7 RC4.
  196. - Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
  197. - Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
  198. variable "fontdir" to the fontutil.pc file which all of the font packages
  199. can autodetect and use instead of having to put manual fontdir overrides
  200. in every single rpm package.
  201. * Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
  202. - Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
  203. and font-util to version 0.99.2 from X11R7 RC3.
  204. - Changed manpage dir from man1x back to man1 due to another upstream change.
  205. - Added fontutil.m4 to file manifest.
  206. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
  207. - Changed package version to 0.99.1 to match the upstream font-util tarball
  208. version, and added "Epoch: 1" to the package for upgrades.
  209. - Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
  210. mapfiles data to install into datadir instead of libdir (#173943)
  211. - Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
  212. libfontenc to be installed that fixes bug #173453, and to also force it
  213. to be installed before xorg-x11-font-utils in a multi-package rpm
  214. transaction, which will ensure that when font packages get installed
  215. during upgrades via anaconda or yum, that the right libfontenc is being
  216. used by mkfontscale/mkfontdir.
  217. - Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
  218. people rebuilding xorg-x11-font-utils, as they'll need to install the new
  219. libfontenc now anyway before they can install the font-utils package.
  220. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
  221. - require newer filesystem (#172610)
  222. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
  223. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  224. X11R7 RC1.
  225. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
  226. - Glob util/map-* files in file manifest.
  227. - Added missing "Obsoletes: xorg-x11-font-utils".
  228. - Added "BuildRequires: pkgconfig".
  229. * Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
  230. - Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
  231. ucs2any, bdftruncate.
  232. * Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
  233. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  234. X11R7 RC1.
  235. - Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
  236. - Updated file manifest to to find the manpages in "man1x".
  237. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
  238. - Initial build.