parole-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. # by default don't build the browser plugin
  2. # use bcond_without to change the default
  3. #%bcond_with mozilla
  4. %define PAROLE_BIN %{_libexecdir}/%{name}
  5. Name: parole
  6. Version: 0.5.0
  7. Release: 1%{?_dist_release}
  8. Summary: Media player for the Xfce desktop
  9. Summary(ja): Xfce デスクトップのメディアプレーヤー
  10. Group: Applications/Multimedia
  11. License: GPLv2+
  12. URL: http://goodies.xfce.org/projects/applications/parole
  13. Source0: http://archive.xfce.org/src/apps/parole/0.3/%{name}-%{version}.tar.bz2
  14. Source10: parole.sh
  15. #Patch1: parole-0.2.0.6-dsofix.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: gettext
  19. BuildRequires: gtk-doc
  20. BuildRequires: gtk2-devel >= 2.20.0
  21. BuildRequires: glib2-devel >= 2.32.0
  22. BuildRequires: gstreamer-devel
  23. BuildRequires: gstreamer-plugins-base-devel >= 0.10.24
  24. BuildRequires: dbus-devel >= 0.60
  25. BuildRequires: dbus-glib-devel >= 0.70
  26. BuildRequires: intltool
  27. BuildRequires: libnotify-devel >= 0.4.1
  28. BuildRequires: libxfcegui4-devel >= 4.8.0
  29. BuildRequires: libxfce4util-devel >= 4.8.0
  30. BuildRequires: libxfce4ui-devel >= 4.8.0
  31. BuildRequires: xfce4-dev-tools
  32. BuildRequires: taglib-devel >= 1.4
  33. #%if %{with mozilla}
  34. #BuildRequires: xulrunner-devel
  35. #%endif
  36. Requires: gstreamer-plugins-good
  37. Obsoletes: %{name}-mozplugin
  38. %description
  39. Parole is a modern simple media player based on the GStreamer framework and
  40. written to fit well in the Xfce desktop. Parole features playback of local
  41. media files, DVD/CD and live streams. Parole is extensible via plugins.
  42. The project still in its early developments stage, but already contains the
  43. following features:
  44. * Audio playback
  45. * Video playback with optional subtitle
  46. * Playback of live sources
  47. %description -l ja
  48. Parole は GStreamer フレームワークに基づき Xfce デスクトップに
  49. 馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
  50. Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
  51. 特色とします。
  52. Parole はプラグインを介して拡張が可能です。
  53. このプロジェクトはまだ開発の初期段階ですが、
  54. 既に以下の機能がふくまれています。
  55. * オーディオの再生
  56. * 任意のサブタイトルがあるビデオの再生
  57. * ライブストリームの再生
  58. %package devel
  59. Summary: Development files for %{name}
  60. Summary(ja): %{name} の開発ファイル
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: gtk-doc
  64. %description devel
  65. The %{name}-devel package contains header files for developing plugins for
  66. %{name}.
  67. %description devel -l ja
  68. %{name}-devel パッケージ は %{name} のプラグインを開発するための
  69. ヘッダファイルを含みます。
  70. #%if %{with mozilla}
  71. #%package mozplugin
  72. #Summary: Browser plugin for %{name}
  73. #Group: Application/Internet
  74. #Requires: %{name} = %{version}-%{release}
  75. #%description mozplugin
  76. #Parole is a modern simple media player based on the GStreamer framework and
  77. #written to fit well in the Xfce desktop. This plugin allows it to be embedded
  78. #in a web browser.
  79. #%endif
  80. %prep
  81. %setup -q
  82. #%patch1 -p1
  83. %build
  84. ./autogen.sh
  85. %configure --disable-static --enable-gtk-doc
  86. #%if %{with mozilla}
  87. # --enable-browser-plugin
  88. #%else
  89. # --disable-browser-plugin
  90. #%endif
  91. make %{?_smp_mflags} V=1
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  96. ## wrapper install
  97. %__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
  98. %__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
  99. %{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
  100. %find_lang %{name}
  101. desktop-file-install \
  102. --delete-original \
  103. --dir=%{buildroot}%{_datadir}/applications \
  104. %{buildroot}/%{_datadir}/applications/%{name}.desktop
  105. %clean
  106. rm -rf $RPM_BUILD_ROOT
  107. %post
  108. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  109. update-mime-database %{_datadir}/mime &> /dev/null || :
  110. %postun
  111. if [ $1 -eq 0 ] ; then
  112. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  113. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  114. fi
  115. update-mime-database %{_datadir}/mime &> /dev/null || :
  116. %posttrans
  117. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  118. %files -f %{name}.lang
  119. %defattr(-,root,root,-)
  120. %doc AUTHORS COPYING README TODO THANKS
  121. %{PAROLE_BIN}
  122. %{_bindir}/%{name}
  123. %dir %{_libdir}/%{name}-0/
  124. %{_libdir}/%{name}-0/*.so
  125. %{_datadir}/applications/%{name}.desktop
  126. %{_datadir}/icons/hicolor/*
  127. %{_datadir}/%{name}/
  128. %files devel
  129. %defattr(-,root,root,-)
  130. %doc %{_datadir}/gtk-doc/html/Parole-Plugins/
  131. %{_includedir}/%{name}/
  132. #%if %{with mozilla}
  133. #%files mozplugin
  134. #%defattr(-,root,root,-)
  135. #%{_libexecdir}/%{name}-media-plugin
  136. #%{_libdir}/mozilla/plugins/%{name}-player.so
  137. #%endif
  138. %changelog
  139. * Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
  140. - new upstream release
  141. * Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
  142. - new upstream release
  143. - deleted Patch1
  144. - added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
  145. - changed BuildRequires
  146. - gtk2-devel >= 2.16.0 to 2.20.0
  147. - glib2-devel >= 2.16.0 to 2.32.0
  148. - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
  149. - libxfcegui4-devel >= 4.6.0 to 4.8.0
  150. - libxfce4util-devel >= 4.6.0 to 4.8.0
  151. * Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
  152. - rebuilt with new libxfce4util
  153. * Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
  154. - added Obsoletes tag: %%{name}-mozplugin
  155. - added wrapper script to detect nonfree package installed
  156. * Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
  157. - new upstream release
  158. - obsoleted -mozplugin package
  159. * Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
  160. - new upstream release
  161. * Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
  162. - new upstream release
  163. * Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
  164. - new upstream release
  165. - added BuildRequires: glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
  166. * Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
  167. - new upstream release
  168. - added BuildRequires: gstreamer-devel
  169. - splitted mozplugin package
  170. * Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
  171. - new upstream release
  172. - dropt all pathces
  173. * Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
  174. - initial build for VineSeed
  175. * Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
  176. - BuildRequire taglib-devel and fix libnotify requirement
  177. * Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
  178. - Update to 0.1.90
  179. - Loads of additional translations
  180. * Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
  181. - Initial package