libwebp-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %bcond_with java
  2. Name: libwebp
  3. Summary: Library and tools for the WebP graphics format
  4. Summary(ja): WebP 画像フォーマットのためのライブラリとツール
  5. Version: 1.2.4
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. # Additional IPR is licensed as well. See PATENTS file for details
  12. License: BSD
  13. URL: https://developers.google.com/speed/webp
  14. Source0: https://github.com/webmproject/libwebp/archive/v%{version}.tar.gz#/libwebp-%{version}.tar.gz
  15. Source1: libwebp_jni_example.java
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libjpeg-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: libtool
  20. BuildRequires: freeglut-devel
  21. %if %{with java}
  22. BuildRequires: swig
  23. BuildRequires: java-1.8.0-openjdk-devel
  24. BuildRequires: jpackage-utils
  25. %endif
  26. %description
  27. WebP is an image format that does lossy compression of digital
  28. photographic images. WebP consists of a codec based on VP8, and a
  29. container based on RIFF. Webmasters, web developers and browser
  30. developers can use WebP to compress, archive and distribute digital
  31. images more efficiently.
  32. %package tools
  33. Summary: The WebP command line tools
  34. Summary(ja): WebP コマンドラインツール
  35. Group: graphics
  36. %description tools
  37. WebP is an image format that does lossy compression of digital
  38. photographic images. WebP consists of a codec based on VP8, and a
  39. container based on RIFF. Webmasters, web developers and browser
  40. developers can use WebP to compress, archive and distribute digital
  41. images more efficiently.
  42. %package devel
  43. Summary: Development files for libwebp, a library for the WebP format
  44. Summary(ja): WebP フォーマットのためのライブラリ libwebp の開発ファイル
  45. Group: programming
  46. Requires: %{name} = %{version}-%{release}
  47. %description devel
  48. WebP is an image format that does lossy compression of digital
  49. photographic images. WebP consists of a codec based on VP8, and a
  50. container based on RIFF. Webmasters, web developers and browser
  51. developers can use WebP to compress, archive and distribute digital
  52. images more efficiently.
  53. %if %{with java}
  54. %package java
  55. Summary: Java bindings for libwebp, a library for the WebP format
  56. Summary(ja): WebP フォーマットのためのライブラリ libwebp の Java バインディング
  57. Group: programming
  58. Requires: %{name} = %{version}-%{release}
  59. Requires: java
  60. Requires: jpackage-utils
  61. %description java
  62. Java bindings for libwebp.
  63. %endif
  64. %prep
  65. %setup -q
  66. %build
  67. %global optflags %{optflags} -fPIC
  68. mkdir -p m4
  69. ./autogen.sh
  70. %configure --disable-static --enable-libwebpmux \
  71. --enable-libwebpdemux --enable-libwebpdecoder \
  72. --disable-neon
  73. make %{?_smp_mflags}
  74. %if %{with java}
  75. # swig generated Java bindings
  76. cp %{SOURCE1} .
  77. cd swig
  78. rm -rf libwebp.jar libwebp_java_wrap.c
  79. mkdir -p java/com/google/webp
  80. swig -ignoremissing -I../src -java \
  81. -package com.google.webp \
  82. -outdir java/com/google/webp \
  83. -o libwebp_java_wrap.c libwebp.swig
  84. gcc %{optflags} -shared \
  85. -I/usr/lib/jvm/java/include \
  86. -I/usr/lib/jvm/java/include/linux \
  87. -I../src \
  88. -L../src/.libs -lwebp libwebp_java_wrap.c \
  89. -o libwebp_jni.so
  90. cd java
  91. javac com/google/webp/libwebp.java
  92. jar cvf ../libwebp.jar com/google/webp/*.class
  93. %endif
  94. %install
  95. make install DESTDIR=%{buildroot}
  96. find "%{buildroot}/%{_libdir}" -type f -name "*.la" -delete
  97. %if %{with java}
  98. # swig generated Java bindings
  99. mkdir -p %{buildroot}/%{_libdir}/%{name}-java
  100. cp swig/*.jar swig/*.so %{buildroot}/%{_libdir}/%{name}-java/
  101. %endif
  102. %files tools
  103. %{_bindir}/*
  104. %{_mandir}/man*/*
  105. %files -n %{name}
  106. %license COPYING PATENTS
  107. %doc README* NEWS AUTHORS
  108. %{_libdir}/%{name}*.so.*
  109. %files devel
  110. %{_libdir}/%{name}*.so
  111. %{_includedir}/*
  112. %{_libdir}/pkgconfig/*
  113. %if %{with java}
  114. %files java
  115. %doc libwebp_jni_example.java
  116. %{_libdir}/%{name}-java/
  117. %endif
  118. %changelog
  119. * Fri Sep 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-1
  120. - new upstream release.
  121. * Fri Apr 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
  122. - new upstream release.
  123. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1-1
  124. - new upstream release.
  125. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.3.1-3
  126. - moved libwebp to System Environment/Libraries Group
  127. * Tue Jul 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.1-2
  128. - rebuild with libpng-1.6.12
  129. * Sat Oct 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.3.1-1
  130. - new upstream release
  131. * Sat Jan 12 2013 IWAI, Masaharu <iwai@alib.jp> 0.2.1-1
  132. - initial build for Vine Linux
  133. * Thu Dec 27 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.2.1-1
  134. - new upstream release 0.2.1
  135. * Fri Dec 21 2012 Adam Tkac <atkac redhat com> - 0.1.3-3
  136. - rebuild against new libjpeg
  137. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  139. * Thu Feb 02 2012 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.3-1
  140. - Several spec improvements by Scott Tsai <scottt.tw@gmail.com>
  141. * Wed May 25 2011 Rahul Sundaram <sundaram@fedoraproject.org> - 0.1.2-1
  142. - Initial spec. Based on openSUSE one