libldb-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. %define talloc_version 2.1.11
  4. %define tdb_version 1.3.15
  5. %define tevent_version 0.9.36
  6. Name: libldb
  7. Summary: A schema-less, ldap like, API and database
  8. Version: 1.3.2
  9. Release: 1%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv3+
  12. URL: http://ldb.samba.org/
  13. Source: http://samba.org/ftp/ldb/ldb-%{version}.tar.gz
  14. # Patches
  15. Patch0001: 0001-ldb-Fix-memory-leak-on-module-context.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libtalloc-devel >= %{talloc_version}
  18. BuildRequires: libtdb-devel >= %{tdb_version}
  19. BuildRequires: libtevent-devel >= %{tevent_version}
  20. BuildRequires: popt-devel
  21. BuildRequires: autoconf
  22. BuildRequires: libxslt
  23. BuildRequires: docbook-style-xsl
  24. BuildRequires: python-devel
  25. BuildRequires: python-rpm-macros
  26. BuildRequires: python-tdb
  27. BuildRequires: python-talloc-devel
  28. BuildRequires: python-tevent
  29. BuildRequires: python3-devel
  30. BuildRequires: python3-rpm-macros
  31. BuildRequires: python3-tdb
  32. BuildRequires: python3-talloc-devel
  33. BuildRequires: python3-tevent
  34. BuildRequires: doxygen
  35. Requires: libtalloc >= %{talloc_version}
  36. Requires: libtdb >= %{tdb_version}
  37. Requires: libtevent >= %{tevent_version}
  38. Provides: bundled(libreplace)
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: tomop
  42. %description
  43. An extensible library that implements an LDAP like API to access remote LDAP
  44. servers, or use local tdb databases.
  45. %package -n ldb-tools
  46. Group: Applications/System
  47. Summary: Tools to manage LDB files
  48. Requires: libldb = %{version}-%{release}
  49. %description -n ldb-tools
  50. Tools to manage LDB files
  51. %package devel
  52. Group: Development/Libraries
  53. Summary: Developer tools for the LDB library
  54. Requires: libldb = %{version}-%{release}
  55. Requires: libtdb-devel >= %{tdb_version}
  56. Requires: libtalloc-devel >= %{talloc_version}
  57. Requires: libtevent-devel >= %{tevent_version}
  58. Requires: pkgconfig
  59. %description devel
  60. Header files needed to develop programs that link against the LDB library.
  61. %package -n python-ldb
  62. Group: System Environment/Libraries
  63. Summary: Python bindings for the LDB library
  64. Requires: libldb = %{version}-%{release}
  65. Requires: python-tdb >= %{tdb_version}
  66. Provides: pyldb = %{version}-%{release}
  67. Obsoletes: pyldb < 1.1.31-2
  68. %description -n python-ldb
  69. Python bindings for the LDB library
  70. %package -n python-ldb-devel
  71. Group: Development/Libraries
  72. Summary: Development files for the Python bindings for the LDB library
  73. Requires: python-ldb = %{version}-%{release}
  74. Requires: python-ldb-devel-common = %{version}-%{release}
  75. Provides: pyldb-devel = %{version}-%{release}
  76. Obsoletes: pyldb-devel <= 1.1.31-2
  77. %description -n python-ldb-devel
  78. Development files for the Python bindings for the LDB library
  79. %package -n python-ldb-devel-common
  80. Summary: Common development files for the Python bindings for the LDB library
  81. %description -n python-ldb-devel-common
  82. Development files for the Python bindings for the LDB library.
  83. This package includes files that aren't specific to a Python version.
  84. %package -n python3-ldb
  85. Group: System Environment/Libraries
  86. Summary: Python3 bindings for the LDB library
  87. Requires: libldb = %{version}-%{release}
  88. Requires: python3-tdb >= %{tdb_version}
  89. %description -n python3-ldb
  90. Python3 bindings for the LDB library
  91. %package -n python3-ldb-devel
  92. Group: Development/Libraries
  93. Summary: Development files for the Python3 bindings for the LDB library
  94. Requires: python3-ldb = %{version}-%{release}
  95. Requires: python-ldb-devel-common = %{version}-%{release}
  96. %description -n python3-ldb-devel
  97. Development files for the Python3 bindings for the LDB library
  98. %if %{build_compat32}
  99. %package -n compat32-%{name}
  100. Summary: A schema-less, ldap like, API and database
  101. Group: System Environment/Libraries
  102. %description -n compat32-%{name}
  103. An extensible library that implements an LDAP like API to access remote LDAP
  104. servers, or use local tdb databases.
  105. %endif
  106. %prep
  107. %setup -q -n ldb-%{version}
  108. %patch1 -p3
  109. %build
  110. # tdb_compat and ccan have no upstream releases to link against yet and their
  111. # API is in flux. It is unsafe to make them public and shared at this time.
  112. %configure \
  113. --disable-rpath \
  114. --disable-rpath-install \
  115. --bundled-libraries=cmocka \
  116. --builtin-libraries=replace \
  117. --with-modulesdir=%{_libdir}/ldb/modules \
  118. --with-privatelibdir=%{_libdir}/ldb \
  119. --extra-python=%{__python3}
  120. make V=1 %{?_smp_mflags}
  121. doxygen Doxyfile
  122. %install
  123. make install DESTDIR=%{buildroot}
  124. rm -f %{buildroot}%{_libdir}/libldb.a
  125. # Shared libraries need to be marked executable for
  126. # rpmbuild to strip them and include them in debuginfo
  127. find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} \;
  128. # Install API docs
  129. cp -a apidocs/man/* $RPM_BUILD_ROOT/%{_mandir}
  130. # LDB 1.1.8+ bug: remove manpage named after full
  131. # file path
  132. rm -f $RPM_BUILD_ROOT/%{_mandir}/man3/_*
  133. %clean
  134. rm -rf %{buildroot}
  135. %post
  136. /sbin/ldconfig
  137. %postun
  138. /sbin/ldconfig
  139. %post -n python-ldb
  140. /sbin/ldconfig
  141. %postun -n python-ldb
  142. /sbin/ldconfig
  143. %post -n python3-ldb
  144. /sbin/ldconfig
  145. %postun -n python3-ldb
  146. /sbin/ldconfig
  147. %if %{build_compat32}
  148. %post -n compat32-%{name}
  149. /sbin/ldconfig
  150. %postun -n compat32-%{name}
  151. /sbin/ldconfig
  152. %endif
  153. %files
  154. %defattr(-,root,root,-)
  155. %dir %{_libdir}/ldb
  156. %{_libdir}/ldb/libcmocka-ldb.so
  157. %{_libdir}/libldb.so.*
  158. %dir %{_libdir}/ldb/modules
  159. %dir %{_libdir}/ldb/modules/ldb
  160. %{_libdir}/ldb/modules/ldb/*.so
  161. %files -n ldb-tools
  162. %defattr(-,root,root,-)
  163. %{_bindir}/ldbadd
  164. %{_bindir}/ldbdel
  165. %{_bindir}/ldbedit
  166. %{_bindir}/ldbmodify
  167. %{_bindir}/ldbrename
  168. %{_bindir}/ldbsearch
  169. %{_libdir}/ldb/libldb-cmdline.so
  170. %{_mandir}/man1/ldbadd.1.*
  171. %{_mandir}/man1/ldbdel.1.*
  172. %{_mandir}/man1/ldbedit.1.*
  173. %{_mandir}/man1/ldbmodify.1.*
  174. %{_mandir}/man1/ldbrename.1.*
  175. %{_mandir}/man1/ldbsearch.1.*
  176. %files devel
  177. %defattr(-,root,root,-)
  178. %{_includedir}/ldb_module.h
  179. %{_includedir}/ldb_handlers.h
  180. %{_includedir}/ldb_errors.h
  181. %{_includedir}/ldb_version.h
  182. %{_includedir}/ldb.h
  183. %{_libdir}/libldb.so
  184. %{_libdir}/pkgconfig/ldb.pc
  185. %{_mandir}/man3/ldb*.gz
  186. %{_mandir}/man3/ldif*.gz
  187. %files -n python-ldb
  188. %defattr(-,root,root,-)
  189. %{python_sitearch}/ldb.so
  190. %{python_sitearch}/_ldb_text.*
  191. %{_libdir}/libpyldb-util.so.1*
  192. %files -n python-ldb-devel
  193. %defattr(-,root,root,-)
  194. %{_libdir}/libpyldb-util.so
  195. %{_libdir}/pkgconfig/pyldb-util.pc
  196. %files -n python-ldb-devel-common
  197. %{_includedir}/pyldb.h
  198. %{_mandir}/man*/Py*.gz
  199. %files -n python3-ldb
  200. %{python3_sitearch}/ldb.cpython-*.so
  201. %{_libdir}/libpyldb-util.cpython-*.so.1*
  202. %{python3_sitearch}/_ldb_text.py
  203. %files -n python3-ldb-devel
  204. %{_libdir}/libpyldb-util.cpython-*.so
  205. %{_libdir}/pkgconfig/pyldb-util.cpython-*.pc
  206. %if %{build_compat32}
  207. %files -n compat32-%{name}
  208. %defattr(-,root,root,-)
  209. %dir %{_libdir}/ldb
  210. %{_libdir}/libldb.so.*
  211. %dir %{_libdir}/ldb/modules
  212. %dir %{_libdir}/ldb/modules/ldb
  213. %{_libdir}/ldb/libldb-cmdline.so
  214. %{_libdir}/ldb/libcmocka-ldb.so
  215. %{_libdir}/ldb/modules/ldb/*.so
  216. %endif
  217. %changelog
  218. * Thu Mar 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  219. - new upstream release.
  220. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  221. - new upstream release.
  222. - dropped Patch1001.
  223. - imported Patch1 from rawhide.
  224. - enabled python3 modules.
  225. - renamed python packages.
  226. * Sat Jul 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.31-1
  227. - new upstream release.
  228. * Sun Dec 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
  229. - new upstream release.
  230. * Wed Feb 24 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.26-1
  231. - new upstream release.
  232. * Fri Dec 18 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.25-1
  233. - new upstream release.
  234. * Thu Dec 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.24-1
  235. - new upstream release.
  236. * Wed Dec 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.23-1
  237. - new upstream release.
  238. * Fri Jul 24 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.21-1
  239. - new upstream release.
  240. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-2
  241. - added compat32 package.
  242. * Fri Mar 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.20-1
  243. - new upstream release.
  244. * Mon Jan 12 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.19-1
  245. - new upstream release.
  246. * Wed Dec 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.18-1
  247. - new upstream release.
  248. * Fri Oct 3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.17-2
  249. - moved libldb and pyldb to System Environment/Libraries Group
  250. - moved ldb-tool to Applications/System Group
  251. * Tue Aug 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.17-1
  252. - new upstream release.
  253. * Wed Jan 08 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-2
  254. - rebuilt with current environment.
  255. * Tue Oct 08 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.16-1
  256. - new upstream release.
  257. * Sun Mar 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-1
  258. - new upstream release.
  259. * Thu Dec 20 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-3
  260. - moved libldb-cmdline.so to main package.
  261. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-2
  262. - fixed dependency.
  263. * Mon Dec 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.14-1
  264. - new upstream release.
  265. - initial build for Vine Linux.
  266. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-2
  267. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  268. * Tue Dec 06 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.4-1
  269. - New upstream release
  270. - Add ldb_module_error() routine
  271. - Fedora: work around unreliable configure check for pytevent
  272. - Drop patch to ignore --disable-silent-rules (included in tarball)
  273. * Thu Dec 01 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-4
  274. - Add patch to ignore --disable-silent-rules
  275. * Wed Nov 23 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-3
  276. - Add explicit mention of the bundled libreplace
  277. - https://fedorahosted.org/fpc/ticket/120
  278. - Add explicit mention of bundled libtdb_compat and libccan
  279. - https://fedorahosted.org/fpc/ticket/119
  280. * Mon Nov 21 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-2
  281. - Build and install API documentation
  282. - Build tdb_compat and ccan statically. They have no upstream releases to
  283. link against yet and their API is in flux. It is unsafe to make them
  284. public and shared at this time.
  285. * Wed Nov 09 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.1.3-1
  286. - New upstream release
  287. - Required for building newer samba4 packages
  288. * Tue Aug 2 2011 Simo Sorce <ssorce@redhat.com> - 1.1.0-1
  289. - Update to 1.1.0
  290. (dependency for samba4 alpha16 snapshot)
  291. * Tue Feb 22 2011 Simo Sorce <ssorce@redhat.com> - 1.0.2-1
  292. - Update to 1.0.2
  293. (dependency for samba4 alpha15 snapshot)
  294. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-2
  295. - Disable rpath
  296. * Fri Feb 11 2011 Stephen Gallagher <sgallagh@redhat.com> - 1.0.0-1
  297. - New upstream release 1.0.0
  298. - SOname bump to account for module loading changes
  299. - Rename libldb-tools to ldb-tools to make upgrades easier
  300. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.22-9
  301. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  302. * Fri Feb 04 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-8
  303. - Fixes from package review
  304. - Change Requires: on tools subpackage to be the exact version/release
  305. - Remove unnecessary BuildRoot directive
  306. * Mon Jan 17 2011 Stephen Gallagher <sgallagh@redhat.com> - 0.9.22-7
  307. - Update to 0.9.22 (first independent release of libldb upstream)