bash-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575
  1. %define bashversion 4.3
  2. %define patchlevel 25
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: ftp://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-001
  17. Patch2: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-002
  18. Patch3: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-003
  19. Patch4: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-004
  20. Patch5: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-005
  21. Patch6: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-006
  22. Patch7: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-007
  23. Patch8: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-008
  24. Patch9: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-009
  25. Patch10: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-010
  26. Patch11: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-011
  27. Patch12: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-012
  28. Patch13: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-013
  29. Patch14: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-014
  30. Patch15: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-015
  31. Patch16: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-016
  32. Patch17: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-017
  33. Patch18: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-018
  34. Patch19: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-019
  35. Patch20: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-020
  36. Patch21: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-021
  37. Patch22: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-022
  38. Patch23: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-023
  39. Patch24: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-024
  40. Patch25: ftp://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-025
  41. # Other patches
  42. Patch101: bash-2.02-security.patch
  43. Patch102: bash-2.03-paths.patch
  44. Patch103: bash-2.03-profile.patch
  45. Patch104: bash-2.05a-interpreter.patch
  46. Patch105: bash-2.05b-debuginfo.patch
  47. Patch106: bash-2.05b-manso.patch
  48. Patch107: bash-2.05b-pgrp_sync.patch
  49. Patch108: bash-2.05b-readline-oom.patch
  50. Patch109: bash-2.05b-xcc.patch
  51. Patch110: bash-3.2-audit.patch
  52. Patch111: bash-3.2-ssh_source_bash.patch
  53. Patch112: bash-bashbug.patch
  54. Patch113: bash-infotags.patch
  55. Patch114: bash-requires.patch
  56. Patch115: bash-setlocale.patch
  57. Patch116: bash-tty-tests.patch
  58. # 484809, check if interp section is NOBITS
  59. Patch117: bash-4.0-nobits.patch
  60. # Do the same CFLAGS in generated Makefile in examples
  61. Patch118: bash-4.1-examples.patch
  62. # Builtins like echo and printf won't report errors
  63. # when output does not succeed due to EPIPE
  64. Patch119: bash-4.1-broken_pipe.patch
  65. # Enable system-wide .bash_logout for login shells
  66. Patch120: bash-4.2-rc2-logout.patch
  67. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  68. Patch121: bash-4.2-coverity.patch
  69. # Don't call malloc in signal handler
  70. Patch122: bash-4.1-defer-sigchld-trap.patch
  71. # 799958, updated info about trap
  72. Patch123: bash-4.2-manpage_trap.patch
  73. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  74. Patch125: bash-4.2-size_type.patch
  75. Buildroot: %{_tmppath}/%{name}-%{version}-root
  76. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  77. Obsoletes: bash <= 1.14.7
  78. Obsoletes: bash2
  79. %description
  80. Bash is a GNU project sh-compatible shell or command language
  81. interpreter. Bash (Bourne Again shell) incorporates useful features
  82. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  83. can be run by bash without modification.
  84. Bash offers several improvements over sh, including command line
  85. editing, unlimited size command history, job control, shell
  86. functions and aliases, indexed arrays of unlimited size and
  87. integer arithmetic in any base from two to 64. Bash is ultimately
  88. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  89. Tools standard.
  90. %package doc
  91. Summary: Documentation for the GNU Bourne Again shell (bash).
  92. Summary: GNU Bourne Again シェル向けドキュメント
  93. Group: Applications/Documentation
  94. Requires: %{name} = %{version}-%{release}
  95. Obsoletes: bash2-doc
  96. %description doc
  97. This is a separate documentation package for the GNU Bourne
  98. Again shell.
  99. %prep
  100. %setup -q -n %{name}-%{bashversion}
  101. # Official upstream patches
  102. %patch1 -p0 -b .001
  103. %patch2 -p0 -b .002
  104. %patch3 -p0 -b .003
  105. %patch4 -p0 -b .004
  106. %patch5 -p0 -b .005
  107. %patch6 -p0 -b .006
  108. %patch7 -p0 -b .007
  109. %patch8 -p0 -b .008
  110. %patch9 -p0 -b .009
  111. %patch10 -p0 -b .010
  112. %patch11 -p0 -b .011
  113. %patch12 -p0 -b .012
  114. %patch13 -p0 -b .013
  115. %patch14 -p0 -b .014
  116. %patch15 -p0 -b .015
  117. %patch16 -p0 -b .016
  118. %patch17 -p0 -b .017
  119. %patch18 -p0 -b .018
  120. %patch19 -p0 -b .019
  121. %patch20 -p0 -b .020
  122. %patch21 -p0 -b .021
  123. %patch22 -p0 -b .022
  124. %patch23 -p0 -b .023
  125. %patch24 -p0 -b .024
  126. %patch25 -p0 -b .025
  127. # Other patches
  128. %patch101 -p1 -b .security
  129. %patch102 -p1 -b .paths
  130. %patch103 -p1 -b .profile
  131. %patch104 -p1 -b .interpreter
  132. %patch105 -p1 -b .debuginfo
  133. %patch106 -p1 -b .manso
  134. %patch107 -p1 -b .pgrp_sync
  135. %patch108 -p1 -b .readline_oom
  136. %patch109 -p1 -b .xcc
  137. %patch110 -p1 -b .audit
  138. %patch111 -p1 -b .ssh_source_bash
  139. %patch112 -p1 -b .bashbug
  140. %patch113 -p1 -b .infotags
  141. %patch114 -p1 -b .requires
  142. %patch115 -p1 -b .setlocale
  143. %patch116 -p1 -b .tty_tests
  144. %patch117 -p1 -b .nobits
  145. %patch118 -p1 -b .examples
  146. %patch119 -p1 -b .broken_pipe
  147. %patch120 -p1 -b .logout
  148. %patch121 -p1 -b .coverity
  149. %patch122 -p1 -b .defer_sigchld_trap
  150. %patch123 -p1
  151. %patch125 -p1 -b .size_type
  152. echo %{version} > _distribution
  153. echo %{release} |sed 's/vl.*//' > _patchlevel
  154. %build
  155. %configure --with-bash-malloc=no
  156. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  157. %install
  158. rm -rf %{buildroot}
  159. # Fix bug #83776
  160. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  161. make DESTDIR=$RPM_BUILD_ROOT install
  162. pushd $RPM_BUILD_ROOT
  163. mkdir ./bin
  164. mv ./usr/bin/bash ./bin/bash
  165. ln -s bash ./bin/sh
  166. rm -f .%{_infodir}/dir
  167. popd
  168. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  169. # make manpages for bash builtins as per suggestion in DOC/README
  170. pushd doc
  171. sed -e '
  172. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  173. /^\.SH NAME/d
  174. s/^bash, //
  175. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  176. s/,//g
  177. b
  178. }
  179. d
  180. ' builtins.1 > man.pages
  181. for i in echo pwd test kill; do
  182. perl -pi -e "s,$i,,g" man.pages
  183. perl -pi -e "s, , ,g" man.pages
  184. done
  185. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  186. for i in `cat man.pages` ; do
  187. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  188. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  189. done
  190. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  191. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  192. # Not for printf, false and true (conflict with coreutils)
  193. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  194. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  195. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  196. popd
  197. %find_lang %{name}
  198. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  199. %clean
  200. rm -rf %{buildroot}
  201. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  202. # to prevent prereq loops
  203. # post is in lua so that we can run it without any external deps. Helps
  204. # for bootstrapping a new install.
  205. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  206. %post -p <lua>
  207. bashfound = false;
  208. shfound = false;
  209. f = io.open("/etc/shells", "r");
  210. if f == nil
  211. then
  212. f = io.open("/etc/shells", "w");
  213. else
  214. repeat
  215. t = f:read();
  216. if t == "/bin/bash"
  217. then
  218. bashfound = true;
  219. end
  220. if t == "/bin/sh"
  221. then
  222. shfound = true;
  223. end
  224. until t == nil;
  225. end
  226. f:close()
  227. f = io.open("/etc/shells", "a");
  228. if not bashfound
  229. then
  230. f:write("/bin/bash\n")
  231. end
  232. if not shfound
  233. then
  234. f:write("/bin/sh\n")
  235. end
  236. f:close()
  237. %files -f %{name}.lang
  238. %defattr(-,root,root)
  239. %doc CHANGES COPYING
  240. %doc examples
  241. %config(noreplace) /etc/bashrc
  242. /bin/bash
  243. /bin/sh
  244. %{_infodir}/bash.info*
  245. %{_mandir}/*/*
  246. %{_mandir}/*/..1*
  247. %{_bindir}/bashbug
  248. %files doc
  249. %defattr(-,root,root)
  250. %doc COMPAT NEWS NOTES POSIX RBASH
  251. %doc examples/functions/ examples/misc/
  252. %doc examples/scripts.noah/ examples/scripts.v2/ examples/scripts/
  253. %doc examples/startup-files/ examples/complete/ examples/loadables/
  254. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  255. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  256. %changelog
  257. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  258. - updated to 4.3 patch level 25
  259. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  260. - update to 4.3 patch level 18
  261. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  262. - update to 4.3 patch level 11
  263. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  264. - update to 4.2 patch level 45
  265. - import some patch from fedora package (122-127)
  266. - patch122: Don't call malloc in signal handler
  267. - patch123: #799958, updated info about trap
  268. - patch124: #695656, block the signal and unblock it after the
  269. new handler is installed
  270. - patch125: Use unsigned type for size
  271. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  272. - patch126: #903833, Fix missing close(), fixes fd leaks
  273. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  274. - remove postun lua script because bash will be never uninstalled
  275. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  276. - update to 4.2 patch level 37
  277. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  278. - update to 4.2 patch level 20
  279. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  280. - update to 4.2 patch level 8
  281. - use lua script in post/postun
  282. - update patches from fedora
  283. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  284. - update to 4.1 patch level 7
  285. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  286. - check if /bin/grep exists on %%post script
  287. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  288. - rebuilt with gcc-4.4.3-3 on ppc
  289. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  290. - rebuilt with new toolchain
  291. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  292. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  293. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  294. - add Requires(post): grep
  295. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  296. - remove obsolete /bin/bash2 entry from /etc/shells
  297. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  298. - add Requires(post): ncurses (should be added by find-requires..)
  299. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  300. - add upstream patch (from 040 to 048)
  301. - build against ncurses-devel (libtinfo)
  302. - spec in utf-8
  303. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  304. - added upstream patch (from 026 to 039)
  305. - added Japanese summary
  306. - applied new versioning policy
  307. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  308. - rebuilt with libtermcap-devel
  309. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  310. - new upstream release
  311. - add upstream patch (from 001 to 025)
  312. - remove Provides: bash2
  313. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  314. - rebuilt with new toolchain
  315. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  316. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  317. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  318. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  319. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  320. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  321. - update to 2.05b
  322. - rebuild with new toolchains
  323. - add make check
  324. - add %postun script based on Fedora development
  325. - README file moved doc package
  326. - update Patch5 and Patch8 from Fedora development
  327. - change Patch6
  328. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  329. - add Patch11--39 from Fedora development 2.05b-36
  330. * Tim Waugh <twaugh@redhat.com>
  331. - Fix parameter expansion in multibyte locales (bug #112657).
  332. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  333. bug #110777).
  334. - Apply upstream patches (bug #109269 among others).
  335. - Fix bash.info (bug #83776).
  336. - Add bash205b-007 patch to fix bug #106876.
  337. - Avoid crashing on multibyte input when locale is set incorrectly
  338. (bug #74266).
  339. - LFS support (bug #103627).
  340. - Fix completion display when multibyte or control characters are to be
  341. shown (bug #90201).
  342. - Fix a warning message (bug #79629).
  343. - Don't build with AFS support (bug #86514).
  344. - Don't explicitly strip binaries (bug #85995).
  345. - Really fix bug #83331 for good.
  346. - Fix builtins.1.
  347. - Actually apply the patch (bug #83331).
  348. - Fix history/UTF-8 bug (bug #83331).
  349. - More tab-completion fixing (bug #72512).
  350. - Force pgrp synchronization (bug #81653).
  351. - Prevent prompt overwriting output (bug #74383).
  352. - Fix '-rbash' (bug #78455).
  353. - Add readline-init patch (bug #74925).
  354. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  355. - Ship '.' man page, which doesn't get picked up by glob.
  356. - Locale shell variables fix (bug #74701).
  357. * Elliot Lee <sopwith@redhat.com>
  358. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  359. cross compiles.
  360. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  361. - update to 2.05
  362. - add README.jpatch to %doc
  363. - remove patch4 (bash2): revert command name in man pages to "bash"
  364. - fix perl command to remove man pages conflict with sh-utils
  365. - remove section of config.h.in from patch0 to prevent remake of configure
  366. - change patch9: define in config-top.h to avoid conflict with patch100
  367. - remove patches 7, 10 & 101
  368. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  369. - made a link for man sh
  370. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  371. - added missing %%post and %%triggerpostun section
  372. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  373. - 2.04-1vl12
  374. - now bash2 is finally bash
  375. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  376. - build for Playstation2
  377. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  378. - 2.04-1vl10
  379. - Provides: bash = %%{version}
  380. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  381. - added Provides: bash
  382. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  383. - Obsoletes: bash
  384. - changed Copyright to License
  385. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  386. - 2.04-1vl7
  387. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  388. - corrected: bashrc-vine -> bashrc
  389. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  390. - combined bash-1.x and bash-2.x packages
  391. - added some patches from bash-2.04-13mdk
  392. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  393. - fix spec macros
  394. - added tests
  395. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  396. - build with gcc-2.95.3
  397. - partially used rpmmacros
  398. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  399. - minor bug fix in spec file
  400. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  401. - 2.04-1vl3
  402. - modified %install and %files section to handle compressed man page(s)
  403. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  404. - added pcomplete patch to fix complete if the candidate list is NULL.
  405. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  406. - updated to 2.04
  407. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  408. - Remove annoying ^H's from documentation
  409. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  410. - patch to detect what executables are required by a script.
  411. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  412. - auto rebuild in the new build environment (release 4)
  413. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  414. - strip binaries.
  415. - include bash-doc correctly.
  416. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  417. - fixed post/postun /etc/shells work.
  418. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  419. - updated again text in the spec file
  420. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  421. - updated text in spec file.
  422. - update to 2.03.
  423. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  424. - build it as bash2 instead of bash
  425. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  426. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  427. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  428. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  429. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  430. - patch for the arm
  431. - use $RPM_ARCH-redhat-linux as the build target
  432. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  433. - rewrite %pre, axe %postun (to avoid prereq loops)
  434. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  435. - resurrect for RH 6.0.
  436. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  437. - update to 2.02.1
  438. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  439. - Package for 5.2.
  440. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  441. - added POSIX.NOTES doc file
  442. - some extraneous doc files removed
  443. - minor .spec file changes
  444. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  445. - upgraded to version 2.02
  446. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  447. - glibc & signal patches no longer required
  448. - added documentation subpackage (doc)
  449. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  450. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  451. is based on a change made in bash 2.0. Should fix some early exit
  452. problems with suspends and fg.
  453. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  454. - added %clean
  455. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  456. - added comment explaining why install-info isn't used
  457. - added mips patch
  458. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  459. - added BuildRoot
  460. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  461. - built against glibc