strongswan-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815
  1. %bcond_with systemd
  2. %bcond_without tss
  3. %global _unpackaged_files_terminate_build 1
  4. %global _hardened_build 0
  5. #%%define prerelease dr1
  6. Name: strongswan
  7. Version: 5.9.4
  8. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  9. Summary: An OpenSource IPsec-based VPN and TNC solution
  10. Summary(ja): オープンソースのIPsec VPN/TNCソリューション
  11. Group: servers,security
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPLv2+
  15. URL: https://www.strongswan.org/
  16. Source0: https://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
  17. Source1: tmpfiles-strongswan.conf
  18. Source1000: strongswan.init
  19. Patch0: strongswan-5.8.4-runtime-dir.patch
  20. Patch1: strongswan-5.6.0-uintptr_t.patch
  21. Patch3: strongswan-5.6.2-CVE-2018-5388.patch
  22. # only needed for pre-release versions
  23. #BuildRequires: autoconf automake
  24. BuildRequires: gmp-devel
  25. BuildRequires: curl-devel
  26. BuildRequires: openldap-devel
  27. BuildRequires: openssl-devel
  28. BuildRequires: sqlite3-devel
  29. BuildRequires: gettext-devel
  30. BuildRequires: libxml2-devel
  31. BuildRequires: pam-devel
  32. BuildRequires: libgcrypt-devel
  33. BuildRequires: iptables-devel
  34. BuildRequires: libcap-devel
  35. %if %{with tss}
  36. BuildRequires: trousers-devel
  37. BuildRequires: json-c-devel >= 0.14
  38. %endif
  39. %if "%{?_dist_release}" != "vl6"
  40. BuildRequires: NetworkManager-libnm-devel
  41. %endif
  42. %if %{with systemd}
  43. BuildRequires: systemd-devel
  44. Requires(post): systemd
  45. Requires(preun): systemd
  46. Requires(postun): systemd
  47. %else
  48. Requires(post): /sbin/chkconfig
  49. Requires(preun): /sbin/chkconfig
  50. Requires(postun): /sbin/chkconfig
  51. %endif
  52. %description
  53. The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
  54. exchange protocols in conjunction with the native NETKEY IPsec stack of the
  55. Linux kernel.
  56. %package libipsec
  57. Summary: Strongswan's libipsec backend
  58. Group: servers,security
  59. %description libipsec
  60. The kernel-libipsec plugin provides an IPsec backend that works entirely
  61. in userland, using TUN devices and its own IPsec implementation libipsec.
  62. %package charon-nm
  63. Summary: NetworkManager plugin for Strongswan
  64. Group: servers,security
  65. Requires: dbus
  66. Obsoletes: %{name}-NetworkManager < 0:5.0.4-5
  67. Conflicts: %{name}-NetworkManger < 0:5.0.4-5
  68. %description charon-nm
  69. NetworkManager plugin integrates a subset of Strongswan capabilities
  70. to NetworkManager.
  71. %if %{with tss}
  72. %package tnc-imcvs
  73. Summary: Trusted network connect (TNC)'s IMC/IMV functionality
  74. Group: servers,security
  75. Requires: %{name} = %{version}
  76. %description tnc-imcvs
  77. This package provides Trusted Network Connect's (TNC) architecture support.
  78. It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
  79. exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
  80. and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
  81. attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
  82. modules can be used by any third party TNC Client/Server implementation
  83. possessing a standard IF-IMC/IMV interface. In addition, it implements
  84. PT-TLS to support TNC over TLS.
  85. %endif
  86. %debug_package
  87. %prep
  88. %setup -q -n %{name}-%{version}%{?prerelease}
  89. %patch0 -p1
  90. %patch1 -p1
  91. %patch3 -p1
  92. %build
  93. # only for snapshots
  94. #autoreconf
  95. # --with-ipsecdir moves internal commands to /usr/libexec/strongswan
  96. # --bindir moves 'pki' command to /usr/libexec/strongswan
  97. # See: http://wiki.strongswan.org/issues/552
  98. # too broken to enable: --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
  99. %configure --disable-static \
  100. --with-ipsec-script=strongswan \
  101. --sysconfdir=%{_sysconfdir}/strongswan \
  102. --with-ipsecdir=%{_libexecdir}/strongswan \
  103. --bindir=%{_libexecdir}/strongswan \
  104. --with-ipseclibdir=%{_libdir}/strongswan \
  105. --enable-nm \
  106. --enable-openssl \
  107. --enable-unity \
  108. --enable-ctr \
  109. --enable-ccm \
  110. --enable-gcm \
  111. --enable-chapoly \
  112. --enable-md4 \
  113. --enable-gcrypt \
  114. --enable-newhope \
  115. --enable-xauth-eap \
  116. --enable-xauth-pam \
  117. --enable-xauth-noauth \
  118. --enable-eap-identity \
  119. --enable-eap-md5 \
  120. --enable-eap-gtc \
  121. --enable-eap-tls \
  122. --enable-eap-ttls \
  123. --enable-eap-peap \
  124. --enable-eap-mschapv2 \
  125. --enable-eap-tnc \
  126. --enable-eap-sim \
  127. --enable-eap-sim-file \
  128. --enable-eap-aka \
  129. --enable-eap-aka-3gpp \
  130. --enable-eap-aka-3gpp2 \
  131. --enable-eap-dynamic \
  132. --enable-eap-radius \
  133. --enable-ext-auth \
  134. --enable-ipseckey \
  135. --enable-pkcs11 \
  136. --enable-farp \
  137. --enable-dhcp \
  138. --enable-ha \
  139. --enable-led \
  140. --enable-sqlite \
  141. --enable-sql \
  142. --enable-tnc-ifmap \
  143. --enable-tnc-pdp \
  144. --enable-tnc-imc \
  145. --enable-tnc-imv \
  146. --enable-tnccs-20 \
  147. --enable-tnccs-11 \
  148. --enable-tnccs-dynamic \
  149. --enable-curl \
  150. --enable-cmd \
  151. --enable-acert \
  152. --enable-aikgen \
  153. --enable-vici \
  154. --enable-swanctl \
  155. --enable-duplicheck \
  156. %if %{with tss}
  157. --enable-tss-trousers \
  158. --enable-aikgen \
  159. --enable-imc-test \
  160. --enable-imv-test \
  161. --enable-imc-scanner \
  162. --enable-imv-scanner \
  163. --enable-imc-attestation \
  164. --enable-imv-attestation \
  165. --enable-imv-os \
  166. --enable-imc-os \
  167. --enable-imc-swid \
  168. --enable-imv-swid \
  169. --enable-imc-swima \
  170. --enable-imv-swima \
  171. --enable-imc-hcd \
  172. --enable-imv-hcd \
  173. %endif
  174. %ifarch x86_64 %{ix86}
  175. --enable-aesni \
  176. %endif
  177. %if %{with systemd}
  178. --enable-systemd \
  179. %endif
  180. --enable-kernel-libipsec \
  181. --with-capabilities=libcap \
  182. %{nil}
  183. make %{?_smp_mflags}
  184. %install
  185. rm -rf %{buildroot}
  186. make install DESTDIR=%{buildroot}
  187. # prefix man pages
  188. for i in %{buildroot}%{_mandir}/*/*; do
  189. if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
  190. mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
  191. fi
  192. done
  193. find %{buildroot} -type f -name '*.la' -delete
  194. # delete unwanted library files - no consumers, so no -devel package
  195. rm %{buildroot}%{_libdir}/strongswan/*.so
  196. # fix config permissions
  197. chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
  198. # Create ipsec.d directory tree.
  199. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
  200. for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
  201. install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
  202. done
  203. %if %{with systemd}
  204. install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_tmpfilesdir}/strongswan.conf
  205. %else
  206. mkdir -p %{buildroot}%{_initdir}
  207. install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
  208. %endif
  209. %post
  210. %if %{with systemd}
  211. %systemd_post %{name}.service
  212. %else
  213. /sbin/chkconfig --add ipsec
  214. %endif
  215. %preun
  216. %if %{with systemd}
  217. %systemd_preun %{name}.service
  218. %else
  219. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  220. /sbin/service ipsec stop
  221. /sbin/chkconfig --del ipsec
  222. fi
  223. %endif
  224. %postun
  225. %if %{with systemd}
  226. %systemd_postun_with_restart %{name}.service
  227. %else
  228. if [ $1 -gt 0 ]; then
  229. /sbin/service ipsec condrestart
  230. fi
  231. %endif
  232. %files
  233. %doc README NEWS TODO ChangeLog
  234. %{!?_licensedir:%global license %%doc}
  235. %license COPYING
  236. %dir %attr(0700,root,root) %{_sysconfdir}/strongswan
  237. %config(noreplace) %{_sysconfdir}/strongswan/*
  238. %dir %{_libdir}/strongswan
  239. %dir %{_libdir}/strongswan/plugins
  240. %dir %{_libexecdir}/strongswan
  241. %{_sbindir}/charon-cmd
  242. %{_sbindir}/strongswan
  243. %{_sbindir}/swanctl
  244. %{_libdir}/strongswan/*.so.*
  245. %exclude %{_libdir}/strongswan/libipsec.so.*
  246. %{_libdir}/strongswan/plugins/*.so
  247. %exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  248. %{_libexecdir}/strongswan/*
  249. %if "%{?_dist_release}" != "vl6"
  250. %exclude %{_libexecdir}/strongswan/charon-nm
  251. %endif
  252. %{_mandir}/man?/*.gz
  253. %{_datadir}/strongswan/templates/config/
  254. %if %{with tss}
  255. %exclude %{_libdir}/strongswan/imcvs
  256. %exclude %{_libdir}/strongswan/libimcv.so.*
  257. %exclude %{_libdir}/strongswan/libtnccs.so.*
  258. %exclude %{_libdir}/strongswan/libradius.so.*
  259. %exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  260. %exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  261. %exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  262. %exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  263. %exclude %{_libexecdir}/strongswan/attest
  264. %exclude %{_libexecdir}/strongswan/pt-tls-client
  265. %{_datadir}/strongswan/templates/database/
  266. %exclude %dir %{_datadir}/strongswan/swidtag
  267. %endif
  268. %if %{with systemd}
  269. %{_sbindir}/charon-systemd
  270. %{_unitdir}/strongswan.service
  271. %{_unitdir}/strongswan-starter.service
  272. %{_tmpfilesdir}/strongswan.conf
  273. %else
  274. %{_initdir}/ipsec
  275. %endif
  276. %if %{with tss}
  277. %files tnc-imcvs
  278. %{_sbindir}/sw-collector
  279. %{_sbindir}/sec-updater
  280. %dir %{_libdir}/strongswan/imcvs
  281. %dir %{_libdir}/strongswan/plugins
  282. %{_libdir}/strongswan/libimcv.so.*
  283. %{_libdir}/strongswan/libtnccs.so.*
  284. %{_libdir}/strongswan/libradius.so.*
  285. %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
  286. %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
  287. %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
  288. %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
  289. %{_libexecdir}/strongswan/attest
  290. %{_libexecdir}/strongswan/pt-tls-client
  291. %dir %{_datadir}/strongswan/swidtag
  292. %{_datadir}/strongswan/swidtag/*.swidtag
  293. %endif
  294. %files libipsec
  295. %{_libdir}/strongswan/libipsec.so.*
  296. %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
  297. %if "%{?_dist_release}" != "vl6"
  298. %files charon-nm
  299. %license COPYING
  300. %{_datadir}/dbus-1/system.d/nm-strongswan-service.conf
  301. %{_libexecdir}/strongswan/charon-nm
  302. %endif
  303. %changelog
  304. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.4-1
  305. - new upstream release.
  306. - dropped Patch100: fixed in upstream.
  307. * Sun Oct 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.3-1
  308. - new upstream release.
  309. - built with openssl-3.0.0.
  310. - imported Patch100 from upstream.
  311. * Mon May 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.2-1
  312. - new upstream release.
  313. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.1-1
  314. - new upstream release.
  315. * Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.0-1
  316. - new upstream release.
  317. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.4-1
  318. - new upstream release.
  319. - imported Patch0 from rawhide.
  320. - fixed systemd stuff.
  321. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.2-1
  322. - new upstream release.
  323. * Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.1-1
  324. - new upstream release.
  325. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.2-1
  326. - new upstream release.
  327. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.1-1
  328. - new upstream release.
  329. - imported Patch3 from rawhide.
  330. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
  331. - initial build for Vine Linux.
  332. * Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
  333. - Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
  334. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
  335. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  336. * Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
  337. - Updated to 5.6.1 (RSA-PSS support)
  338. * Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
  339. - Rebuilt for libjson-c.so.3
  340. * Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
  341. - Fix the placement of charon-nm D-Bus policy
  342. * Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
  343. - Updated to 5.6.0
  344. - Fixup configure arguments, enabled a bunch of new features
  345. - Added new BuildRequires:
  346. - Fixup Obsolete/Conflicts, use license macro
  347. - Don't require autoconf/autotools for non-snapshots
  348. - Remove macro overuse, remove fedora/rhel checks and sysvinit support
  349. - Make listings/grouping of all plugins/libs to reduce file listing
  350. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
  351. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  352. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
  353. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  354. * Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
  355. - Updated to 5.5.3
  356. * Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
  357. - Updated to 5.5.2
  358. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
  359. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  360. * Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
  361. - Resolves: #1367796 - Enable the unity plugin
  362. * Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
  363. - New version 5.5.0
  364. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
  365. - Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
  366. * Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
  367. - New version 5.4.0
  368. * Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
  369. - New version 5.3.5
  370. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
  371. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  372. * Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
  373. - Enable IKEv2 GCM (requires gcrypt module as well)
  374. * Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
  375. - new version 5.3.3
  376. * Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
  377. - Resolves: #1264598 - strongswan: many configuration files are not protected
  378. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
  379. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  380. * Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
  381. - new version 5.3.2
  382. * Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
  383. - new version 5.3.1
  384. * Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
  385. - new version 5.3.0
  386. * Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
  387. - Fixes strongswan swanctl service issue rhbz#1193106
  388. * Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
  389. - new version 5.2.2
  390. * Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
  391. - Enabled ccm, and ctr plugins as it seems enabling just openssl does
  392. not work for using ccm and ctr algos.
  393. * Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
  394. - New strongswan developer release 5.2.2dr1
  395. * Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
  396. - 1167331: Enabled native systemd support.
  397. - Does not disable old systemd, starter, ipsec.conf support yet.
  398. * Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
  399. - New upstream release 5.2.1
  400. * Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
  401. - New upstream release candidate 5.2.1rc1
  402. * Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
  403. - new version 5.2.1dr1
  404. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
  405. - use upstream patch for json/json-c dependency
  406. * Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
  407. - Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
  408. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
  409. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  410. * Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
  411. - Resolves: #1081804 - enable Kernel IPSec support
  412. * Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
  413. - rebuilt
  414. * Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
  415. - fix json-c dependency
  416. * Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
  417. - New upstream release 5.2.0
  418. - The Attestation IMC/IMV pair supports the IMA-NG
  419. measurement format
  420. - Aikgen tool to generate an Attestation Identity Key bound
  421. to a TPM
  422. - Swanctl tool to provide a portable, complete IKE
  423. configuration and control interface for the command
  424. line using vici interface with libvici library
  425. - PT-EAP transport protocol (RFC 7171) for TNC
  426. - Enabled support for acert for checking X509 attribute certificate
  427. - Updated patches, removed selinux patch as upstream has fixed it
  428. in this release.
  429. - Updated spec file with minor cleanups
  430. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
  431. - improve prerelease macro
  432. * Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
  433. - Resolves: #1111895 - bump to 5.2.0dr6
  434. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
  435. - Related: #1087437 - remove or upstream all patches not specific to fedora/epel
  436. * Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
  437. - fix the pre-release version according to guidelines before it gets branched
  438. * Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
  439. - new version 5.2.0dr5
  440. - add json-c-devel to build deps
  441. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
  442. - merge two related patches
  443. * Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
  444. - clean up the patches a bit
  445. * Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
  446. - New upstream developer release 5.2.0dr4
  447. - Attestation IMV/IMC supports IMA-NG measurement format now
  448. - Aikgen tool to generate an Attestation Identity Key bound
  449. to a TPM
  450. - PT-EAP transport protocol (RFC 7171) for TNC
  451. - vici plugin provides IKE Configuration Interface for charon
  452. - Enabled support for acert for checking X509 attribute certificate
  453. - Updated patches
  454. - Updated spec file with minor cleanups
  455. * Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
  456. - new version 5.1.3
  457. * Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
  458. - new version 5.1.3rc1
  459. * Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
  460. - #1069928 - updated libexec patch.
  461. * Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
  462. - fixed el6 initscript
  463. - fixed pki directory location
  464. * Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
  465. - clean up the specfile a bit
  466. - replace the initscript patch with an individual initscript
  467. - patch to build for epel6
  468. * Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
  469. - #1071353 - bump to 5.1.2
  470. - #1071338 - strongswan is compiled without xauth-pam plugin
  471. - remove obsolete patches
  472. - sent all patches upstream
  473. - added comments to all patches
  474. - don't touch the config with sed
  475. * Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
  476. - Fixed full hardening for strongswan (full relro and PIE).
  477. The previous macros had a typo and did not work
  478. (see bz#1067119).
  479. - Fixed tnc package description to reflect the current state of
  480. the package.
  481. - Fixed pki binary and moved it to /usr/libexece/strongswan as
  482. others binaries are there too.
  483. * Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
  484. - #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
  485. * Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
  486. - Removed redundant patches and *.spec commands caused by branch merging
  487. * Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
  488. - rebuilt
  489. * Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
  490. - Resolves: 973315
  491. - Resolves: 1036844
  492. * Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
  493. - Support for PT-TLS (RFC 6876)
  494. - Support for SWID IMC/IMV
  495. - Support for command line IKE client charon-cmd
  496. - Changed location of pki to /usr/bin
  497. - Added swid tags files
  498. - Added man pages for pki and charon-cmd
  499. - Renamed pki to strongswan-pki to avoid conflict with
  500. pki-core/pki-tools package.
  501. - Update local patches
  502. - Fixes CVE-2013-6075
  503. - Fixes CVE-2013-6076
  504. - Fixed autoconf/automake issue as configure.ac got changed
  505. and it required running autoreconf during the build process.
  506. - added strongswan signature file to the sources.
  507. * Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
  508. - Fixed initialization crash of IMV and IMC particularly
  509. attestation imv/imc as libstrongswas was not getting
  510. initialized.
  511. * Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
  512. - Enabled fips support
  513. - Enabled TNC's ifmap support
  514. - Enabled TNC's pdp support
  515. - Fixed hardocded package name in this spec file
  516. * Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
  517. - rhbz#981429: New upstream release
  518. - Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
  519. - Fixes rhbz#991859 failed to build in rawhide
  520. - Updated local patches and removed which are not needed
  521. - Fixed errors around charon-nm
  522. - Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
  523. libstrongswan-sshkey.so
  524. - Added utility imv_policy_manager
  525. * Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
  526. - rename strongswan-NetworkManager to strongswan-charon-nm
  527. - fix enable_nm macro
  528. * Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
  529. - %%files tries to package some of the shared objects as directories (#984437)
  530. - fix broken systemd unit file (#984300)
  531. - fix rpmlint error: description-line-too-long
  532. - fix rpmlint error: macro-in-comment
  533. - fix rpmlint error: spelling-error Summary(en_US) fuctionality
  534. - depend on 'systemd' instead of 'systemd-units'
  535. - use new systemd scriptlet macros
  536. - NetworkManager subpackage should have a copy of the license (#984490)
  537. - enable hardened_build as this package meets the PIE criteria (#984429)
  538. - invocation of "ipsec _updown iptables" is broken as ipsec is renamed
  539. to strongswan in this package (#948306)
  540. - invocation of "ipsec scepclient" is broken as ipsec is renamed
  541. to strongswan in this package
  542. - add /etc/strongswan/ipsec.d and missing subdirectories
  543. - conditionalize building of strongswan-NetworkManager subpackage as the
  544. version of NetworkManager in EL6 is too old (#984497)
  545. * Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
  546. - Patch to fix a major crash issue when Freeradius loads
  547. attestatiom-imv and does not initialize libstrongswan which
  548. causes crash due to calls to PTS algorithms probing APIs.
  549. So this patch fixes the order of initialization. This issues
  550. does not occur with charon because libstrongswan gets
  551. initialized earlier.
  552. - Patch that allows to outputs errors when there are permission
  553. issues when accessing strongswan.conf.
  554. - Patch to make loading of modules configurable when libimcv
  555. is used in stand alone mode without charon with freeradius
  556. and wpa_supplicant.
  557. * Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
  558. - Enabled TNCCS 1.1 protocol
  559. - Fixed libxm2-devel build dependency
  560. - Patch to fix the issue with loading of plugins
  561. * Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
  562. - New upstream release
  563. - Fixes for CVE-2013-2944
  564. - Enabled support for OS IMV/IMC
  565. - Created and applied a patch to disable ECP in fedora, because
  566. Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
  567. it non-compliant to TCG's PTS standard, but there is no choice
  568. right now. see redhat bz # 319901.
  569. - Enabled Trousers support for TPM based operations.
  570. * Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
  571. - Rebuilt for a single specfile for rawhide/f19/f18/el6
  572. * Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
  573. - New upstream release
  574. - Enabled curl and eap-identity plugins
  575. - Enabled support for eap-radius plugin.
  576. * Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
  577. - Add gettext-devel to BuildRequires because of epel6
  578. - Remove unnecessary comments
  579. * Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
  580. - Enabled support for eap-radius plugin.
  581. * Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
  582. - Update to upstream release 5.0.2
  583. - Created sub package strongswan-tnc-imcvs that provides trusted network
  584. connect's IMC and IMV funtionality. Specifically it includes PTS
  585. based IMC/IMV for TPM based remote attestation and scanner and test
  586. IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
  587. by any third party TNC Client/Server implementation possessing a
  588. standard IF-IMC/IMV interface.
  589. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
  590. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  591. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
  592. - Update to release 5.0.1
  593. * Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
  594. - Add plugins to interoperate with Windows 7 and Android (#862472)
  595. (contributed by Haim Gelfenbeyn)
  596. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
  597. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  598. * Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
  599. - Fix configure substitutions in initscripts
  600. * Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
  601. - Update to current upstream release
  602. - Comment out all stuff that is only needed for git builds
  603. - Remove renaming patch from git
  604. - Improve init patch used for EPEL
  605. * Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
  606. - Build with openssl plugin enabled
  607. * Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
  608. - Add README.Fedora with link to 4.6 to 5.0 migration information
  609. * Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
  610. - Snapshot of upcoming major release
  611. - Move patches and renaming upstream
  612. http://wiki.strongswan.org/issues/194
  613. http://wiki.strongswan.org/issues/195
  614. - Notified upstream about manpage issues
  615. * Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
  616. - Make initscript patch more distro-neutral
  617. - Add links to bugreports for patches
  618. * Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
  619. - New upstream version (CVE-2012-2388)
  620. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
  621. - Add --enable-nm to configure
  622. - Add NetworkManager-devel to BuildRequires
  623. - Add NetworkManager-glib-devel to BuildRequires
  624. - Add strongswan-NetworkManager package
  625. * Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
  626. - New version of Strongswan
  627. - Support for RFC 3110 DNSKEY (see upstream changelog)
  628. - Fix corrupt scriptlets
  629. * Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
  630. - #808612 - strongswan binary renaming side-effect
  631. * Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
  632. - New upstream version
  633. - Changed from .tar.gz to .tar.bz2
  634. - Added libstrongswan-pkcs8.so
  635. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
  636. - Fix initscript's status function
  637. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
  638. - Expand tabs in config files for better readability
  639. - Add sysvinit script for epel6
  640. * Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
  641. - Fix program name in systemd unit file
  642. * Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
  643. - Improve fedora/epel conditionals
  644. * Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
  645. - Protect configuration directory from ordinary users
  646. - Add still missing directory /etc/strongswan
  647. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
  648. - Change directory structure to avoid clashes with Openswan
  649. - Prefixed all manpages with 'strongswan_'
  650. - Every file now includes 'strongswan' somewhere in its path
  651. - Removed conflict with Openswan
  652. - Finally fix permissions on strongswan.conf
  653. * Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
  654. - Change license tag from GPL to GPLv2+
  655. - Change permissions on /etc/strongswan.conf to 644
  656. - Rename ipsec.8 manpage to strongswan.8
  657. - Fix empty scriptlets for non-fedora builds
  658. - Add ldconfig scriptlet
  659. - Add missing directories and files
  660. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
  661. - Bump to version 4.6.1
  662. * Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
  663. - Add systemd scriptlets
  664. - Add conditions to also support EPEL6
  665. * Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
  666. - Experimental build for development