rrdtool-vl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291
  1. # Basic Information
  2. Name: rrdtool
  3. Summary: RRDtool - Round Robin Database tool
  4. Summary(ja): RRDtool - ラウンドロビンデータベースツール
  5. Version: 1.7.2
  6. Release: 3%{?_dist_release}
  7. Group: admin-tools,graphics
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: yasumichi
  11. License: GPLv2+ with exceptions
  12. URL: http://oss.oetiker.ch/rrdtool/
  13. Source0: http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
  14. Patch3: rrdtool-1.6.0-ruby-2-fix.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. # Dependency
  17. BuildRequires: glib2-devel
  18. BuildRequires: glibc-devel
  19. BuildRequires: libdbi-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: lua-devel
  22. BuildRequires: pango-devel
  23. BuildRequires: perl(ExtUtils::MakeMaker)
  24. BuildRequires: python-devel
  25. BuildRequires: python-setuptools
  26. BuildRequires: ruby-devel
  27. BuildRequires: tcl-devel
  28. %description
  29. It is pretty easy to gather status information from all sorts of things,
  30. ranging from the temperature in your office to the number of octets which
  31. have passed through the FDDI interface of your router. But it is not so
  32. trivial to store this data in a efficient and systematic manner. This is
  33. where RRDtool kicks in. It lets you log and analyze the data you gather from
  34. all kinds of data-sources (DS). The data analysis part of RRDtool is based
  35. on the ability to quickly generate graphical representations of the data
  36. values collected over a definable time period.
  37. #%%description -l ja
  38. %package devel
  39. Summary: Libraries and include files of RRDtool
  40. Group: system
  41. Requires: %{name} = %{version}-%{release}
  42. %description devel
  43. Libraries and include files of RRDtool
  44. %package doc
  45. Summary: RRDtool documentation
  46. Summary(ja): RRDtool のドキュメント
  47. Group: documentation
  48. BuildArch: noarch
  49. %description doc
  50. RRD is the Acronym for Round Robin Database. RRD is a system to store and
  51. display time-series data (i.e. network bandwidth, machine-room temperature,
  52. server load average). This package contains documentation on using RRD.
  53. %package tcl
  54. Summary: RRDTool modules for tcl
  55. Group: programming
  56. Requires: %{name} = %{version}-%{release}
  57. %description tcl
  58. RRDTool bindings for Tcl.
  59. %package -n perl-rrdtool
  60. Summary: Perl RRDtool bindings
  61. Summary(ja): RRDTool の perl バインディング
  62. Group: programming
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  65. %description -n perl-rrdtool
  66. The Perl RRDTool bindings.
  67. %package -n python-rrdtool
  68. Summary: Python RRDTool bindings
  69. Summary(ja): RRDTool の Python バインディング
  70. Group: programming
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: python(abi) = %{python_version}
  73. %description -n python-rrdtool
  74. RDTool bindings for python.
  75. %package -n python3-rrdtool
  76. Summary: Python3 RRDTool bindings
  77. Summary(ja): RRDTool の Python3 バインディング
  78. Group: programming
  79. BuildRequires: python3-devel
  80. BuildRequires: python3-rpm-macros
  81. BuildRequires: python3-setuptools
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: python(abi) = %{python3_version}
  84. %description -n python3-rrdtool
  85. RDTool bindings for python3.
  86. %package -n ruby-rrdtool
  87. Summary: Ruby RRDTool bindings
  88. Summary(ja): RRDTool の ruby バインディング
  89. Group: programming
  90. Requires: %{name} = %{version}-%{release}
  91. %description -n ruby-rrdtool
  92. RRDtool bindings for Ruby.
  93. %prep
  94. %setup -q
  95. %patch3 -p1 -b .ruby-2-fix
  96. autoreconf -vif
  97. %build
  98. %configure \
  99. --disable-rpath \
  100. --disable-static \
  101. --enable-perl-site-install \
  102. --with-perl-options="INSTALLDIRS=vendor" \
  103. --enable-ruby \
  104. --enable-ruby-site-install \
  105. --with-pic
  106. # Fix another rpath issue
  107. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
  108. bindings/perl-shared/Makefile.PL
  109. # Remove Rpath from Ruby
  110. %{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
  111. bindings/ruby/extconf.rb
  112. sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
  113. perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
  114. %{__make} %{?_smp_mflags}
  115. %{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
  116. %install
  117. %{__rm} -rf ${RPM_BUILD_ROOT}
  118. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  119. pushd bindings/python
  120. %{py3_install}
  121. popd
  122. # Install ruby module by force
  123. mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
  124. make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
  125. # We only want .txt and .html files for the main documentation
  126. rm -rf docs_to_be_included
  127. mkdir -p docs_to_be_included/html docs_to_be_included/txt
  128. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
  129. mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
  130. # Put perl docs in perl package
  131. rm -rf docs_perl
  132. mkdir -p docs_perl/html
  133. mv docs_to_be_included/html/RRD*.html docs_perl/html/
  134. # Clean up
  135. %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
  136. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
  137. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
  138. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  139. %{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
  140. chmod -x ${RPM_BUILD_ROOT}%{_datadir}/rrdtool/examples/*.py
  141. %find_lang %{name}
  142. %clean
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %post -p /sbin/ldconfig
  145. %postun -p /sbin/ldconfig
  146. %files -f %{name}.lang
  147. %defattr(-,root,root)
  148. #doc COPYING NEWS README TODO
  149. %{_bindir}/rrd*
  150. %{_libdir}/lua/*/rrd.so.*
  151. %{_libdir}/librrd*.so.*
  152. %{_mandir}/man1/*.1*
  153. %{_datadir}/rrdtool/examples/cgi-demo.cgi
  154. %files devel
  155. %defattr(-,root,root)
  156. %{_includedir}/rrd*.h
  157. %{_libdir}/lua/*/rrd.so
  158. %{_libdir}/librrd.so
  159. %{_libdir}/pkgconfig/librrd.pc
  160. %{_mandir}/man3/librrd.3*
  161. %files doc
  162. %defattr(-,root,root,-)
  163. %license COPYRIGHT LICENSE
  164. %doc CONTRIBUTORS TODO NEWS THREADS
  165. %doc docs_to_be_included/html docs_to_be_included/txt
  166. %files tcl
  167. %defattr(-,root,root)
  168. %doc bindings/tcl/README
  169. #%{_datadir}/rrdtool/ifOctets.tcl
  170. #%{_datadir}/rrdtool/pkgIndex.tcl
  171. %{_libdir}/tclrrd*.so
  172. %{_libdir}/rrdtool/*.tcl
  173. %files -n perl-rrdtool
  174. %defattr(-,root,root)
  175. %{perl_vendorlib}/RRDp.pm
  176. %{perl_vendorarch}/RRDs.pm
  177. %{perl_vendorarch}/auto/RRDs/RRDs.so
  178. %{_datadir}/rrdtool/examples/*.pl
  179. %{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
  180. %{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
  181. %{_mandir}/man3/RRD?.3pm*
  182. %files -n python-rrdtool
  183. %defattr(-,root,root)
  184. %license bindings/python/COPYING
  185. %doc bindings/python/README*
  186. %{python_sitearch}/rrdtool-*-py*.egg-info
  187. %{python_sitearch}/rrdtool.so
  188. %files -n python3-rrdtool
  189. %defattr(-,root,root)
  190. %license bindings/python/COPYING
  191. %doc bindings/python/README*
  192. %{python3_sitearch}/rrdtool-*-py*.egg-info
  193. %{python3_sitearch}/rrdtool.*.so
  194. %{_datadir}/rrdtool/examples/*.py
  195. %files -n ruby-rrdtool
  196. %defattr(-,root,root,-)
  197. %doc bindings/ruby/README
  198. %{ruby_vendorarchdir}/RRD.so
  199. %changelog
  200. * Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-3
  201. - fixed dependency.
  202. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-2
  203. - rebuilt with python-3.8.
  204. * Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
  205. - new upstream release.
  206. - built with ruby-2.6.5.
  207. - added python3 support.
  208. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  209. - new upstream release.
  210. - rebuilt with perl-5.26.
  211. - rebuilt with ruby-2.4.6.
  212. - updated Patch3.
  213. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
  214. - rebuild with ruby-2.2.3
  215. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
  216. - rebuild with libdbi-0.9.0
  217. * Mon Jan 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
  218. - new upstream release.
  219. - added Group tag to subpackages
  220. - added ruby subpackages
  221. - split documents into subpackages
  222. - added %%post and %%postun section
  223. * Tue Jul 1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
  224. - new upstream release.
  225. * Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
  226. - initial build for Vine Linux