mplayer-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472
  1. %define with_vaapi 1
  2. %define with_libvpx 1
  3. %define name mplayer
  4. %define version 1.0
  5. %define extver rc4
  6. %define release 41%{?extver:.%{extver}}%{?_dist_release}
  7. %define svndate 20100709
  8. #% define release 40.%{svndate}%{?_dist_release}
  9. %define ttfontdir /usr/share/fonts
  10. %define ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  11. TrueType-sazanami-gothic/sazanami-gothic
  12. Summary: The Movie Player
  13. Summary(ja): 動画プレイヤー
  14. Name: %{name}
  15. Version: %{version}
  16. Release: %{release}
  17. Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  18. #Source0: mplayer-export-%{svndate}.tar.bz2
  19. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
  20. Source10: mplayer-snapshot-vine.sh
  21. #Patch2: %{name}-config.patch
  22. Patch2: %{name}-config-20100709-vine.patch
  23. Patch8: %{name}-manlinks.patch
  24. Patch14: %{name}-nodvdcss.patch
  25. ## Vine
  26. Patch50: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  27. License: GPLv2+
  28. Group: Applications/Multimedia
  29. URL: http://www.mplayerhq.hu/
  30. BuildRequires: SDL-devel
  31. BuildRequires: aalib-devel
  32. BuildRequires: alsa-lib-devel
  33. BuildRequires: cdparanoia-devel
  34. BuildRequires: desktop-file-utils
  35. BuildRequires: esound-devel
  36. BuildRequires: enca-devel
  37. BuildRequires: freetype2-devel >= 2.0.9
  38. BuildRequires: fribidi-devel
  39. BuildRequires: fontconfig-devel
  40. BuildRequires: giflib-devel
  41. BuildRequires: gtk2-devel
  42. BuildRequires: mesa-libGL-devel
  43. BuildRequires: libXinerama-devel
  44. BuildRequires: libXScrnSaver-devel
  45. BuildRequires: libXv-devel
  46. BuildRequires: libXvMC-devel
  47. BuildRequires: libXxf86dga-devel
  48. BuildRequires: libXxf86vm-devel
  49. BuildRequires: libass-devel
  50. BuildRequires: libpng-devel
  51. BuildRequires: libjpeg-devel
  52. BuildRequires: libdvdread
  53. BuildRequires: libmpcdec-devel >= 1.2.1
  54. BuildRequires: librtmp-devel >= 2.3
  55. BuildRequires: speex-devel >= 1.1
  56. %if %{?_dist_release} != "vl5"
  57. %{?with_vaapi:BuildRequires:libva-devel}
  58. %endif
  59. BuildRequires: libvdpau-devel
  60. BuildRequires: libvorbis-devel
  61. %if %{?_dist_release} != "vl5"
  62. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.1}
  63. %endif
  64. BuildRequires: lzo-devel >= 2
  65. BuildRequires: pulseaudio-lib-devel
  66. BuildRequires: speex-devel >= 1.1
  67. BuildRequires: twolame-devel
  68. BuildRequires: xorg-x11-devel
  69. BuildRequires: yasm
  70. BuildRequires: zlib-devel
  71. # *-devel packages provided by other self-build-* should only be listed
  72. # in self-build-%{name}.spec as PreReq.
  73. ##Requires: self-build-mplayer-codecs
  74. ##BuildRequires: self-build-libdvdcss
  75. ##BuildRequires: self-build-libdvdnav
  76. ##BuildRequires: self-build-faac
  77. ##BuildRequires: self-build-lame
  78. ##BuildRequires: self-build-libdca
  79. ##BuildRequires: self-build-x264 >= 0.0.0-15.20110322
  80. ##BuildRequires: self-build-xvidcore >= 0.9.2
  81. ##BuildRequires: self-build-faad2 >= 2.6
  82. ##BuildRequires: self-build-libmad
  83. ##BuildRequires: self-build-libmpeg2
  84. Requires: TrueType-vlgothic
  85. Requires: mesa-libGL
  86. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  87. %description
  88. MPlayer can play most standard video formats out of the box and almost
  89. all others with the help of external codecs.
  90. MPlayer currently works best from the command line, but visual feedback
  91. for many functions is available from its onscreen status display (OSD),
  92. which is also used for displaying subtitles.
  93. MPlayer also has a GUI with skin support and several unofficial alternative
  94. graphical frontends are available.
  95. MEncoder is a command line video encoder for advanced users that can
  96. be built from the MPlayer source tree. Unofficial graphical frontends
  97. exist but arenot included.
  98. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  99. support for some newer codecs are not yet inpmlemented.
  100. You should install mplayer-codecs package if you want to play videos
  101. using those new codecs.
  102. %description -l ja
  103. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  104. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用することで再生できます。
  105. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  106. 多くの操作は字幕と同様に、
  107. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  108. MPlayer には スキンを変更できる GUI も用意されていますし、
  109. また複数の非公式なフロントエンドも利用できます。
  110. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  111. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  112. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  113. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  114. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  115. をインストールする必要があります。
  116. %prep
  117. %setup -q -n MPlayer-%{version}%{extver}
  118. #%setup -q -n mplayer-export-%{svndate}
  119. %patch2 -p1 -b .config
  120. %patch8 -p1 -b .manlinks
  121. %patch14 -p1 -b .nodvdcss
  122. %patch50 -p1 -b .x11
  123. %build
  124. ./configure \
  125. --prefix=%{_prefix} \
  126. --confdir=%{_sysconfdir}/mplayer \
  127. --enable-runtime-cpudetection \
  128. --extra-cflags="$RPM_OPT_FLAGS" \
  129. --disable-libdvdcss-internal \
  130. --disable-dvdread-internal \
  131. --enable-dvdread \
  132. --enable-dvdnav \
  133. \
  134. --disable-faac-lavc \
  135. --disable-mp3lame-lavc \
  136. --disable-x264-lavc \
  137. \
  138. --disable-faad-internal \
  139. \
  140. --disable-libopenjpeg \
  141. \
  142. --enable-vdpau \
  143. \
  144. --disable-bitmap-font \
  145. --disable-termcap \
  146. --enable-xvmc \
  147. --with-xvmclib=XvMCW \
  148. \
  149. --enable-largefiles \
  150. --enable-menu \
  151. --enable-gui \
  152. --language=ja,en \
  153. ;
  154. %{__make} %{?_smp_mflags}
  155. %install
  156. %{__rm} -rf ${RPM_BUILD_ROOT}
  157. %{__make} install INSTALLSTRIP= \
  158. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  159. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  160. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  161. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  162. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  163. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  164. ;
  165. ## install some default config files
  166. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  167. %{__install} -pm 644 etc/example.conf \
  168. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  169. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  170. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  171. # install default skin
  172. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  173. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  174. %{__tar} xjf %{SOURCE1}
  175. %{__ln_s} Blue default
  176. popd
  177. # make sybolic link to ttf font for subtitle
  178. for i in %{ttfontlist}; do
  179. if [ -e %{ttfontdir}/$i.ttf ];then
  180. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  181. break;
  182. fi;
  183. done
  184. ## install TOOLS
  185. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  186. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  187. done
  188. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  189. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  190. done
  191. for file in vobshift.py ; do
  192. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  193. done
  194. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  195. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  196. %clean
  197. %{__rm} -rf ${RPM_BUILD_ROOT}
  198. %files
  199. %defattr(-,root,root)
  200. %doc AUTHORS Changelog Copyright LICENSE README
  201. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  202. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  203. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  204. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  205. %{_bindir}/mplayer
  206. %{_bindir}/gmplayer
  207. %{_bindir}/mencoder
  208. %{_datadir}/mplayer/skins/Blue
  209. %{_datadir}/mplayer/skins/default
  210. %{_datadir}/mplayer/subfont.ttf
  211. %{_datadir}/applications/mplayer.desktop
  212. %{_datadir}/pixmaps/mplayer.xpm
  213. %{_mandir}/man1/mplayer.1*
  214. %{_mandir}/man1/mencoder.1*
  215. ## TOOLS
  216. %{_bindir}/aconvert
  217. %{_bindir}/calcbpp
  218. %{_bindir}/countquant
  219. %{_bindir}/divx2svcd
  220. %{_bindir}/dvd2divxscript
  221. %{_bindir}/mencvcd
  222. %{_bindir}/midentify
  223. %{_bindir}/mpconsole
  224. %{_bindir}/qepdvcd
  225. %{_bindir}/subsearch
  226. %{_bindir}/vobshift
  227. %{_datadir}/mplayer/*.fp
  228. %changelog
  229. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  230. - new upstream release
  231. - ready for Vine Linux 6
  232. - revived support for Vine Linux 5
  233. - added BuildRequires:
  234. - libass-devel
  235. - librtmp-devel >= 2.3
  236. - speex-devel >= 1.1
  237. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  238. - added BuildRequires:
  239. - aalib-devel
  240. - enca-devel
  241. - lzo-devel
  242. - speex-devel
  243. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  244. - updated fixed %{name}-config.patch
  245. - applied %{name}-config-20100709-vine.patch
  246. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  247. - change release to sync with self-build-mplayer
  248. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  249. - updated source snapshot 20100709
  250. - renamed %%Source10 to mplayer-snapshot-vine.sh
  251. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  252. - added BuildRequires: libvpx-devel >= 0.9.1
  253. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  254. - updated source snapshot 20100621
  255. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  256. - updated source snapshot 20100615
  257. - added BuildRequires: libXinerama-devel
  258. - dropped vl4 support
  259. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  260. - updated source snapshot 20100410
  261. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  262. - updated source snapshot 20100401
  263. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  264. - updated source snapshot 20100326
  265. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  266. - updated source snapshot 20100317
  267. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  268. - updated source snapshot 20100216
  269. - moved scripts from TOOLS
  270. - added --disable-libopenjpeg in configure options
  271. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  272. - updated source snapshot 20100201
  273. - dropped obsolete patches
  274. - added BuildRequires:
  275. - libvdpau-devel
  276. - libXScrnSaver-devel
  277. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  278. - update mplayer-config-20091215-vine.patch
  279. - update mplayer-20091215-x86_32-compile.patch
  280. - added --enable-runtime-cpudetection in configure options
  281. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  282. - source snapshot 20091031
  283. - updated mplayer-20091031-x86_32-compile.patch
  284. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  285. - source snapshot 20091003
  286. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  287. - change release to sync with self-build-mplayer
  288. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  289. - source snapshot 20090905
  290. - added settings for vl6
  291. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  292. - source snapshot 20090821
  293. - replaced BR: libungif-devel with BR: giflib-devel
  294. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  295. - source snapshot 20090722
  296. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  297. - source snapshot 20090702
  298. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  299. - source snapshot 20090611
  300. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  301. - added Requires: TrueType-vlgothic
  302. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  303. - source snapshot 20090522
  304. - build with x264 >= 0.0.0-9.20090522
  305. - updated mplayer-20090522-nodvdcss.patch
  306. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  307. - change release to sync with self-build-mplayer
  308. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  309. - source snapshot 20090502
  310. - updated mplayer-20090503-x86_32-compile.patch
  311. - updated mplayer-20090502-nodvdcss.patch
  312. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  313. - applied mplayer-config-vine.patch
  314. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  315. - source snapshot 20090327
  316. - updated mplayer-20090327-x86_32-compile.patch
  317. - updated mplayer-20090325-nodvdcss.patch
  318. - dropped gmplayer-about-vine.patch
  319. - install some default config files
  320. - added configure options:
  321. - --disable-termcap
  322. - --enable-xvmc
  323. - --with-xvmclib=XvMCW
  324. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  325. - fixed %%files for *.conf
  326. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  327. - source snapshot 20090305
  328. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  329. - source snapshot 20090227
  330. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  331. - source snapshot 20090216
  332. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  333. - source snapshot 20090206
  334. - dropped mplayer-man-zh_CN.patch
  335. - updated mplayer-20090206-nodvdcss.patch
  336. - changed to PreReq: self-build-faad2 from faad2-devel
  337. - added PreReq: self-build-libmad
  338. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  339. - source snapshot 20090131
  340. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  341. - change release to sync with self-build-mplayer
  342. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  343. - source snapshot
  344. - update mplayer-20090122-nodvdcss.patch
  345. - added BuildRequires:
  346. - faad2-devel
  347. - libmpcdec-devel
  348. - twolame-devel
  349. - yasm
  350. - faac-devel (as PreReq in self-build-%{name})
  351. - lame-devel (as PreReq in self-build-%{name})
  352. - libdca-devel (as PreReq in self-build-%{name})
  353. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  354. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  355. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  356. - source snapshot
  357. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  358. --disable-faad-internal in configure options
  359. - dropped gmplayer-add-flv-extension.patch
  360. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  361. - source snapshot
  362. - fixed License
  363. - added some patches from RPM Fusion
  364. - updated gmplayer-about-vine.patch for 20081001 snapshot
  365. - added BuildRequires: libdvdread
  366. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  367. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  368. in configure options
  369. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  370. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  371. - fixed License
  372. - added some devel packages to support OpenGL
  373. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  374. - spec in utf8
  375. - fix sybolic link of subfont for vl5
  376. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  377. - add "Patch105: CVE-2008-1558.patch".
  378. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  379. - build with new versioning policy.
  380. - fix Source[01] URLs.
  381. - add "Patch200: gmplayer-about-vine.patch".
  382. - add "Patch201: gmplayer-add-flv-extension.patch".
  383. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  384. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  385. CVE-2008-0629, CVE-2008-0630)
  386. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  387. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  388. - change source download URL. <BTS:VineLinux:603>
  389. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  390. - fix CONFDIR for make install. <BTS:wishes:33>
  391. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  392. - initial build for Vine Linux