moby-engine-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570
  1. %bcond_with systemd
  2. %bcond_with man
  3. # moby
  4. %global goipath_moby github.com/docker/docker
  5. %global git_moby https://%%{goipath_moby}
  6. #%%global commit_moby 9fdeb9c3de2f2d9f5799be373f27b2f9df44609d
  7. #%%global shortcommit_moby %%(c=%%{commit_moby}; echo ${c:0:7})
  8. # cli
  9. %global goipath_cli github.com/docker/cli
  10. %global git_cli https://%%{goipath_cli}
  11. #%%global commit_cli baeda1f82a10204ec5708d5fbba130ad76cfee49
  12. #%%global shortcommit_cli %%(c=%%{commit_cli}; echo ${c:0:7})
  13. # tini
  14. %global git_tini https://github.com/krallin/tini
  15. %global commit_tini 0b44d3665869e46ccbac7414241b8256d6234dc4
  16. %global shortcommit_tini %(c=%{commit_tini}; echo ${c:0:7})
  17. Name: moby-engine
  18. Summary: The open-source application container engine
  19. Version: 27.1.1
  20. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  21. Group: virtualization
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. License: Apache-2.0
  25. URL: https://www.docker.com
  26. Source0: %{git_moby}/archive/v%{version}/moby-%{version}.tar.gz
  27. Source1: %{git_cli}/archive/refs/tags/v%{version}.tar.gz#/cli-%{version}.tar.gz
  28. Source2: %{git_tini}/archive/%{commit_tini}/tini-%{shortcommit_tini}.tar.gz
  29. Source3: docker.service
  30. Source4: docker.sysconfig
  31. Source5: moby-engine-systemd-sysusers.conf
  32. Source100: docker.init
  33. Source101: docker.sysconfig-sysvinit
  34. # Specfile license
  35. Source200: moby-engine.spec.license
  36. ExclusiveArch: i686 x86_64
  37. BuildRequires: containerd
  38. BuildRequires: btrfs-progs-devel
  39. BuildRequires: device-mapper-devel
  40. BuildRequires: golang
  41. BuildRequires: pkgconfig(libseccomp) >= 2.3.0
  42. BuildRequires: make
  43. BuildRequires: pkgconfig(audit)
  44. # Build dependencies for tini
  45. BuildRequires: cmake
  46. BuildRequires: glibc-static
  47. # required packages on install
  48. Requires: containerd
  49. Requires: iptables
  50. Requires: runc
  51. Requires: tar
  52. Requires: xz
  53. %if %{with systemd}
  54. BuildRequires: systemd-devel
  55. #BuildRequires: firewalld-filesystem
  56. Requires: systemd
  57. %endif
  58. # Replace the old Docker packages
  59. Provides: docker = %{version}-%{release}
  60. Provides: docker-latest = %{version}-%{release}
  61. # conflicting packages
  62. Conflicts: docker-ce
  63. Conflicts: docker-ce-cli
  64. Conflicts: docker-common
  65. Conflicts: docker-ee
  66. Conflicts: docker-engine-cs
  67. Conflicts: docker-io
  68. Conflicts: podman-docker
  69. %description
  70. Docker is an open source project to build, ship and run any application as a
  71. lightweight container.
  72. Docker containers are both hardware-agnostic and platform-agnostic. This means
  73. they can run anywhere, from your laptop to the largest EC2 compute instance and
  74. everything in between - and they don't require you to use a particular
  75. language, framework or packaging system. That makes them great building blocks
  76. for deploying and scaling web apps, databases, and backend services without
  77. depending on a particular stack or provider.
  78. %package nano
  79. Summary: GNU nano syntax highlighting files for Moby
  80. BuildArch: noarch
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: nano
  83. %description nano
  84. This package installs %{summary}.
  85. %prep
  86. %setup -q -a 1 -a 2 -n moby-%{version}
  87. # correct rpmlint errors for bash completion
  88. sed -i '/env bash/d' cli-%{version}/contrib/completion/bash/docker
  89. %build
  90. mkdir -p _build/bin
  91. mkdir -p src/github.com/docker
  92. ln -sf `pwd` src/github.com/docker/docker
  93. # build docker-proxy / libnetwork
  94. (
  95. # Build binary using `golang-github-docker-libnetwork-devel`
  96. # (github.com/docker/libnetwork) installed in system GOPATH.
  97. export GOPATH="%{_datadir}/gocode:"`pwd`
  98. export GO111MODULE=off
  99. go build -o _build/bin/docker-proxy github.com/docker/docker/cmd/docker-proxy
  100. )
  101. # build tini (installed as docker-init)
  102. (
  103. cd tini-%{commit_tini}
  104. %cmake
  105. make tini-static -C "%{__cmake_builddir}"
  106. )
  107. %global buildtime %(date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +"%Y-%m-%dT%H:%M:%SZ")
  108. # build engine
  109. (
  110. mkdir -p src/github.com/docker
  111. # Link source and vendored deps into local GOPATH.
  112. ln -fns ../../.. src/%{goipath_moby}
  113. # Build using source and vendored deps in local GOPATH.
  114. export GOPATH="${PWD}"
  115. export GO111MODULE=off
  116. export LDFLAGS="-s -w"
  117. export LDFLAGS+=" -X github.com/docker/docker/dockerversion.Version=%{version}"
  118. export LDFLAGS+=" -X github.com/docker/docker/dockerversion.GitCommit=%{shortcommit_moby}"
  119. export LDFLAGS+=" -X github.com/docker/docker/dockerversion.IAmStatic=false"
  120. export LDFLAGS+=" -X 'github.com/docker/docker/dockerversion.BuildTime=%{buildtime}'"
  121. export DOCKER_BUILDTAGS="seccomp selinux journald"
  122. export BUILDTAGS="${DOCKER_BUILDTAGS}"
  123. export GOBUILDTAGS="${BUILDTAGS}"
  124. go build -o _build/bin/dockerd %{goipath_moby}/cmd/dockerd
  125. # VERSION=%%{version} DOCKER_GITCOMMIT=%%{shortcommit_moby} bash sh dynbinary
  126. # mv bundles/dynbinary-daemon/dockerd-%%{version} _build/bin/dockerd
  127. )
  128. # build cli
  129. (
  130. cd cli-%{version}
  131. mkdir -p src/github.com/docker
  132. # Link source and vendored deps into local GOPATH.
  133. ln -fns ../../.. src/%{goipath_cli}
  134. # export DISABLE_WARN_OUTSIDE_CONTAINER=1
  135. # Build using source and vendored deps in local GOPATH.
  136. export GOPATH="${PWD}"
  137. export GO111MODULE=off
  138. export LDFLAGS="\
  139. -w \
  140. -X \"github.com/docker/cli/cli/version.GitCommit=%{shortcommit_cli}\" \
  141. -X \"github.com/docker/cli/cli/version.BuildTime=%{buildtime}\" \
  142. -X \"github.com/docker/cli/cli/version.Version=%{version}\" \
  143. "
  144. export BUILDTAGS="pkcs11"
  145. export GOBUILDTAGS="${BUILDTAGS}"
  146. go build -o ../_build/bin/docker %{goipath_cli}/cmd/docker
  147. # make VERSION=%%{version} GITCOMMIT=%%{shortcommit_cli} dynbinary
  148. )
  149. %install
  150. # install binary
  151. install -Dpm 755 _build/bin/docker _build/bin/dockerd -t %{buildroot}%{_bindir}/
  152. # install proxy
  153. install -Dpm 755 _build/bin/docker-proxy -t %{buildroot}%{_libexecdir}/docker/
  154. # install tini
  155. install -Dpm 755 tini-%{commit_tini}/%{__cmake_builddir}/tini-static %{buildroot}%{_libexecdir}/docker/docker-init
  156. # install udev rules
  157. install -Dpm 644 contrib/udev/80-docker.rules -t %{buildroot}%{_usr}/lib/udev/rules.d/
  158. %if %{with systemd}
  159. # add init scripts
  160. install -Dpm 644 %{SOURCE3} contrib/init/systemd/docker.socket -t %{buildroot}%{_unitdir}/
  161. # for additional args
  162. install -Dpm 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/sysconfig/docker
  163. # Install sysusers configuration
  164. install -Dpm 0644 %{SOURCE5} %{buildroot}%{_sysusersdir}/moby-engine.conf
  165. %else
  166. # for additional args
  167. install -Dpm 755 %{SOURCE100} %{buildroot}%{_initdir}/docker
  168. install -Dpm 644 %{SOURCE101} %{buildroot}%{_sysconfdir}/sysconfig/docker
  169. %endif
  170. # add bash completions
  171. install -Dpm 644 cli-%{version}/contrib/completion/bash/docker -t %{buildroot}%{_datadir}/bash-completion/completions/
  172. # add nano files
  173. install -Dpm 644 contrib/syntax/nano/Dockerfile.nanorc -t %{buildroot}%{_datadir}/nano/
  174. for cli_file in LICENSE MAINTAINERS NOTICE README.md; do
  175. cp "cli-%{version}/$cli_file" "cli-$cli_file"
  176. done
  177. %pre
  178. %if %{with systemd}
  179. %sysusers_create_compat %{SOURCE5}
  180. %else
  181. if ! getent group docker > /dev/null; then
  182. groupadd --system docker
  183. fi
  184. %endif
  185. %post
  186. %if %{with systemd}
  187. if [ ! -L /var/run -a ! -e /var/run/docker ]; then
  188. ln -sf /run/docker /var/run/docker
  189. fi
  190. %systemd_post docker.service docker.socket
  191. %else
  192. if [ $1 -eq 1 ]; then
  193. /sbin/chkconfig --add docker
  194. fi
  195. %endif
  196. %preun
  197. %if %{with systemd}
  198. %systemd_preun docker.service docker.socket
  199. %else
  200. if [ $1 -eq 0 -o -x /usr/bin/systemctl ]; then
  201. /sbin/chkconfig docker off
  202. /sbin/chkconfig --del docker
  203. fi
  204. %endif
  205. %postun
  206. %if %{with systemd}
  207. %systemd_postun_with_restart docker.service
  208. %endif
  209. %files
  210. %license LICENSE cli-LICENSE
  211. %doc AUTHORS CONTRIBUTING.md MAINTAINERS NOTICE README.md
  212. %doc cli-MAINTAINERS cli-NOTICE cli-README.md
  213. %config(noreplace) %{_sysconfdir}/sysconfig/docker
  214. %{_bindir}/docker
  215. %{_bindir}/dockerd
  216. %dir %{_libexecdir}/docker/
  217. %{_libexecdir}/docker/docker-proxy
  218. %{_libexecdir}/docker/docker-init
  219. %{_usr}/lib/udev/rules.d/80-docker.rules
  220. %{_datadir}/bash-completion/completions/docker
  221. %if %{with man}
  222. %{_mandir}/man1/docker*.1*
  223. %{_mandir}/man5/{Dockerfile,docker-config-json}.5*
  224. %{_mandir}/man8/dockerd.8*
  225. %endif
  226. %if %{with systemd}
  227. %{_unitdir}/docker.service
  228. %{_unitdir}/docker.socket
  229. %{_sysusersdir}/moby-engine.conf
  230. %else
  231. %{_initdir}/docker
  232. %endif
  233. %files nano
  234. %dir %{_datadir}/nano
  235. %{_datadir}/nano/Dockerfile.nanorc
  236. %changelog
  237. * Wed Jul 24 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 27.1.1-1
  238. * Tue Jul 23 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 27.1.0-1
  239. - new upstream release.
  240. * Thu Jul 18 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 27.0.3-2
  241. - added i686 support.
  242. * Mon Jul 15 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 27.0.3-1
  243. - initial build for Vine Linux.
  244. * Sun Feb 11 2024 Maxwell G <maxwell@gtmx.me> - 24.0.5-4
  245. - Rebuild for golang 1.22.0
  246. * Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org>
  247. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  248. * Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org>
  249. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  250. * Wed Aug 23 2023 LuK1337 <priv.luk@gmail.com> - 24.0.5-1
  251. - Update moby-engine to 24.0.5
  252. * Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org>
  253. - Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
  254. * Sun Jan 29 2023 John Ghatas <john@johnghatas.com>
  255. - Update moby-engine to 23.0.4
  256. * Sun Jan 29 2023 Sérgio Basto <sergio@serjux.com>
  257. - Update moby-engine to 20.10.23
  258. * Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org>
  259. - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
  260. * Sun Jan 01 2023 Sérgio Basto <sergio@serjux.com>
  261. - Update moby-engine to 20.10.22
  262. * Wed Dec 14 2022 Dan Čermák <dan.cermak@cgc-instruments.com> - 20.10.21-1
  263. - Update to 20.10.21
  264. - Fix build, use libnetwork from golang-github-docker-0:22.06.0~beta
  265. * Thu Oct 20 2022 Jan Kuparinen <copperi@fedoraproject.org> - 20.10.20-1
  266. - Update to 20.10.20.
  267. - Mitigates CVE-2022-39253
  268. * Tue Oct 18 2022 Jan Kuparinen <copperi@fedoraproject.org> - 20.10.19-1
  269. - Update to 20.10.19.
  270. * Sat Sep 10 2022 Maxwell G <gotmax@e.email> - 20.10.18-1
  271. - Update to 20.10.18.
  272. - Mitigates CVE-2022-36109 / GHSA-rc4r-wh2q-q6c4
  273. * Tue Aug 30 2022 Luca BRUNO <lucab@lucabruno.net> - 20.10.17-8
  274. - Move 'docker' group creation logic to a sysusers.d fragment
  275. Resolves: rhbz#1745936
  276. * Fri Aug 05 2022 Maxwell G <gotmax@e.email> - 20.10.17-7
  277. - Migrate to SPDX license identifiers
  278. - Generate debuginfo
  279. - Specfile improvements
  280. * Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org>
  281. - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
  282. * Tue Jul 19 2022 Maxwell G <gotmax@e.email> - 20.10.17-5
  283. - Rebuild for CVE-2022-{1705,32148,30631,30633,28131,30635,30632,30630,1962} in
  284. golang
  285. * Mon Jul 04 2022 Maxwell G <gotmax@e.email> - 20.10.17-4
  286. - Only build on %%golang_arches (i.e. where golang is available).
  287. * Sun Jun 19 2022 Maxwell G <gotmax@e.email> - 20.10.17-3
  288. - Rebuilt for CVE-2022-1996, CVE-2022-24675, CVE-2022-28327, CVE-2022-27191,
  289. CVE-2022-29526, CVE-2022-30629.
  290. * Sat Jun 11 2022 Maxwell G <gotmax@e.email> - 20.10.17-2
  291. - Rebuild for new golang-github-docker-libnetwork
  292. * Fri Jun 10 2022 Maxwell G <gotmax@e.email> - 20.10.17-1
  293. - Update to 20.10.17. Fixes rhbz#2095714.
  294. * Fri May 13 2022 Maxwell G <gotmax@e.email> - 20.10.16-1
  295. - Update to 20.10.16.
  296. * Sat May 07 2022 Maxwell G <gotmax@e.email> - 20.10.15-1
  297. - Update to 20.10.15 (rhbz#2082501).
  298. - Fix BUILDTAGS (rhbz#2082924).
  299. - Make non-binary subpackages noarch.
  300. * Mon Apr 11 2022 Maxwell G <gotmax@e.email> - 20.10.14-1
  301. - Update to 20.10.14. Fixes rhbz#2063052.
  302. - Mitigate CVE-2022-24769.
  303. * Mon Jan 31 2022 Maxwell G <gotmax@e.email> - 20.10.12-3
  304. - Fixes FTBFS. Closes rhbz#2046748.
  305. - Use %%gobuild instead of Makefile to build binaries
  306. - Add explanatory comments.
  307. - Normalize install commands
  308. - Make compliant with SourceURL Guidelines
  309. - Remove no longer necessary `ExcludeArch: ppc64`.
  310. * Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 20.10.12-2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
  312. * Tue Jan 11 2022 Maxwell G <gotmax@e.email> - 20.10.12-1
  313. - Update to 20.10.12. Fixes rhbz#2032534.
  314. - Install zsh completions to the correct directory. Fixes rhbz#2038888.
  315. * Mon Nov 22 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10-11-1
  316. - Update to upstream 20.10.11 (fixes rhbz#2024384)
  317. - Mitigates CVE-2021-41190 (fixes rhbz#2024940)
  318. * Fri Oct 29 2021 Maxwell G <gotmax@e.email> - 20.10.10-1
  319. - Update to 20.10.10 (fixes rhbz#2015385)
  320. - Update virtual provides
  321. * Fri Oct 08 2021 Maxwell G <gotmax@e.email> - 20.10.9-1
  322. - Update to 20.10.9 (fixes rhbz#2010508)
  323. - Patch seccomp policy to fix clone3() issue (fixes rhbz#2011523 and rhbz#1988199)
  324. * Sun Aug 15 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10.8-1
  325. - Update to upstream 20.10.8 (fixes rhbz#1990148)
  326. - Fix seccomp support (fixes rhbz#1986092)
  327. * Sun Aug 15 2021 Dusty Mabe <dusty@dustymabe.com> - 20.10.7-3
  328. - Remove `Requires(post)` on firewalld-filesystem.
  329. * Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 20.10.7-2
  330. - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
  331. * Fri Jul 16 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10.7-1
  332. - Update to upstream 20.10.7 (fixes rhbz#1967390)
  333. * Tue May 04 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10.6-2
  334. - Add conflict with podman-docker
  335. * Tue Apr 20 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10.6-1
  336. - Update to upstream 20.10.6 (#1948605)
  337. - Re-bundle moby dependencies to fix gRPC issues with Swarm
  338. (https://github.com/coreos/fedora-coreos-tracker/issues/793)
  339. * Sun Mar 14 2021 Olivier Lemasle <o.lemasle@gmail.com> - 20.10.5-1
  340. - Update to latest upstream 20.10.5 - fixes #1903426
  341. - Upstream brings compatibility with cgroups v2 - fixes #1746355
  342. - Remove package moby-engine-vim (dockerfile.vim has been merged in upstream vim)
  343. - Remove firewalld docker zone, since dockerd can now communicate with firewalld - fixes #1852680
  344. - Build dockerd and docker-proxy from unbundled source packages
  345. - Remove fixed storage-driver (cf. https://src.fedoraproject.org/rpms/moby-engine/pull-request/6)
  346. * Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 19.03.13-3.ce.git4484c46
  347. - Rebuilt for updated systemd-rpm-macros
  348. See https://pagure.io/fesco/issue/2583.
  349. * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 19.03.13-2.ce.git4484c46
  350. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  351. * Fri Oct 02 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.13-1.ce.git4484c46
  352. - Update to upstream 19.03.13 (#1837641)
  353. * Fri Oct 02 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.11-4.ce.git42e35e6
  354. - Fix FTBFS: adapt to change to CMake builds (#1864160)
  355. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 19.03.11-3.ce.git42e35e6
  356. - Second attempt - Rebuilt for
  357. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  358. * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 19.03.11-2.ce.git42e35e6
  359. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  360. * Sun Jun 07 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.11-1.ce.git42e35e6
  361. - Update to upstream 19.03.11 to prevent CVE-2020-13401
  362. * Thu May 07 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.8-2.ce.gitafacb8b
  363. - Configure storage-driver explicitely (fixes #1832301)
  364. - Add firewalld zone: trust interface docker0, as firewalld now uses nftables
  365. by default and docker communicates with iptables (fixes #1817022)
  366. * Mon Mar 16 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.8-1.ce.gitafacb8b
  367. - Update to latest upstream release - Docker CE 19.03.8
  368. - Prune unused BuildRequires
  369. * Sun Mar 8 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.7-2.ce.git7141c19
  370. - Add Conflicts with docker-ce-cli and Obsoletes docker-common
  371. * Sat Mar 7 2020 Olivier Lemasle <o.lemasle@gmail.com> - 19.03.7-1.ce.git7141c19
  372. - Update to latest upstream release - Docker CE 19.03.7
  373. - Add Epoch: 2 to Obsoletes for docker and docker-latest
  374. * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 18.09.8-3.ce.git0dd43dd
  375. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  376. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 18.09.8-2.ce.git0dd43dd
  377. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  378. * Thu Jul 18 2019 Olivier Lemasle <o.lemasle@gmail.com> - 18.09.8-1.ce.git0dd43dd
  379. - Update to latest upstream release - Docker CE 18.09.8
  380. * Sat Jul 13 2019 Olivier Lemasle <o.lemasle@gmail.com> - 18.09.7-5.ce.git2d0083d
  381. - Move docker-init and docker-proxy to /usr/libexec/docker
  382. - Update moby-engine-nano summary to follow guidelines
  383. * Sat Jul 13 2019 Olivier Lemasle <o.lemasle@gmail.com> - 18.09.7-4.ce.git2d0083d
  384. - Add nofile ulimit to default docker daemon options (#1715254, #1708115)
  385. * Fri Jul 12 2019 Olivier Lemasle <o.lemasle@gmail.com> - 18.09.7-3.ce.git2d0083d
  386. - rebuilt
  387. * Fri Jul 12 2019 Olivier Lemasle <o.lemasle@gmail.com> - 18.09.7-2.ce.git2d0083d
  388. - Depend on packaged versions "runc" and "containerd" instead of building them.
  389. * Thu Jun 27 2019 David Michael <dm0@redhat.com> - 18.09.7-1.ce.git2d0083d
  390. - Update docker-ce to commit 2d0083d (version 18.09.7).
  391. - Update runc to commit 425e105.
  392. - Update containerd to commit 894b81a (1.2.6).
  393. - Update docker-proxy to commit e7933d4.
  394. * Tue May 14 2019 David Michael <dm0@redhat.com> - 18.09.6-1.ce.git481bc77
  395. - Update docker-ce to commit 481bc77 (version 18.09.6).
  396. - Update docker-proxy to commit 872f0a8.
  397. - Obsolete and provide the docker and docker-latest packages. (#1700006)
  398. * Thu Apr 11 2019 David Michael <dm0@redhat.com> - 18.09.5-1.ce.gite8ff056
  399. - Update docker-ce to commit e8ff056 (version 18.09.5).
  400. - Update docker-runc to commit 2b18fe1.
  401. - Update docker-containerd to commit bb71b10 (version 1.2.5).
  402. - Update docker-proxy to commit 4725f21.
  403. - Report the correct engine version.
  404. - Install symlinks to unprefixed runc/containerd program names.
  405. * Thu Mar 28 2019 David Michael <dm0@redhat.com> - 18.06.3-2.ce.gitd7080c1
  406. - Conflict with docker-common. (#1693397)
  407. * Thu Feb 21 2019 David Michael <dm0@redhat.com> - 18.06.3-1.ce.gitd7080c1
  408. - Update docker-ce to commit d7080c1 (version 18.06.3).
  409. * Tue Feb 12 2019 David Michael <dm0@redhat.com> - 18.06.2-1.ce.git6d37f41
  410. - Update docker-ce to commit 6d37f41 (version 18.06.2).
  411. - Update docker-runc to commit a592beb.
  412. * Mon Feb 11 2019 David Michael <dm0@redhat.com> - 18.06.1-3.ce.gite68fc7a
  413. - Apply a runc patch for CVE-2019-5736.
  414. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 18.06.1-2.ce.gite68fc7a
  415. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  416. * Thu Nov 29 2018 David Michael <dm0@redhat.com> - 18.06.1-1.ce.gite68fc7a
  417. - Update docker-ce to commit e68fc7a (version 18.06.1).
  418. - Update docker-runc to commit 69663f0.
  419. - Update docker-containerd to commit 468a545 (version 1.1.2).
  420. - Update docker-proxy to commit 3ac297b.
  421. - Backport a fix for mounting named volumes.
  422. - Create a "docker" group for non-root Docker access.
  423. - Support systemd socket-activation.
  424. - Make runc and containerd commit IDs match their expected values.
  425. - Preserve containerd debuginfo.
  426. * Mon Nov 12 2018 Marcin Skarbek <rpm@skarbek.name> - 18.06.0-2.ce.git0ffa825
  427. - add configuration file
  428. - update service file
  429. * Sat Aug 18 2018 Lokesh Mandvekar <lsm5@fedoraproject.org> - 18.06.0-1.ce.git0ffa825
  430. - Resolves: #1539161 - first upload to Fedora
  431. - built docker-ce commit 0ffa825
  432. - built docker-runc commit ad0f5255
  433. - built docker-containerd commit a88b631
  434. - built docker-proxy commit a79d368
  435. - built docker-init commit fec3683
  436. * Tue Mar 20 2018 Lokesh Mandvekar <lsm5@fedoraproject.org> - 17.03.2-4.ce.gitf5ec1e2
  437. - correct some rpmlint errors
  438. * Wed Feb 21 2018 Lokesh Mandvekar <lsm5@fedoraproject.org> - 17.03.2-3.ce
  439. - docker-* symlinks to moby-* (RE: gh PR 34226)
  440. * Wed Feb 21 2018 Lokesh Mandvekar <lsm5@fedoraproject.org> - 17.03.2-2.ce
  441. - rename binaries as per upstream gh PR 34226
  442. * Fri Jan 26 2018 Lokesh Mandvekar <lsm5@fedoraproject.org> - 17.03.2-1
  443. - initial build
  444. - built moby commit f5ec1e2
  445. - built cli commit 4b61f56
  446. - built docker-runc commit 2d41c047
  447. - built docker-containerd commit 3addd84
  448. - built docker-proxy commit 7b2b1fe