polkit-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452
  1. %bcond_with systemd
  2. Summary: PolicyKit Authorization Framework
  3. Summary(ja): PolicyKit 認証フレームワーク
  4. Name: polkit
  5. Version: 124
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://www.freedesktop.org/wiki/Software/polkit
  12. Source0: https://github.com/polkit-org/polkit/archive/refs/tags/%{version}.tar.gz
  13. Source1: polkit.sysusers
  14. Patch1: no-session-for-cookie.patch
  15. Patch2: pkttyagent-coredump-after-eof.patch
  16. Patch3: session-monitor-watch-sessions-only.patch
  17. Patch4: pkpermission-watch-changed-ssn-only.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: meson
  20. BuildRequires: glib2-devel
  21. BuildRequires: expat-devel
  22. BuildRequires: pam-devel
  23. BuildRequires: duktape-devel
  24. BuildRequires: gtk-doc
  25. BuildRequires: intltool
  26. BuildRequires: gobject-introspection-devel
  27. %if %{with systemd}
  28. BuildRequires: systemd-devel
  29. %{?systemd_requires}
  30. %else
  31. BuildRequires: elogind-devel
  32. %endif
  33. Requires: dbus
  34. Obsoletes: PolicyKit <= 0.10
  35. Provides: PolicyKit = 0.11
  36. Obsoletes: polkit-desktop-policy < 0.103
  37. Provides: polkit-desktop-policy = 0.103
  38. %if %{with systemd}
  39. %{?systemd_requires}
  40. %endif
  41. %description
  42. PolicyKit is a toolkit for defining and handling authorizations.
  43. It is used for allowing unprivileged processes to speak to privileged
  44. processes.
  45. %package devel
  46. Summary: Development files for PolicyKit
  47. Summary(ja): PolicyKit の開発用ファイル
  48. Group: programming
  49. Requires: %name = %{version}-%{release}
  50. Requires: %name-docs = %{version}-%{release}
  51. Requires: pkgconfig
  52. Requires: glib2-devel
  53. %description devel
  54. Development files for PolicyKit.
  55. %package docs
  56. Summary: Development documentation for PolicyKit
  57. Summary(ja): PolicyKit の開発用ドキュメント
  58. Group: documentation
  59. Requires: %name-devel = %{version}-%{release}
  60. Requires: gtk-doc
  61. %description docs
  62. Development documentation for PolicyKit.
  63. %debug_package
  64. %prep
  65. %autosetup -p1
  66. %if %{without systemd}
  67. sed -i -e '/systemd_sysusers_dir = /d' meson.build
  68. %endif
  69. %build
  70. %meson \
  71. -D authfw=pam \
  72. -D examples=false \
  73. -D gtk_doc=true \
  74. -D introspection=true \
  75. -D man=true \
  76. %if %{with systemd}
  77. -D session_tracking=libsystemd-login \
  78. %else
  79. -D session_tracking=libelogind \
  80. %endif
  81. -D tests=false
  82. %meson_build
  83. %install
  84. %meson_install
  85. %if %{with systemd}
  86. install -Dpm 0644 %{SOURCE1} %{buildroot}%{_sysusersdir}/polkit.conf
  87. %endif
  88. mv -f %{buildroot}%{_prefix}/lib/pam.d %{buildroot}%{_sysconfdir}/
  89. rm -f %{buildroot}%{_libdir}/*.la
  90. %find_lang polkit-1
  91. %pre
  92. %if %{with systemd}
  93. %sysusers_create_compat %{SOURCE1}
  94. %else
  95. groupadd -g 27 -r polkitd >/dev/null 2>&1 || :
  96. useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd >/dev/null 2>&1 || :
  97. exit 0
  98. %endif
  99. %post
  100. %if %{with systemd}
  101. %systemd_post polkit.service
  102. %endif
  103. %if %{with systemd}
  104. %preun
  105. %systemd_preun polkit.service
  106. %endif
  107. %postun
  108. %if %{with systemd}
  109. %systemd_postun_with_restart polkit.service
  110. %endif
  111. %files -f polkit-1.lang
  112. %license COPYING
  113. %doc NEWS.md README.md
  114. %{_libdir}/lib*.so.*
  115. %{_datadir}/man/man1/*
  116. %{_datadir}/man/man8/*
  117. %{_datadir}/dbus-1/system-services/*
  118. %if %{with systemd}
  119. %{_unitdir}/polkit.service
  120. %{_sysusersdir}/polkit.conf
  121. %endif
  122. %dir %{_datadir}/polkit-1/
  123. %dir %{_datadir}/polkit-1/actions
  124. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
  125. %attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
  126. %{_datadir}/polkit-1/rules.d/50-default.rules
  127. %{_datadir}/polkit-1/policyconfig-1.dtd
  128. %dir %{_sysconfdir}/polkit-1
  129. %attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
  130. %dir %{_datadir}/dbus-1
  131. %dir %{_datadir}/dbus-1/system.d
  132. %{_datadir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
  133. %{_sysconfdir}/pam.d/polkit-1
  134. %{_bindir}/pkaction
  135. %{_bindir}/pkcheck
  136. %{_bindir}/pkttyagent
  137. %dir %{_prefix}/lib/polkit-1
  138. %{_prefix}/lib/polkit-1/polkitd
  139. %{_libdir}/girepository-1.0/*.typelib
  140. # see upstream docs for why these permissions are necessary
  141. %attr(4755,root,root) %{_bindir}/pkexec
  142. %attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
  143. %files devel
  144. %{_libdir}/lib*.so
  145. %{_libdir}/pkgconfig/*.pc
  146. %{_datadir}/gir-1.0/*.gir
  147. %{_includedir}/*
  148. %dir %{_datadir}/gettext
  149. %dir %{_datadir}/gettext/its
  150. %{_datadir}/gettext/its/*
  151. %files docs
  152. %{_datadir}/gtk-doc/html/*
  153. %changelog
  154. * Thu Jul 18 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 124-1
  155. - new upstream release.
  156. * Sat Mar 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.120-2
  157. - imported Patch1002 from upstream to fix CVE-2021-4115.
  158. * Thu Jan 27 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.120-1
  159. - new upstream release.
  160. - dropped Patch1000: fixed in upstream.
  161. - imported Patch1001 from upstream to fix CVE-2021-4034.
  162. * Sat Jun 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.118-2
  163. - added Patch1000 to fix CVE-2021-3560.
  164. - dropped ldconfig scriptlets.
  165. * Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.118-1
  166. - new upstream release.
  167. * Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.117-1
  168. - new upstream release.
  169. - dropped Patch1-3: fixed in upstream.
  170. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
  171. - added systemd support (disabled as default).
  172. - imported Patch1-3 from rawhide.
  173. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
  174. - new upstream release.
  175. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
  176. - really enabled elogind.
  177. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
  178. - new upstream release.
  179. - enabled elogind: ConsoleKit is obsolete.
  180. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
  181. - new upstream release
  182. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
  183. - new upstream release
  184. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
  185. - new upstream release
  186. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
  187. - new upstream release
  188. - add BuildRequires: js-devel
  189. - remove BuildRequires: eggdbus-devel
  190. - remove polkit-desktop-policy subpackage (based on fedora)
  191. - historical changelogs are following:
  192. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
  193. - new upstream release
  194. * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
  195. - new upstream release
  196. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
  197. - new upstream release
  198. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
  199. - new upstream release
  200. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
  201. - build with rpm-4.8.1-1 for pkg-config file
  202. * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
  203. - update to 0.96
  204. - BR: eggdbus-devel >= 0.6
  205. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
  206. - remove Obsoletes:/Provides: PolicyKit*
  207. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
  208. - initial build for Vine Linux
  209. * Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
  210. - Update to upstream release 0.107
  211. * Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
  212. - Add forgotten Requires(pre): shadow-utils
  213. * Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
  214. - Update to upstream release 0.106
  215. - Authorizations are no longer controlled by .pkla files - from now
  216. on, use the new .rules files described in the polkit(8) man page
  217. * Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
  218. - Update to upstream release 0.105
  219. - Nuke patches that are now upstream
  220. - Change 'PolicyKit' to 'polkit' in summary and descriptions
  221. * Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
  222. - Don't leak file descriptors (bgo #671486)
  223. * Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
  224. - Make the -docs subpackage noarch
  225. * Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
  226. - Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
  227. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  229. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
  230. - Nuke the ConsoleKit run-time requirement
  231. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
  232. - Update to upstream release 0.104
  233. - Force usage of systemd (instead of ConsoleKit) for session tracking
  234. * Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
  235. - Update to upstream release 0.103
  236. - Drop upstreamed patch
  237. - Drop Fedora-specific policy, it is now upstream (fdo #41008)
  238. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
  239. - Rebuilt for glibc bug#747377
  240. * Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
  241. - Add patch to neuter the annoying systemd behavior where stdout/stderr
  242. is sent to the system logs
  243. * Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
  244. - Update to 0.102 release
  245. * Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
  246. - Allow setting the pretty hostname without a password for wheel,
  247. change matches systemd in git
  248. * Mon May 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
  249. - Update the action id of the datetime mechanism
  250. * Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
  251. - CVE-2011-1485 (#697951)
  252. * Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
  253. - Also allow org.kde.kcontrol.kcmclock.save without password for wheel
  254. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
  255. - Fix typo in pkla file (thanks notting)
  256. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
  257. - Nuke desktop_admin_r and desktop_user_r groups - just use the
  258. wheel group instead (#688363)
  259. - Update the set of configuration directives that gives users
  260. in the wheel group extra privileges
  261. * Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
  262. - New upstream version
  263. * Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
  264. - New upstream version
  265. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  267. * Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
  268. - Own /usr/libexec/polkit-1
  269. * Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
  270. - Enable introspection
  271. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
  272. - Fix #629515 in a way that doesn't require autoreconf
  273. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
  274. - Include polkitagentenumtypes.h (#629515)
  275. * Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
  276. - Update to upstream release 0.98
  277. - Co-own /usr/share/gtk-doc (#604410)
  278. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
  279. - Rebuid to work around bodhi limitations
  280. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
  281. - Fix a ConsoleKit interaction bug
  282. * Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
  283. - Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
  284. - Require GLib >= 2.25.12 instead of 2.25.11
  285. - Ensure polkit-gnome packages earlier than 0.97 are not used with
  286. these packages
  287. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
  288. - Rebuild
  289. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
  290. - Update to 0.97. This release contains a port from EggDBus to the
  291. GDBus code available in recent GLib releases.
  292. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
  293. - Update to 0.96
  294. - Disable introspection support for the time being
  295. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
  296. - Rebuild
  297. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
  298. - Update to 0.95
  299. - Drop upstreamed patches
  300. * Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
  301. - Fix a typo in pklocalauthority(8)
  302. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
  303. - Refine how Obsolete: is used and also add Provides: (thanks Jesse
  304. Keating and nim-nim)
  305. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
  306. - Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
  307. - Obsolete old PolicyKit packages
  308. * Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
  309. - Update to git snapshot
  310. - Drop upstreamed patches
  311. - Turn on GObject introspection
  312. - Don't delete desktop_admin_r and desktop_user_r groups when
  313. uninstalling polkit-desktop-policy
  314. * Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
  315. - Add some patches from git master
  316. - Sort pkaction(1) output
  317. - Bug 23867 UnixProcess vs. SystemBusName aliasing
  318. * Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
  319. - Add desktop_admin_r and desktop_user_r groups along with a first cut
  320. of default authorizations for users in these groups.
  321. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
  322. - Disable GObject Introspection for now as it breaks the build
  323. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
  324. - Update to upstream release 0.94
  325. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  326. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  327. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
  328. - Rebuild
  329. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
  330. - Update to 0.93
  331. * Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
  332. - Don't make docs noarch (I *heart* multilib)
  333. - Change license to LGPLv2+
  334. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
  335. - Rebuild
  336. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
  337. - Update to 0.92 release
  338. * Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
  339. - Update to 0.92 snapshot
  340. * Mon Feb 9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
  341. - Initial spec file.