stunnel-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600
  1. %bcond_with systemd
  2. %bcond_with crypto_policies
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: 5.72
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. License: GPLv2
  12. URL: https://www.stunnel.org/
  13. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  14. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  15. Source2: Certificate-Creation
  16. Source3: sfinger.xinetd
  17. Source4: stunnel-sfinger.conf
  18. Source5: pop3-redirect.xinetd
  19. Source6: stunnel-pop3s-client.conf
  20. Source7: stunnel@.service
  21. Source100: stunnel.init
  22. Patch0: stunnel-5.50-authpriv.patch
  23. Patch1: stunnel-5.61-systemd-service.patch
  24. Patch3: stunnel-5.69-system-ciphers.patch
  25. Patch5: stunnel-5.72-default-tls-version.patch
  26. Patch6: stunnel-5.56-curves-doc-update.patch
  27. BuildRoot: %{_tmppath}/stunnel-root
  28. # util-linux is needed for rename
  29. BuildRequires: openssl-devel
  30. BuildRequires: pkgconfig
  31. BuildRequires: util-linux
  32. %if %{with systemd}
  33. %{?systemd_requires}
  34. %else
  35. Requires(post): chkconfig
  36. Requires(preun): chkconfig /sbin/service
  37. Requires(postun): /sbin/service
  38. %endif
  39. %global pidfile %{_rundir}/stunnel/stunnel.pid
  40. # Do not generate provides for private libraries
  41. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  42. %description
  43. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  44. Layer) support to ordinary applications. For example, it can be used
  45. in conjunction with imapd to create an SSL secure IMAP server.
  46. %debug_package
  47. %prep
  48. %setup -q
  49. %patch0 -p1
  50. %patch1 -p1
  51. %if %{with crypto_policies}
  52. %patch3 -p1
  53. %endif
  54. %patch5 -p1
  55. %patch6 -p1
  56. # Fix the stack protector flag
  57. sed -i 's/-fstack-protector/-fstack-protector-strong/' configure
  58. # modify systemd service unit
  59. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  60. %build
  61. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  62. if pkg-config openssl ; then
  63. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  64. LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"; export LDFLAGS
  65. fi
  66. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  67. --with-bashcompdir=%{_datadir}/bash-completion/completions \
  68. CPPFLAGS="$CPPFLAGS -UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  69. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  73. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  74. make install DESTDIR=$RPM_BUILD_ROOT
  75. # Move the translated man pages to the right subdirectories, and strip off the
  76. # language suffixes.
  77. for lang in pl ; do
  78. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  79. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  80. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  81. done
  82. mkdir -p srpm-docs
  83. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  84. %if %{with systemd}
  85. mkdir -p %{buildroot}%{_unitdir}
  86. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  87. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  88. %else
  89. install -d -m755 %{buildroot}%{_initdir}
  90. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  91. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  92. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  93. ENABLED=0
  94. EOF
  95. %endif
  96. %clean
  97. rm -rf $RPM_BUILD_ROOT
  98. %if %{without systemd}
  99. %pre
  100. if /sbin/service stunnel status >/dev/null; then
  101. touch /var/lib/rpm-state/stunnel
  102. /sbin/service stunnel stop
  103. fi
  104. %endif
  105. %post
  106. if [ -e /etc/stunnel/stunnel.conf ]; then
  107. sed -i -e 's|/var/run/|/run/stunnel/|' /etc/stunnel/stunnel.conf
  108. fi
  109. %if %{with systemd}
  110. %systemd_post %{name}.service
  111. %else
  112. /sbin/chkconfig --add stunnel
  113. %endif
  114. %preun
  115. %if %{with systemd}
  116. %systemd_preun %{name}.service
  117. %else
  118. if [ $1 -eq 0 -o -x /usr/bin/systemctl ]; then
  119. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  120. /sbin/chkconfig --del stunnel
  121. fi
  122. %endif
  123. %if %{with systemd}
  124. %postun
  125. %systemd_postun_with_restart %{name}.service
  126. %endif
  127. %if %{without systemd}
  128. %posttrans
  129. if [ -e /var/lib/rpm-state/stunnel -a ! -x /usr/bin/systemctl ]; then
  130. rm -f /var/lib/rpm-state/stunnel
  131. /sbin/service stunnel start
  132. fi
  133. %endif
  134. %files
  135. %defattr(-,root,root)
  136. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  137. %doc tools/stunnel.conf-sample
  138. %doc srpm-docs/*
  139. %license COPY*
  140. %lang(en) %doc doc/en/*
  141. %lang(po) %doc doc/pl/*
  142. %{_bindir}/stunnel
  143. %exclude %{_bindir}/stunnel3
  144. %exclude %{_datadir}/doc/stunnel
  145. %{_libdir}/stunnel
  146. %exclude %{_libdir}/stunnel/libstunnel.la
  147. %{_mandir}/man8/stunnel.8*
  148. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  149. %dir %{_sysconfdir}/%{name}
  150. %dir %{_sysconfdir}/%{name}/conf.d
  151. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  152. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  153. %if %{with systemd}
  154. %{_unitdir}/%{name}*.service
  155. %else
  156. %{_initdir}/stunnel
  157. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  158. %endif
  159. %dir %{_datadir}/bash-completion/completions
  160. %dir %{_datadir}/bash-completion
  161. %{_datadir}/bash-completion/completions/*
  162. %changelog
  163. * Mon Jul 29 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.72-1
  164. - new upstream release.
  165. * Mon Oct 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.60-1
  166. - new upstream release.
  167. - built with openssl-3.0.0.
  168. - imported Patch100 from openmandriva.
  169. * Thu May 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.59-1
  170. - new upstream release.
  171. - diabled crypto-policies (not implemented for Vine Linux).
  172. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.58-1
  173. - new upstream release.
  174. - uodated patches.
  175. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  176. - new upstream release.
  177. - replaced all patches.
  178. - added systemd support (disabled as default).
  179. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  180. - new upstream release.
  181. - updated Patch0,1.
  182. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  183. - rebuid with OpenSSL 1.0.2k
  184. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  185. - new upstream release.
  186. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  187. - new upstream release.
  188. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  189. - new upstream release.
  190. - fixed dates in %%changelog.
  191. - updated all patches.
  192. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  193. - initial build for Vine Linux
  194. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  195. - 884183: support for full relro.
  196. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  197. - New upstream realease 4.54
  198. - Updated local patches
  199. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  200. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  201. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  202. - New upstream realease 4.53
  203. - Updated local patches
  204. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  205. - New upstream realease 4.52
  206. - Updated local patches
  207. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  209. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  210. - New upstream realease 4.50
  211. - Updated local patches
  212. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  213. - New upstream realease 4.44
  214. - Updated local patches
  215. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  216. - New upstream realease 4.42
  217. - Updated local patches
  218. - Fixes #732069
  219. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  220. - New upstream realease 4.41
  221. - Updated local patches to match the new release
  222. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  223. - New upstream realease 4.37
  224. - Updated local patches to match the new release
  225. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  226. - New upstream realease 4.35
  227. - Updated authpriv and sample patches to match the new release
  228. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  229. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  230. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  231. - New upstream realease 4.34
  232. - Updated authpriv and sample patches to match the new release
  233. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  234. - New upstream realease 4.33
  235. - Updated authpriv and sample patches to match the new release
  236. - Addresses bz 580117 (inted mode support issue)
  237. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  238. - New upstream realease 4.32
  239. - Updated authpriv and sample patches to match the new release
  240. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  241. - New upstream realease 4.31
  242. - Updated authpriv and sample patches to match the new release
  243. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  244. - New upstream realease 4.30
  245. - Updated authpriv and sample patches for the new release
  246. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  247. - New upstream realease 4.29
  248. - Updated authpriv and sample patches for the new release
  249. - Modified spec file to include dist tag
  250. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  251. - rebuilt with new openssl
  252. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  253. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  254. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  255. - Fix the previous patch.
  256. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  257. - Avoid aliasing undefined by ISO C
  258. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  259. - Update to stunnel-4.27.
  260. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  261. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  262. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  263. - disable openssl upstream fips mode
  264. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  265. - Update to stunnel-4.26.
  266. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  267. - Use a clearer error message if the service name is unknown in "accept"
  268. Resolves: #450344
  269. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  270. - Update to stunnel-4.25
  271. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  272. - Drop stunnel3
  273. Resolves: #442842
  274. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  275. - Update to stunnel-4.24
  276. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  277. - Update to stunnel-4.22
  278. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  279. - Autorebuild for GCC 4.3
  280. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  281. - Rebuild with openssl-0.9.8g
  282. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  283. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  284. Resolves: #301971
  285. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  286. Resolves: #322281
  287. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  288. - Port to NSS
  289. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  290. - Update BuildRequires for the separate tcp_wrappers-devel package
  291. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  292. - Update to stunnel-4.20
  293. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  294. - Update to stunnel-4.19
  295. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  296. - Update to stunnel-4.18
  297. - Remove unused stunnel.cnf from the src.rpm
  298. - Fix some rpmlint warnings
  299. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  300. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  301. (#203001)
  302. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  303. - rebuild
  304. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  305. - Update to stunnel-4.15
  306. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  307. - bump again for double-long bug on ppc(64)
  308. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  309. - rebuilt for new gcc4.1 snapshot and glibc changes
  310. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  311. - Use pthread threading to fix crash on x86_64 (#179236)
  312. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  313. - rebuilt
  314. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  315. - Rebuild with newer openssl
  316. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  317. - Update to stunnel-4.14
  318. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  319. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  320. - Update to stunnel-4.13
  321. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  322. - Update to stunnel-4.12
  323. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  324. - Enable IPv6 (#169050, patch by Peter Bieringer)
  325. - Don't ship another copy of man pages in HTML
  326. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  327. - Update to stunnel-4.11
  328. - Fix int/size_t mismatches in stack_info ()
  329. - Update Certificate-Creation for /etc/pki
  330. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  331. - Fix inetd mode
  332. - Remove unnecessary Requires: and BuildRequires:
  333. - Clean up the spec file
  334. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  335. - update to 4.10
  336. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  337. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  338. coreutils (#133961)
  339. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  340. - update to 4.08
  341. - build stunnel as a PIE binary
  342. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  343. - Convert man pages to UTF-8
  344. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  345. - rebuilt
  346. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  347. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  348. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  349. - update to 4.05
  350. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  351. - rebuilt
  352. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  353. - rebuilt
  354. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  355. - Fix libtool
  356. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  357. - rebuilt
  358. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  359. - fix xinetd configuration samples
  360. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  361. - rebuild
  362. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  363. - rebuilt
  364. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  365. - update to 4.04
  366. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  367. - use pkgconfig for information about openssl, if available
  368. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  369. - update to 4.03
  370. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  371. - update to 4.02
  372. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  373. - don't create a dummy cert
  374. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  375. - update to 4.00
  376. - remove textutils and fileutils as buildreqs, add automake/autoconf
  377. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  378. - automated rebuild
  379. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  380. - automated rebuild
  381. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  382. - rebuild in new environment
  383. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  384. - update to 3.22, correcting a format-string vulnerability
  385. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  386. - update to 3.21a
  387. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  388. - log using LOG_AUTHPRIV facility by default (#47289)
  389. - make permissions on stunnel binary 0755
  390. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  391. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  392. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  393. tcp wrappers not being thrad-safe
  394. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  395. - update to 3.17
  396. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  397. - update to 3.16
  398. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  399. - update to 3.15
  400. - enable tcp-wrappers support
  401. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  402. - remove explicit requirement on openssl (specific version isn't enough,
  403. we have to depend on shared library version anyway)
  404. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  405. - update to 3.14
  406. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  407. - depend on make (#33148)
  408. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  409. - rebuild in new environment
  410. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  411. - update to 3.13 to get pthread, OOB, 64-bit fixes
  412. - don't need sdf any more
  413. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  414. - pull in sdf to build the man page (#22892)
  415. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  416. - update to 3.11
  417. - chuck the SIGHUP patch (went upstream)
  418. - chuck parts of the 64-bit clean patch (went upstream)
  419. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  420. - update to 3.10
  421. - more 64-bit clean changes, hopefully the last bunch
  422. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  423. - change piddir from the default /var/stunnel to /var/run
  424. - clean out pid file on SIGHUP
  425. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  426. - update to 3.9 to get a security fix
  427. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  428. - change all unsigned longs to u_int32_t when dealing with network
  429. addresses
  430. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  431. - make stunnel.pem also be (missingok)
  432. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  433. - move to Applications/Internet group
  434. - clean up %%post script
  435. - make stunnel.pem %%ghost %%config(noreplace)
  436. - provide a sample file for use with xinetd
  437. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  438. - FHS compliance fixes
  439. - modify defaults
  440. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  441. - update to 3.8
  442. - do not create certificate if one already exists
  443. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  444. - update to 3.7
  445. - add patch to find /usr/share/ssl
  446. - change some perms
  447. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  448. - Modify spec file to match Red Hat standards
  449. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  450. - Updated to 3.4a
  451. - Patched for OpenSSL 0.9.4
  452. - Cleaned up files section
  453. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  454. - Updated to 3.3
  455. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  456. - Initial RPMification