libdatrie-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Double-Array Trie Library
  3. Name: libdatrie
  4. Version: 0.2.5
  5. Release: 2%{?_dist_release}
  6. Source0: http://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.gz
  7. License: GPLv2
  8. Group: System Environment/Libraries
  9. URL: http://linux.thai.net/~thep/datrie/datrie.html
  10. BuildRequires: doxygen
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: Takemikaduchi
  15. %description
  16. This is an implementation of double-array structure for representing trie,
  17. as proposed by Junichi Aoe.
  18. Trie is a kind of digital search tree, an efficient indexing method with
  19. O(1) time complexity for searching. Comparably as efficient as hashing,
  20. trie also provides flexibility on incremental matching and key spelling
  21. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  22. dictionaries.
  23. %package devel
  24. Summary: Development tools for libdatrie
  25. Summary(ja): libdatrie の開発環境
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: pkgconfig
  29. %description devel
  30. Header files and libraries for building a extension library for the
  31. libdatrie.
  32. %package doc
  33. Summary: Documentation for libdatrie
  34. Summary(ja): libdatrie 用のドキュメント
  35. Group: Documentation
  36. Requires: %{name} = %{version}-%{release}
  37. BuildArch: noarch
  38. %description doc
  39. This package contains documentation for libdatrie
  40. # compat32
  41. %package -n compat32-%{name}
  42. Summary: Double-Array Trie Library
  43. Group: System Environment/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description -n compat32-%{name}
  46. This is an implementation of double-array structure for representing trie,
  47. as proposed by Junichi Aoe.
  48. Trie is a kind of digital search tree, an efficient indexing method with
  49. O(1) time complexity for searching. Comparably as efficient as hashing,
  50. trie also provides flexibility on incremental matching and key spelling
  51. manipulation. This makes it ideal for lexical analyzers, as well as spelling
  52. dictionaries.
  53. %package -n compat32-%{name}-devel
  54. Summary: Development tools for libdatrie
  55. Summary(ja): libdatrie の開発環境
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}-%{release}
  58. Requires: pkgconfig
  59. %description -n compat32-%{name}-devel
  60. Header files and libraries for building a extension library for the
  61. libdatrie.
  62. %prep
  63. %setup -q
  64. %build
  65. %configure \
  66. --disable-static
  67. %{__make} %{?_smp_mflags}
  68. %install
  69. %{__rm} -rf ${RPM_BUILD_ROOT}
  70. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  71. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  72. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  73. %clean
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %post -p /sbin/ldconfig
  76. %postun -p /sbin/ldconfig
  77. %files
  78. %defattr(-,root,root,-)
  79. %doc COPYING ChangeLog NEWS README
  80. %{_bindir}/trietool-0.2
  81. %{_libdir}/%{name}.so.*
  82. %{_mandir}/man1/*.gz
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %{_includedir}/datrie
  86. %{_libdir}/%{name}.so
  87. %{_libdir}/pkgconfig/datrie-0.2.pc
  88. %files doc
  89. %defattr(-,root,root,-)
  90. %{_docdir}/%{name}/README.migration
  91. %{_docdir}/datrie
  92. %if %{build_compat32}
  93. %files -n compat32-%{name}
  94. %defattr(-, root, root,-)
  95. %{_libdir}/%{name}.so.*
  96. %files -n compat32-%{name}-devel
  97. %defattr(-, root, root,-)
  98. %{_libdir}/%{name}.so
  99. %endif
  100. %changelog
  101. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-2
  102. - remove *.pc from compat32-%{name}-devel
  103. - fix typo
  104. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.5-1
  105. - initial build for Vine Linux