libglade2-vl.spec 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320
  1. %define __libtoolize :
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define libxml2_version 2.4.29
  4. %define gtk2_version 2.6.0
  5. %define pango_version 1.8.0
  6. Summary: The libglade library for loading user interfaces.
  7. Name: libglade2
  8. Version: 2.6.4
  9. Release: 5%{?_dist_release}
  10. License: LGPL
  11. Group: System Environment/Libraries
  12. Source: libglade-%{version}.tar.bz2
  13. #Source2: fixed-ltmain.sh
  14. URL: http://www.gnome.org/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libxml2-devel >= %{libxml2_version}
  17. BuildRequires: gtk2-devel >= %{gtk2_version}
  18. BuildRequires: pango-devel >= %{pango_version}
  19. BuildRequires: python-devel >= 2.2.1
  20. BuildRequires: python >= 2.2.1
  21. Requires(post): libxml2 >= %{libxml2_version}
  22. Requires(postun): libxml2 >= %{libxml2_version}
  23. Requires(post): xml-common
  24. Requires(postun): xml-common
  25. %description
  26. Libglade is a small library that allows a program to load its user
  27. interface from am XML description at runtime. Libglade uses the XML
  28. file format used by the GLADE user interface builder GLADE, so
  29. libglade acts as an alternative to GLADE's code generation
  30. approach. Libglade also provides a simple interface for connecting
  31. handlers to the various signals in the interface (on platforms where
  32. the gmodule library works correctly, it is possible to connect all the
  33. handlers with a single function call). Once the interface has been
  34. instantiated, libglade gives no overhead, so other than the short
  35. initial interface loading time, there is no performance tradeoff.
  36. #'
  37. %package devel
  38. Summary: The files needed for libglade application development.
  39. Group: Development/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. Requires: libxml2-devel >= %{libxml2_version}
  42. Requires: gtk2-devel >= %{gtk2_version}
  43. Conflicts: libglade < 0.17
  44. %description devel
  45. The libglade-devel package contains the libraries and include files
  46. that you can use to develop libglade applications.
  47. %package -n compat32-%{name}
  48. Summary: The libglade library for loading user interfaces.
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. %description -n compat32-%{name}
  52. Libglade is a small library that allows a program to load its user
  53. interface from am XML description at runtime. Libglade uses the XML
  54. file format used by the GLADE user interface builder GLADE, so
  55. libglade acts as an alternative to GLADE's code generation
  56. approach. Libglade also provides a simple interface for connecting
  57. handlers to the various signals in the interface (on platforms where
  58. the gmodule library works correctly, it is possible to connect all the
  59. handlers with a single function call). Once the interface has been
  60. instantiated, libglade gives no overhead, so other than the short
  61. initial interface loading time, there is no performance tradeoff.
  62. #'
  63. %package -n compat32-%{name}-devel
  64. Summary: The files needed for libglade application development.
  65. Group: Development/Libraries
  66. Requires: %{name}-devel = %{version}-%{release}
  67. Requires: compat32-%{name} = %{version}-%{release}
  68. Requires: compat32-libxml2-devel >= %{libxml2_version}
  69. Requires: compat32-gtk2-devel >= %{gtk2_version}
  70. %description -n compat32-%{name}-devel
  71. The libglade-devel package contains the libraries and include files
  72. that you can use to develop libglade applications.
  73. %prep
  74. %setup -q -n libglade-%{version}
  75. %build
  76. #rm ltmain.sh && cp %{SOURCE2} ltmain.sh
  77. %configure --disable-gtk-doc --disable-static
  78. make %{?_smp_mflags}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. %makeinstall
  82. install -m755 libglade-convert $RPM_BUILD_ROOT%{_bindir}
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  84. %clean
  85. rm -rf $RPM_BUILD_ROOT
  86. %post
  87. /sbin/ldconfig
  88. CATALOG=/etc/xml/catalog
  89. /usr/bin/xmlcatalog --noout --add "system" \
  90. "http://glade.gnome.org/glade-2.0.dtd" \
  91. "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
  92. %postun
  93. /sbin/ldconfig
  94. # remove entries only on removal of package
  95. if [ "$1" = 0 ]; then
  96. CATALOG=/etc/xml/catalog
  97. /usr/bin/xmlcatalog --noout --del \
  98. "file://%{_datadir}/xml/libglade/glade-2.0.dtd" $CATALOG
  99. fi
  100. %post -n compat32-%{name} -p /sbin/ldconfig
  101. %postun -n compat32-%{name} -p /sbin/ldconfig
  102. %files
  103. %defattr(-, root, root)
  104. %doc AUTHORS ChangeLog NEWS README COPYING
  105. %{_libdir}/lib*.so.*
  106. %{_datadir}/xml
  107. %files devel
  108. %defattr(-, root, root)
  109. %doc test-libglade.c
  110. %{_bindir}/*
  111. %{_libdir}/lib*.so
  112. %{_libdir}/pkgconfig/*.pc
  113. %{_includedir}/*
  114. %{_datadir}/gtk-doc
  115. %if %{build_compat32}
  116. %files -n compat32-%{name}
  117. %defattr(-, root, root)
  118. %{_libdir}/lib*.so.*
  119. %files -n compat32-%{name}-devel
  120. %defattr(-, root, root)
  121. %{_libdir}/lib*.so
  122. %{_libdir}/pkgconfig/*.pc
  123. %endif
  124. %changelog
  125. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.4-5
  126. - build with rpm-4.8.1-1 for pkg-config file
  127. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
  128. - rebuilt with new toolchain
  129. * Sun Jul 12 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-3
  130. - added compat32-libglade2-devel for x86_64 architecture
  131. * Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
  132. - add Requires(post,postun): xml-common
  133. - remove static library
  134. * Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  135. - new upstream release
  136. * Mon Sep 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-1
  137. - new upstream release
  138. - run /usr/bin/xmlcatlog at %%post and %%postun section
  139. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-1vl5
  140. - used %%{?_dist_release} tag
  141. - removed lib*.la from devel package
  142. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.2-0vl1
  143. - new upstream release
  144. * Wed Aug 2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.0-0vl1
  145. - new upstream release
  146. * Fri May 26 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.1-0vl2
  147. - added compat32-libglade2 package for x86_64 architecture support
  148. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
  149. - new upstream version
  150. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  151. - new upstream release
  152. * Tue Jun 17 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.0-0vl1
  153. - new upstream release
  154. - drop obsoleted Source2
  155. - s/COPYRIGHT/LICENSE/
  156. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl2
  157. - rebuild with python2
  158. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-0vl1
  159. - build for Vine Linux
  160. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  161. - automated rebuild
  162. * Sat Jun 15 2002 Havoc Pennington <hp@redhat.com>
  163. - 2.0.0
  164. - check over file list, add XML DTD to it
  165. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  166. - rebuild in different environment
  167. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  168. - don't run auto*
  169. * Fri May 17 2002 Havoc Pennington <hp@redhat.com>
  170. - 1.99.12
  171. - remove gtk-doc hack, --disable-gtk-doc now works
  172. * Thu May 2 2002 Havoc Pennington <hp@redhat.com>
  173. - 1.99.11
  174. * Thu Apr 4 2002 Jeremy Katz <katzj@redhat.com>
  175. - 1.99.10
  176. * Tue Mar 19 2002 Alex Larsson <alexl@redhat.com>
  177. - Update autoconf dependency to 2.53
  178. * Mon Mar 11 2002 Alex Larsson <alexl@redhat.com>
  179. - Update to 1.99.9
  180. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  181. - Bump for rebuild
  182. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  183. - Bump for rebuild
  184. * Tue Feb 19 2002 Alex Larsson <alexl@redhat.com>
  185. - Add horrible buildroot check hacks. Require new Gtk+.
  186. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  187. - rebuild for new gtk
  188. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  189. - Rebuild against new GTK+
  190. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  191. - put "nogtkdoc" patch back, it avoids X display requirement
  192. - automake14
  193. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  194. - 1.99.5.90 snap
  195. - comment out "nogtkdoc" patch, don't run autoconf
  196. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  197. - new 1.99.4.91 snap with Jacob's fixes, he
  198. assures me we are 1.99.4.90 ABI-compatible
  199. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  200. - new 1.99.4.90 snap, gtk 1.3.11
  201. * Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
  202. - new snap, rebuild on gtk 1.3.10
  203. * Sat Oct 6 2001 Havoc Pennington <hp@redhat.com>
  204. - new snap, add hack to avoid trying to build docs
  205. - add the ltmain.sh hack to avoid relinking
  206. * Mon Sep 24 2001 Havoc Pennington <hp@redhat.com>
  207. - new snap
  208. * Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
  209. - convert libglade rpm to libglade2 rpm, initial build of libglade2
  210. * Mon Aug 20 2001 Jonathan Blandford <jrb@redhat.com>
  211. - Escape strings, #51966
  212. * Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
  213. - add build requires, bug #49508
  214. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  215. - Bump release + rebuild.
  216. * Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
  217. - New Version.
  218. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  219. - Rebuild for GTK+-1.2.9 include paths
  220. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  221. - add libtoolize to make porting to new archs easy
  222. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  223. - 0.14
  224. - added patch for gtk-doc scanner linkage
  225. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  226. - Up Epoch and release
  227. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  228. - automatic rebuild
  229. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  230. - specfile fixes
  231. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  232. - Upgraded to libglade-0.13
  233. - Use %makeinstall, since that is required when %configure is used.
  234. * Fri May 19 2000 Owen Taylor <otaylor@redhat.com>
  235. - Upgraded to libglade-0.12
  236. * Tue Sep 07 1999 Elliot Lee <sopwith@redhat.com>
  237. - Updated RHL 6.1 package to libglade-0.5
  238. * Sun Nov 1 1998 James Henstridge <james@daa.com.au>
  239. - Updated the dependencies of the devel package, so users must have gtk+-devel.
  240. * Sun Oct 25 1998 James Henstridge <james@daa.com.au>
  241. - Initial release 0.0.1