pango-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613
  1. %define glib2_version 2.36.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.3.9
  4. %define fontconfig_version 2.10.91
  5. %define cairo_version 1.12.2
  6. # biarch support
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. %define _querymodules_suffix %{nil}
  9. %if %{build_compat32}
  10. %define _querymodules_suffix -32
  11. %endif
  12. Summary: System for layout and rendering of internationalized text.
  13. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  14. Name: pango
  15. Version: 1.34.1
  16. Release: 1%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.34/pango-%{version}.tar.xz
  20. URL: http://www.pango.org
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. # We need to prereq this so we can run pango-querymodules
  23. Requires: glib2 >= %{glib2_version}
  24. Requires: freetype2 >= %{freetype2_version}
  25. BuildRequires: libtool >= 1.4.2
  26. BuildRequires: glib2-devel >= %{glib2_version}
  27. BuildRequires: pkgconfig >= %{pkgconfig_version}
  28. BuildRequires: freetype2-devel >= %{freetype2_version}
  29. BuildRequires: fontconfig-devel >= %{fontconfig_version}
  30. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  31. BuildRequires: cairo-devel >= %{cairo_version}
  32. BuildRequires: libSM-devel
  33. BuildRequires: gobject-introspection-devel
  34. BuildRequires: libthai-devel
  35. BuildRequires: harfbuzz-devel
  36. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  37. # Look for pango.modules in an arch-specific directory
  38. Patch0: pango-1.31.2-lib64.patch
  39. Patch1: pango-1.28.1-gobject-introspection.patch
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. %description
  43. Pango is a system for layout and rendering of internationalized text.
  44. %description -l ja
  45. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  46. %package devel
  47. Summary: System for layout and rendering of internationalized text.
  48. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}
  51. Requires: glib2-devel >= %{glib2_version}
  52. Requires: freetype2-devel >= %{freetype2_version}
  53. Requires: cairo-devel >= %{cairo_version}
  54. Requires: libX11-devel, libXft-devel, libXrender-devel
  55. Requires: harfbuzz-devel
  56. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  57. %description devel
  58. The pango-devel package includes the static libraries, header files,
  59. and developer docs for the pango package.
  60. Install pango-devel if you want to develop programs which will use
  61. pango.
  62. #####################################################################
  63. # compat32
  64. %package -n compat32-%{name}
  65. Summary: System for layout and rendering of internationalized text.
  66. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  67. Group: Development/Libraries
  68. %description -n compat32-%{name}
  69. Pango is a system for layout and rendering of internationalized text.
  70. %description -n compat32-%{name} -l ja
  71. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  72. %package -n compat32-%{name}-devel
  73. Summary: Development files for pango
  74. Summary(ja): pango 用の開発ファイル
  75. Group: Development/Libraries
  76. Requires: compat32-%{name} = %{version}
  77. Requires: %{name}-devel = %{version}
  78. %description -n compat32-%{name}-devel
  79. The pango-devel package includes the static libraries, header files,
  80. and developer docs for the pango package.
  81. %prep
  82. %setup -q -n pango-%{version}
  83. %patch0 -p1 -b .lib64
  84. # %patch1 -p1 -b .gi
  85. %build
  86. ###%configure --with-included-modules=basic-fc
  87. (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
  88. %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
  89. make %{?_smp_mflags}
  90. %install
  91. rm -rf $RPM_BUILD_ROOT
  92. make DESTDIR=$RPM_BUILD_ROOT install
  93. # biarch support
  94. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
  95. touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
  96. %if %{build_compat32}
  97. cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
  98. $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
  99. %endif
  100. # remove unpackaged files
  101. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
  103. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %post
  107. /sbin/ldconfig
  108. %{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
  109. %postun -p /sbin/ldconfig
  110. %if %{build_compat32}
  111. %post -n compat32-%{name}
  112. /sbin/ldconfig
  113. %{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
  114. %postun -p /sbin/ldconfig -n compat32-%{name}
  115. %endif
  116. %files
  117. %defattr(-, root, root)
  118. %doc README AUTHORS COPYING NEWS
  119. %doc pango-view/HELLO.txt
  120. #doc README AUTHORS COPYING ChangeLog
  121. #doc examples/HELLO.utf8
  122. %{_bindir}/pango-querymodules
  123. %{_bindir}/pango-view
  124. %{_libdir}/libpango*-*.so.*
  125. %{_libdir}/pango
  126. %{_libdir}/girepository-1.0
  127. %{_mandir}/man*/*
  128. %dir %{_sysconfdir}/pango
  129. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  130. %files devel
  131. %defattr(-, root, root)
  132. %{_libdir}/libpango*.so
  133. %{_includedir}/*
  134. %{_libdir}/pkgconfig/*
  135. %{_datadir}/gtk-doc/*
  136. %{_datadir}/gir-1.0
  137. %if %{build_compat32}
  138. %files -n compat32-%{name}
  139. %defattr(-, root, root)
  140. %{_libdir}/libpango*-*.so.*
  141. %{_bindir}/pango-querymodules%{_querymodules_suffix}
  142. %{_libdir}/pango
  143. %dir %{_sysconfdir}/pango/%{_arch}
  144. %ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
  145. %files -n compat32-%{name}-devel
  146. %defattr(-, root, root)
  147. %{_libdir}/libpango*.so
  148. %endif
  149. %changelog
  150. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
  151. - new upstream release
  152. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  153. - new upstream release
  154. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
  155. - new upstream release
  156. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
  157. - new upstream release
  158. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
  159. - new upstream release
  160. - update Patch0 (pango-1.31.2-lib64.patch)
  161. - add BuildRequires: harfbuzz-devel
  162. * Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  163. - new upstream release
  164. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  165. - new upstream release
  166. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
  167. - add BuildRequires: libthai-devel
  168. * Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
  169. - new upstream release
  170. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
  171. - new upstream release
  172. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
  173. - new upstream release with security fixes (CVE-2011-0020, 0064)
  174. - add Vendor/Distri tags
  175. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  176. - add BuildRequires: libSM-devel, gobject-introspection-devel
  177. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  178. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  179. - build with rpm-4.8.1-1 for pkg-config file
  180. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  181. - new upstream release
  182. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  183. - new upstream release
  184. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  185. - changed %%makeinstall to make install with DESTDIR option
  186. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  187. - new upstream release
  188. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  189. - new upstream release
  190. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  191. - new upstream release
  192. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  193. - new upstream release
  194. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  195. - new upstream release
  196. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  197. - new upstream release
  198. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  199. - removed %%if !%%{build_compat32} case condition
  200. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  201. - new upstream release
  202. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  203. - new upstream release
  204. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  205. - new upstream release
  206. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  207. - new upstream release
  208. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  209. - new upstream release
  210. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  211. - new upstream release
  212. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  213. - new upstream release
  214. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  215. - spec in UTF-8 actually
  216. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  217. - new upstream release
  218. - rebuilt with xorg-x11 7.3
  219. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  220. - new upstream release
  221. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  222. - used %{?_dist_release}
  223. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  224. - new upstream release
  225. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  226. - new upstream release
  227. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  228. - new upstream release
  229. - added Patch0 instead of Patch5
  230. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  231. - replace build with new environment
  232. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  233. - rebuild with new environment
  234. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  235. - new upstream release
  236. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  237. - new upstream release
  238. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  239. - new upstream release
  240. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  241. - new upstream release
  242. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  243. - new upstream release
  244. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  245. - new upstream release
  246. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  247. - rebuild with cairo-1.2.0
  248. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  249. - add Patch10 to create fake style(italic/bold) for all fonts.
  250. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  251. - This patch is not applied in upstream, but it seems usefull
  252. for us.
  253. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  254. - new upstream release
  255. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  256. - new upstream release
  257. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  258. - new upstream release
  259. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  260. - fix broken dependancy
  261. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  262. - new upstream release
  263. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  264. - new upstream release
  265. - add compat32 package for x86_64 arch support
  266. - add Patch5 for biarch support
  267. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  268. - new upstream release
  269. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  270. - new upstream release
  271. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  272. - new upstream release
  273. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  274. - rebuild with cairo-0.9
  275. - add patch10 to disable building example programs
  276. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  277. - new upstream release
  278. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  279. - new upstream release
  280. - drop obsolete patches
  281. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  282. - new upstream release
  283. - import upstream patches from fedora package.
  284. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  285. - new upstream release
  286. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  287. - new upstream release
  288. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  289. - remove unneeded dependancy to freetype2-devel
  290. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  291. - add patch10 to build against freetype-2.1.7
  292. - rebuild with freetype-2.1.7
  293. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  294. - new upstream release
  295. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  296. - new upstream release
  297. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  298. - new upstream release
  299. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  300. - merge patch1,2 from rawhide package.
  301. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  302. - new upstream release
  303. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  304. - new upstream release
  305. - Build for Vine Linux, specfile are based on rawhide release
  306. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  307. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  308. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  309. - explicitly require pangoxft to be built, so we catch situations such
  310. as xft.pc moving to /usr/X11R6
  311. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  312. hack
  313. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  314. - 1.1.3
  315. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  316. - Require the necessary freetype version, don't just
  317. BuildRequires it (#74744)
  318. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  319. - Own /etc/pango (#73962, Enrico Scholz)
  320. - Remove .la files from the build root
  321. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  322. - require glib 2.0.6-3, try rebuild on more arches
  323. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  324. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  325. as in gdmgreeter)
  326. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  327. - Fix linked list manipulation problem that was causing hang for anaconda
  328. - Fix warning from loading mini-fonts with context == NULL
  329. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  330. - Fix major memory leak in the last patch
  331. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  332. - Actually use language tags at the rendering layer (should fix #68211)
  333. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  334. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  335. - Fix bug causing hex boxes to be misrendered
  336. leaving RPATH (#66005)
  337. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  338. fonts with embedded bitmaps (#67851)
  339. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  340. - Make basic-x shaper work with our big-5 fonts
  341. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  342. - New upstream tarball with hooks for change-on-the fly font rendering
  343. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  344. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  345. ABI changes for pango's OpenType code.
  346. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  347. - Add some Korean aliases that the installer wants
  348. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  349. - automated rebuild
  350. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  351. - devel package requires fontconfig/Xft devel packages
  352. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  353. - rebuild in different environment
  354. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  355. - Snapshot with Xft2/fontconfig support
  356. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  357. - Version 1.0.2
  358. - Patch for charmaps problem
  359. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  360. - automated rebuild
  361. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  362. - rebuild in different environment
  363. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  364. - add patch to adjust to newer version of freetype
  365. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  366. - Update to version 1.0.1, remove patch
  367. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  368. - Patch from CVS for big speedup with FreeType-2.0.9
  369. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  370. - Rebuild
  371. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  372. - Version 1.0.0
  373. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  374. - Update to 0.26
  375. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  376. - Bump for rebuild
  377. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  378. - Update to 0.25
  379. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  380. - add horrible buildrequires hack
  381. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  382. - 0.24.90 cvs snap
  383. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  384. - Version 0.24
  385. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  386. - automated rebuild
  387. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  388. - new snap 0.23.90
  389. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  390. - rebuild with 64-bit-fixed glib
  391. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  392. - Version 0.22
  393. - add explicit check for required glib2 version before we do the build,
  394. so we don't end up with bad RPMs on --nodeps builds
  395. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  396. no one had updated recently
  397. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  398. - Version 0.21
  399. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  400. - cvs snap
  401. - new cvs snap with a bugfix
  402. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  403. - sync with Owen's changes, fix up dependency versions
  404. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  405. - 0.19
  406. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  407. - build CVS snap
  408. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  409. - no relinking junk
  410. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  411. - Version 0.18
  412. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  413. - Configure --disable-gtk-doc
  414. - BuildRequires freetype-devel, XFree86-devel
  415. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  416. - 0.17
  417. - libtool hackarounds
  418. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  419. - 0.16, rename back to pango from pango-gtkbeta
  420. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  421. - Obsolete fribidi-gtkbeta
  422. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  423. - Remove that patch I just put in
  424. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  425. - Patch pangox.pc.in to include -Iincludedir
  426. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  427. - final 0.13
  428. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  429. - New 0.13 tarball
  430. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  431. - 0.13pre1
  432. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  433. - Rename to 0.12b to avoid versioning problems
  434. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  435. - Move to a CVS snapshot
  436. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  437. - Move back to /usr
  438. - Version 0.12
  439. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  440. - Add missing %%defattr
  441. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  442. - Rebuild with a prefix of /opt/gtk-beta
  443. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  444. - version 0.11
  445. - add --without-qt
  446. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  447. - Make the devel package require *-gtkbeta-* not the normal packages.
  448. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  449. - GTK+ snapshot version installing in /opt/gtk-beta
  450. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  451. - Created spec file