totem-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.36.0
  5. %define _gtk_ver 3.8.0
  6. %define _gnomeicon_ver 3.8.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.11.93
  10. %define _gstpb_ver 0.11.93
  11. %define _gstpg_ver 0.11.93
  12. %define _gstpbad_ver 0.11.93
  13. %define _xulrunner_ver 1.9
  14. %define _nautilus_ver 3.8.0
  15. %define _shared_mime_info_ver 0.17
  16. %define _unique_ver 1.0
  17. %define _totem_pl_parser_ver 3.4.4
  18. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  19. %define mozplug_dir %{_libdir}/mozilla/plugins
  20. Summary: Movie player for GNOME 3
  21. Summary(ja): GNOME3 用動画プレイヤー
  22. Name: totem
  23. Version: 3.8.2
  24. Release: 1%{?_dist_release}
  25. License: GPL
  26. Group: Applications/Multimedia
  27. URL: http://www.gnome.org/projects/totem/
  28. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: Takemikaduchi
  33. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: dbus-devel >= %{_dbus_ver}
  36. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  37. BuildRequires: gettext
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: yelp-tools
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: grilo-devel
  43. BuildRequires: bluez-libs-devel >= 4.15
  44. BuildRequires: lirc
  45. BuildRequires: unique-devel >= %{_unique_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pylint
  48. BuildRequires: pygobject3-devel
  49. BuildRequires: libpeas-devel
  50. BuildRequires: libXtst-devel
  51. BuildRequires: gsettings-desktop-schemas-devel
  52. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  53. BuildRequires: vala
  54. BuildRequires: gstreamer1-devel >= %{_gst_ver}
  55. BuildRequires: gstreamer1-plugins-base-devel >= %{_gstpb_ver}
  56. BuildRequires: gstreamer1-plugins-good >= %{_gstpg_ver}
  57. BuildRequires: gstreamer1-plugins-bad-free-devel >= %{_gstpbad_ver}
  58. BuildRequires: clutter-gtk-devel
  59. BuildRequires: clutter-gst-devel
  60. BuildRequires: libmx-devel
  61. %if %{build_plugin}
  62. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  63. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  64. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  65. %endif
  66. Requires: gstreamer1 >= %{_gst_ver}
  67. Requires: gstreamer1-plugins-base >= %{_gstpb_ver}
  68. Requires: gstreamer1-plugins-good >= %{_gstpg_ver}
  69. Requires: gstreamer1-plugins-bad-free >= %{_gstpbad_ver}
  70. Requires: iso-codes
  71. Obsoletes: nautilus-media
  72. Obsoletes: %{name}-gstreamer < 2.30.1-2
  73. Obsoletes: %{name}-xine < 2.30.1-2
  74. Obsoletes: %{name}-common < 2.30.1-3
  75. Provides: nautilus-media
  76. Provides: %{name}-common = %{version}-%{release}
  77. Requires(post): ldconfig, desktop-file-utils, GConf2
  78. Requires(postun): ldconfig, desktop-file-utils
  79. Requires(preun): GConf2
  80. %description
  81. Totem is simple movie player for the Gnome desktop. It features a
  82. simple playlist, a full-screen mode, seek and volume controls, as well as
  83. a pretty complete keyboard navigation.
  84. %if %{build_plugin}
  85. %package mozilla
  86. Summary: Totem movie plugin for Mozilla
  87. Summary(ja): Mozilla 用 Totem 動画プラグイン
  88. Group: Applications/Internet
  89. Requires: %{name} = %{version}-%{release}
  90. Obsoletes: %{name}-mozilla-common
  91. Obsoletes: %{name}-mozilla-gstreamer
  92. Obsoletes: %{name}-mozilla-xine
  93. %description mozilla
  94. Totem is simple movie player for the Gnome desktop. It features a
  95. simple playlist, a full-screen mode, seek and volume controls, as well as
  96. a pretty complete keyboard navigation.
  97. This package contains a Totem video plugin for Mozilla. It allows Totem
  98. movie player to be embedded into a web browser.
  99. %endif
  100. %package devel
  101. Summary: Plugin writer's documentation for totem
  102. Group: Development/Libraries
  103. Requires: %{name} = %{version}-%{release}
  104. %description devel
  105. The %{name}-devel package contains API documentation for
  106. developing developing plugins for %{name}.
  107. %prep
  108. %setup -q
  109. %build
  110. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-1.0 --print-all > /dev/null
  111. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  112. %configure \
  113. --enable-python \
  114. --enable-vala \
  115. --enable-nautilus \
  116. --enable-gmp-plugin \
  117. --enable-narrowspace-plugin \
  118. --enable-mully-plugin \
  119. --disable-vegas-plugin \
  120. %if %{build_plugin}
  121. --enable-browser-plugins
  122. %else
  123. --disable-browser-plugins
  124. %endif
  125. make %{?_smp_mflags}
  126. %install
  127. rm -rf $RPM_BUILD_ROOT
  128. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  129. make install DESTDIR=$RPM_BUILD_ROOT
  130. # remove unneeded files
  131. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  132. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  133. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  134. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  135. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  136. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  137. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  138. # remove unused file
  139. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  140. %find_lang %{name} --with-gnome
  141. # save space by linking identical images in translated docs
  142. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  143. for f in $helpdir/C/figures/*.png; do
  144. b="$(basename $f)"
  145. for d in $helpdir/*; do
  146. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  147. g="$d/figures/$b"
  148. if [ -f "$g" ]; then
  149. if cmp -s $f $g; then
  150. rm "$g"; ln -s "../../C/figures/$b" "$g"
  151. fi
  152. fi
  153. fi
  154. done
  155. done
  156. %clean
  157. %__rm -rf %{buildroot}
  158. %post
  159. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  160. touch %{_datadir}/icons/hicolor
  161. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  162. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  163. fi
  164. %postun
  165. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  166. touch %{_datadir}/icons/hicolor
  167. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  168. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  169. fi
  170. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  171. %posttrans
  172. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  173. %files -f %{name}.lang
  174. %defattr(-,root,root,-)
  175. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  176. %{_bindir}/totem
  177. %{_bindir}/totem-audio-preview
  178. %{_bindir}/totem-video-thumbnailer
  179. %{_datadir}/GConf/gsettings/opensubtitles.convert
  180. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  181. %{_datadir}/GConf/gsettings/totem.convert
  182. %{_datadir}/applications/%{name}.desktop
  183. %{_datadir}/glib-2.0/schemas/*.xml
  184. %{_datadir}/icons/*/*/*/*
  185. %{_datadir}/thumbnailers/totem.thumbnailer
  186. %{_datadir}/%{name}
  187. %{_datadir}/gtk-doc/html/totem
  188. %{_libdir}/libtotem.so.*
  189. %{_libdir}/girepository-1.0/*.typelib
  190. %dir %{_libdir}/totem
  191. %dir %{_libdir}/totem/plugins
  192. %{_libdir}/totem/plugins/apple-trailers/
  193. %{_libdir}/totem/plugins/autoload-subtitles
  194. %{_libdir}/totem/plugins/brasero-disc-recorder
  195. %{_libdir}/totem/plugins/chapters
  196. %{_libdir}/totem/plugins/dbus
  197. %{_libdir}/totem/plugins/grilo
  198. %{_libdir}/totem/plugins/gromit
  199. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  200. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  201. %{_libdir}/totem/plugins/lirc
  202. %{_libdir}/totem/plugins/media-player-keys
  203. %{_libdir}/totem/plugins/ontop
  204. %{_libdir}/totem/plugins/opensubtitles
  205. %{_libdir}/totem/plugins/properties
  206. %{_libdir}/totem/plugins/pythonconsole
  207. %{_libdir}/totem/plugins/recent
  208. %{_libdir}/totem/plugins/rotation
  209. %{_libdir}/totem/plugins/screensaver
  210. %{_libdir}/totem/plugins/screenshot
  211. %{_libdir}/totem/plugins/skipto
  212. %{_libdir}/totem/plugins/save-file/libsave-file.so
  213. %{_libdir}/totem/plugins/save-file/save-file.plugin
  214. %if %{build_plugin}
  215. %{_libdir}/nautilus/extensions-3.0/*.so*
  216. %endif
  217. %{_libexecdir}/%{name}/totem-bugreport.py
  218. %{_mandir}/man1/*
  219. %if %{build_plugin}
  220. %files mozilla
  221. %defattr(-,root,root,-)
  222. %{mozplug_dir}/*
  223. %{_libexecdir}/totem-plugin-viewer
  224. %endif
  225. %files devel
  226. %defattr(-, root, root,-)
  227. %{_includedir}/totem
  228. %{_libdir}/libtotem.so
  229. %{_libdir}/pkgconfig/totem.pc
  230. %{_datadir}/gir-1.0/Totem-1.0.gir
  231. %{_datadir}/gtk-doc/html/totem
  232. %changelog
  233. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  234. - new upstream release
  235. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  236. - new upstream release
  237. - add BuildRequires: yelp-tools, vala
  238. - change configure option (--enable-vala)
  239. * Thu Nov 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  240. - new upstream release
  241. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  242. - new upstream release
  243. - change BuildRequires: gstreamer1-plugins-bad-free-devel instead of gstreamer1-plugins-bad-free
  244. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  245. - new upstream release
  246. - add BuildRequires: gsettings-desktop-schemas-devel, gstreamer1-plugins-bad-free, grilo-devel
  247. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  248. - new upstream release
  249. * Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  250. - add configure option (--disable-vegas-plugin)
  251. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  252. - new upstream release
  253. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  254. - new upstream release
  255. - add BuildRequires: pylint
  256. - remove BuildRequires: libgdata-devel
  257. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  258. - new upstream release
  259. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  260. - new upstream release
  261. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  262. - new upstream release
  263. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  264. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  265. - new upstream release
  266. - change BuildRequires: gtk3-devel instead of gtk2-devel
  267. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  268. clutter-gst-devel, libmx-devel
  269. - change configure option (--disable-vala)
  270. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  271. - new upstream release
  272. - fix %files
  273. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  274. - new upstream release
  275. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  276. - clean up spec file
  277. - remove totem-common and merged to totem main package.
  278. - add Obsoletes: totem-common
  279. - remove unneeded BR: and R:
  280. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  281. - libmusicbrainz, alternatives
  282. - remove explicit dependency
  283. - gtk2, glib2, dbus
  284. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  285. - add R: gstreamer-plugins-good
  286. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  287. - rebuild with libgdata (add youtube plugin)
  288. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  289. - add Obsolete: totem-gstreamer, totem-xine)
  290. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  291. - new upstream release
  292. - chagnge _gst_ver from 0.10.19 to 0.10.29
  293. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  294. - new upstream release
  295. - drop totem-tracker package
  296. - add BuildRequires: unique-devel
  297. - remove BuildRequires: hal-devel
  298. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  299. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  300. - remove unneeded autoreconf
  301. - add BR: lirc
  302. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  303. - new upstream release
  304. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  305. - remove bemused plugin
  306. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  307. - new upstream release
  308. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  309. - added tracker video search sub-package
  310. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  311. - new upstream release
  312. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  313. - new upstream release
  314. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  315. - remove libxine dependency from totem-common
  316. - build xine backend with minimum dependency
  317. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  318. - add BR: bluez-libs-devel >= 4.15
  319. - fix typo in %%postun xine
  320. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  321. - rebuild with bluez-libs-devel-4.15
  322. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  323. - new upstream release
  324. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  325. - new upstream release
  326. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  327. - new upstream release
  328. - add patch1 to build with xulrunner-1.9
  329. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  330. - new upstream release
  331. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  332. - new upstream release
  333. - disabled devel package (replaced by totem-pl-parser-devel)
  334. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  335. - new upstream release
  336. - update version macros
  337. - enable browser plugins on x86_64
  338. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  339. - new upstream release
  340. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  341. - upstream release
  342. - drop obsolete ja.po.patch (patch0)
  343. - revert change of 1.4.4-0vl2
  344. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  345. - upstream release
  346. - enable browser plugins (exclude x86_64 arch)
  347. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  348. - upstream release
  349. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  350. - update configure options
  351. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  352. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  353. - fix mistranslation (patch0)
  354. - add icon symlink
  355. - add BuildRequires: gstreamer-plugins-good
  356. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  357. - upstream release
  358. - update %%_glib_ver, %%_xine_ver
  359. - add BuildRequires: hal
  360. - update %%configure options
  361. - update %%files
  362. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  363. - upstream release
  364. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  365. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  366. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  367. - upstream release
  368. - drop obsolete patch0
  369. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  370. - upstream release
  371. - add patch0 to build with intltool-0.35
  372. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  373. - upstream release
  374. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  375. - upstream release
  376. - update alternatives entry
  377. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  378. - upstream release
  379. - drop fix-sort-function.patch (was merged to upstream, #331426)
  380. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  381. - rebuild with gnome-2.14rc
  382. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  383. - upstream release
  384. - add macros
  385. - _gtk_ver, _glib_ver
  386. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  387. - _dbus_ver
  388. - _gst_ver, gstpb_ver, _xine_ver
  389. - add fix-sort-function.patch to build with glib < 2.9.1
  390. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  391. - upstream release
  392. - add BuildRequires:
  393. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  394. - gnome-vfs2-devel >= 2.9.92
  395. - dbus-devel >= 0.35
  396. - use gstreamer-0.10 as backend for totem-gstreamer
  397. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  398. - use gstreamer08 instead of gstreamer
  399. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  400. - upstream release
  401. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  402. - fix missing links
  403. - update file list
  404. - update update-alternatives scripts
  405. - fix totem-gstreamer's %%postun script
  406. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  407. - upstream release
  408. - add BuildRequires: iso-codes, libmusicbrainz-devel
  409. - add Requires: iso-codes, libmusicbrains to -common package
  410. - remove BuildRequires: nautilus-cd-burner
  411. - remove Requires: nautilus-cd-burner from -common package
  412. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  413. - totem-gstreamer obsoletes nautilus-media
  414. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  415. - upstream release
  416. - add Requires(post,postun): alternatives for gstreamer,xine
  417. - add Requires(postun,triggers): alternatives for common
  418. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  419. - upstream release
  420. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  421. - build xine backend
  422. - move common files to common package
  423. - move GStreamer related files to gstreamer package
  424. - install xine related files to xine package
  425. - fix scripts
  426. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  427. - upstream release
  428. - update URL
  429. - move *.{a,la} to devel package
  430. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  431. - fix %%{post,preun} script (video-thumbnail.schemas)
  432. - sync with Fedora Core's 1.0.1-1
  433. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  434. - Update to upstream version 1.0.1
  435. - Break out devel package
  436. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  437. - add %%{post,pre}un script
  438. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  439. - initial build for Vine Linux
  440. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  441. - fix %%post
  442. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  443. - Obsolete nautilus-media
  444. - Install property page and thumbnailer
  445. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  446. - Update to 0.101
  447. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  448. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  449. missing menu entry (144088)
  450. - Remove workaround for desktop file being misinstalled, fixed
  451. by above patch
  452. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  453. - New upstream version 0.100
  454. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  455. - update to 0.99.22
  456. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  457. - Add patch to remove removed items from package from help
  458. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  459. - New upstream 0.99.19
  460. - Fixes crasher with CD playback (see NEWS)
  461. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  462. - Call update-desktop-database in post
  463. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  464. - update to 0.99.18
  465. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  466. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>