grep-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. Summary: The GNU versions of grep pattern matching utilities.
  2. Summary(ja): GNU版 grep パターンマッチングユーティリティ
  3. Name: grep
  4. Version: 2.5.1
  5. Release: 60%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Base
  8. Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}a.tar.bz2
  9. Patch0: grep-2.5.1-fgrep.patch
  10. Patch1: grep-2.5.1-bracket.patch
  11. Patch2: grep-2.5-i18n.patch
  12. Patch3: grep-2.5.1-oi.patch
  13. Patch4: grep-2.5.1-manpage.patch
  14. Patch5: grep-2.5.1-color.patch
  15. Patch6: grep-2.5.1-icolor.patch
  16. Patch10: grep-2.5.1-egf-speedup.patch
  17. Patch11: grep-2.5.1-dfa-optional.patch
  18. Patch12: grep-2.5.1-tests.patch
  19. Patch13: grep-2.5.1-w.patch
  20. Patch14: grep-P.patch
  21. Patch15: grep-mem-exhausted.patch
  22. Patch16: grep-empty-pattern.patch
  23. Patch100: grep-2.5.1-egf-non-utf8-null-break.patch
  24. URL: http://www.gnu.org/software/grep/
  25. Prereq: /sbin/install-info
  26. Buildroot: %{_tmppath}/%{name}-%{version}-root
  27. Buildrequires: texinfo, gettext, gzip
  28. %description
  29. The GNU versions of commonly used grep utilities. Grep searches
  30. through textual input for lines which contain a match to a specified
  31. pattern and then prints the matching lines. GNU's grep utilities
  32. include grep, egrep and fgrep.
  33. You should install grep on your system, because it is a very useful
  34. utility for searching through text.
  35. %description -l ja
  36. 一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
  37. する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
  38. ティにはgrep, egrep, fgrepが入っています。
  39. テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
  40. してください。
  41. %prep
  42. %setup -q -n %{name}-%{version}a
  43. %patch0 -p1 -b .fgrep
  44. %patch1 -p1 -b .bracket
  45. %patch2 -p1 -b .i18n
  46. %patch3 -p1 -b .oi
  47. %patch4 -p1 -b .manpage
  48. %patch5 -p1 -b .color
  49. %patch6 -p1 -b .icolor
  50. %patch10 -p1 -b .egf-speedup
  51. %patch11 -p1 -b .dfa-optional
  52. %patch12 -p1 -b .tests
  53. %patch13 -p1 -b .w
  54. %patch14 -p1 -b .P
  55. %patch15 -p1 -b .mem-exhausted
  56. %patch16 -p1 -b .empty-pattern
  57. %patch100 -p1 -b egf-non-utf8-null-break
  58. chmod a+x tests/fmbtest.sh
  59. %build
  60. [ ! -e configure ] && ./autogen.sh
  61. %configure CPPFLAGS="-I%{_includedir}/pcre" \
  62. --prefix=%{_prefix} \
  63. --disable-perl-regexp \
  64. --without-included-regex
  65. make
  66. %install
  67. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  68. %makeinstall prefix=$RPM_BUILD_ROOT%{_prefix} exec_prefix=$RPM_BUILD_ROOT
  69. %ifos Linux
  70. mkdir -p $RPM_BUILD_ROOT/bin
  71. mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin
  72. rm -rf $RPM_BUILD_ROOT%{_prefix}/bin
  73. %endif
  74. gzip -9f $RPM_BUILD_ROOT%{_infodir}/grep*
  75. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  76. # Use symlinks for egrep and fgrep
  77. ln -sf grep $RPM_BUILD_ROOT/bin/egrep
  78. ln -sf grep $RPM_BUILD_ROOT/bin/fgrep
  79. %find_lang %{name}
  80. %check
  81. make check
  82. %clean
  83. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  84. %post
  85. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
  86. %preun
  87. if [ $1 = 0 ]; then
  88. [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
  89. fi
  90. %files -f %{name}.lang
  91. %defattr(-,root,root)
  92. %doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog
  93. %ifos Linux
  94. /bin/*
  95. %else
  96. %{_prefix}/bin/*
  97. %endif
  98. %{_infodir}/*.info.gz
  99. %{_mandir}/*/*
  100. %changelog
  101. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
  102. - rebuilt against current toolchain
  103. - fix license tag
  104. - use CPPFLAGS= argument to configure to add an -I option.
  105. - Do not set LDFLAGS=-s for "make install".
  106. * Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
  107. - rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
  108. - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
  109. - applied new versioning policy, spec in utf-8
  110. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
  111. - rebuild for Vine Linux 4.x
  112. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
  113. - add Patch100 to fix infinite loop with 'grep -F'
  114. thanks to M.H (<BTS:484>)
  115. - based on Fedora devel 2.5.1-57
  116. * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
  117. - Make preun scriptlet unconditionally succeed (bug #223697).
  118. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
  119. - Fixed count of patterns when the last is an empty string (bug #204255).
  120. * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
  121. - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
  122. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
  123. - rebuild
  124. * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
  125. - Applied upstream patch to fix '-D skip' (bug #189580).
  126. * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
  127. - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
  128. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
  129. - bump again for double-long bug on ppc(64)
  130. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
  131. - rebuilt for new gcc4.1 snapshot and glibc changes
  132. * Fri Feb 3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
  133. - Prevent 'grep -P' from segfaulting (bug #171379).
  134. * Sat Oct 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
  135. - changed Group to System Environment/Base
  136. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
  137. - based on Fedora development 2.5.1-50
  138. * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
  139. - Futher fixing for bug #161700.
  140. * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
  141. - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
  142. * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
  143. - Build requires recent pcre-devel (bug #154626).
  144. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
  145. - Run 'make check'.
  146. - Fixed -w handling for EGexecute. Now 'make check' passes.
  147. - Cache MB_CUR_MAX value in egf-speedup patch.
  148. - Fixed variable shadowing in egf-speedup patch.
  149. - Removed redundant (and incorrect) code in prline.
  150. * Fri Jan 7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
  151. - More -w tests from Jakub Jelinek.
  152. - Rebased on 2.5.1a.
  153. * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
  154. - More tests (Jakub Jelinek).
  155. - Jakub Jelinek's much improved -Fi algorithm.
  156. - Removed bogus part of grep-2.5.1-fgrep patch.
  157. * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
  158. - Fixed -Fi for multibyte input (bug #143079).
  159. * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
  160. - Bypass kwset matching when ignoring case and processing multibyte input
  161. (bug #143079).
  162. * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
  163. - Further UTF-8 processing avoided since a '\n' byte is always an
  164. end-of-line character in that encoding.
  165. * Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
  166. - Fixed a busy loop in the egf-speedup patch (bug #140781).
  167. * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
  168. - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
  169. (bug #138558).
  170. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
  171. - Fixed last patch.
  172. * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
  173. - Applied patch from Karsten Hopp to fix background colour problems with
  174. --color output (bug #138913).
  175. * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
  176. - Prevent false matches when DFA is disabled (bug #138558).
  177. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
  178. - Automatically disable DFA when processing multibyte input. GREP_USE_DFA
  179. environment variable overrides.
  180. * Fri Nov 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
  181. - Fixes to egf-speedup patch: now it does not change any functionality,
  182. as intended.
  183. - GREP_NO_DFA now turns off the DFA engine, for performance testing.
  184. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
  185. - More improvements to egf-speedup patch (bug #138076).
  186. * Thu Nov 4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
  187. - Small improvements to egf-speedup patch.
  188. * Wed Nov 3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
  189. - Remove mb-caching hack.
  190. - Better multibyte handling in EGexecute() and Fexecute().
  191. - Don't need regex.c changes in grep-2.5-i18n.patch.
  192. * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
  193. - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
  194. multibyte characters (bug #133932).
  195. * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
  196. - Applied patch from Robert Scheck to tidy spec file and add a URL
  197. tag (bug #135185).
  198. * Sun Sep 5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
  199. - based on Fedora development 2.5.1-29
  200. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  201. - More build requirements (bug #125323).
  202. * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
  203. - Fix dfa multibyte character class matching when -i is used (bug #123363).
  204. - Use bracket patch before i18n patch to make it clear that the bug exists
  205. upstream.
  206. * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
  207. - Fix fgrep (bug #116909).
  208. * Mon Jan 5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
  209. - Work around glibc bug #112869 (segfault in re_compile_pattern).
  210. - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
  211. * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
  212. - Another multibyte efficiency bug-fix (bug #111800).
  213. * Mon Dec 8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
  214. - Fixed [:alpha:]-type character classes (bug #108484).
  215. - Fixed -o -i properly (bug #111489).
  216. * Sat Dec 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
  217. - Fixed 'fgrep -i' (bug #111614).
  218. * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
  219. - Another two multibyte efficiency bug-fixes (bug #110524).
  220. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
  221. - Fixed a multibyte efficiency bug.
  222. * Thu Nov 6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
  223. - Turn on multibyte efficiency patch again to shake out bugs.
  224. * Wed Oct 8 2003 Tim Waugh <twaugh@redhat.com>
  225. - Fixed man page bug (bug #106267).
  226. * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
  227. - Use symlinks for egrep/fgrep, rather than shell script wrappers.
  228. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
  229. - Fix debuginfo package.
  230. * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
  231. - Finally give up on making grep go fast. :-(
  232. * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
  233. - Fixed grep -i bug introduced by cache.
  234. * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
  235. - Redo the gofast patch (bug #97785).
  236. * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
  237. - Fixed a bug in the gofast patch (bug #97266).
  238. * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
  239. - Go faster (bug #69900).
  240. - Fix man page.
  241. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
  242. - Use system regex again.
  243. * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
  244. - Fixed bug in go-fast patch.
  245. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
  246. - Go fast (bug #69900).
  247. - Run test suite.
  248. - rebuild with new toolchains
  249. - build with --disable-prel-regexp option
  250. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
  251. - based on Rawhide 2.5.1-7
  252. - Don't install /usr/share/info/dir.
  253. - Fix -o -i (bug #72641).
  254. - i18n patch.
  255. * Sat Jul 6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  256. - 2.5-0vl1
  257. - update to 2.5
  258. - change i18n patch
  259. * Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  260. - 2.5-0vl1
  261. - update to 2.5
  262. - change i18n patch
  263. * Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  264. - 2.4.2-4vl1
  265. - usr better macros (%%configure/%%makeinstall)
  266. * Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
  267. - 2.4-3vl1
  268. - merge ja patch
  269. * Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  270. - gzip info pages (Bug #9035)
  271. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  272. - fix description
  273. * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
  274. - update to 2.4.
  275. * Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
  276. - prereq install-info
  277. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  278. - auto rebuild in the new build environment (release 2)
  279. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  280. - upgraded to grep 2.3, added install-info %post/%preun for info
  281. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  282. - Injected new description and group.
  283. * Sat May 09 1998 Prospector System <bugs@redhat.com>
  284. - translations modified for de, fr, tr
  285. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  286. - updated to 2.2
  287. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  288. - updated from 2.0 to 2.1
  289. - spec file cleanups
  290. - added BuildRoot
  291. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  292. - built against glibc