gnome-bluetooth-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406
  1. Summary: GNOME Bluetooth Subsystem
  2. Summary(ja): GNOME Bluetooth サブシステム
  3. Name: gnome-bluetooth
  4. Version: 2.28.6
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://live.gnome.org/GnomeBluetooth
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/0.11/%{name}-%{version}.tar.bz2
  10. Source1: 61-gnome-bluetooth-rfkill.rules
  11. #----------------------------------------------------------------------------
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. #----------------------------------------------------------------------------
  14. #BuildRequires: autoconf >= 2.57
  15. BuildRequires: bluez-libs-devel >= 2.8
  16. #BuildRequires: bluez-utils
  17. BuildRequires: libgnomeui-devel >= 2.2
  18. BuildRequires: libbonobo-devel >= 2.0
  19. BuildRequires: GConf2-devel >= 2.0
  20. BuildRequires: hal-devel
  21. BuildRequires: unique-devel
  22. BuildRequires: libnotify-devel
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: intltool, automake, libtool, gettext
  25. Requires: %{name}-libs = %{version}-%{release}
  26. Requires(pre): GConf2
  27. Requires(post): GConf2
  28. Requires(preun): GConf2
  29. Requires: bluez >= 4.42
  30. Requires: obexd
  31. ExcludeArch: s390 s390x
  32. ## Patch1: gnome-bluetooth-0.8.0-desktop.patch
  33. #----------------------------------------------------------------------------
  34. %description
  35. This package contains a library with widgets for Bluetooth applications.
  36. %description -l ja
  37. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  38. ライブラリが含まれます。
  39. #----------------------------------------------------------------------------
  40. %package libs
  41. Summary: Libraries for applications, which use gnome-bluetooth
  42. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  43. Group: Development/Libraries
  44. %description libs
  45. This package contains the libraries for applications,
  46. which use gnome-bluetooth.
  47. %description libs -l ja
  48. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  49. ライブラリが含まれています。
  50. #----------------------------------------------------------------------------
  51. %package devel
  52. Summary: Files for the development of applications, which use gnome-bluetooth
  53. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  54. Group: Development/Libraries
  55. License: LGPLv2+
  56. Requires: %{name}-libs = %{version}-%{release}
  57. Requires: gtk-doc pkgconfig
  58. Requires: glib2-devel
  59. Requires: libbtctl-devel
  60. %description devel
  61. This package contains the files for the development of applications,
  62. which will use gnome-bluetooth.
  63. %description devel -l ja
  64. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  65. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  66. #----------------------------------------------------------------------------
  67. %prep
  68. %setup -q -n gnome-bluetooth-%{version}
  69. ## %patch1 -p1 -b .dfix
  70. %build
  71. %configure --disable-desktop-update --disable-icon-update
  72. make %{?_smp_mflags}
  73. #----------------------------------------------------------------------------
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. # we do not want .la files
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
  81. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  82. # Remove the gnome-obex-server
  83. # rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
  84. %find_lang gnome-bluetooth2
  85. %find_lang %{name} --with-gnome
  86. cat %{name}.lang >> gnome-bluetooth2.lang
  87. # save space by linking identical images in translated docs
  88. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  89. for f in $helpdir/C/figures/*.png; do
  90. b="$(basename $f)"
  91. for d in $helpdir/*; do
  92. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  93. g="$d/figures/$b"
  94. if [ -f "$g" ]; then
  95. if cmp -s $f $g; then
  96. rm "$g"; ln -s "../../C/figures/$b" "$g"
  97. fi
  98. fi
  99. fi
  100. done
  101. done
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %pre
  105. #if [ "$1" -gt 1 ]; then
  106. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  107. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  108. # gconftool-2 --makefile-uninstall-rule \
  109. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  110. # fi
  111. #fi
  112. if [ "$1" -gt 1 ]; then
  113. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  114. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  115. gconftool-2 --makefile-uninstall-rule \
  116. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  117. fi
  118. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  119. gconftool-2 --makefile-uninstall-rule \
  120. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  121. >& /dev/null || :
  122. fi
  123. fi
  124. %post
  125. scrollkeeper-update -q
  126. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  127. gconftool-2 --makefile-install-rule \
  128. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  129. >& /dev/null || :
  130. %preun
  131. #if [ "$1" -eq 0 ]; then
  132. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  133. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  134. # gconftool-2 --makefile-uninstall-rule \
  135. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  136. # fi
  137. #fi
  138. if [ "$1" -eq 0 ]; then
  139. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  140. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  141. gconftool-2 --makefile-uninstall-rule \
  142. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  143. fi
  144. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  145. gconftool-2 --makefile-uninstall-rule \
  146. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  147. >& /dev/null || :
  148. fi
  149. fi
  150. %postun
  151. scrollkeeper-update -q
  152. if [ $1 -eq 0 ] ; then
  153. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  154. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  155. fi
  156. %post libs
  157. /sbin/ldconfig
  158. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  159. %posttrans libs
  160. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  161. %postun libs
  162. /sbin/ldconfig
  163. if [ $1 -eq 0 ] ; then
  164. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  165. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  166. fi
  167. #----------------------------------------------------------------------------
  168. %files -f %{name}.lang
  169. %defattr(-, root, root)
  170. %doc README NEWS COPYING
  171. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas
  172. %{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
  173. %{_bindir}/bluetooth-*
  174. %{_libdir}/gnome-bluetooth/
  175. %{_datadir}/applications/*.desktop
  176. %{_datadir}/gnome-bluetooth/
  177. %{_datadir}/locale/*
  178. %{_mandir}/man1/*
  179. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  180. %files libs
  181. %defattr(-,root,root,-)
  182. %doc COPYING.LIB
  183. %{_libdir}/libgnome-bluetooth.so.*
  184. %{_datadir}/icons/hicolor/*/apps/*
  185. %{_datadir}/icons/hicolor/*/status/*
  186. %files devel
  187. %defattr(-,root,root,-)
  188. %{_includedir}/gnome-bluetooth/
  189. %{_libdir}/libgnome-bluetooth.so
  190. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  191. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  192. #----------------------------------------------------------------------------
  193. # Maintainers: babasaki@mindgear.org
  194. #
  195. #----------------------------------------------------------------------------
  196. %changelog
  197. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  198. - new upstream release
  199. - merge spec file from FC package
  200. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  201. - Update to 0.11.0 (VineSeed)
  202. - added "# Maintainers: " comments.
  203. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  204. - FedoraCore - LOGS
  205. -- 0.11.0-5
  206. -- Rebuild against new bluez-libs
  207. -- 0.11.0-4
  208. -- Changed name of icon file(#444811)
  209. -- 0.11.0-3
  210. -- Remove gnome-obex-server, we should use gnome-user-share now
  211. -- 0.11.0-1
  212. -- gcc43 rebuild
  213. -- 0.11.0 - Update to 0.11.0
  214. -- 0.10.0 - Update to 0.10.0
  215. -- 0.9.1-4
  216. -- marked gnome-obex-server.schemas as config file
  217. -- changed upstream URL
  218. -- 0.9.1-3
  219. -- fixed wrong source URL
  220. -- 0.9.1-2
  221. -- rebuilt for F8
  222. -- changed license tag to GPLv2 and LGPLv2+
  223. -- 0.9.1-1
  224. -- Upgrade to 0.9.1 to fix a crasher in the server
  225. -- 0.9.0-1
  226. -- Update for 0.9.0
  227. -- Fix installation of the python bindings
  228. -- 0.8.0-4
  229. -- Remove unncessary gconfd killing from scripts (#224561)
  230. -- 0.8.0-3
  231. -- corrected BuildRoot
  232. -- smp flags added
  233. -- specfile cleanup
  234. -- fixed desktop file
  235. - Updated specfile
  236. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  237. - Updated specfile
  238. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  239. - Import gnome-bluetooth - Packager: Babasaki
  240. - Updated specfile (downgrade -> 0.8.0-0vl1)
  241. #----------------------------------------------------------------------------
  242. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  243. - version 0.8.0
  244. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  245. - rebuild
  246. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  247. - bump for new openobex
  248. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  249. - Missing automake, libtool, gettext BR
  250. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  251. - Bump for new libbluetooth
  252. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  253. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  254. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  255. - install schemata correctly (bug #193518)
  256. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  257. - more build requires (bug #193374)
  258. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  259. - pydir fixes for lib64
  260. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  261. - version 0.7.0
  262. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  263. - bump again for double-long bug on ppc(64)
  264. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  265. - rebuilt for new gcc4.1 snapshot and glibc changes
  266. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  267. - rebuilt
  268. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  269. - Fix relative path for the icons in desktop files which no longer works
  270. with the icon cache.
  271. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  272. - new version 0.6.0
  273. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  274. - rebuild for new cairo
  275. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  276. - Minor spec file cleanups.
  277. - Fix relative path for the icons in desktop files which no longer works
  278. with the icon cache.
  279. - Remove useless zero epochs.
  280. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  281. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  282. - removed base requirement from libs
  283. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  284. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  285. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  286. - rebuilt
  287. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  288. - added gnome hbox patch for bug rh#149215
  289. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  290. - added requires for python-abi
  291. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  292. - split package into app, libs and devel
  293. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  294. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  295. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  296. - buildrequire pygtk2-devel (bug 135032)
  297. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  298. - fixed segfault on file receive (bug 133041)
  299. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  300. - buildrequire libbtctl-devel
  301. - buildrequire openobex-devel >= 1.0.1
  302. - pythondir -> pyexecdir
  303. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  304. - added build dependency for librsvg2-devel
  305. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  306. - added pydir patch
  307. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  308. - version 0.5.1
  309. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  310. - rebuilt
  311. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  312. - corrected BuildRequires
  313. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  314. - added EggToolBar patch for gcc34
  315. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  316. - rebuilt
  317. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  318. - rebuilt
  319. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  320. - added autofoo patch
  321. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  322. - add .so to gnome-vfs module, if libtool does not!
  323. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  324. - call libtool finish
  325. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  326. - new version 0.4.1
  327. * Wed Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  328. - initial RPM