gmime-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303
  1. %define apiver 3.0
  2. %define docver 3.2
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: Library for creating and parsing MIME messages
  5. Summary(ja): MIMEメッセージを生成またパースするためのライブラリ
  6. Name: gmime
  7. Version: 3.2.15
  8. Release: 1%{?_dist_release}
  9. Group: system
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: GPL
  13. URL: https://github.com/jstedfast/gmime
  14. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  15. Source0: https://github.com/jstedfast/gmime/releases/download/%{version}/gmime-%{version}.tar.xz
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: glib2-devel >= 2.26.0
  18. BuildRequires: gpgme-devel
  19. BuildRequires: libgpg-error-devel
  20. BuildRequires: pkgconfig(zlib)
  21. BuildRequires: gobject-introspection-devel
  22. BuildRequires: vala
  23. BuildRequires: automake, libtool, gettext, gtk-doc
  24. # Mono only availible on these:
  25. %define mono_archs none
  26. # no mono on s390 for now: s390 s390x
  27. %ifarch %mono_archs
  28. BuildRequires: mono-devel gtk-sharp2-gapi
  29. BuildRequires: gtk-sharp2 >= 2.8.0
  30. %define monodir %{_prefix}/lib/mono
  31. %endif
  32. %description
  33. The GMime suite provides a core library and set of utilities which may be
  34. used for the creation and parsing of messages using the Multipurpose
  35. Internet Mail Extension (MIME).
  36. %package devel
  37. Summary: Header files to develop libgmime applications
  38. Group: programming
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: glib2-devel
  41. %description devel
  42. The GMime suite provides a core library and set of utilities which may be
  43. used for the creation and parsing of messages using the Multipurpose
  44. Internet Mail Extension (MIME). The devel-package contains header files
  45. to develop applications that use libgmime.
  46. %ifarch %mono_archs
  47. %package sharp
  48. Summary: mono bindings for gmime
  49. Group: system
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: gtk-sharp2
  52. %description sharp
  53. The GMime suite provides a core library and set of utilities which may be
  54. used for the creation and parsing of messages using the Multipurpose
  55. Internet Mail Extension (MIME). The devel-package contains support
  56. for developing mono applications that use libgmime.
  57. %endif
  58. %debug_package
  59. %prep
  60. %setup -q
  61. %build
  62. %ifarch %mono_archs
  63. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  64. MONO_ARGS="--enable-mono"
  65. %endif
  66. %configure --disable-static $MONO_ARGS
  67. %make_build V=1
  68. %install
  69. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  70. %make_install
  71. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  72. # Don't conflict with sharutils:
  73. #mv $RPM_BUILD_ROOT%{_bindir}/uuencode $RPM_BUILD_ROOT%{_bindir}/gmime-uuencode
  74. #mv $RPM_BUILD_ROOT%{_bindir}/uudecode $RPM_BUILD_ROOT%{_bindir}/gmime-uudecode
  75. %files
  76. %license COPYING
  77. %doc AUTHORS README* TODO
  78. #%{_bindir}/gmime-uu??code
  79. %{_libdir}/lib*.so.*
  80. %dir %{_libdir}/girepository-1.0
  81. %{_libdir}/girepository-1.0/GMime-3.0.typelib
  82. %files devel
  83. %{_libdir}/lib*.so
  84. %{_libdir}/pkgconfig/gmime-%{apiver}.pc
  85. %{_includedir}/gmime-%{apiver}
  86. %dir %{_datadir}/gir-1.0
  87. %{_datadir}/gir-1.0/GMime-3.0.gir
  88. %dir %{_datadir}/gtk-doc
  89. %dir %{_datadir}/gtk-doc/html
  90. %{_datadir}/gtk-doc/html/gmime-%{docver}
  91. %dir %{_datadir}/vala
  92. %{_datadir}/vala/*
  93. %ifarch %mono_archs
  94. %files sharp
  95. %defattr(-,root,root,-)
  96. %{_libdir}/pkgconfig/gmime-sharp-%{apiver}.pc
  97. %{monodir}/gac/gmime-sharp
  98. %{monodir}/gmime-sharp-%{apiver}
  99. %{_datadir}/gapi-2.0/gmime-api.xml
  100. %endif
  101. %changelog
  102. * Fri Jul 12 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.15-1
  103. - new upstream release.
  104. * Fri May 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.7-1
  105. - new upstream release.
  106. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.3-1
  107. - new upstream release.
  108. - disabled to build mono stuff.
  109. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.20-1
  110. - new upstream release
  111. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.19-2
  112. - rebuild with VineSeed environment
  113. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.19-1
  114. - new upstream release
  115. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.17-1
  116. - new upstream release
  117. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.16-1
  118. - new upstream release
  119. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.15-1
  120. - new upstream release
  121. * Thu Jan 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.13-1
  122. - new upstream release
  123. * Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.12-1
  124. - new upstream release
  125. * Fri Oct 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.11-1
  126. - new upstream release
  127. * Thu Jun 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.10-1
  128. - new upstream release
  129. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.9-1
  130. - new upstream release
  131. * Sun Apr 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.7-1
  132. - new upstream release
  133. - remove Patch4
  134. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  135. - new upstream release
  136. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  137. - new upstream release
  138. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
  139. - new upstream release
  140. - add BuildRequires: gpgme-devel
  141. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.25-1
  142. - new upstream release
  143. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.24-1
  144. - new upstream release
  145. * Wed Jan 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.22-1
  146. - new upstream release
  147. * Tue Dec 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.21-1
  148. - new upstream release
  149. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.20-1
  150. - new upstream release
  151. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.19-1
  152. - new upstream release
  153. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.17-2
  154. - rebuild with rpm-4.8.1 for pkg-config file
  155. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.17-1
  156. - new upstream release
  157. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.15-1
  158. - new upstream release
  159. - fix files for gmime-2.4
  160. - drop Patch1, Patch2, Patch3
  161. * Thu Sep 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.23-1vl5
  162. - new upstream release
  163. - rebuilt with mono-2.0
  164. - added gmime-2.2.23-gacutil.patch
  165. * Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.2.9-1vl5
  166. - applied new versioning policy, spec in utf-8
  167. - updated gmime to 2.2.9
  168. - dropt gmime-2.2.3-libdir.patch
  169. - dropt gmime-2.2.3-automake.patch
  170. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  171. - initial build for Vine Linux
  172. * Tue Feb 6 2007 Alexander Larsson <alexl@redhat.com> - 2.2.3-5
  173. - Fix build with new automake (#224157)
  174. * Thu Oct 12 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-4
  175. - Bump glib requirement to 2.6 (#209565)
  176. * Tue Sep 5 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-3
  177. - fix gmime-config multilib conflict (#205208)
  178. * Sat Aug 19 2006 Matthias Clasen <mclasen@redhat.com> - 2.2.3-2
  179. - Rebuild
  180. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 2.2.3-1
  181. - Upgrade to 2.2.3
  182. - Use the new mono libdir
  183. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
  184. - rebuild
  185. * Fri Jun 9 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-2
  186. - Disable mono parts on s390* as mono doesn't build on s390 atm
  187. * Tue May 23 2006 Alexander Larsson <alexl@redhat.com> - 2.2.1-1
  188. - Update to 2.2.1
  189. - Fix multilib -devel conflict by using pkg-config in gmime-config (#192675)
  190. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.1.19-4
  191. - BuildRequires: gtk-sharp2 on mono archs only
  192. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-3
  193. - Rebuild
  194. * Tue Feb 7 2006 Jesse Keating <jkeating@redhat.com> - 2.1.19-2.1
  195. - rebuilt for new gcc4.1 snapshot and glibc changes
  196. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 2.1.19-2
  197. - Rebuild
  198. * Sun Jan 22 2006 Alexander Larsson <alexl@redhat.com> - 2.1.19-1
  199. - Update to 2.1.19 (needed by beagle 0.2.0)
  200. * Thu Jan 19 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-3
  201. - Build on s390x
  202. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> 2.1.17-2
  203. - build gmime-sharp conditionally on mono arches
  204. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 2.1.17-1
  205. - Move from Extras to Core, Update to 2.1.17, add gmime-sharp subpackage
  206. * Wed Aug 10 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.15-1
  207. - Update to 2.1.15
  208. - Use dist
  209. * Wed May 18 2005 Colin Charles <colin@fedoraproject.org> - 2.1.9-5
  210. - bump release, request build on ppc
  211. * Thu Mar 31 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.1.9-4
  212. - add dep glib2-devel for pkgconfig in -devel package
  213. * Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.3
  214. - Remove ldconfig from Requires pre and post
  215. * Mon Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.2
  216. - BR zlib-devel
  217. - Don't ship empty news file
  218. - Fixes to the files section
  219. - Change ldconfig in post* calls to -p /sbin/ldconfig
  220. * Sun Oct 17 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.9-0.fdr.1
  221. - Initial RPM release.