chromium-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. #% define with_system_icu 1
  7. %endif
  8. %define svn_rev 51404
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 6.0.454.0
  14. Release: 2%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. %{?nosrc:NoSource: 0}
  22. %{?nosrc:NoSource: 1}
  23. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. Source2: repack_chromium_archive.sh
  25. # Script used to create the tar.lzma archive from a checked out source
  26. #Source3: pack_chromium_source.sh
  27. Source3: pack_chromium_source-vine.sh
  28. #Source10: chromium.desktop
  29. Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. #Source31: default_bookmarks.html
  36. #Source31: default_bookmarks.html.vine
  37. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  38. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  39. Provides: chromium-browser = %{version}
  40. #Obsoletes: chromium-browser < %{version}
  41. ## Start Patches
  42. # Many changes to the gyp system so we can use system libraries
  43. # My first ever patch set. I hope I did well.
  44. Patch3: chromium-gyp-system-icu.patch
  45. Patch4: chromium-no-sqlite-debug.patch
  46. Patch5: chromium-gyp-system-04-nss-nspr.patch
  47. Patch7: chromium-codechanges-nss-nspr.patch
  48. Patch8: chromium-codechanges-zlib.patch
  49. #Patch9: chromium-drop-sse.patch
  50. Patch10: chromium-fix-wrapper.patch
  51. Patch12: chromium-no-test-sources.patch
  52. Patch13: chromium-no-courgette.patch
  53. Patch14: chromium-master-prefs-path.patch
  54. #Patch15: chromium-media-probe.patch
  55. Patch16: chromium-icu-code-changes.patch
  56. Patch17: chromium-system-glew.patch
  57. Patch18: chromium-system-expat.patch
  58. Patch19: chromium-system-zlib.patch
  59. Patch20: chromium-noffmpeg.patch
  60. Patch21: chromium-system-old-ffmpeg-way.patch
  61. Patch23: chromium-disable-mmx.patch
  62. Patch24: chromium-fix-yuv_row_posix-shared.patch
  63. Patch25: tcmalloc-factory.patch
  64. # Vine
  65. #Patch40: chromium-5.0.353-no-ffmpeg-vine.patch
  66. ## Gentoo patches
  67. # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
  68. #Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
  69. BuildRequires: gcc gcc-c++
  70. %if %{?_dist_release} == "vl5"
  71. BuildRequires: libstdc++34 libstdc++34-devel
  72. %elseif %{?_dist_release} == "vl6"
  73. BuildRequires: libstdc++ libstdc++-devel
  74. %endif
  75. BuildRequires: libevent
  76. ##!!BuildRequires: pkg-config
  77. BuildRequires: python
  78. ##!!BuildRequires: python-xml
  79. BuildRequires: python-pyxml
  80. BuildRequires: perl bison flex gperf
  81. ##!!BuildRequires: wdiff
  82. ##!!BuildRequires: update-desktop-files
  83. BuildRequires: desktop-file-utils
  84. BuildRequires: lzma
  85. ##!!BuildRequires: mozilla-nss-devel
  86. BuildRequires: nss-devel
  87. ##!!BuildRequires: alsa-devel
  88. BuildRequires: alsa-lib-devel
  89. BuildRequires: gtk2-devel
  90. BuildRequires: glib2-devel
  91. BuildRequires: cairo-devel >= 1.6
  92. ##!!BuildRequires: mozilla-nspr-devel
  93. BuildRequires: nspr-devel
  94. ##!!BuildRequires: gconf2-devel
  95. BuildRequires: GConf2-devel
  96. BuildRequires: freetype2-devel
  97. ##!!BuildRequires: dbus-1-devel
  98. BuildRequires: dbus-devel
  99. BuildRequires: libxslt-devel
  100. BuildRequires: libxml2-devel
  101. BuildRequires: libjpeg-devel
  102. BuildRequires: zlib-devel
  103. ##!!BuildRequires: libbz2-devel
  104. BuildRequires: bzip2-devel
  105. BuildRequires: cups-devel
  106. %if %{?_dist_release} == "vl6"
  107. BuildRequires: fdupes
  108. %endif
  109. ##!!BuildRequires: libexpat-devel
  110. BuildRequires: expat-devel
  111. BuildRequires: libpng-devel
  112. BuildRequires: sqlite3-devel
  113. BuildRequires: gnutls-devel
  114. %if %{?_dist_release} == "vl5"
  115. BuildRequires: gnome-keyring-devel
  116. %elseif %{?_dist_release} == "vl6"
  117. BuildRequires: libgnome-keyring-devel
  118. %endif
  119. BuildRequires: glew-devel
  120. ##!!BuildRequires: Mesa-devel
  121. BuildRequires: mesa-libGLU-devel
  122. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  123. BuildRequires: libevent-devel
  124. ##Vine Linux
  125. BuildRequires: libXScrnSaver-devel
  126. #BuildRequires: gle-devel
  127. #BuildRequires: webkit-gtk-devel
  128. #BuildRequires: scons
  129. %ifarch x86_64
  130. Requires: nspluginwrapper
  131. %endif
  132. ##!!Requires: alsa
  133. Requires: alsa-lib
  134. # shouldn't be required to name all dependencies
  135. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  136. ## Recommends the ffmpeg libraries (available from packman)
  137. #Recommends: libavcodec52 libavformat52 libavutil50
  138. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  139. %description
  140. Chromium is the open-source project behind Google Chrome.
  141. We invite you to join us in our effort to help build a safer, faster,
  142. and more stable way for all Internet users to experience the web,
  143. and to create a powerful platform for developing a new generation of
  144. web applications.
  145. %description -l ja
  146. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  147. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  148. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  149. ウェブアプリケーションの新しい世代を発展させるように
  150. 強力なプラットホームを作成するために、
  151. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  152. %prep
  153. [ -d %{name} ] && %__rm -rf %{name}
  154. lzma -cd %{SOURCE0} | tar xf -
  155. %setup -D -T -n %{name}
  156. # use static libicu
  157. #%if %{?_dist_release} == "vl5"
  158. cd src/third_party || exit 1
  159. %__rm -rf icu || exit 1
  160. tar jxvf %{SOURCE100} || exit 1
  161. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  162. cd - || exit 1
  163. #%endif
  164. # use system libicu only if >= 4.0
  165. %{?with_system_icu:%patch3 -p1}
  166. %patch4 -p1
  167. %patch5 -p1
  168. %patch7 -p1
  169. %patch8 -p1
  170. #%patch9 -p1
  171. %patch10 -p1
  172. #%patch11 -p1
  173. %patch12 -p1
  174. %patch13 -p1
  175. %patch14 -p1
  176. #%patch15 -p0
  177. %{?with_system_icu:%patch16 -p1}
  178. %patch17 -p1
  179. %patch18 -p1
  180. %patch19 -p1
  181. %patch20 -p1
  182. %patch21 -p1
  183. #%patch22 -p1
  184. %patch25 -p1
  185. %ifarch %ix86
  186. %patch23 -p1
  187. %endif
  188. %patch24 -p1
  189. # apply vendor patch after substitution
  190. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  191. %build
  192. ## create make files
  193. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  194. for i in src/build/common.gypi; do
  195. %__sed -i "s|'-march=pentium4',||g" $i
  196. %__sed -i "s|'-msse2',||g" $i
  197. %__sed -i "s|'-mfpmath=sse',||g" $i
  198. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  199. %__sed -i "s|'-m32',||g" $i
  200. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  201. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  202. done
  203. # '
  204. pushd src
  205. ./build/gyp_chromium -f make build/all.gyp \
  206. -Duse_system_ffmpeg=1 \
  207. -Duse_system_zlib=1 \
  208. -Duse_system_libpng=1 \
  209. -Duse_system_bzip2=1 \
  210. -Duse_system_libbz2=1 \
  211. -Duse_system_libjpeg=1 \
  212. -Duse_system_libxml=1 \
  213. -Duse_system_libxslt=1 \
  214. -Duse_system_libevent=1 \
  215. -Dproprietary_codecs=1 \
  216. -Dlinux_fpic=1 \
  217. %{?with_system_icu:-Duse_system_icu=1} \
  218. %{!?with_system_icu:-Duse_system_icu=0} \
  219. %ifarch %{ix86}
  220. -Dtarget_arch=ia32 \
  221. -Ddisable_sse2=1 \
  222. %endif
  223. %ifarch x86_64
  224. -Dtarget_arch=x64 \
  225. %endif
  226. %if %{?_dist_release} == "vl6"
  227. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  228. %endif
  229. -Drelease_extra_cflags=-fPIC \
  230. ;
  231. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  232. #%__make -r -j5 chrome BUILDTYPE=Release
  233. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  234. popd
  235. %install
  236. %{__rm} -rf %{buildroot}
  237. ## Create install directories
  238. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  239. %{__mkdir_p} %{buildroot}%{_bindir}
  240. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  241. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  242. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  243. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  244. # chromium 'make' deposits us back at the top level build directory
  245. pushd src/out/Release
  246. ls -l
  247. # clean somechromium-codechanges-zlib.patch
  248. # clean debug junk
  249. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  250. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  251. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  252. %{__rm} -f ncdecode_table ncdecode_tablegen
  253. # clean other temporary binaries used in the compilation of chromium
  254. %{__rm} -f protoc xdg-settings
  255. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  256. # Man page
  257. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  258. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  259. # Add startup file with plugins enabled
  260. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  261. #!/bin/bash
  262. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  263. EOF
  264. # # link to browser plugin path. Plugin patch doesn't work. Why?
  265. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  266. # pushd %{buildroot}%{_libdir}/%{name}
  267. # %{__ln_s} %{_libdir}/browser-plugins plugins
  268. # popd
  269. pushd %{buildroot}%{_libdir}/%{name}
  270. %ifarch x86_64
  271. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  272. %else
  273. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  274. %endif
  275. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  276. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  277. #touch %{buildroot}%{_libdir}/libavformat.so.52
  278. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  279. #touch %{buildroot}%{_libdir}/libavutil.so.50
  280. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  281. popd
  282. # Install desktop-related files
  283. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  284. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  285. desktop-file-install --vendor Vine \
  286. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  287. --delete-original \
  288. --mode 644 \
  289. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  290. # Install the master_preferences file
  291. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  292. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  293. ## install o3d plugin
  294. #pushd src/o3d/build/out/Release
  295. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  296. %clean
  297. %{__rm} -rf %{buildroot}
  298. %files
  299. %defattr(-,root,root)
  300. %doc src/AUTHORS src/LICENSE
  301. %dir %{_libdir}/%{name}
  302. %attr(0755,root,root) %{_bindir}/%{name}
  303. %{_mandir}/man1/*
  304. %{_datadir}/applications/*%{name}.desktop
  305. %{_datadir}/pixmaps/%{name}.png
  306. %{_libdir}/%{name}/*
  307. %config %{_sysconfdir}/%{name}
  308. #%{_libdir}/browser-plugins/*
  309. #%exclude %{_libdir}/libavcodec.so.52
  310. #%exclude %{_libdir}/libavutil.so.50
  311. #%exclude %{_libdir}/libavformat.so.52
  312. %changelog
  313. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  314. - build for Vine Linux 5.x
  315. - add BuildRequires: gnome-keyring-devel
  316. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  317. - updated to snapshot 6.0.454
  318. - added BuildRequires:
  319. - sqlite3-devel
  320. - gnutls-devel
  321. - libgnome-keyring-devel
  322. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  323. - updated to snapshot 6.0.431.0 r49253
  324. - added BuildRequires: cups-devel
  325. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  326. - updated to snapshot 6.0.405.0 r47263
  327. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  328. - unused with_system_icu (for vl6)
  329. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  330. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  331. - updated to snapshot 5.0.378.0 r44472
  332. - used with_system_icu (for vl6)
  333. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  334. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  335. - updated to snapshot 5.0.372.0 r43947
  336. - added BuildRequires: glew-devel
  337. - changed Group tag to Applications/Internet
  338. - added Summary(ja) and %%description -l ja
  339. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  340. - updated to snapshot 5.0.365.0 r42966
  341. - merged 5.0.353.0-4vl5
  342. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  343. - build on Vine Linux 5.1
  344. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  345. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  346. - updated to snapshot 5.0.364.0 r42779
  347. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  348. - updated to snapshot 5.0.359.0 r42116
  349. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  350. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  351. - fixed master_preferences.vine, little
  352. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  353. - fixed to install master_preferences
  354. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  355. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  356. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  357. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  358. - updated to snapshot 5.0.353.0 r41449
  359. * Wed Mar 10 2010 bgmerrell@novell.com
  360. - Add master_preferences source file and install it to /etc/chromium.
  361. - Create a new patch (chromium-master-prefs-path.patch) which tells
  362. chromium to look in /etc/chromium for the master_preferences file
  363. (instead of looking in the default directory, which is the same
  364. directory as the 'chrome' binary).
  365. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  366. - updated to snapshot 5.0.335.0 r39556
  367. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  368. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  369. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  370. - updated to snapshot 5.0.330.0 r39074
  371. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  372. - use_system_ffmpeg
  373. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  374. - added Requires: nspluginwrapper
  375. - fixed a symbolic link of plugins directory with nspluginwrapper
  376. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  377. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  378. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  379. - added BuildRequires: mesa-libGLU-devel
  380. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  381. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  382. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  383. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  384. - Update to 4.0.260
  385. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  386. - Update to 4.0.259
  387. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  388. - Update to 4.0.258
  389. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  390. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  391. changed to having an built-in v8
  392. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  393. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  394. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  395. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  396. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  397. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  398. - update to newer svn snapshot
  399. + Obsoletes fwrite patch (included upstream)
  400. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  401. - update to newer svn snapshot
  402. + Requires newer version of v8
  403. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  404. - do not force SSE on x86 (drop-sse.patch)
  405. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  406. - Update to newer svn snapshot
  407. - Fixed spec file in order to build
  408. - Included patch to build with system zlib
  409. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  410. - package renamed to chromium
  411. - cleaned up spec file
  412. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  413. - v8 is now built as a separate package, and is required
  414. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  415. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  416. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  417. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  418. - initial build
  419. #% changelog
  420. * Sun Jan 24 2010 prusnak@suse.cz
  421. - added vendor to user agent (chromium-vendor.patch.in)
  422. * Sun Nov 29 2009 prusnak@suse.cz
  423. - added --enable-sync to wrapper to enable bookmark sync
  424. * Fri Nov 13 2009 tittiatcoke@gmail.com
  425. - update to 247.0 svn 31928
  426. * Fri Oct 30 2009 tittiatcoke@gmail.com
  427. - update to 229.0 svn 30454
  428. + Fix regression where popups and app frames lost their titlebars.
  429. + Makes it so that when a folder is open on the bookmark bar
  430. and the mouse moves over another folder, the menu for that
  431. folder is shown.
  432. + Lazily create the find bar.
  433. + Polish to the gmail checker sample.
  434. * New, crisper icons that are exactly 19x19
  435. * Add a loading animation at the beginning before Gmail
  436. responds.
  437. * Fix a bug where we sometimes don't update the UI after a
  438. logout/login cycle.
  439. + Refactor widget methods to support desktop notifications,
  440. including GTK stubs.
  441. + Find-in-page should not ding while deleting characters.
  442. + Add SSL wrapper for linux and mac. This allows notifier to
  443. use chrome's SSL layer instead of OpenSSL.
  444. + Add three of the six extensions to PAC that Internet Explorer supports.
  445. + WebSocket support in chromium. (Run with --enable-web-sockets
  446. enables WebSocket features.)
  447. + Do not allow GTK File Chooser dialogs to return directories.
  448. + Fix the notifier SSL layer to make notifications work for
  449. Linux Bookmark sync.
  450. + linux: don't override mouse selection behavior in omnibox
  451. * Sun Oct 25 2009 tittiatcoke@gmail.com
  452. - Update to 224.4 svn 30027
  453. + First cut at new page and browser action docs based
  454. on new API. Deleted old stuff.
  455. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  456. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  457. + Minimize dependency of user scripts
  458. + Fixup the flip_framer eof-handling semantics now that we have
  459. the FIN bit in place
  460. + app depends on x11 because of active_window_watcher_x
  461. + Adding two images for the new Extension managment UI
  462. + Removing hard-coded Chrome Frame output path
  463. + Rearrange clipboard code
  464. + Fix crash bug when attempting to download a url with unsupported scheme,
  465. e.g. 'data:', by 'Alt + Click'
  466. + GTK: Change text for extension download UI
  467. + Ignore invalid urls on command line
  468. + Make dropped tabs animate from where they were dropped.
  469. + Make room for the full width of the tab placeholder.
  470. + Make tab dragging as smooth as glass.
  471. + Remove an annoying NOTIMPLEMNETED
  472. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  473. + If we're in the middle of a drag, don't allow the user to middle
  474. click to close or right click for the context menu
  475. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  476. + Remove +x bit from files that shouldn't have it
  477. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  478. + Adding new image needed for the managment UI
  479. + Fix a race bug where content scripts would not apply to the first page load
  480. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  481. + Fix bubbles deactivating the opaque frame
  482. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  483. + ake all pepper plugins default to windowless and transparent
  484. + Add styles for printing
  485. + Implement the new extension management UI
  486. + Add support for to automation interface load install and load extensions
  487. + GTK: theme the info bar border
  488. + Update V8 to version 1.3.16.1
  489. + Introduce WebSecurityPolicy for security related methods
  490. + New button scheme...borders are separate from the inner contents so
  491. that they can be highlighted / depressed independently
  492. + When opening Chrome maximized with an application window already
  493. running, the Chrome window was not activated
  494. + Fix compatibility problems with FileZilla FTP Server
  495. + Remove the extension shelf on Linux
  496. + Fix the proxy host and port string to start with http:// if it does not already
  497. + Enable HTML5 databases for all extension renderer processes