OpenImageIO-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324
  1. %bcond_with bootstrap
  2. %bcond_with external_pugixml
  3. %global subname oiio
  4. Name: OpenImageIO
  5. Version: 2.4.10.0
  6. Release: 1%{?_dist_release}
  7. Summary: Library for reading and writing images
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD
  12. URL: https://sites.google.com/site/openimageio/home
  13. Source0: https://github.com/OpenImageIO/oiio/archive/v%{version}.tar.gz#/oiio-%{version}.tar.gz
  14. # Images for test suite
  15. #Source1: oiio-images.tar.gz
  16. BuildRequires: cmake
  17. BuildRequires: git
  18. BuildRequires: txt2man
  19. BuildRequires: qt5-qtbase-devel
  20. BuildRequires: fmt-devel
  21. BuildRequires: robin-map-devel
  22. BuildRequires: libboost-devel
  23. BuildRequires: libboost-python3
  24. BuildRequires: libboost-filesystem
  25. BuildRequires: libboost-chrono
  26. #BuildRequires: glew-devel
  27. BuildRequires: OpenEXR-devel
  28. BuildRequires: python3-devel
  29. BuildRequires: python3-rpm-macros
  30. # BuildRequires: openssl-devel
  31. BuildRequires: libpng-devel libtiff-devel openjpeg2-devel giflib-devel
  32. BuildRequires: libwebp-devel
  33. BuildRequires: Field3D-devel
  34. BuildRequires: hdf5-devel
  35. BuildRequires: zlib-devel
  36. BuildRequires: jasper-devel
  37. BuildRequires: LibRaw-devel
  38. %if %{with external_pugixml}
  39. BuildRequires: pugixml-devel
  40. %endif
  41. BuildRequires: pybind11-devel
  42. %if %{without bootstrap}
  43. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  44. # If an ABI incompatible update is done in one, the other also needs to be
  45. # rebuilt.
  46. BuildRequires: OpenColorIO-devel
  47. %endif
  48. Obsoletes: python-OpenImageIO
  49. # We don't want to provide private python extension libs
  50. %{?filter_setup:
  51. %filter_provides_in %{python3_sitearch}/.*\.so$
  52. %filter_setup
  53. }
  54. %description
  55. OpenImageIO is a library for reading and writing images, and a bunch of related
  56. classes, utilities, and applications. Main features include:
  57. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  58. writing 2D images that is format agnostic.
  59. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  60. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  61. PNM/PPM/PGM/PBM, Field3d.
  62. - An ImageCache class that transparently manages a cache so that it can access
  63. truly vast amounts of image data.
  64. %package -n python3-%{name}
  65. Summary: Python 3 bindings for %{name}
  66. Group: programming
  67. Requires: %{name} = %{version}-%{release}
  68. %description -n python3-%{name}
  69. Python3 bindings for %{name}.
  70. %package utils
  71. Summary: Command line utilities for %{name}
  72. Group: graphics
  73. Requires: %{name} = %{version}-%{release}
  74. %description utils
  75. Command-line tools to manipulate and get information on images using the
  76. %{name} library.
  77. %package iv
  78. Summary: %{name} based image viewer
  79. Group: graphics
  80. Requires: %{name} = %{version}-%{release}
  81. %description iv
  82. A really nice image viewer, iv, based on %{name} classes (and so will work
  83. with any formats for which plugins are available).
  84. %package devel
  85. Summary: Documentation for %{name}
  86. Group: programming
  87. Requires: %{name} = %{version}-%{release}
  88. %description devel
  89. Development files for package %{name}
  90. %debug_package
  91. %prep
  92. %setup -q -n oiio-%{version}
  93. %if %{with external_pugixml}
  94. # Remove bundled pugixml
  95. rm -f src/include/OpenImageIO/pugixml.hpp \
  96. src/include/OpenImageIO/pugiconfig.hpp \
  97. src/libutil/OpenImageIO/pugixml.cpp
  98. %endif
  99. # Remove bundled tbb
  100. %{__rm} -rf src/include/tbb
  101. # Install test images
  102. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  103. #tar --strip-components=1 -xzf %{SOURCE1}
  104. %build
  105. %{__rm} -rf %{_vpath_builddir}
  106. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  107. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  108. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  109. -DCMAKE_CXX_STANDARD=17 \
  110. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  111. -DBUILDSTATIC=OFF \
  112. -DLINKSTATIC=OFF \
  113. -DPYTHON_VERSION=%{python3_version} \
  114. -DINSTALL_DOCS:BOOL=FALSE \
  115. -DINSTALL_FONTS:BOOL=FALSE \
  116. %if %{with external_pugixml}
  117. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  118. %endif
  119. -DUSE_TBB:BOOL=FALSE \
  120. -DUSE_OPENSSL:BOOL=TRUE \
  121. -DSTOP_ON_WARNING:BOOL=FALSE \
  122. -DJPEG_INCLUDE_DIR=%{_includedir} \
  123. -DOPENJPEG_INCLUDE_DIR=$(pkg-config --variable=includedir libopenjp2) \
  124. -DOpenGL_GL_PREFERENCE=GLVND \
  125. -DVERBOSE=TRUE
  126. %cmake_build
  127. %install
  128. %cmake_install
  129. # # Move man pages to the right directory
  130. # mkdir -p %{buildroot}%{_mandir}/man1
  131. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  132. %files
  133. %license LICENSE*
  134. %doc CHANGES.md CONTRIBUTING.md README.md
  135. %{_libdir}/libOpenImageIO.so.*
  136. %{_libdir}/libOpenImageIO_Util.so.*
  137. %files -n python3-%{name}
  138. %{python3_sitearch}/OpenImageIO
  139. %files utils
  140. %exclude %{_bindir}/iv
  141. %{_bindir}/*
  142. # %exclude %{_mandir}/man1/iv.1.gz
  143. # %{_mandir}/man1/*.1.gz
  144. %files iv
  145. %{_bindir}/iv
  146. # %{_mandir}/man1/iv.1.gz
  147. %files devel
  148. %{_libdir}/libOpenImageIO.so
  149. %{_libdir}/libOpenImageIO_Util.so
  150. %dir %{_libdir}/pkgconfig
  151. %{_libdir}/pkgconfig/OpenImageIO.pc
  152. %dir %{_libdir}/cmake/OpenImageIO
  153. %{_libdir}/cmake/OpenImageIO/*
  154. %{_includedir}/*
  155. %changelog
  156. * Mon Apr 10 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.10.0-1
  157. - new upstream release.
  158. * Thu Mar 02 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.9.0-1
  159. - new upstream release.
  160. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.18.0-1
  161. - new upstream release.
  162. - dropped ldconfig scriptlets.
  163. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.11.1-1
  164. - new upstream release.
  165. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9.0-1
  166. - new upstream release.
  167. * Fri Sep 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.6.1-1
  168. - new upstream release.
  169. * Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.10.1-1
  170. - new upstream release.
  171. - built with boost-1.72.0.
  172. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
  173. - new upstream release.
  174. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  175. - update to 1.8.17
  176. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  177. - update to 1.8.16
  178. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  179. - drop BuildRequires: openssl-devel
  180. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  181. - update to 1.7.19
  182. - using macro
  183. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  184. - rebuild with hdf5-1.8.20
  185. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  186. - update to 1.7.17
  187. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  188. - rebuilt with LibRaw-0.17.2.
  189. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  190. - rebuild with gcc-5.4.0
  191. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  192. - new upstream release
  193. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  194. - new upstream release
  195. - remove Patch0
  196. - create python-%%{name} subpackage
  197. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  198. - rebuild with glew-1.13.0
  199. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  200. - initial build for Vine Linux
  201. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  202. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  203. - rebuild (openexr)
  204. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  205. - Update to latest upstream release.
  206. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  207. - Update to latest upstream release.
  208. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  209. - Rebuild for Field3D 1.4.3.
  210. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  211. - Rebuild for pugixml 1.4
  212. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  214. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  215. - Update to latest upstream release.
  216. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  217. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  218. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  219. - Rebuild for boost 1.55.0
  220. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  221. - rebuild for boost 1.55.0
  222. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  223. - Update to latest upstream release.
  224. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  225. - Update to latest upstream release.
  226. - Add libgif as build requirement.
  227. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  228. - rebuild (openexr)
  229. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  230. - rebuilt for GLEW 1.10
  231. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  232. - Update to latest upstream release.
  233. - Fix ppc builds (BZ#1021977).
  234. - Add conditionals to build requirements for EPEL 6.
  235. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  236. - Update to latest upstream release.
  237. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  238. - rebuild (ilmbase/openexr)
  239. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  240. - Update to latest upstream release.
  241. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  243. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  244. - Rebuild for boost 1.54.0