self-build-mikutter-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. %define pkgname mikutter
  2. %define sourceurl http://mikutter.hachune.net/bin/%{pkgname}.%{version}.tar.gz
  3. Summary: Package to automatically build %{pkgname} rpm package
  4. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  5. Name: self-build-%{pkgname}
  6. Version: 3.2.12
  7. Release: 1%{?_dist_release}
  8. Source0: %{pkgname}-vl.spec
  9. License: GPLv3
  10. Group: Restricted Software
  11. Requires(post): self-build-setup >= 0.9.9
  12. # (build)requies of target package.
  13. Requires(post): alsa-utils
  14. Requires(post): ruby >= 1.9.3
  15. Requires(post): ruby-gtk2 >= 1.5.0
  16. Requires(post): rcairo >= 1.10.0
  17. Requires(post): desktop-file-utils
  18. # for gem install
  19. Requires(post): ruby-devel
  20. Requires(post): zlib-devel
  21. BuildArch: noarch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. Packager: Takemikaduchi
  24. %description
  25. mikutter is simple, powerful and moeful twitter client.
  26. If you install this package, it automaticaly downloads source
  27. code, compile it, and create rpm packages of
  28. %{pkgname}-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. 全てのミク廃、そして Twitter 中毒者へ贈る、至高の Twitter
  50. Client を目指す Twitter Client。
  51. このパッケージをインストールすると、自動的にソースコードを
  52. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  53. の rpm パッケージを作成します。
  54. また apt-get コマンドや synaptic パッケージマネージャから実行
  55. した場合は、作成された rpm パッケージのインストールも自動的に
  56. 行います。
  57. [注意]
  58. コンパイルに必要な多くの関連パッケージを要求するので通常より
  59. ディスクの領域を多く消費します。
  60. またインストール時にコンパイルを行うため、通常より時間がかか
  61. る場合があります。(環境にもよりますが数分から数十分程度)
  62. [self-build パッケージについて]
  63. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  64. 違反する可能性があるものがあります。その為、このような問題が
  65. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  66. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  67. ジという方法を採っています。
  68. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  69. アのライセンス、および利用する国の各種法令に従ってください。
  70. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  71. センスの購入などが必要となる場合がありますので、利用する目的
  72. や形態に応じて各自で判断し適切な対応を取ってください。
  73. %prep
  74. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  75. %install
  76. %{__rm} -rf ${RPM_BUILD_ROOT}
  77. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  79. %clean
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %posttrans
  82. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 5000
  83. gem install nokogiri httpclient moneta
  84. %files
  85. %{_datadir}/%{name}
  86. %changelog
  87. * Mon Feb 01 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.12-1
  88. - new upstream release
  89. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.9-1
  90. - new upstream release
  91. * Fri Sep 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-2
  92. - rebuild with ruby-2.2.3
  93. * Sat Aug 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
  94. - new upstream release
  95. * Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
  96. - new upstream release
  97. * Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.4-1
  98. - new upstream release
  99. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  100. - new upstream release
  101. * Sun Oct 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.7-1
  102. - new upstream release
  103. * Tue Sep 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.6-1
  104. - new upstream release
  105. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.5-1
  106. - new upstream release
  107. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.3-1
  108. - new upstream release
  109. * Sun Jun 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  110. - new upstream release
  111. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1537-1
  112. - new upstream release
  113. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1476-1
  114. - new upstream release
  115. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1430-1
  116. - new upstream release
  117. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.2.1410-1
  118. - initial build