wxPython-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define buildflags WXPORT=gtk2 UNICODE=1
  4. Name: wxPython
  5. Version: 2.8.12.0
  6. Release: 1%{?dist}
  7. Summary: GUI toolkit for the Python programming language
  8. Group: Development/Languages
  9. License: LGPLv2+ and wxWidgets
  10. URL: http://www.wxpython.org/
  11. Source0: http://downloads.sourceforge.net/wxpython/%{name}-src-%{version}.tar.bz2
  12. # fix aui imports
  13. # http://trac.wxwidgets.org/ticket/12107
  14. Patch0: wxPython-2.8.12.0-aui.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. # make sure to keep this updated as appropriate
  17. BuildRequires: wxGTK-devel >= 2.8.11
  18. BuildRequires: python-devel
  19. BuildRequires: gtk2-devel
  20. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  21. # packages should depend on "wxPython", not "wxPythonGTK2", but in case
  22. # one does, here's the provides for it.
  23. Provides: wxPythonGTK2 = %{version}-%{release}
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. wxPython is a GUI toolkit for the Python programming language. It allows
  28. Python programmers to create programs with a robust, highly functional
  29. graphical user interface, simply and easily. It is implemented as a Python
  30. extension module (native code) that wraps the popular wxWindows cross
  31. platform GUI library, which is written in C++.
  32. %package devel
  33. Group: Development/Libraries
  34. Summary: Development files for wxPython add-on modules
  35. Requires: %{name} = %{version}-%{release}
  36. Requires: wxGTK-devel
  37. %description devel
  38. This package includes C++ header files and SWIG files needed for developing
  39. add-on modules for wxPython. It is NOT needed for development of most
  40. programs which use the wxPython toolkit.
  41. %package docs
  42. Group: Documentation
  43. Summary: Documentation and samples for wxPython
  44. Requires: %{name} = %{version}-%{release}
  45. BuildArch: noarch
  46. %description docs
  47. Documentation, samples and demo application for wxPython.
  48. %prep
  49. %setup -q -n wxPython-src-%{version}
  50. %patch0 -p1 -b .aui
  51. # fix libdir otherwise additional wx libs cannot be found
  52. %__sed -i -e 's|/usr/lib|%{_libdir}|' wxPython/config.py
  53. %build
  54. # Just build the wxPython part, not all of wxWindows which we already have
  55. # in Fedora
  56. cd wxPython
  57. # included distutils is not multilib aware; use normal
  58. %__rm -rf distutils
  59. python setup.py %{buildflags} build
  60. %install
  61. %__rm -rf $RPM_BUILD_ROOT
  62. cd wxPython
  63. python setup.py %{buildflags} install --root=$RPM_BUILD_ROOT
  64. # this is a kludge....
  65. %if "%{python_sitelib}" != "%{python_sitearch}"
  66. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wx.pth $RPM_BUILD_ROOT%{python_sitearch}
  67. %__mv $RPM_BUILD_ROOT%{python_sitelib}/wxversion.py* $RPM_BUILD_ROOT%{python_sitearch}
  68. %endif
  69. %clean
  70. %__rm -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc wxPython/licence
  74. %{_bindir}/*
  75. %{python_sitearch}/wx.pth
  76. %{python_sitearch}/wxversion.py*
  77. %dir %{python_sitearch}/wx-2.8-gtk2-unicode/
  78. %{python_sitearch}/wx-2.8-gtk2-unicode/wx
  79. %{python_sitearch}/wx-2.8-gtk2-unicode/wxPython
  80. %{python_sitelib}/*egg-info
  81. %{python_sitearch}/wx-2.8-gtk2-unicode/*egg-info
  82. %files devel
  83. %defattr(-,root,root,-)
  84. %dir %{_includedir}/wx-2.8/wx/wxPython
  85. %{_includedir}/wx-2.8/wx/wxPython/*.h
  86. %dir %{_includedir}/wx-2.8/wx/wxPython/i_files
  87. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.i
  88. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.py*
  89. %{_includedir}/wx-2.8/wx/wxPython/i_files/*.swg
  90. %files docs
  91. %defattr(-,root,root,-)
  92. %doc wxPython/docs wxPython/demo wxPython/samples
  93. %changelog
  94. * Sun May 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.0-1
  95. - initial build based on Fedora rawhide
  96. * Tue Apr 26 2011 Dan Horák <dan[at]danny.cz> - 2.8.12.0-1
  97. - update to 2.8.12.0 (#699207)
  98. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.11.0-5
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  100. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.8.11.0-4
  101. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  102. * Mon Jul 12 2010 Dan Horák <dan@danny.cz> - 2.8.11.0-3
  103. - rebuilt against wxGTK-2.8.11-2
  104. * Sun Jul 11 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.8.11.0-2
  105. - Include egg-info when build on recent RHEL
  106. * Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
  107. - update to 2.8.11.0 (#593837, #595936, #597639)
  108. * Sun May 2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
  109. - rebuilt with wxGTK 2.8.11
  110. * Wed Mar 17 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-2
  111. - add missing module (#573961)
  112. * Sat Jan 16 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-1
  113. - update to 2.8.10.1
  114. - backport to wxGTK 2.8.10 API
  115. - cleaned up BRs
  116. * Thu Jan 7 2010 Hans de Goede <hdegoede@redhat.com> - 2.8.9.2-4
  117. - Change python_foo macros to use %%global as the new rpm will break
  118. using %%define here, see:
  119. https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00093.html
  120. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.2-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  122. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-2
  123. - add patch to fix compile failure for contrib/gizmos/_treelist.i
  124. * Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-1
  125. - update to 2.8.9.2
  126. - create noarch docs subpackage
  127. * Thu Mar 5 2009 Lubomir Rintel <lkundrak@v3.sk> - 2.8.9.1-4
  128. - Rebuilt for newer wxgtk package
  129. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.1-3
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  131. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.8.9.1-2
  132. - Rebuild for Python 2.6
  133. * Tue Sep 30 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.1-1
  134. - update to 2.8.9.1
  135. - fix libdir for additional wx libraries (#306761)
  136. * Mon Sep 29 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.0-1
  137. - update to 2.8.9.0
  138. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.8.8.0-2
  139. - fix license tag
  140. * Thu Jul 31 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.8.0-1
  141. - update to 2.8.8.0 (bug #457408)
  142. - a fix for bug #450073 is included in the upstream release, so
  143. dropping that patch.
  144. * Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> - 2.8.7.1-5
  145. - Fix an attribute error when importing wxPython (compat) module
  146. (redhat bugzilla 450073, 450074)
  147. * Sat Jun 6 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-4
  148. - gratuitously bump package release number to work around build system
  149. glitch. again, but it will work this time.
  150. * Wed Jun 4 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-3
  151. - gratuitously bump package release number to work around build system
  152. glitch
  153. * Thu Feb 21 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-2
  154. - include egg-info files for fedora 9 or greater
  155. * Wed Feb 20 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-1
  156. - update to 2.8.7.1
  157. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.8.4.0-3
  158. - Autorebuild for GCC 4.3
  159. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.8.4.0-2
  160. - Rebuild for selinux ppc32 issue.
  161. * Wed Jul 11 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.4.0-1
  162. - update to 2.8.4.0
  163. - obsolete compat-wxPythonGTK
  164. * Sun Apr 15 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.3.0-1
  165. - update to 2.8.3.0
  166. * Fri Dec 15 2006 Matthew Miller <mattdm@mattdm.org> - 2.8.0.1-1
  167. - update to 2.8.0.1
  168. - make buildrequire wxGTK of version-wxpythonsubrelease
  169. - add wxaddons to filelist
  170. * Mon Dec 11 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-3
  171. - bump release for rebuild against python 2.5.
  172. * Mon Aug 28 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-2
  173. - bump release for FC6 rebuild
  174. * Thu Apr 13 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-1
  175. - version 2.6.3.2
  176. - move wxversion.py _into_ lib64. Apparently that's the right thing to do. :)
  177. - upstream tarball no longer includes embedded.o (since I finally got around
  178. to pointing that out to the developers instead of just kludging it away.)
  179. - buildrequires to just libGLU-devel instead of mesa-libGL-devel
  180. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-4
  181. - grr. bump relnumber.
  182. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-3
  183. - oh yeah -- wxversion.py not lib64.
  184. * Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-2
  185. - buildrequires mesa-libGLU-devel
  186. * Thu Mar 30 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-1
  187. - update to 2.6.3.0
  188. - wxGTK and wxPython versions are inexorably linked; make BuildRequires
  189. be exact, rather than >=.
  190. - make devel subpackage as per comment #7 in bug #163440.
  191. * Thu Nov 24 2005 Matthew Miller <mattdm@mattdm.org> - 2.6.1.0-1
  192. - update to 2.6.0.0
  193. - merge in changes from current extras 2.4.x package
  194. - Happy Thanksgiving
  195. - build animate extention again -- works now.
  196. * Thu Apr 28 2005 Matthew Miller <mattdm@bu.edu> - 2.6.0.0-bu45.1
  197. - get rid of accidental binaries in source tarball -- they generates
  198. spurious dependencies and serve no purpose
  199. - update to 2.6.0.0 and build for Velouria
  200. - switch to Fedora Extras base spec file
  201. - enable gtk2 and unicode and all the code stuff (as FE does)
  202. - disable BUILD_ANIMATE extension from contrib -- doesn't build
  203. - files are in a different location now -- adjust to that
  204. - zap include files (needed only for building wxPython 3rd-party modules),
  205. because I don't think this is likely to be very useful. Other option
  206. would be to create a -devel package, but I think that'd be confusing.
  207. * Tue Feb 08 2005 Thorsten Leemhuis <fedora at leemhuis dot info> 0:2.4.2.4-4
  208. - remove included disutils - it is not multilib aware; this
  209. fixes build on x86_64
  210. * Tue Jan 06 2004 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.3
  211. - rename package to wxPythonGTK2, provide wxPython (see bug 927)
  212. - dont ship binaries in /usr/share
  213. * Thu Nov 20 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.2
  214. - add missing buildrequires: python-devel, wxGTK2-gl
  215. * Sun Nov 02 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.1
  216. - Initial RPM release.
  217. ~