OpenDX-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342
  1. %define samplesname dxsamples
  2. %define sver 4.4.0
  3. %define dxdir %{_libdir}/dx
  4. Name: OpenDX
  5. Summary: IBM OpenDX (Data Explorer)
  6. Version: 4.4.4
  7. Release: 0vl1
  8. Source: http://opendx.npaci.edu/source/dx-%{version}.tar.gz
  9. Source1: http://opendx.npaci.edu/source/dxsamples-%{sver}.tar.gz
  10. Source2: icons-dx.tar.bz2
  11. Patch4: dx-4.2.0-errno.patch.bz2
  12. Patch5: dx-4.2.0-xkb.patch.bz2
  13. Patch6: dx-4.3.2-types.patch.bz2
  14. URL: http://www.opendx.org/
  15. Group: Applications/Engineering
  16. License: IBM Public License
  17. BuildRequires: autoconf
  18. BuildRequires: bison
  19. BuildRequires: flex
  20. BuildRequires: freetype2-devel
  21. BuildRequires: XOrg-gl-devel
  22. BuildRequires: ImageMagick-devel
  23. BuildRequires: openMotif-devel
  24. BuildRequires: libjbig-devel
  25. BuildRequires: netcdf-devel
  26. %ifnarch ppc
  27. BuildRequires: hdf-devel
  28. %endif
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. %description
  31. OpenDX is a uniquely powerful, full-featured software package for the
  32. visualization of scientific, engineering and analytical data: Its open
  33. system design is built on a standard interface environments. And its
  34. sophisticated data model provides users with great flexibility in
  35. creating visualizations.
  36. %package devel
  37. Summary: Development libraries for OpenDX
  38. Summary(ja): OpenDX の開発用ファイル
  39. Group: Development/Libraries
  40. Requires: OpenDX = %{version}
  41. %description devel
  42. This package contains the header files and includes necessary to for developing
  43. applications with OpenDX.
  44. %prep
  45. %setup -q -n dx-%{version} -a 1
  46. %patch4 -p1 -b .errno
  47. %patch5 -p1 -b .xkb
  48. %patch6 -p1 -b .types
  49. autoconf
  50. %build
  51. CFLAGS="%optflags -O1 -fno-fast-math -fno-exceptions" \
  52. CXXFLAGS="%optflags -O1 -fno-fast-math -fno-exceptions -Wno-deprecated" \
  53. %configure --prefix=%{_libdir} \
  54. --with-x \
  55. --with-magick \
  56. --with-netcdf \
  57. --with-jbig \
  58. --without-javadx
  59. %__make LIBTOOL=/usr/bin/libtool
  60. (cd %{samplesname}-%{sver}
  61. %configure --prefix=%{_libdir}
  62. %__make LIBTOOL=/usr/bin/libtool)
  63. %install
  64. rm -rf $RPM_BUILD_ROOT
  65. mkdir -p $RPM_BUILD_ROOT%{_libdir} \
  66. $RPM_BUILD_ROOT%{_includedir}
  67. %makeinstall prefix=$RPM_BUILD_ROOT%{_libdir} \
  68. libdir=$RPM_BUILD_ROOT%{dxdir} \
  69. mandir=$RPM_BUILD_ROOT%{_mandir} LIBTOOL=/usr/bin/libtool
  70. ln -sf %{dxdir}/include/dxconfig.h $RPM_BUILD_ROOT%{_includedir}/dxconfig.h
  71. ln -sf %{dxdir}/include/dxl.h $RPM_BUILD_ROOT%{_includedir}/dxl.h
  72. ln -sf %{dxdir}/include/dx $RPM_BUILD_ROOT%{_includedir}/dx
  73. ln -sf %{dxdir}/lib_linux/libDX.a $RPM_BUILD_ROOT%{_libdir}/libDX.a
  74. ln -sf %{dxdir}/lib_linux/libDXcallm.a $RPM_BUILD_ROOT%{_libdir}/libDXcallm.a
  75. ln -sf %{dxdir}/lib_linux/libDXL.a $RPM_BUILD_ROOT%{_libdir}/libDXL.a
  76. ln -sf %{dxdir}/lib_linux/libDXlite.a $RPM_BUILD_ROOT%{_libdir}/libDXlite.a
  77. rm -rf $RPM_BUILD_ROOT%{dxdir}/man
  78. #
  79. (cd $RPM_BUILD_ROOT/%{dxdir}/html
  80. ln -sf allguide.htm index.htm
  81. ln -sf allguide.htm index.html
  82. )
  83. #
  84. (cd %{samplesname}-%{sver}
  85. make install prefix=$RPM_BUILD_ROOT%{_libdir} LIBTOOL=/usr/bin/libtool
  86. )
  87. mkdir -p $RPM_BUILD_ROOT%{dxdir}/lib
  88. install -m 644 ./lib/mdf2c.awk $RPM_BUILD_ROOT%{dxdir}/lib/
  89. # fix dxexec path
  90. mv $RPM_BUILD_ROOT%{_bindir}/dxexec $RPM_BUILD_ROOT%{dxdir}/bin_linux/dxexec
  91. ln -s %{dxdir}/bin_linux/dxexec $RPM_BUILD_ROOT%{_bindir}/dxexec
  92. # remove files not packaged
  93. rm -rf $RPM_BUILD_ROOT%{_libdir}/bin/dx
  94. # icons
  95. mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps \
  96. $RPM_BUILD_ROOT%{_datadir}/applications
  97. tar xjf %{SOURCE2} -C $RPM_BUILD_ROOT%{_datadir}/pixmaps
  98. # desktop file entry
  99. cat >$RPM_BUILD_ROOT%{_datadir}/applications/opendx.desktop <<EOF
  100. [Desktop Entry]
  101. Name=OpenDX
  102. Comment=IBM OpenDX Visualization Data Explorer
  103. exec=%{_bindir}/dx
  104. Icon=dx.png
  105. Terminal=0
  106. Type=Application
  107. Encoding=UTF-8
  108. Category=Application;Graphics;3DGraphics;Visualization;
  109. EOF
  110. # Clean installed tree
  111. find $RPM_BUILD_ROOT/%_libdir -type f -or -type d | xargs chmod go-w
  112. rm -f $RPM_BUILD_ROOT%{dxdir}/samples/outboard/Makefile_os2 \
  113. $RPM_BUILD_ROOT%{dxdir}/samples/user/Makefile_os2
  114. rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_alphax
  115. rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_hp700
  116. rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_ibm6000
  117. rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_sgi
  118. rm -f $RPM_BUILD_ROOT/%_libdir/dx/samples/data/externalfilter_solaris
  119. %clean
  120. rm -rf $RPM_BUILD_ROOT
  121. %files
  122. %defattr(-,root,root)
  123. %doc AUTHORS LICENSE README
  124. %dir %{dxdir}
  125. %{_bindir}/*
  126. %{_mandir}/*/*
  127. %{dxdir}/bin
  128. %{dxdir}/bin_linux
  129. %{dxdir}/doc
  130. %{dxdir}/fonts
  131. %{dxdir}/help
  132. %{dxdir}/html
  133. %{dxdir}/lib
  134. %{dxdir}/lib_linux/lib*.so.*
  135. %{dxdir}/ui
  136. %{dxdir}/java
  137. %{_datadir}/pixmaps/*
  138. %{_datadir}/applications/opendx.desktop
  139. %files devel
  140. %defattr(-,root,root)
  141. %attr(644,root,root) %{_libdir}/*.a
  142. %doc dxsamples-%{version}/ChangeLog
  143. %{_includedir}/*
  144. %{dxdir}/include
  145. %{dxdir}/samples
  146. %{dxdir}/lib_linux/lib*.a
  147. %{dxdir}/lib_linux/lib*.la
  148. %{dxdir}/lib_linux/lib*.so
  149. %{dxdir}/lib_linux/arch.mak
  150. %{dxdir}/lib/mdf2c.awk
  151. %changelog
  152. * Thu Dec 20 2007 Shu KONNO <owa@bg.wakwak.com> 4.4.4-0vl1
  153. - updated dx to 4.4.4
  154. - updated dxsamples to 4.4.0
  155. * Tue Jun 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-0vl4
  156. - rebuilt with new toolchain
  157. * Thu Jul 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-0vl3
  158. - rebuilt with ImageMagick 6.2.6.3
  159. - changed devel Group to Development/Libraries
  160. * Tue Oct 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.3.2-0vl2
  161. - s/jbigkit-devel/libjbig-devel/
  162. * Sat Oct 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.2-0vl1
  163. - initial build for Vine Linux based on MDK package.
  164. * Wed Aug 24 2005 Oden Eriksson <oeriksson@mandriva.com> 4.3.2-11mdk
  165. - rebuilt against new Magick libs
  166. * Mon Jul 11 2005 Giuseppe Ghibメ<ghibo@mandriva.com> 4.3.2-10mdk
  167. - Rebuilt with gcc 4.0.1.
  168. - Added Patch6 to avoid problems with graphwiz types.h.
  169. * Wed Mar 23 2005 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-9mdk
  170. - Rebuilt against latest ImageMagick.
  171. * Mon Feb 07 2005 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-8mdk
  172. - Rebuilt against latest ImageMagick.
  173. * Thu Jan 20 2005 Frederic Lepied <flepied@mandrakesoft.com> 4.3.2-7mdk
  174. - rebuild to have the correct dependencies
  175. * Fri Aug 20 2004 Laurent MONTEL <lmontel@mandrakesoft.com> 4.3.2-6mdk
  176. - Rebuild with new menu
  177. * Thu Jul 29 2004 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-5mdk
  178. - Merged Gwenole patch: fix deps (from AMD64 4.3.2-1.1mdk version).
  179. * Mon Jul 19 2004 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-4mdk
  180. - Rebuilt under new gcc 3.4.1.
  181. * Thu Jul 01 2004 Michael Scherer <misc@mandrake.org> 4.3.2-3mdk
  182. - rebuild for new ImageMagick
  183. * Sat Jun 12 2004 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-2mdk
  184. - Rebuilt.
  185. * Thu Dec 18 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.2-1mdk
  186. - Release 4.3.2.
  187. * Thu Nov 06 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.0-4mdk
  188. - Fixed path for dxexec executable, which prevents dx to start properly.
  189. * Fri Oct 24 2003 Stefan van der Eijk <stefan@eijk.nu> 4.3.0-3mdk
  190. - BuildRequires.
  191. * Wed Aug 27 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.0-2mdk
  192. - Fixed DIRM distriblint prob.
  193. - Removed unused patches.
  194. * Fri Aug 08 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.3.0-1mdk
  195. - Release 4.3.0.
  196. - Use -O1 for now for gcc 3.3.1.
  197. - Moved samples to devel package.
  198. - Disabled Patch1,2,3,6 as no longer needed.
  199. - Don't use %%make macro on building, otherwise doesn't build.
  200. * Thu Jul 17 2003 David BAUDENS <baudens@mandrakesoft.com> 4.2.0-8mdk
  201. - Rebuild
  202. * Tue Jul 15 2003 Per リyvind Karlsen <peroyvind@sintrax.net> 4.2.0-7mdk
  203. - fix gcc-3.3 build (P6)
  204. - use %%make macro
  205. - fix location of man pages
  206. * Tue Feb 18 2003 Giuseppe Ghibメ<ghibo@mandrakesoft.cm> 4.2.0-6mdk
  207. - Added Patch2,3 from cvs (report by Nikos Platis).
  208. - Added Patch4,5 for get compiling under latest glibc and XFree86.
  209. * Sat Nov 30 2002 Stefan van der Eijk <stefan@eijk.nu> 4.2.0-5mdk
  210. - BuildRequires
  211. - Remove files not packaged
  212. * Mon Nov 25 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.2.0-4mdk
  213. - Less verbose %%description.
  214. * Fri Nov 22 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.2.0-3mdk
  215. - Rebuilt against latest ImageMagick.
  216. * Mon Nov 11 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.2.0-2mdk
  217. - Added patch to use stringstreams and not deprecated C++ classes.
  218. * Tue Sep 10 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.2.0-1mdk
  219. - New version: 4.2.0.
  220. * Tue Sep 10 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-12mdk
  221. - Added missed file mdf2c.awk (reported by Nikos Platis).
  222. * Wed Aug 28 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-11mdk
  223. - Rebuilt against latest netcdf-devel package.
  224. * Wed Aug 14 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-10mdk
  225. - Automated rebuild with gcc 3.2-0.3mdk
  226. * Thu Jul 25 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-9mdk
  227. - Automated rebuild with gcc3.2
  228. * Mon Jun 3 2002 Gwenole Beauchesne <gbeauchesne@mandrakesoft.com> 4.1.3-8mdk
  229. - Use %%make
  230. - Patch1: ISO C++ fixes
  231. - Patch0: Don't include /usr/include in include search path
  232. * Thu Feb 21 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-7mdk
  233. - rebuilt.
  234. * Sat Feb 02 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-6mdk
  235. - rebuilt against HDF 4.1r5.
  236. * Thu Jan 24 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-5mdk
  237. - fixed icons (png).
  238. * Mon Oct 15 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-4mdk
  239. - Rebuilt against latest libpng.
  240. * Thu Sep 06 2001 Stefan van der Eijk <stefan@eijk.nu> 4.1.3-3mdk
  241. - BuildRequires: flex
  242. - Removed BuildRequires: zlib-devel
  243. * Wed Aug 01 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-2mdk
  244. - added -fno-exceptions to compilation flags (thanks to Randall Hopper).
  245. - forced -O2 due to gcc bug.
  246. * Tue Jun 12 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.3-1mdk
  247. - updated to version 4.1.3.
  248. - cleaned SPEC file.
  249. * Thu Mar 22 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-7mdk
  250. - run aclocal/autoconf only for non ix86 architectures.
  251. - added menu entry.
  252. * Sat Mar 17 2001 David BAUDENS <baudens@mandrakesoft.com> 4.1.0-6mdk
  253. - Don't BuildRequires HDF on PPC (HDF doesn't support PPC architecture)
  254. - Use optimizations on PPC
  255. * Fri Mar 16 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 4.1.0-5mdk
  256. - Prefer arch "linux" to arch "alphax", for alpha.
  257. - Re-generate configure with autoconf for each build.
  258. * Mon Feb 26 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-4mdk
  259. - add netcdf support.
  260. * Sat Feb 24 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-3mdk
  261. - added samples.
  262. - added patches for allowing static building (thanks jloup).
  263. - added mandirs.
  264. - fixed docs.
  265. - split into main and devel package.
  266. * Tue Dec 26 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-2mdk
  267. - added netcdf, hdf, cdf support.
  268. * Mon Oct 09 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-1mdk
  269. - more macros.
  270. - added patch for ImageMagick.
  271. * Sat Oct 07 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 4.1.0-0.9mdk
  272. - initial release.