SDL_gfx-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Summary: SDL graphics drawing primitives and other support functions
  2. Summary(ja): SDLの基本的な描画機能とその他の機能を提供するライブラリ
  3. Name: SDL_gfx
  4. Version: 2.0.23
  5. Release: 2%{?_dist_release}
  6. Source0: %{name}-%{version}.tar.gz
  7. License: LGPL
  8. Group: System Environment/Libraries
  9. URL: http://www.ferzkopp.net/joomla/
  10. BuildRequires: SDL-devel >= 1.2.0
  11. BuildRequires: libX11-devel
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. %define all_x86 i386 i586 i686 athlon
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. %description
  17. The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
  18. provided basic drawing routines such as lines, circles or polygons and
  19. SDL_rotozoom which implemented a interpolating rotozoomer for SDL
  20. surfaces.
  21. The current components of the SDL_gfx library are:
  22. * Graphic Primitives (SDL_gfxPrimitves.h)
  23. * Rotozoomer (SDL_rotozoom.h)
  24. * Framerate control (SDL_framerate.h)
  25. %ifarch %{all_x86}
  26. * MMX image filters (SDL_imageFilter.h)
  27. %endif
  28. The library is backwards compatible to the above mentioned code. Its
  29. is written in plain C and can be used in C++ code.
  30. %description -l ja
  31. SDL_gfx は SDL_gfxPrimitives コードから発展したライブラリであり、線や
  32. 円、ポリゴンの描画を行う基本的な機能と、SDL サーフェースの回転・拡大
  33. ・縮小を行う SDL_rotozoom を提供します。
  34. 現在の SDL_gfx ライブラリに含まれているのは:
  35. * 基本的な画像の描画 (SDL_gfxPrimitves.h)
  36. * SDL サーフェースの回転、拡大、縮小 (SDL_rotozoom.h)
  37. * フレームレート制御 (SDL_framerate.h)
  38. %ifarch %{all_x86}
  39. * MMX イメージフィルタ (SDL_imageFilter.h)
  40. %endif
  41. このライブラリは先に述べたコードとの後方互換性を持っています。この
  42. ライブラリは C 言語で記述されており、C++ からでも使用できます。
  43. #-----------------------------------------------------------------------------
  44. %package devel
  45. Summary: Libraries and includes to develop SDL_gfx programs
  46. Summary(ja): SDL_gfx 用の開発ライブラリおよびヘッダファイル
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}
  49. %description devel
  50. This package includes the files needed for developing and compiling
  51. applications which use the SDL_gfx library.
  52. You should install the SDL_gfx-devel package if you would like to
  53. develop applications based on SDL_gfx.
  54. %description devel -l ja
  55. このパッケージは SDL_gfx ライブラリを使用するアプリケーションを開発
  56. するのに必要なライブラリやヘッダファイルを含んでいます。
  57. SDL_gfx をベースにしたアプリケーションを開発するなら、このパッケージ
  58. をインストールしてください。
  59. #-----------------------------------------------------------------------------
  60. %package demos
  61. Summary: SDL_gfx demo programs
  62. Summary(ja): SDL_gfx デモプログラム
  63. Group: Applications/Other
  64. Requires: %{name} = %{version}
  65. AutoReqProv: no
  66. %description demos
  67. SDL_gfx demo applications and source code.
  68. It is necessary to compile to run demo applications.
  69. %description demos -l ja
  70. SDL_gfx のデモアプリケーションとソースコードです。
  71. デモアプリケーションを実行するには自分でコンパイルする必要があります。
  72. #-----------------------------------------------------------------------------
  73. %prep
  74. %setup -q
  75. %build
  76. %ifarch %{ix86}
  77. %configure --disable-static
  78. %else
  79. %configure --disable-static --disable-mmx
  80. %endif
  81. %__make
  82. %install
  83. %__rm -rf $RPM_BUILD_ROOT
  84. %__make install DESTDIR=$RPM_BUILD_ROOT
  85. %__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  86. %__install -d $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
  87. %__install -m644 %{_builddir}/%{name}-%{version}/Test/m4/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos/m4
  88. %__rm -rf %{_builddir}/%{name}-%{version}/Test/m4
  89. %__install -m755 %{_builddir}/%{name}-%{version}/Test/* $RPM_BUILD_ROOT/%{_datadir}/SDL_gfx-demos
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  91. %clean
  92. %__rm -rf $RPM_BUILD_ROOT
  93. %post -p /sbin/ldconfig
  94. %postun -p /sbin/ldconfig
  95. %files
  96. %defattr(-,root,root)
  97. %doc AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README*
  98. %doc Docs/
  99. %{_libdir}/libSDL_gfx.so.*
  100. %files devel
  101. %defattr(-,root,root)
  102. %{_libdir}/pkgconfig/SDL_gfx.pc
  103. %{_libdir}/libSDL_gfx.so
  104. %{_includedir}/SDL/*
  105. %files demos
  106. %defattr(-,root,root)
  107. %{_datadir}/SDL_gfx-demos
  108. %changelog
  109. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-2
  110. - rebuild with VineSeed environment
  111. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.23-1
  112. - new upstream release
  113. - add BuildRequires: libX11-devel
  114. * Mon Sep 20 2010 IWAI, Masaharu <iwai@alib.jp> 2.0.22-1
  115. - new upstream release
  116. - add pkg-config file in devel package
  117. - remove *.a
  118. - move *.so file: main to devel
  119. * Sat Sep 20 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-1
  120. - new upstream release
  121. - applied new versioning policy
  122. - spec in UTF-8
  123. * Mon Jan 15 2007 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  124. - new upstream release
  125. - added %post and %postun section
  126. * Mon Jun 26 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-1vl2
  127. - rebuild to correct version mismatch.(1vl1 already exist in Vine Plus/3.0)
  128. - change SDL_gfx-demos Group to Applications/Other.
  129. - add SDL_gfx-demos description.
  130. * Wed Aug 24 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.13-0vl2
  131. - disable MMX on non-x86 archtecture
  132. * Sat May 14 2005 kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.13-0vl1
  133. - initial build for VineSeed Plus.