STLport-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Name: STLport
  2. Version: 5.2.1
  3. Release: 1%{?_dist_release}
  4. Summary: C++ STL library compatible with the latest ANSI/ISO C++ specification
  5. Summary(ja): ANSI/ISO C++ 仕様に沿った C++ 標準テンプレートライブラリ
  6. Group: System Environment/Libraries
  7. License: Opensource (Free and Unrestricted)
  8. URL: http://www.stlport.org/
  9. Source: %{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. %description
  14. The ANSI/ISO C++ specifcation includes a standard C++ library, also known as
  15. the STL. GCC by default comes with an implementation that does not comply
  16. with this standard, but instead partly implements an older version. STLport
  17. is freely available version, based on the SGI STL implementation. It is
  18. fully-compliant, supported, and very fast. Includes special debugging
  19. facilities, and interesting and useful extensions to the standard.
  20. %package devel
  21. Summary: STLport development headers and documentation
  22. Summary(ja): STL の開発用ヘッダファイルとドキュメント
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. Documentarion and headers for STLport
  27. %prep
  28. %setup -q
  29. %build
  30. ./configure \
  31. --prefix=%{_prefix} \
  32. --bindir=%{_bindir} \
  33. --libdir=%{_libdir} \
  34. --includedir=%{_includedir} \
  35. --use-compiler-family=gcc \
  36. --enable-static \
  37. ;
  38. pushd build/lib
  39. export OPT="${RPM_OPT_FLAGS}"
  40. make clean all %{?_smp_mflags}
  41. popd
  42. %check
  43. make check
  44. %install
  45. rm -rf $RPM_BUILD_ROOT
  46. make DESTDIR=$RPM_BUILD_ROOT install
  47. # fix library path
  48. mv $RPM_BUILD_ROOT$RPM_BUILD_ROOT%{_prefix}/lib/* $RPM_BUILD_ROOT%{_libdir}/
  49. rm -rf $RPM_BUILD_ROOT/home
  50. %post -p /sbin/ldconfig
  51. %postun -p /sbin/ldconfig
  52. %post devel -p /sbin/ldconfig
  53. %postun devel -p /sbin/ldconfig
  54. %clean
  55. rm -rf %{buildroot}
  56. %files
  57. %defattr(-,root,root)
  58. %doc INSTALL INSTALL.unixes README doc etc
  59. %{_libdir}/libstlport.so.*
  60. %{_libdir}/libstlportg.so.*
  61. %{_libdir}/libstlportstlg.so.*
  62. %files devel
  63. %defattr(-,root,root)
  64. %{_includedir}/stlport
  65. %{_libdir}/libstlport*.a
  66. %{_libdir}/libstlport*.so
  67. %changelog
  68. * Tue Dec 14 2010 Shu KONNO <owa@bg.wakwak.com> 5.2.1-1
  69. - updated STLport to 5.2.1
  70. * Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-2vl5
  71. - fixed copy option for symlink at %%install
  72. * Sun Oct 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.5-1vl5
  73. - updated to 5.1.5
  74. - modified build, install scripts
  75. - applied new versioning policy, spec in utf-8
  76. * Wed Dec 21 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl2
  77. - fixed typo at Group:
  78. * Mon Dec 19 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.2-0vl1
  79. - updated to 4.6.2
  80. - rebuilt with new toolchains
  81. - changed Group:
  82. - added Japanese summary
  83. - added %post, %postun section
  84. * Fri Sep 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0-0vl1
  85. - built for Vine