SysVinit-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395
  1. Summary: Programs which control basic system processes.
  2. Summary(ja): 基本的なシステムプロセスを制御するプログラム
  3. Name: SysVinit
  4. Version: 2.88dsf
  5. Release: 5%{_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: daisuke
  10. License: GPLv2+
  11. URL: http://savannah.nongnu.org/projects/sysvinit/
  12. Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
  13. Patch1: sysvinit-2.78-man.patch
  14. Patch2: sysvinit-2.86-autofsck.patch
  15. Patch3: sysvinit-2.86-loginshell.patch
  16. Patch4: sysvinit-2.86-inittab.patch
  17. Patch5: sysvinit-2.86-single.patch
  18. Patch6: sysvinit-2.88-quiet.patch
  19. Patch14: sysvinit-2.88-ipv6.patch
  20. Patch15: sysvinit-2.88-omit.patch
  21. Patch16: sysvinit-2.88-wall-maxlines.patch
  22. Patch17: sysvinit-2.88-wall-broadcast-message.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Requires: pam >= 0.66-5
  25. Requires: %{name}-tools = %{version}-%{release}
  26. Requires: filesystem
  27. Requires: util-linux >= 2.30.1
  28. %description
  29. The SysVinit package contains a group of processes that control
  30. the very basic functions of your system. SysVinit includes the init
  31. program, the first program started by the Linux kernel when the
  32. system boots. Init then controls the startup, running, and shutdown
  33. of all other programs.
  34. %description -l ja
  35. SysVinit パッケージには,システムの非常に基本的な機能を制御する
  36. プロセスが収められています.例えば,システム起動時に Linux カーネルに
  37. よって最初に起動されるプログラムである init 等です.init はその後
  38. システムの起動や,他のプログラムの起動/終了を制御します.
  39. %package tools
  40. Summary: Tools used for process management.
  41. Summary(ja): プロセス管理に使用するツール
  42. Group: system
  43. Requires: util-linux >= 2.30.1
  44. Requires: procps >= 3.3.17
  45. %description tools
  46. The sysvinit-tools package contains various tools used for process
  47. management.
  48. $description -l ja tools
  49. SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
  50. が含まれています。
  51. %debug_package
  52. %prep
  53. %setup -q -n sysvinit-%{version}
  54. # We use a shell, not sulogin. Other random man fixes go here (such as #192804)
  55. %patch1 -p1 -b .manpatch
  56. # Unlink /.autofsck on shutdown -f
  57. %patch2 -p1 -b .autofsck
  58. # Invoke single-user shell as a login shell (#105653)
  59. %patch3 -p1 -b .loginshell
  60. # Adjust examples in inittab(5) to more accurately reflect RH/Fedora
  61. # usage (#173572)
  62. %patch4 -p1 -b .inittabdocs
  63. # Fix single user mode (#176348)
  64. %patch5 -p1 -b .single
  65. # Be less verbose when booted with 'quiet'
  66. %patch6 -p1 -b .quiet
  67. # Change accepted ipv6 addresses (#573346)
  68. %patch14 -p1 -b .ipv6
  69. # Add option to pidof to exclude similar processes to omitted processes (#632321)
  70. %patch15 -p1 -b .omit
  71. # Fix counting MAXLINES in wall
  72. %patch16 -p1 -b .maxlines
  73. # Raise limit for broadcast message
  74. %patch17 -p1 -b .broadcast
  75. # for newer glibc.
  76. sed -i -e '/stat.h/a #include <sys/sysmacros.h>' src/mountpoint.c
  77. sed -i -e '/utsname.h/a #include <sys/sysmacros.h>' src/bootlogd.c
  78. %build
  79. make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
  80. %install
  81. rm -rf $RPM_BUILD_ROOT
  82. for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
  83. mkdir -p $RPM_BUILD_ROOT/$I
  84. done
  85. make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
  86. BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
  87. rm -f $RPM_BUILD_ROOT/bin/pidof
  88. ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
  89. rm -f $RPM_BUILD_ROOT/sbin/bootlogd
  90. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
  91. chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
  92. # Remove these files, as we use upstart as /sbin/init.
  93. rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
  94. rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
  95. rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
  96. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
  97. # /sbin/fstab-decode is part of initscripts
  98. rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
  99. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
  100. # /bin/mountpoint is part of util-linux >= 2.20
  101. rm -f $RPM_BUILD_ROOT/bin/mountpoint
  102. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/mountpoint.*
  103. # utmpdump and sulogin is part of util-linux >= 2.22
  104. rm -f $RPM_BUILD_ROOT%{_bindir}/utmpdump
  105. rm -f $RPM_BUILD_ROOT/sbin/sulogin
  106. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/utmpdump.*
  107. rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/sulogin.*
  108. # pidof is part of procps >= 3.3.17
  109. rm -f $RPM_BUILD_ROOT/sbin/pidof
  110. rm -f $RPM_BUILD_ROOT%{_mandir}/man8/pidof*
  111. rm -f $RPM_BUILD_ROOT%{_bindir}/*
  112. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/*
  113. %post
  114. [ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
  115. exit 0
  116. %clean
  117. rm -rf $RPM_BUILD_ROOT
  118. %files tools
  119. %defattr(-,root,root)
  120. %license COPYRIGHT
  121. %doc doc/Changelog
  122. /sbin/killall5
  123. %{_mandir}/man8/killall5*
  124. %changelog
  125. * Fri Oct 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.88dsf-5
  126. - removed pidof which is part of procps >= 3.3.17.
  127. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.88dsf-4
  128. - removed last,lastb,mesg and wall which is part of util-linux = 2.30.
  129. * Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-3
  130. - remove sulogin and utmpdump which are part of util-linux >= 2.22
  131. * Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-2
  132. - remove mountpoint which is part of util-linux >= 2.20
  133. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
  134. - update to 2.88dsf
  135. - only build -tools subpackage
  136. * Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
  137. - new upstream release (2.87dsf)
  138. - remove upstreamed or obsoleted patches
  139. - split off a -tools subpackage to avoid upstart conflicts
  140. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
  141. - new upstream release
  142. * Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
  143. - add script to create $RPM_BUILD_ROOT/bin in %%install section
  144. * Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
  145. - install initreq.h
  146. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
  147. - new upstream release
  148. - merged with fedora package.
  149. * Tue Jul 17 2001 <sagami@vinelinux.org>
  150. - 2.78-10vl3: fix orphan symlink in %%doc
  151. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  152. - 2.78-10vl1
  153. - rebuilt under new %%{_mandir} definition
  154. - added Japanese summary and description
  155. * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
  156. - build with gcc-2.95.3
  157. - partially used rpmmacros
  158. * Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
  159. - add change_console, for changing console used by init
  160. * Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
  161. - block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
  162. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  163. - rebuilt
  164. * Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
  165. - clean up killall5 some
  166. * Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  167. - update to 2.85, remove already applied patches
  168. * Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
  169. - fix s390x build
  170. - fix silly warning (#83943)
  171. * Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
  172. - fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
  173. - fix segfault in spawn() function in shutdown
  174. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  175. - rebuilt
  176. * Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
  177. - Pass __cc macro to build, to facilitate cross-compiling
  178. - _smp_mflags
  179. * Mon Dec 2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
  180. - rebuild on all arches
  181. - change sulogin message to be slightly more correct (#65828)
  182. * Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
  183. - don't strip binaries
  184. - have wall not write to non-ttys (#65412)
  185. - update usage for halt/reboot (#57753)
  186. - allow '-t' argument to last for checking state at certain times (#56863)
  187. - make 'pidof /foo/bar' not match /baz/bar (#53918)
  188. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  189. - automated rebuild
  190. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  191. - automated rebuild
  192. * Tue Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
  193. - add patch to log messages on shutdown/reboot
  194. * Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
  195. - update to 2.84
  196. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  197. - automated rebuild
  198. * Fri Nov 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
  199. - Fix pidof -o (#55954)
  200. - Handle RPM_OPT_FLAGS
  201. - s/Copyright/License/
  202. * Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
  203. - update to 2.79
  204. * Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
  205. - unlink /.autofsck on shutdown -f
  206. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  207. - Bump release + rebuild.
  208. * Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
  209. - update 'no logout' patch
  210. - fix setting of CREAD to work with 2.4.3+ kernels (#45284)
  211. * Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
  212. - show users with no login pid but no logout record as gone (#42550,
  213. <cwolf@starclass.com>)
  214. - fix sulogin to *always* work without a tty (#40934)
  215. * Tue Apr 3 2001 Bill Nottingham <notting@redhat.com>
  216. - set umask 022 on startup
  217. - manpage tweaks (#21628, #27173)
  218. * Mon Apr 2 2001 Bill Nottingham <notting@redhat.com>
  219. - fix dangling symlink in %%doc (#34383)
  220. * Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
  221. - don't run telinit u if we don't appear to be on the root fs
  222. * Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
  223. - run telinit u on upgrade
  224. * Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
  225. - document '-n' option to wall, make it root-only (#18672)
  226. - don't open files in sulogin unless they're really ttys (#21862)
  227. * Tue Aug 8 2000 Bill Nottingham <notting@redhat.com>
  228. - set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
  229. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  230. - automatic rebuild
  231. * Thu Jun 8 2000 Bill Nottingham <notting@redhat.com>
  232. - fix the md5 code (#11534)
  233. - rebuild for FHS & the like
  234. * Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
  235. - ignore sigint in sulogin (#9803)
  236. - touch file in root directory if powering off (#7318)
  237. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  238. - rebuild for sparc baud rates > 38400.
  239. * Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
  240. - update to 2.78-final
  241. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  242. - handle compressed manpages
  243. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  244. - build to fix dependency problem
  245. * Mon Jan 10 2000 Bill Nottingham <notting@redhat.com>
  246. - update to 2.78
  247. * Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
  248. - on big endian machines use a kludge for broken pam md5 passwords
  249. * Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
  250. - update to 2.77
  251. * Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
  252. - move pam_console stuff to usermode package
  253. * Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
  254. - requires usermode to express the dependency on /usr/bin/consolehelper
  255. (#2813)
  256. * Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
  257. - make man page references to single-user mode consistent with RH usage
  258. * Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
  259. - remove /etc/initlvl compatibility symlink from file list (#2236).
  260. * Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
  261. - pam.d files marked noreplace
  262. - added poweroff as a console application
  263. * Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
  264. - marked config files as such in consolehelper part of filelist
  265. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  266. - auto rebuild in the new build environment (release 8)
  267. * Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
  268. - consolehelper support
  269. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  270. - glibc 2.1
  271. * Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
  272. - poweroff symlink not included (problem #762)
  273. * Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
  274. - Fix a securelevel releated security hole. Go on, try and break append
  275. only files + securelevel now ;-)
  276. * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
  277. - remove /etc/nologin at end of shutdown.
  278. - compile around missing SIGPWR on sparc
  279. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  280. - translations modified for de, fr, tr
  281. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  282. - upgraded to 2.74
  283. - fixed the package source url... (yeah, it was wrong !)
  284. * Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
  285. - fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
  286. 22 bytes, not 24...). Fix in -md5.patch
  287. * Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
  288. - /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
  289. just plain wrong..
  290. - /usr/bin/utmpdump was missing in the files section, although it was
  291. explicitly patched into PROGS.
  292. - added attr's to the files section.
  293. - various small fixes.
  294. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  295. - updated to 2.71
  296. - built against glibc 2.0.4
  297. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  298. - Added sulogin.8 man page to file list.