dSFMT-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. %define pkg_name dSFMT
  2. %define pkg_version 2.2.3
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Double precision SIMD-oriented Fast Mersenne Twister
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD
  9. Group: System Environment/Libraries
  10. URL: http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT
  11. Source0: http://www.math.sci.hiroshima-u.ac.jp/~m-mat/MT/SFMT/%{name}-src-%{version}.tar.gz
  12. Patch0: %{name}-%{version}_sharedlib.patch
  13. Patch1: %{name}-%{version}_pkgconfig.patch
  14. Patch2: %{name}-%{version}_exportfuns.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: nkf
  17. %description
  18. The purpose of dSFMT is to speed up the generation by avoiding
  19. the expensive conversion of integer to double (floating point).
  20. dSFMT directly generates double precision floating point
  21. pseudo-random numbers which have the IEEE Standard for Binary
  22. Floating-Point Arithmetic (ANSI/IEEE Std 754-1985) format.
  23. dSFMT is only available on the CPUs which use IEEE 754 format
  24. double precision floating point numbers.
  25. dSFMT doesn't support integer outputs.
  26. dSFMT supports the output of double precision floating point
  27. pseudo-random numbers which distribute in the range of
  28. [1, 2), [0, 1), (0, 1] and (0, 1).
  29. And it also supports the various periods form 2^521 - 1 to 2^132049 - 1.
  30. #'
  31. %description -l ja
  32. dSFMT の開発目的は整数から浮動小数点数への変換のコストを避けることにあります。
  33. dSFMT は IEEE Standard for Binary Floating-Point Arithmetic (ANSI/IEEE Std
  34. 754-1985) 形式の倍精度浮動小数点擬似乱数を直接生成します。 したがって、dSFMT
  35. は IEEE 754 形式の倍精度浮動小数点数を使用する CPU でしか利用出来ません。
  36. dSFMT は整数の出力をサポートしません。
  37. dSFMT がサポートするのは [1, 2), [0, 1), (0, 1], (0, 1) の範囲に分布する
  38. 倍精度浮動小数点擬 似乱数です。また、2^521 - 1 から 2^216091 - 1 までの様々な
  39. 周期をサポートします。
  40. %package devel
  41. Summary: Development files for %{name}
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. %description devel
  45. The %{name}-devel package contains libraries and header files for
  46. developing applications that use %{name}.
  47. %prep
  48. %setup -q -n %{name}-src-%{version}
  49. %patch0 -p1 -b .sharedlib
  50. %patch1 -p0 -b .pkgconfig
  51. %patch2 -p1 -b .exportfuns
  52. nkf -w -Lu --overwrite README.jp.txt
  53. %build
  54. %{__make} %{?_smp_mflags} sharedlib \
  55. libdir=%{_libdir} CCFLAGS="-fPIC %{optflags}"
  56. %install
  57. %{make_install} libdir=%{_libdir}
  58. %{__install} -pm644 %{name}.pc ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/
  59. %check
  60. %{__make} std-check
  61. %clean
  62. %{__rm} -rf ${RPM_BUILD_ROOT}
  63. %post -p %{_syssbindir}/ldconfig
  64. %postun -p %{_syssbindir}/ldconfig
  65. %files
  66. %doc CHANGE-LOG.txt LICENSE.txt README.txt README.jp.txt
  67. %doc html/
  68. %{_libdir}/*.so.*
  69. %files devel
  70. %{_libdir}/*.so
  71. %{_libdir}/pkgconfig/%{name}.pc
  72. %{_includedir}/*.h
  73. %changelog
  74. * Sat Jun 09 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
  75. - initial build for Vine Linux
  76. * Wed Sep 3 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 2.2.3-4
  77. - Move documentation to -devel-doc package.
  78. - Run tests (modify and simplify Makefile patch to do this).
  79. * Sat Jun 28 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 2.2.3-3
  80. - Add patch to export functions required to use the library.
  81. * Tue Jun 17 2014 Xavier Lamien <laxathom@fedoraproject.org> - 2.2.3-2
  82. - Update license.
  83. - lower variable into Makefile.
  84. * Thu Jun 5 2014 Xavier Lamien <laxathom@fedoraproject.org> - 2.2.3-1
  85. - Initial RPM release.